Jump to content
Andy Somerfield

Affinity Photo Customer Beta (1.8.0.163)

Recommended Posts

Status: Beta

Purpose: Features, Improvements, Fixes

Requirements: Purchased Affinity Photo

Mac App Store: Not submitted

Download ZIP: Download

Auto-update: Not available.

EDIT: Link fixed (was pointing to an old DMG, not the new ZIP). Apologies..

 

Hello,

We are pleased to announce the immediate availability of the first beta of Affinity Photo 1.8 for macOS.

Photo 1.8 is a significant change to the currently shipping 1.7 version, so, as ever, I would strongly urge users to avoid the 1.8 beta for critical work. This is a pre-release build of 1.8 - we will release more builds before 1.8 ships. Things will be broken in this build - please use it to explore the new features and not for real work.

If this is your first time using a customer beta of an Affinity app, it’s worth noting that the beta will install as a separate app - alongside your store version. They will not interfere with each other at all and you can continue to use the store version for critical work without worry.

It’s also worth noting that we aren’t done yet - we are still working through reported bugs from previous releases and hope to fix as many as possible before the final release of 1.8. We also plan to add more features prior to the 1.8 release.

With all that said, we hope that you will enjoy the new capabilities introduced in this release and we look forward to any and all feedback you give to us.

Many thanks (as always),

Affinity Photo Team  :ph34r:

 

Changes This Build

- Overhauled the “File -> New” dialog - user templates are now supported.
- Implemented unified toolbar for appropriately modern macOS versions.
- Updated PANTONE palettes to include new Solid and Bridge sets.
- Renamed EXIF panel to Metadata and added support for user-editable fields, including IPTC).
- Added ability to read metadata from an XMP sidecar file (enable in Preferences).
- Added native CR3 support to the SerifLabs RAW engine.
- Added a new lens profile selector to Develop.
- Reimplemented the HSL filter's HSV option.
- Improved quality & file size of results when exporting JPEG.
- Switching to a mask node will now automatically switch to the grey colour slider.

- Improved lens correction of RAW files coming from lenses with fixed focal length.
- Improved unsharp mask “threshold” slider.
- Improved selection refinement performance & quality.
- Improved the noise reduction filter result when applied to JPEGs.
- Improved precision of Gaussian algorithm (to reduce banding).
- Improved reporting of file load errors (could previously report file corruption incorrectly).
- Improved performance of operations with large selections.
- Improved memory use with alternate futures and when replacing image layers.
- Improvements to Photoshop plugin support, notably for DxO plugins (but also for many others).

- Fixed Styles to show styles that would normally be invisible.
- Fixed crash when loading some corrupt JPEGs (valid image data, but corrupt following data).
- Fixed deletion of brushes / styles / etc. not reducing disk usage correctly.
- Fixed PSD export of hidden layers.
- Fixed angle cursors when the view has been rotated.
- Fixed “Create Palette” from CMYK images resulting in RGB colours.
- Fixed Pixel Selection appears incorrectly when started near page edge.
- Fixed rasterising a fill layer goes wrong after changing document size.
- Fixed Marquee Selection not constraining to a square if you drag across the right diagonal.
- Fixed mis-identification of some Tamron lenses mounted to Canon bodies.
- Fixed failure to load some PSB files (and failing to report errors).
- Fixed missing EXIF data for CRWs.
- Fixed crash importing PSD files containing embedded colour profiles with unicode characters in their names.

- Assorted other small fixes and improvements.
- Localisation improvements.

To be notified about all future Mac beta updates, please follow this beta notification thread 

To be notified when this update comes out of beta and is fully released to all Affinity Photo customers, please follow this release notification thread

Share this post


Link to post
Share on other sites

Friendly reminder—if you find any issues with the beta, please post them as a separate post here.

If you wish to open existing 1.7 files in the 1.8 beta, I would encourage you to work on a copy of the file as once that file is saved in 1.8, it will not open in the 1.7 retail version again.

Thanks for your support :11_blush:

Share this post


Link to post
Share on other sites

For anybody wondering if this 1.8.0.163 build is compatible with StudioLink & the 1.8.0.523 build of the Affinity Publisher beta, it is. :)

So now all we Mac beta testers need is a Affinity Designer beta build that also works with StudioLink & whatever is the current Publisher beta build & we can test all of the Publisher beta's personas.


Affinity Photo 1.8.4, Affinity Designer 1.8.4, Affinity Publisher 1.8.4;  2020 iMac 27"; 3.8GHz i7, Radeon Pro 5700, 40GB RAM; macOS 10.15.6
Affinity Photo 
1.8.4.186 & Affinity Designer 1.8.4.4 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 14.0.1

Share this post


Link to post
Share on other sites

With the new unified toolbar, which leads to a more cramped row of tools, it would be nice if individual buttons for the various Personas could become available in the Customize Tools panel. For instance, i don't use raw processing and so far never have had the desire to use the Tone Mapping or Export persona. I could therefore save some space by omitting these buttons.


Affinity Photo - Affinity Designer - Affinity Publisher | macOS 11 Big Sur on 8GB MBP13 2013 | macOS 10.15 Catalina on 16GB MBP13 2017

Share this post


Link to post
Share on other sites
14 hours ago, Andy Somerfield said:

Renamed EXIF panel to Metadata and added support for user-editable fields, including IPTC).

Many will be happy with this. :)

Best regards!


You'll never know what you can do until you get it up as high as you can go!   

AMD FX 8350 :: Radeon HD 7870 :: Windows 10 ::  http://mithferion.deviantart.com/

Oxygen Icons :: Free Quality Fonts :: Public Domain Pictures :: iOS 11 Design Resources :: iOS App Icon Template :: Hot to do High Quality Art :: Mesh Warp / Distort Tool Considerations

Share this post


Link to post
Share on other sites

The "Edit in Affinity Photo Beta" and "Edit with Affinity Photo Beta" (on Catalina)  discussion regarding Affinity Photo beta is now here. Feel free to follow it if you wish (auto-follow is not automatic on split posts [and not open for discussion here])


Patrick Connor
Serif Europe Ltd

Latest releases on each platform 

 

Share this post


Link to post
Share on other sites

Thanks I now can use Affinity once again. It’s been a nuisance not being to be able to use Affinity. But we’ll done and glad this is now resolved.

once again thanks

Share this post


Link to post
Share on other sites

Quick question: Should I leave the beta version in my Download folder or move it to the Applications folder? It seems to run from the download folder just fine.

 

Share this post


Link to post
Share on other sites

I recently purchased a camera that is unsupported by AP and see that it IS being supported on this Beta.  I don't see this Beta even being supported through Windows, not to mention that it seems to lack some features of retail version, so my real question is when are we going to see these file formats supported in an update or do I need to either look to finding a Windows Beta or a new editing software?

Share this post


Link to post
Share on other sites

Ho @resultsphotography, welcome to the forums!

 

17 hours ago, resultsphotography said:

I don't see this Beta even being supported through Windows,

You are in the "Photo Beta on Mac" section of the forum.

 

For the Windows version betas, you should be looking here: 

https://forum.affinity.serif.com/index.php?/forum/34-photo-beta-on-windows/

Share this post


Link to post
Share on other sites

Still have failed to fix the style bug I reported and found the last time around you got rid of Styles they are missing the original Styles also when clicking on a style they don't wanna add to what you are doing that whole feature is broken for a long time now since 1.7 it was broken and still is in 1.8 also has need work since 1.6 please fix this I also paid good money for this program so no excuse also have the Program on Windows now as well I would really like this fixed ASAP. No work arounds just fixed it's broken doesn't work very well at all.

Share this post


Link to post
Share on other sites

Basically when you select a Style they don't always apply to what you are doing in general it's very annoying and has been a long time bug that needs to be fixed I've honestly wasted hours playing around with it that's how bad it doesn't always work that well. A lot of the time I'll have to create a new project or something like that just to try and maybe get it working. It's awful. 

Share this post


Link to post
Share on other sites
8 hours ago, ellj said:

Basically when you select a Style they don't always apply to what you are doing...

What kind of layer (vector or quick shape, text, pixel, image, etc.) are you trying to apply a style to, & what are the attributes (fx, stroke, fill, etc.) of that style? Not all style attributes can be applied to all layer types -- for example, a stroke attribute can't be applied to a pixel layer because pixel layers are not vector paths so they have no path to add a stroke to.

BTW, the original 1.6 styles are available if you want to use them. Download them using the link in this post by @Callum.

As an aside, no biggie but your posts would be easier to read if you including a bit more punctuation. Sometimes it is hard to figure out where one sentence or clause ends & the next begins.


Affinity Photo 1.8.4, Affinity Designer 1.8.4, Affinity Publisher 1.8.4;  2020 iMac 27"; 3.8GHz i7, Radeon Pro 5700, 40GB RAM; macOS 10.15.6
Affinity Photo 
1.8.4.186 & Affinity Designer 1.8.4.4 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 14.0.1

Share this post


Link to post
Share on other sites
10 hours ago, ellj said:

Basically when you select a Style they don't always apply to what you are doing in general it's very annoying and has been a long time bug that needs to be fixed

I don't recall seeing any bugs reported in that area. If @R C-R's hints don't resolve your problem, it might be worthwhile for you to start a new topic in the Questions forum to describe (in detail) the problem you have, and possibly provide a sample .afphoto file to demonstrate it.

 


-- Walt

Windows 10 Home, version 2004 (19041.388),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop:  8GB memory, Intel Core i7-3625QM @ 2.30GHz, Intel HD Graphics 4000 or NVIDIA GeForce GT 630M
Affinity Photo 1.8.5.703 and 1.9.0.864 Beta   / Affinity Designer 1.8.5.703 and 1.9.0.864 Beta  / Affinity Publisher 1.8.5.703 and 1.9.0.863 Beta.

Share this post


Link to post
Share on other sites
7 hours ago, R C-R said:

What kind of layer (vector or quick shape, text, pixel, image, etc.) are you trying to apply a style to, & what are the attributes (fx, stroke, fill, etc.) of that style? Not all style attributes can be applied to all layer types -- for example, a stroke attribute can't be applied to a pixel layer because pixel layers are not vector paths so they have no path to add a stroke to.

BTW, the original 1.6 styles are available if you want to use them. Download them using the link in this post by @Callum.

As an aside, no biggie but your posts would be easier to read if you including a bit more punctuation. Sometimes it is hard to figure out where one sentence or clause ends & the next begins.

It appears to be an issue with layers for whatever reason the meta data must mess up for some reason that makes me not be able to apply it to it so I have to take my stuff and put into a different new Project instead. I happens wayyy too much for me anyway when I am working on stuff I always have a lot of different versions of the projects that I am working on because I always save lots of different copies of them for what I am working on always. It's just anything that I am working even have had the issue with text before as well also it's an issue with a lot of stuff and it needs to be fixed it does not work flawlessly like in the tutorial video that's for sure for me anyway. I have mentioned before that the original like 5 or 6 styles are missing that was with earlier versions of the app and it was never fixed before when I reported it like the Rainbow 1 and that sure I can import them but it's a pain in the butt with different devices I just want them there in general it should be fixed in general otherwise it's just dumb to take them away since it adds extra time to the workflow I would just like them always there in general. Idk I just report the issue and I just type it as is plus it's frustrating the issue in general when Affinity doesn't want to fix this issue in general and makes me mad after I have taken the time to report it before and nobody actually fixed the issue after it was removed by mistake.

Share this post


Link to post
Share on other sites
5 hours ago, walt.farrell said:

I don't recall seeing any bugs reported in that area. If @R C-R's hints don't resolve your problem, it might be worthwhile for you to start a new topic in the Questions forum to describe (in detail) the problem you have, and possibly provide a sample .afphoto file to demonstrate it.

 

It is explained in detail and I have I just feel like that Affinity has ignored me and chooses not to fix this for me. Anything that you create it doesn't work very well in general for me for a few versions now in general. I don't think that it needs a new topic either it just needs to be addressed and fixed fast since it has been an issue for a while it just needs to fixed even in the beta since it is the version in development right now just fix it finally for me since it was originally most likely broken with a previous version of a beta in development. It just seems like that Affinity is taking the Apple approach to issues thinking that everything is fine when it really isn't and needs to be fixed.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.