Mark Ingram

Affinity Designer Customer Beta - 1.6.0.82

109 posts in this topic

Click here to download the latest beta
 
Status: Customer Beta
Purpose: New features
Requirements: A valid product key, issued when Windows Affinity Designer version 1.5 was purchased.

This is a beta of a substantial change to our codebase and as much as we have tried to ensure the quality of the code, it is considered to be not suitable for production use. This means that you should not attempt to use it for commercial purposes or for any other activity that you may be adversely affected by the application failing. In addition it is definitely worth noting that files created in Affinity 1.6 may not open in 1.5 so always make a copy of your important documents before opening them in 1.6 to ensure you do not accidentally overwrite them and are unable to open them in your 1.5 version.

We hope you enjoy the latest build, and as always, if you've got any problems, please don't hesitate to post here and we'll get back to you as soon as we can. Thanks once again for your continued feedback.

If you have a general question about the software, please head over to the Questions Forum, or if you have any suggestions, please head over to the Feature Requests forum.
 
Fixes

  • Fixed Gradient flyout incorrectly showing previously applied gradient
  • Added keyline added around main window and dialogs
  • Added Radial Controller support option into preferences
  • Fixed ghost text objects shown in the view after creating text and moving it
  • Fixed lines shooting out when drawing with the Surface Pen
  • Changed pen tilt to be mirrored around vertical
  • Fixed selection refinement in CMYK documents
  • Fixed vector export of corner tool and filter effects on vector clips
  • Changed Path Text to use the same icon as Artistic Text
  • Added blacklisting of broken colour profiles (if loading them causes a crash, the next time the application runs, it will skip that profile)
  • Changed Find in Layers Panel to switch to the Layers Panel if it's not visible
  • Fixed FX Symbol failing to show on clipped objects
  • Fixed being unable to change font of multi-font selection
  • Fixed ICC profile combo boxes being too wide
  • Fixed more Light UI issues
  • Fixed missing Arrow Ends icons on context toolbar
  • Fixed Assets category text size is too small
  • Fixed a number of the fields in Adjustments are clipped
  • Fixed HSL Adjust able to enter invalid values for Hue Shift
  • Fixed exporting of clipped text frames
  • Fixed OpenType MarkToLigature rule, which fixes accents on certain font glyphs
  • Fixed import of Russian RTF text with "Language for non-Unicode programs" in Windows set to Russian
  • Fixed SVG export to export radial and elliptical fills as vector regardless of transform
  • Fixed PDF export to export radial and elliptical gradients as vector even if sheared
  • Fixed uncommitted nudge transforms getting reverted when the user hits Escape
  • Fixed crash when closing document
  • Fixed blank documents prompting to save on close
  • Fixed memory leak in Export dialog
  • Fixed crash when changing export options then attempting to export on a new document
  • Fixed sporadic crash when panning a document
  • Fixed sporadic crash when attempting to open files via Explorer
  • Fixed crash when the user right clicks in the open file dialog, when they have bad shell extensions installed (e.g. AMD drivers)
  • Fixed some objects failing to invalidate properly
  • Fixed more Russian UI issues
  • Fixed untranslated Hintline items
  • Fixed pressing the X on the close dialog closing the document without saving
  • Fixed crash loading EPS files
  • Fixed black rectangle around shape when exporting due to Outline FX
  • Fixed crash with massive filter nodes
  • Fixed Path Text handle dragging
  • Fixed selection brush size not being remembered
  • Fixed sporadic crash when editing memory intensive images

Share this post


Link to post
Share on other sites

Well done team!

We should be getting close to RC now.


Windows 10 64bit ¤ AMD A10-6700 APU ¤ AMD Radeon HD8670D + R7 240 2GB Dual Graphics ¤ 16GB DDR3 Ram

Share this post


Link to post
Share on other sites

Tried, as usual, with XP-Pen Star03 (Ugee M708) tablet and the high precision tablet input enabled. (latest driver: Dec 29 - 2016 - V8.1.2016.1002, WinTab32 V8.1.2016.906 / 10x6”, 2048-levels, System: Windows 8.1 x64 + 16GB RAM + Geforce 755M + SSD).

Problems with a tablet are only with AD Beta - other apps (most of which is using high-precision "Wacom" tablet input) works fine (Rebelle, ClipStudio, Sketchbook, Krita, ClipStudio, Photoshop).

Vector brush (tried to create a line from left to down-right - screenshot) creates this huge amount of curves (selected a few to show where they lead outside a canvas). Drawing with pixel brush slows the application down with stroke slowly appearing (minutes) combined with a heavy processor and memory load that can go up to 8GB or more - screenshot). The AD after this does not close completely - the window disappears, the CPU load also but the memory stays full (screenshot). It is necessary to terminate the process => no crash log.

Progress on another bugs is amazing and I'm really excited about this version. Thanks for this software.

01-vector.jpg

01-raster.jpg

process.JPG

AnthonyaMase likes this

Share this post


Link to post
Share on other sites
15 minutes ago, kzidek said:

Tried, as usual, with XP-Pen Star03 (Ugee M708) tablet and the high precision tablet input enabled.

 

What happens when you don't use "High Precision Tablet Input"?

Wiredframe likes this

Share this post


Link to post
Share on other sites
2 hours ago, Mark Ingram said:
  • Changed Find in Layers Panel to switch to the Layers Panel if it's not visible

 

Wonderful. Works now 'as advertised'. Thank you!

 

d.

Mark Ingram likes this

Affinity Designer 1.5.3.69 (beta 1.6.0.82) - Affinity Photo 1.5.2.69 (beta 1.6.0.82) - Windows 10 64-bit - Core i7 - 16GB - Intel HD Graphics 4600 & NVIDIA GeForce GTX 960M

Share this post


Link to post
Share on other sites

Hi all,

thanks to the team for the new beta.
a small bug I've discovered
the color gradient tool
can not be operated with the slider
as soon as a color is changed, the adjustment window closes.

Likewise, the mid point and opacity dont with the slider can controlled

see  screenshot

Screen-1.thumb.jpg.e367bce2e7c2f64aeb26b6850a0f51fe.jpg

best regards
Gnobelix

 

sorry my mistake , please move AP BETA

Chris J and Sean P like this

Share this post


Link to post
Share on other sites

Could you please stop with developing so many bugs? Thanks!

:4_joy:

rubs likes this

System                                                              Notebook Lenovo P50

CPU: Intel i7-3770K                                        CPU: Intel i7-6700HQ

RAM: 16 GB                                                      RAM: 32 GB

GPU: GTX 1070                                               GPU: NVIDIA Quadro M2000M 4 GB

SSD: Samsung 840 EVO 250 GB                SSD: Samsung 850 Pro 500GB

OS: Windows 10 Pro x64                               OS: Windows 10 x64

TFT: 2 x Samsung SyncMaster P2450         TFT: 2 x Lenovo

Share this post


Link to post
Share on other sites

Export dimensions still do not update when trying to quick export selection without background. The whole canvas is about 1000x1000 px - the selection clearly is recognized as 700x500px in the transform-panel but the export-dimensions do not update and are recognized as 14x18px - which could be the dimensions of the first element after the software-update I wanted to quick export. the export itself is then distorted: the elements are squished into the 14x18px.

affinity-export-bug.PNG

broken-export.jpg

Share this post


Link to post
Share on other sites
4 hours ago, Mark Ingram said:

Fixed uncommitted nudge transforms getting reverted when the user hits Escape

 

Hi Mark, Thanks for the fix, now I can use AD Beta again. However there is a new and a bit odd behavior -- after using the keyboard, it's necessary to press Esc twice (!) to deselect the current object. With the mouse the behavior is as expected, i.e. pressing Esc once deselects the current object(s).

 

4 hours ago, Mark Ingram said:

Fixed missing Arrow Ends icons on context toolbar

 

Thanks for this and for the other fixes.

Share this post


Link to post
Share on other sites

That's an impressive set of updates..well done Affinity Team....

 

Looking Good:)

 

A couple of things I have noticed:

1. Added a style (sunset) to rectangle and grab a handle to resize (left/right) and a smaller  'rectangular flicker' appears in the direction of the movement. Turning off effects [fx] applied to style stops this occurring.

2. Still getting a sticky slider on the transform panel (Rotate) if you select nodes on a path and scrub the slider (constantly trying to reset to Zero). 

Chris J and JohaWeber like this

AP:AD 1.5.3.69 + Beta [1.6.082] | AP 1.5.2.69 + Beta [1.6.082]

OS:Windows 10 Pro 1703 OS Build 15063.483
Rig:AMD FX 8350 and AMD Radeon 16.12.2 (R9 380 Series) + Wacom Intuous 4M with driver 6.3.23-1

Share this post


Link to post
Share on other sites

well, anyone see some problems with Wacom??? i found some bugs with my wacom intuos but still haven't time to review those.

Share this post


Link to post
Share on other sites
3 hours ago, awan said:

anyway, about this vers. is "preassure" not working? anyone?

If you mean Brush pressure then that is working OK for me

(Using a Wacom tablet)


Due to the impending Brexit negotiations, punctuation, spelling and grammar will be used sparingly until further notice.

Share this post


Link to post
Share on other sites
23 minutes ago, dutchshader said:

hello awan,

 

not on a wacom , but a huion, pressure is working fine.

 

22 minutes ago, carl123 said:

If you mean Brush pressure then that is working OK for me

(Using a Wacom tablet)

Thanks for reply,

im not bringing my tablet to the office. so i decide to edited my lineart manually with "pressure" table, (i screenshoot-ed it), i tried to play around but nothing happen. 

click to preview thank's

Share this post


Link to post
Share on other sites
14 hours ago, rubs said:

 

Hi Mark, Thanks for the fix, now I can use AD Beta again. However there is a new and a bit odd behavior -- after using the keyboard, it's necessary to press Esc twice (!) to deselect the current object. With the mouse the behavior is as expected, i.e. pressing Esc once deselects the current object(s).

Ah, you mean if you move an object with the arrow keys, you are required to press Esc twice? I just checked the release and it only requires one press of the Esc key so I'll log this. 

rubs likes this

Share this post


Link to post
Share on other sites
3 hours ago, Chris B said:

Ah, you mean if you move an object with the arrow keys, you are required to press Esc twice? I just checked the release and it only requires one press of the Esc key so I'll log this. 

 

Yes, please. But please do not bring the Escape key bug again in the process :)

JohaWeber likes this

Share this post


Link to post
Share on other sites
21 hours ago, Mark Ingram said:

 

What happens when you don't use "High Precision Tablet Input"?

The application does not freeze or use more memory than normal. It is fine and stable, but the line quality in Pixel Persona is unusable. I'm primarily focused on digital painting which I would like to completely do trough AD, but it is not possible yet. Images - AD (High Precision disabled + Star 03) versus Clip Studio and Rebelle side by side with tablet settings.

ADBeta.jpg

ClipStudio.jpg

Rebelle.jpg

Share this post


Link to post
Share on other sites

"Requirements: A valid product key, issued when Windows Affinity Designer version 1.5 was purchased."

 

And when is the valid product key inserted into the beta version...?  I have a valid product key but it is not inserted during the install process - not asked for nor does the installer seek it out from the already installed latest version of AD on my computer - that "latest version" would be the one that was purchased and kept up to date... >:(


"...life is what happens to you while you're busy making other plans..." john lennon

Share this post


Link to post
Share on other sites
10 hours ago, ScootCoot said:

"Requirements: A valid product key, issued when Windows Affinity Designer version 1.5 was purchased."

 

And when is the valid product key inserted into the beta version...?  I have a valid product key but it is not inserted during the install process - not asked for nor does the installer seek it out from the already installed latest version of AD on my computer - that "latest version" would be the one that was purchased and kept up to date... >:(

When you install the full version and enter your product key, the installer saves it in the registry. The beta installer reads the key from there. If it can't find it (e.g. if you're installing the beta on a different computer) it will ask you to type it in again. 

JohaWeber likes this

Share this post


Link to post
Share on other sites
On 6.9.2017 at 8:00 PM, JohaWeber said:

Export dimensions still do not update when trying to quick export selection without background. The whole canvas is about 1000x1000 px - the selection clearly is recognized as 700x500px in the transform-panel but the export-dimensions do not update and are recognized as 14x18px - which could be the dimensions of the first element after the software-update I wanted to quick export. the export itself is then distorted: the elements are squished into the 14x18px.

 

Any statement on this one? It really drives me insane!

Share this post


Link to post
Share on other sites
5 hours ago, JohaWeber said:

 

Any statement on this one? It really drives me insane!

Hi JohaWeber,

Would you be able to attach your file shown in the screenshot please? As I'm not getting this myself - see below.

Export Settings.png

JohaWeber likes this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now