Jump to content
Mark Daniel

Affinity Publisher Public Beta - 1.7.0.337

Recommended Posts

Thank you for quickly reporting the file issues highlighted by the changes for Linked and Embedded resources and bearing with us while we ironed those out. We are pleased to announce Build 337 which fixes the following issues in Builds 330 & 326 which were withdrawn.

[337]
- After modifying an embedded file you could no longer save the document
- After replacing a linked resource the document could become corrupted and could not be re opened.
- Making multiple resources linked in the Resource manager could crash the application
- The application could fail to save to folder linked to OneDrive 

[330]
- Converting an Embedded resource to Linked could delete the original resource
- Replacing Image on a placed PDF could leave Resource Manager in an inconsistent state
- Crash copying and pasting embedded document resources

Status: Public Beta
Purpose: Stability and General Testing
Requirements: Mac OS 10.9 or above

Hi,

We are pleased to announce that Affinity Publisher build 337 is now available as a manual download from the link above. To be notified when there is a new beta please press follow on this announcement thread.

As this is a beta it is considered to be not suitable for production use. This means that you should not attempt to use it for commercial purposes or for any other activity where you may be adversely affected by the application failing, including the total loss of any documents. 

We hope you enjoy the product, and as always, if you've got any problems installing or running up, please don't hesitate to post in this thread. 

Any problems actually using this version please make a new topic in this forum and we'll get back to you as soon as we can. Please feel free to leave general suggestions and comments in the Discussion Forum

Many thanks for your continued feedback.

---

Fixes and Improvements 

A Note about Linked Images

Backing data and hi-res previews are now discarded for linked images when the containing document is saved, resulting in a drop in Publication file size. Please note that unfortunately this will not apply for linked images in existing documents, they will have to be replaced in order to see an effect. When a document with linked images is opened you may now momentarily see a low-res preview before the full image is loaded and 'pops in'. This is expected behaviour.

Other Fixes

Menus / Studio
(Win) Docking Pinning Panel to the left/right causes crash on next run up
Deleting global colours could cause crash
(Mac) OS accented colour set to Graphite now works correctly for font controls etc
Fixes for Expression Parser

Tools
Fixed selection of Picture Frames from Masters
Vector cropped object in Picture Frame now scales correctly

Text / Tables
Fixed noticeable text lag under some circumstances with Character Panel visible
Fixed auto-correct crash e.g. typing (a)
(MacOS) Ctrl+Alt+Tab in a table inserts a tab and switches document
Prevented deletion of entire cell range with non contiguous selection
On converting a shape to a text frame the context toolbar now shows the correct text tools
Fix for Find / Replace All when found ranges were adjacent

Resources
Improved locating missing resources on file load
Fix for Resource Manager incorrectly reporting resources as modified under some circumstances
DocX improvements - fixes for lists, colours and paragraph run properties
---

Earlier Release Notes Beta 312

Share this post


Link to post
Share on other sites
2 hours ago, Mark Daniel said:

[337]
- After modifying an embedded file you could no longer save the document
- After replacing a linked resource the document could become corrupted and could not be re opened.
- Making multiple resources linked in the Resource manager could crash the application
- The application could fail to save to folder linked to OneDrive 

Should this not be [326] ?

Share this post


Link to post
Share on other sites

All seems to be working great - re-linked folder of tiffs for a kids book and re-saved, gone from 897mb to 122mb

Proper job


Mac Pro Cheese-grater (Early 2009)
2.93 GHz 6-Core Intel Xeon
48 GB 1333 MHz DDR3 ECC Ram
NVIDIA GeForce GT 630 - 2 GB
Ugee 19" Graphics Tablet Monitor
Mac OS 10.11.6 El Capitan

Affinity Designer, Photo and Publisher 1.7.1 + Betas when available

Binger.jpg.1f81574106cc2dea8ae65d0a572b9ef9.jpg
www.bingercreative.co.uk

Share this post


Link to post
Share on other sites

When use affinity photo document, the size of the file doesn't drop down, only when use other formats like jpgs

Share this post


Link to post
Share on other sites

The DMG (Disk-Image file) generates the following warning message during installment here.

beta_image.jpg.b78f352f29bd7047f8fbd62051b4a891.jpg


☛ Affinity Designer 1.7.1 ◆ Affinity Photo 1.7.1 ◆ OSX El Capitan

Share this post


Link to post
Share on other sites

In the previous build I had 2 files that I replaced the links and then saved. In build 337 it says both are corrupted. Is there any way to recover them?

Share this post


Link to post
Share on other sites
16 minutes ago, Jeremy Bohn said:

In the previous build I had 2 files that I replaced the links and then saved. In build 337 it says both are corrupted. Is there any way to recover them?

If by "previous build" you mean 326 or 330 then probably not, sorry. Both builds were withdrawn as they had the ability to corrupt files quite easily.

Upload them to a new thread and we can take a look


Patrick Connor
Serif (Europe) Ltd.

Latest releases on each platform 

Share this post


Link to post
Share on other sites
14 minutes ago, Patrick Connor said:

If by "previous build" you mean 326 or 330 then probably not, sorry. Both builds were withdrawn as they had the ability to corrupt files quite easily.

Upload them to a new thread and we can take a look

Thanks, I had worked on the files before these builds were pulled. Anyway, I forgot I have my Time Machine backups.

Share this post


Link to post
Share on other sites

Hi there is a simple bug on text selection on all Affinity software - Photo, Designer and Publisher.  If you start with the text tool and then select a font you want to use the font selection reverts to Arial. This exists with the Art Text Tool as well as the Frame Text Tool.  The only workaround is to start typing in Arial and then change the text selection - and while this workaround works it really slows down my workflow, and honestly it's really quite annoying. This was not the case in previous betas and also with the MAS versions. Please fix.

Share this post


Link to post
Share on other sites

I have found the same thing.   They not only revert to the default font Arial, but a default font size.    

1 hour ago, abarkalo said:

Hi there is a simple bug on text selection on all Affinity software - Photo, Designer and Publisher.  If you start with the text tool and then select a font you want to use the font selection reverts to Arial. This exists with the Art Text Tool as well as the Frame Text Tool.  The only workaround is to start typing in Arial and then change the text selection - and while this workaround works it really slows down my workflow, and honestly it's really quite annoying. This was not the case in previous betas and also with the MAS versions. Please fix.

 


21.5 iMAC Retina 4K display. MacOS Sierra v. 10.12.6 (which I am not changing).  3.1 GHz quad-core Intel Core i5, Turbo Boost up to 3.6 GHz.  Memory 8 GB 1867 MHz LPDDR3.  1TB Fusion Drive.  Intel Iris Pro Graphics 6200 1536 MB.   iPad Pro 12.9, iOS v. 12.3.1, Apple Pencil.  Affinity Publisher 1.7.2,  Affinity Photo 1.7.2, Affinity Designer 1.7.2.   

Magic mouse.9_9

Share this post


Link to post
Share on other sites

I have shipped this text selection issue over to a new topic in the Bugs section.


21.5 iMAC Retina 4K display. MacOS Sierra v. 10.12.6 (which I am not changing).  3.1 GHz quad-core Intel Core i5, Turbo Boost up to 3.6 GHz.  Memory 8 GB 1867 MHz LPDDR3.  1TB Fusion Drive.  Intel Iris Pro Graphics 6200 1536 MB.   iPad Pro 12.9, iOS v. 12.3.1, Apple Pencil.  Affinity Publisher 1.7.2,  Affinity Photo 1.7.2, Affinity Designer 1.7.2.   

Magic mouse.9_9

Share this post


Link to post
Share on other sites
On 5/26/2019 at 11:57 AM, abarkalo said:

Hi there is a simple bug on text selection on all Affinity software - Photo, Designer and Publisher.  If you start with the text tool and then select a font you want to use the font selection reverts to Arial. This exists with the Art Text Tool as well as the Frame Text Tool.  The only workaround is to start typing in Arial and then change the text selection - and while this workaround works it really slows down my workflow, and honestly it's really quite annoying. This was not the case in previous betas and also with the MAS versions. Please fix.

I just tried this (Mac version, build 337) and can't duplicate it, with either of the text tools. Changing the font before I start typing works - no reversion to Arial and no change to the size if I've changed that. Tried changing the base font to something other than Arial, and once I select a different font, it sticks then too - no reversion. Odd...wonder why some are seeing this and others not?

Share this post


Link to post
Share on other sites
22 minutes ago, PaddyD said:

I just tried this (Mac version, build 337) and can't duplicate it, with either of the text tools. Changing the font before I start typing works - no reversion to Arial and no change to the size if I've changed that. Tried changing the base font to something other than Arial, and once I select a different font, it sticks then too - no reversion. Odd...wonder why some are seeing this and others not?

Did you try selecting the tool, then changing the font before you draw the Text Frame?


-- Walt

Windows 10 Home, version 1903 (18362.239), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.2.471 and 1.7.2.464 Beta   / Affinity Designer 1.7.2.471 and 1.7.2.4464 Beta  / Affinity Publisher 1.7.2.471 and 1.7.3.475 Beta

Share this post


Link to post
Share on other sites
On 5/26/2019 at 11:57 AM, abarkalo said:

Hi there is a simple bug on text selection on all Affinity software - Photo, Designer and Publisher.  If you start with the text tool and then select a font you want to use the font selection reverts to Arial.

For me, it's actually worse than that.

When I start by clicking on the text tool and then selecting some arbitrary font F, my selection does not even register.

Here's what I'm told the selected font is before I select font F:

image.png.d13ee900b014d471d34f646390ae270c.png

And here's what I'm told the selected font is after I select font F:

image.png.b661fb2ed69677e7d6afd8c6a30f83f3.png

And even leaving that issue aside … Arial? … I mean, really?

 


Using macOS 10.13.6,    Publisher 1.7.1.408,    and Publisher Beta 1.7.2.420.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×