Jump to content
AdamW

Affinity Publisher Public Beta - 1.7.0.128

Recommended Posts

This thread is locked, there is a newer beta available from the thread pinned to the top of this forum

Click here to download the latest beta for Windows

Status: Public Beta
Purpose: General Testing
Requirements: None

As this is a beta it is considered to be not suitable for production use. This means that you should not attempt to use it for commercial purposes or for any other activity where you may be adversely affected by the application failing, including the total loss of any documents. 

We hope you enjoy the latest build, and as always, if you've got any problems installing or running up, please don't hesitate to post here.

Any problems actually using this version please post to post in this forum and we'll get back to you as soon as we can. Many thanks for your continued feedback.

Please post any bug reports here. Please feel free to leave general suggestions and comments in the Discussion Forum.

Fix List

Document / Page Management
- Fixed crash opening some documents containing images on a Master Page
- Pages Panel updated to improve layout and performance
- Add Page buttons now enabled correctly after converting Artboard based document to Spread on Windows
- Removed bleed setup from Add Master Page dialog, it is a document setting
- Select Anchor to page should be selected by default for scaling in spread properties
- Fixed Page redraw after deleting artboards

General Tools and Menus
- Added Layer > Arrange, Alignment, Geometry, Transform, Insertion
- Added Layer > New Layer, Layer > New Adjustment
- Preferences options missing from dialog drop down menu
- Fixed marquee zoom when using the <Space>+<Ctrl>
- Fixed Find and Replace text field drop menus on Mac
- Fixed toolbar customisation - Distribute, Operations on Mac
- Fixed Guides editing default for Select Tool on Mac
- Updated minimum Zoom Out for view
- Fixed crash when assigning keyboard shortcut to File > Place on Windows

Text Tool
- Symbols indicating overflowing text added to text frames
- Fixed bug redrawing text flow after unlinking text frames
- Text wrap options dialog fixed for light UI on Windows

Text Panels / Text Style Editor
- Tidied Paragraph style dropdown drawing on Mac
- Fixed application of Kerning by dragging icon on Mac
- Text Styles Panel fixed to display description fully
- Fixed deselection of Stylistic Sets from Character Panel
- Fixed Initial Words not applying in Text Styles
- Fixed hyphenation Minimum Score not applying in Text Styles
- Fixed bullet character style for bullet not applying if tab stop value is 0 in Text Styles
- Fixed 'Ignore space if same style' not applying in Text Styles on Windows

Tables
- Icons added to table row / column extenders to advertise their purpose
- Table tool headers now reflect insets
- Frame settings now applied correctly to new tables
- Double-click on default format now edits that format rather than creating a duplicate

Resources / Resource Manager
- On File > Open, if linked resources are missing, request to locate

Assets
- Fixed Asset thumbnails when asset include image in CMYK document

Picture Frames
- Fixed Convert placed image to Picture Frame
- Custom zoom and placement maintained when Picture Frame is resized

Print / Export
- All formats now export with optional bleed
- Fixed export of Artboards in embedded afdesign files
- Print model not saved with pre-set on Windows
- Double sided prints always flips on longest side on Windows

 

Share this post


Link to post
Share on other sites

Installed perfectly...and I can open the old docs!:)


APh & AD 1.7.1.404 + Beta AD 1.7.1.404 | APh 1.7.1.404 + Beta AP 1.7.1.404 RC2
APu 1.7.1.404

OS:Windows 10 Pro 1903 OS Build 18362.175
Rig:AMD FX 8350 and AMD Radeon (R9 380 Series) Settings Version 19.06.2(Adrenalin, 
Radeon Settings Version
19.1.1) + Wacom Intuous 4M with driver 6.3.35-3

 

 

Share this post


Link to post
Share on other sites

SETUP FAILED

... so I uninstalled with Revo uninstaller and hunted out all mention of Affinity Publisher, rebooted and was able to install this beta successfully

It is worth noting that the attempt to update the installation of Publisher totally broke it making it necessary to completely uninstall and reinstall the program ... there was no gentle failure that one could back away from

Edited by Rick G
Further developments

Affinity Designer 1.7.0.367 & beta 1.7.0.390 Affinity Photo 1.7.0.367 beta  1.7.0.390 Affinity Publisher 1.7.0.399

Windows 10 Pro 64-bit 1709

CPU Intel Core i7 4770 @ 3.40GHz Haswell 22nm Technology

RAM 32.0 GB Dual-Channel DDR3 @ 798 MHz (11-11-11-28)

Motherboard Gigabyte Technology Co. Ltd. B85M-D3H (SOCKET 0)

Graphics Intel HD Graphics 4600 (Gigabyte)

yoda.png

Share this post


Link to post
Share on other sites

Hi Rick G

/have you tried restarting your machine to flush out any background windows updates?

 If so try running this Microsoft Tool which should identify and clean up install and uninstall issues then try again to see if the setup will succeed for you?

Thanks


Serif Europe Ltd - Check the latest news at www.affinity.serif.com

Share this post


Link to post
Share on other sites

I had the same problem as above (install from build 58 failed, and left no usable installation), and the suggestion above (rebooting and allowing pending Windows updates to complete) did allow me to install.

I do think it is a problem that there is no uninstaller.

Share this post


Link to post
Share on other sites
1 hour ago, Chris_K said:

Hi Rick G

/have you tried restarting your machine to flush out any background windows updates?

 If so try running this Microsoft Tool which should identify and clean up install and uninstall issues then try again to see if the setup will succeed for you?

Thanks

Yes, thank you. I had edited my post to reflect that I had cleaned up manually and had success. Thanks for the tool. I grabbed it and will keep it around. I am thinking the Publisher installer has some deeper issues going on. I am sure it will get figured out


Affinity Designer 1.7.0.367 & beta 1.7.0.390 Affinity Photo 1.7.0.367 beta  1.7.0.390 Affinity Publisher 1.7.0.399

Windows 10 Pro 64-bit 1709

CPU Intel Core i7 4770 @ 3.40GHz Haswell 22nm Technology

RAM 32.0 GB Dual-Channel DDR3 @ 798 MHz (11-11-11-28)

Motherboard Gigabyte Technology Co. Ltd. B85M-D3H (SOCKET 0)

Graphics Intel HD Graphics 4600 (Gigabyte)

yoda.png

Share this post


Link to post
Share on other sites
30 minutes ago, trajanmcgill said:

I had the same problem as above (install from build 58 failed, and left no usable installation), and the suggestion above (rebooting and allowing pending Windows updates to complete) did allow me to install.

I do think it is a problem that there is no uninstaller.

We are looking into these installer problems, thanks for persevering.


Patrick Connor

Serif (Europe) Ltd.

Share this post


Link to post
Share on other sites
13 minutes ago, Patrick Connor said:

Thanks Rick G, good to know you can join in again.

Just reporting, that's all. No crying. There is something going on in there. If you need more information when that happens let us know.. I had just rebooted within an hour or so of trying to install that beta so ....

I did have photo and some other progs open and had been burning movies 

LOL grin 2.gif


Affinity Designer 1.7.0.367 & beta 1.7.0.390 Affinity Photo 1.7.0.367 beta  1.7.0.390 Affinity Publisher 1.7.0.399

Windows 10 Pro 64-bit 1709

CPU Intel Core i7 4770 @ 3.40GHz Haswell 22nm Technology

RAM 32.0 GB Dual-Channel DDR3 @ 798 MHz (11-11-11-28)

Motherboard Gigabyte Technology Co. Ltd. B85M-D3H (SOCKET 0)

Graphics Intel HD Graphics 4600 (Gigabyte)

yoda.png

Share this post


Link to post
Share on other sites

Hi,

On the older machine (for me), installation ran ok. Haven't got any described problems. Thanks Affinity Team for a quick update. More checking soon...

All the best!!!!!


Affinity Designer & Photo 1.6.5.123, Affinity Publisher 1.7.0.162

Packard Bell EasyNote TK85, Intel i3, 6GB DDR3, AMD Radeon HD 6370M, Windows 10 Home 1809

Share this post


Link to post
Share on other sites
7 hours ago, Rick G said:

Just reporting, that's all. No crying. There is something going on in there. If you need more information when that happens let us know.. I had just rebooted within an hour or so of trying to install that beta so ....

I did have photo and some other progs open and had been burning movies 

LOL grin 2.gif

Same problem as before. No other Affinity apps active.  Installer says "Setup fails".  Reboot and run again - no problem.  Perhaps it should say "Please Restart and try the Install again".  In that case if it then fails it's meaningful.  I do know that there was a restart pending due to another software update.

Share this post


Link to post
Share on other sites

Thanks for the new Beta :)
Installation was working well without any Problems. Will start testing in the evening.

I found a little, but terrible thing.
For example i create a circle. In the top Menu i klick on Show Rotation Centre. So far so good, but if i need Guidelines, the point of Rotaion Centre will be hidden if i move the Guidelines. I think that it is a bug because in Photo and Designer Rotation Centre will be not hidden if i move Guidelines.
And what i found too is that the Rotation Centre, if i move it, snaps to the horizontal Guideline, but not to the vertical Guideline.
 


Win 10 Home Edition    AP 1.6.5.123    AD 1.6.5.123    APUB 1.7.0.238     ...and the current Beta´s

Have a nice day.

Share this post


Link to post
Share on other sites
6 hours ago, Uwe367 said:

I found a little, but terrible thing.

Please post bugs into a new thread in this forum, thank you. New threads in this forum create a support ticket to try to make sure bugs are not overlooked. [moving your post into a new thread does not create a ticket or I would do that].


Patrick Connor

Serif (Europe) Ltd.

Share this post


Link to post
Share on other sites
42 minutes ago, Patrick Connor said:

Please post bugs into a new thread in this forum, thank you. New threads in this forum create a support ticket to try to make sure bugs are not overlooked. [moving your post into a new thread does not create a ticket or I would do that].

Ok. I post it in a new thread this evening when i'm back at home. Thanks for your hint.


Win 10 Home Edition    AP 1.6.5.123    AD 1.6.5.123    APUB 1.7.0.238     ...and the current Beta´s

Have a nice day.

Share this post


Link to post
Share on other sites

I'm not able to download the newest version. It goes through the motions of downloading but doesn't show up in downloads. I've repaired, uninstalled, and installed-nothing works. Still at 1.7.0.57.

Share this post


Link to post
Share on other sites

Thank you for the update. Installed but having 1 issue so far which I'll post in the bugs.


iMac: iMac (Retina 4K, 21.5-inch, 2017)  -   3.4 GHz Intel Core i5   -   8 GB 2400 MHz DDR4  -  Radeon Pro 560 4096 MB 

Windows: Nvidia gtx 960m 4k uhd 2gb ram video (Windows 10 Pro) -  Laptop screen (resolution 3840x2160 magnified 300%)

Share this post


Link to post
Share on other sites

After installing update 1.7.0.128 both Affinity Photo and Affinity Designer refused to open. Running the installers and attempting "Repair" failed but uninstalling and re-installing brought both back to life.

Share this post


Link to post
Share on other sites

Hi there. First time trying the new Publisher.  Update to the new version when perfect... I always 'install as administrator' incase that matters still?

Looking forward to trying it all out :)

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×