Jump to content
Mark Ingram

Affinity Designer Customer Beta - 1.6.0.84

Recommended Posts

Click here to download the latest beta
 
Status: Customer Beta
Purpose: Stability
Requirements: A valid product key, issued when Windows Affinity Designer version 1.5 was purchased.

This is a beta of a substantial change to our codebase and as much as we have tried to ensure the quality of the code, it is considered to be not suitable for production use. This means that you should not attempt to use it for commercial purposes or for any other activity that you may be adversely affected by the application failing. In addition it is definitely worth noting that files created in Affinity 1.6 may not open in 1.5 so always make a copy of your important documents before opening them in 1.6 to ensure you do not accidentally overwrite them and are unable to open them in your 1.5 version.

We hope you enjoy the latest build, and as always, if you've got any problems, please don't hesitate to post here and we'll get back to you as soon as we can. Thanks once again for your continued feedback.

If you have a general question about the software, please head over to the Questions Forum, or if you have any suggestions, please head over to the Feature Requests forum.
 
Fixes

  • Fixed PDF export rasterising embedded documents for PDF/X-1 if they don't need a transparency group
  • Fixed PDF export with Device Link colour profiles
  • Fixed crash when trying to create palette from TIFF
  • Fixed Snapping Candidates option not being remembered
  • Fixed Curves Adjustment graph appearance in 32-bit mode
  • Fixed 'File Not Found' error when dragging files from 7zip
  • Fixed being unable to type in fill opacity 
  • Fixed being unable to mouse wheel scroll in the Typography panel
  • Fixed rendering documents at less than 100% zoom, when Windows Display Scale is set to 125% or less 
  • Fixed being unable to load multiple files at the same time
  • Fixed brush random scatter not being random enough
  • Fixed Slice panel to synchronise with the selection
  • Fixed objects pasting incorrectly from a constrained object
  • Fixed laggy Brush Editor dialog sliders

Share this post


Link to post
Share on other sites

Please don't forget about this: 

I'm insisting on this because most UI designers use the font styles extensively and it's so annoying and a waste of time to look for a specific font weight in a list that doesn't make any sense.

Since the Mac version doesn't have this problem I don't think it hard to implement, right guys?

Thanks for the awesome job btw! You rock!


Check out my awesome Windows 10 Themes!

Share this post


Link to post
Share on other sites
2 hours ago, dpcdpc11 said:

Please don't forget about this: 

I'm insisting on this because most UI designers use the font styles extensively and it's so annoying and a waste of time to look for a specific font weight in a list that doesn't make any sense.

Since the Mac version doesn't have this problem I don't think it hard to implement, right guys?

Thanks for the awesome job btw! You rock!

Hi dpcdpc11,
How would you expect these to be ordered? Is the issue that Arial Black and Arial Narrow isn't separated from Arial? If so what other fonts have you found this with?

 

EDIT: Or are you expecting the lightest style ordered to the darkest?

Share this post


Link to post
Share on other sites

Is it possible to explain the criteria chosen for the fixes? I see a couple ones that were recently posted (which is nice), but there are a myriad important problems that need urgent fixes. For example, Save As and other Save / Open dialogs still don't remember locations adequately. This is absolutely non-standard in Windows and incredibly annoying. It's quite a simple fix, but remains to be done despite requests from many users.

 

Thanks.

Share this post


Link to post
Share on other sites
1 hour ago, Sean P said:

Hi dpcdpc11,
How would you expect these to be ordered? Is the issue that Arial Black and Arial Narrow isn't separated from Arial? If so what other fonts have you found this with?

So you just can't see it, can you?? Please open the Mac version and the Windows version and compare.

Since I only have a PC here's a comparison with PS:

FKP3dg.jpg.0d459d21dd708aef9a7af2a373816124.jpg

Which one make most sense to you?? AD or PS?

In case you don't see it I'll explain: the font style should be arranged from the lightest to boldest. Makes sense now?

Can't believe I have to tell this to someone developing a graphic design software... Really guys!

Now look at another comparison, Montserrat:

qJR0fU.jpg.bb2fd1ce8165b0544065f78034420775.jpg

See the chaos in AD?


Check out my awesome Windows 10 Themes!

Share this post


Link to post
Share on other sites
23 minutes ago, MEB said:

Hi dpcdpc11,
I believe i already replied to you in another thread regarding this problem (forgive me if not).
This issue is already logged to be looked at.

I know you replied but I just wanted to make sure if this "feature" is by design or a bug and since Sean is asking me how do I expect this to work I'm guessing it's by design.

So yeah... hopefully it will be ok on the final release.

Thanks for taking in all the critiques and comments :)

You rock!


Check out my awesome Windows 10 Themes!

Share this post


Link to post
Share on other sites

A very huge thanks for all the work (in both AP and AD) in perfecting/improving anything related to PDF / CMYK / print and color managing workflows in general ,so key in my own professional activity, and I guess, for many designers and illustrators like me (specially if like me, do both jobs (imo, photographers will benefit from this, too)) needing professional solutions for printing. And for all the other fixes, of course!  :).   Bugs are hunted/detected kind of easily, but fixed when it is humanly possible, or a light comes over an outstanding problem. There's no magic wand for it. And I know is really a painful task (only being a very bad and noob coder, but spent most hours in my professional life working besides programmers, seeing them sweating blood and tears...). So, really, the effort is very much appreciated.


Affinity Designer and Affinity Photo licenses, Windows 7, i7  860 (2009) 2.8 GHz,  8 GB RAM, GTX 1050 2 GB, HD 7200 RPM.  Wacom Intuos 4 XL.

Share this post


Link to post
Share on other sites
2 hours ago, SrPx said:

Bugs are hunted/detected kind of easily, but fixed when it is humanly possible, or a light comes over an outstanding problem. There's no magic wand for it. And I know is really a painful task (only being a very bad and noob coder, but spent most hours in my professional life working besides programmers, seeing them sweating blood and tears...). So, really, the effort is very much appreciated.

 

Being a veteran programmer and software/UX tester myself, I can tell you that not all bugs are easily spotted. Some are well hidden and show only under certain circumstances. Some problems in AD, however, wouldn't even fall in the bugs category. The example given is something that's still pending, but it's quite an easy fix in C#/.NET (the technology used in the Windows front-end).

 

On the other hand, problems like the flawed constraints implementations, are bugs and don't look like easy fixes to me, so they will probably take some time.

 

Anyway I still wonder how the proirities are sorted. I'd appreciate some clarification.

Share this post


Link to post
Share on other sites
20 hours ago, HagensWatch said:

Just curious...is there going to be an Affinity Designer released for the iPad anytime soon?

1. I hope, no.
2. I'm afraid, yes.


My Specs:
- Processor: AMD Phenom™ II X4 955 Processor 3.20 GHz- RAM: 8 GB
- Graphics card: NVIDIA GeForce GTS 250
- Monitor: SyncMaster F2380 (resolution 1920x1080)
- Operating system: Windows 10 Pro (1803) / 64 bit

Share this post


Link to post
Share on other sites

New to the beta so hopefully I'm putting this in the right place. This seems to be where people are reporting bugs.

Bug:

When a color is change in the gradient flyout if you are using something other than linear it will change back to linear.

 

Example: If you are using a elliptical gGradient and than change a color it will turn into a linear gradient.

Video_2017-10-03_131125.gif

Share this post


Link to post
Share on other sites
11 hours ago, RPC said:

New to the beta so hopefully I'm putting this in the right place. This seems to be where people are reporting bugs.

Bug:

When a color is change in the gradient flyout if you are using something other than linear it will change back to linear.

 

Example: If you are using a elliptical gGradient and than change a color it will turn into a linear gradient.

 

Hi RPC,

Welcome to the Affinity Forums. Thanks for the Gif and letting us know! This is a known issue that has been addressed by development and will be in the next beta.

Share this post


Link to post
Share on other sites
2 hours ago, Sean P said:

Hi RPC,

Welcome to the Affinity Forums. Thanks for the Gif and letting us know! This is a known issue that has been addressed by development and will be in the next beta.

Nice! This bug drives me crazy :D

Share this post


Link to post
Share on other sites
On 10/2/2017 at 2:24 PM, rubs said:

Is it possible to explain the criteria chosen for the fixes? I see a couple ones that were recently posted (which is nice), but there are a myriad important problems that need urgent fixes. For example, Save As and other Save / Open dialogs still don't remember locations adequately. This is absolutely non-standard in Windows and incredibly annoying. It's quite a simple fix, but remains to be done despite requests from many users.

 

Thanks.

Hi rubs, 

We're currently working on this - expect a fix in the next (or next again) beta. 

Jon

 

Share this post


Link to post
Share on other sites
9 minutes ago, Jon W said:

Hi rubs, 

We're currently working on this - expect a fix in the next (or next again) beta. 

Jon

 

 

Thanks for answering! Looking forward to it.

Share this post


Link to post
Share on other sites
26 minutes ago, rubs said:

Hi,

What about this? Just select all objects then group them -- some objects will disappear (in fact they are moved to outside the artboard). No constraints are used whatsoever. Will this be fixed soon? Thanks.

 

Bug - objects disappear when grouping.afdesign

This is a known issue that is with development to fix. I've passed your file onto development.

Share this post


Link to post
Share on other sites

Hi, 

Thanks for the latest Beta version...fantastic effort as usual by the Affinity Team....I am impressed!  It's getting harder to find obvious bugs...well..with this version :)

 

But....There is this little event....

I have been using it this week to do some 'inking' with the stabiliser tool. but when I import a file (PSD output from Sketchbook Pro 8.50) I keep getting a 'temporary' visual rectangle on the screen.. It's occurred 3 times in last 2 days. It can be Black or White as in the sample attached. Switch to Outline mode and it's gone... 

square.JPG


APh & AD 1.7.1.445 + Beta AD 1.7.3.476 | APh 1.7.1.404 + Beta AP 1.7.3.476
APu 1.7.1.404 +Beta Apu 1.7.3.475

OS:Windows 10 Pro 1903 OS Build 18362.365
Rig:AMD FX 8350 and AMD Radeon (R9 380 Series) Settings Version 19.09.2(Adrenalin 2019, 
Radeon Settings Version
19.1.1) + Wacom Intuous 4M with driver 6.3.35-3

 

 

Share this post


Link to post
Share on other sites
11 hours ago, Stuart_R said:

Hi, 

Thanks for the latest Beta version...fantastic effort as usual by the Affinity Team....I am impressed!  It's getting harder to find obvious bugs...well..with this version :)

 

But....There is this little event....

I have been using it this week to do some 'inking' with the stabiliser tool. but when I import a file (PSD output from Sketchbook Pro 8.50) I keep getting a 'temporary' visual rectangle on the screen.. It's occurred 3 times in last 2 days. It can be Black or White as in the sample attached. Switch to Outline mode and it's gone... 

 

Hi Stuart,
Does it occur every time you open the same PSD or is it very occasionally? Would you be able to attach an offending PSD please?

Share this post


Link to post
Share on other sites
2 hours ago, Sean P said:

Hi Stuart,
Does it occur every time you open the same PSD or is it very occasionally? Would you be able to attach an offending PSD please?

Hi Sean,

 

I have attached the working file (I did some more work on the file itself unfortunately..) The issue is intermittent and disappears when you toggle outline mode (easy work around). It has occurred on a couple of files...I have been trying to re-create it this morning without success. 

 

Current project workflow = Initial Sketch Sketchbook Pro (8.5 [recent update]); save as PSD (default SP save), open in Affinity Designer Beta. and occasionally you see the previous image upload on the screen (but the colour of the rectangle can change!) ...good luck with this one:)

 

inktober-06-sword2.zip


APh & AD 1.7.1.445 + Beta AD 1.7.3.476 | APh 1.7.1.404 + Beta AP 1.7.3.476
APu 1.7.1.404 +Beta Apu 1.7.3.475

OS:Windows 10 Pro 1903 OS Build 18362.365
Rig:AMD FX 8350 and AMD Radeon (R9 380 Series) Settings Version 19.09.2(Adrenalin 2019, 
Radeon Settings Version
19.1.1) + Wacom Intuous 4M with driver 6.3.35-3

 

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×