Jump to content
Mark Ingram

Affinity Designer Customer Beta - 1.6.0.76

Recommended Posts

Click here to download the latest beta
 
Status: Customer Beta
Purpose: New features
Requirements: A valid product key, issued when Windows Affinity Designer version 1.5 was purchased.

This is the third beta of a substantial change to our codebase and as much as we have tried to ensure the quality of the code, it is considered to be not suitable for production use. This means that you should not attempt to use it for commercial purposes or for any other activity that you may be adversely affected by the application failing. In addition it is definitely worth noting that files created in Affinity 1.6 may not open in 1.5 so always make a copy of your important documents before opening them in 1.6 to ensure you do not accidentally overwrite them and are unable to open them in your 1.5 version.

We hope you enjoy the latest build, and as always, if you've got any problems, please don't hesitate to post here and we'll get back to you as soon as we can. Thanks once again for your continued feedback.

If you have a general question about the software, please head over to the Questions Forum, or if you have any suggestions, please head over to the Feature Requests forum.
 
Fixes

  • Fixed document draw for display scales other than 100% and 200%
  • Changed Colour Picker "Presets" to "Radius" text
  • Fixed crash when attempting to open documents which we don’t understand
  • Reduced memory usage during selection refinement
  • Fixed stabiliser context bar options not updating when switching modes (thanks Aammppaa)
  • Fixed transforming objects leaving part of the original object position visible
  • Fixed crash when attempting to re-open a document which had failed to autosave
  • Added "Show All" and "Unlock All"
  • Added Russian translations
  • Fixed failure to load multiple image files at the same time
  • Fixed auto slices not moving when the parent objects move
  • Fixed Artboards to stop them adding their grids and guides if they are part of the selection that is to be transformed
  • Fixed snapping relative to Artboards
  • Added support for tablets being plugged/unplugged while the app is running
  • Fixed Print dialog has truncated text and list control
  • Fixed CMYK values being able to exceed 100%
  • Fixed Path text baseline control having wrong ranges
  • Fixed Character panel font type dropdown is not remembered when docked
  • Fixed files saved with selections are not reflected correctly when reopened
  • Improved line breaks for Chinese text
  • Fixed PDF import of clipped groups containing a single line of text
  • Fixed PDF import of vector clips
  • Fixed preview brush nozzles not representing the current tablet rotation/tilt/angle

Share this post


Link to post
Share on other sites
11 minutes ago, Mark Ingram said:

Added "Show All" and "Unlock All"

 

These are welcome new features, thanks. And it's a good thing we can assign keyboard shortcuts to them.

Share this post


Link to post
Share on other sites

Great to have a new beta. Thanks team Affinity :)


Win7 Ultimate x64   |   i5-3570K @ 3.4GHz   |   16 GB RAM   |   120 GB SSD   |   nVidia GTX 660 Ti   |   Huion 1060 Plus

How I make GIFs >>> ScreenToGIF (Windows only, Open Source, Portable, ~600kB)

Share this post


Link to post
Share on other sites

Hello, I am very happy with this great update, I see that a lot of errors have been solved, I update it and in the first instance it is more polished and fluid and more optimized: 3


_____________________________________________________________________________________________________________________________________

 

Dell Inspiron 7547 / S.O.: Windows 10 Pro Insider Preview Build 18329.19h1 / Intel(R) HD Graphics Family / Intel Core(TM) i7-4510u 2.0GHz 2.60GHz / 8Gb RAM

Share this post


Link to post
Share on other sites
1 hour ago, Mark Ingram said:

You should also notice the artboard bug you reported has been fixed :)

 

 

Great, thanks! Nice to know that.

Share this post


Link to post
Share on other sites

Do you guys know how to rotate the canvas using gestures on a tablet.

I am currently using the windows version in a Wacom MobileStudio Pro 16.

When I use the gestures, I am only able to scale the canvas, but it does not rotate.

I tried both 1.5 and the 1.6beta.

Please advise.

Share this post


Link to post
Share on other sites

Hi. Is the inverted art-board background color on both light and dark modes intentional? eg background turns dark when switching to light mode.


Core i5 3570 @ 3.4GHz    |     8GB Hyperx Memory      |      Radeon R9 270X     |    Samsung 120 SSD

Share this post


Link to post
Share on other sites

Text on Path was a bit better now.

Atleast I could move the start and end position before typing anything.

But sometimes it is still not possible to move the positions afterwards.

I just painted some (overlapping) circles and added Text on path to it.


System                                                              Notebook Lenovo P50

CPU: Intel i7-3770K                                        CPU: Intel i7-6700HQ

RAM: 16 GB                                                      RAM: 32 GB

GPU: GTX 1070                                               GPU: NVIDIA Quadro M2000M 4 GB

SSD: Samsung 840 EVO 250 GB                SSD: Samsung 850 Pro 500GB

OS: Windows 10 Pro x64                               OS: Windows 10 x64

TFT: 2 x Samsung SyncMaster P2450         TFT: 2 x Lenovo

Share this post


Link to post
Share on other sites

Sub-components of Boolean compounds can't be selected with Ctrl+Click on the page, but only by selecting in the Layers studio.

This is a regression since 1.5

 

Probably connected to previously reported bug > 

 

 


Win7 Ultimate x64   |   i5-3570K @ 3.4GHz   |   16 GB RAM   |   120 GB SSD   |   nVidia GTX 660 Ti   |   Huion 1060 Plus

How I make GIFs >>> ScreenToGIF (Windows only, Open Source, Portable, ~600kB)

Share this post


Link to post
Share on other sites

I'm struggling to understand the intended logic of the 'shift+drag' system in 1.6.0.75 to continue the last stroke aspect of the brush tool. It's too glitchy at moment I'm afraid and it makes it very hard to test to know what is going on. Here is what I end up with when I try to make straight lines, using shift to continue the line. It almost never respects the pressure sensitivity intended and I don't know when it is even working or not because it's so slow. Sometimes it doesn't show/register anything, and instead I was getting the windows sticky keys popup.  It works more consistently in 1.5.2.69, but you can see in the second image that it pretty much never acknowledges the 'end click' pen pressure properly, only the start, but then it clearly reads the pressure and shows it in the 'start' of the next line.

AFbeta 1_6_06_76 shift and drag.jpg

AF 1_5_2_69 shift and drag.jpg

Share this post


Link to post
Share on other sites

This is gonna be one of those things people are gonna look at me funny over, cuz it's such a little thing. But I just have to ask...

How difficult would it be for you all to use the standard Win10 minimize/maximize/close buttons in Designer and Photo? I'm used to the size and spacing of them, to the point I can hit them without even looking, plus it'll look more like it fits in better with the rest of the OS.

Yeah, I know. It's not a big deal, but I just gotta ask.

 

 

 

Share this post


Link to post
Share on other sites
3 hours ago, awan said:

Dude? where is print button? :D

 

Hi awan, this has been fixed for the next build. You can press TAB to get around to the OK button, then hit ENTER, as a work around (though you might accidentally hit Cancel by mistake...).

Share this post


Link to post
Share on other sites
On 24.7.2017 at 11:47 PM, Renzatic said:

This is gonna be one of those things people are gonna look at me funny over, cuz it's such a little thing. But I just have to ask...

How difficult would it be for you all to use the standard Win10 minimize/maximize/close buttons in Designer and Photo? I'm used to the size and spacing of them, to the point I can hit them without even looking, plus it'll look more like it fits in better with the rest of the OS.

Yeah, I know. It's not a big deal, but I just gotta ask.

 

 

 

 


 

 

Share this post


Link to post
Share on other sites

Internal consistency is one of the nicest things about MacOS, yeah. It's not enough to drive me to switch platforms, but seeing how nice things are over on the other side of the fence does occasionally make me a little jealous. :P

 

 

 

Share this post


Link to post
Share on other sites
3 hours ago, Renzatic said:

Internal consistency is one of the nicest things about MacOS, yeah. It's not enough to drive me to switch platforms, but seeing how nice things are over on the other side of the fence does occasionally make me a little jealous. :P

 

 

 

don't worry, it is not perfect either 

\DEtMhkaUwAETAUs.jpg


 

 

Share this post


Link to post
Share on other sites

At least they're the same three circles, always the same size, and grouped together with the same spacing between them.

...wow. I just realized I'm a UI nerd!

 

Share this post


Link to post
Share on other sites

Good to see the beta process continue but still no sign it seems of the brush crosshair/'always on' brush preview problems being addressed. It has to be said that despite this being raised fairly consistently for a few months, I've yet to see an acknowledgement from the Affinity team that this problem is even one being replicated elsewhere; all I can say is that is it present on both my workstation and laptop and they share completely different architecture, so I can only assume that it is an issue experienced by others.

It's a real shame as it is one of the potential killer abilities of Designer over Illustrator - really the first vector software to have a genuine, natural media function like this since CH's Expression, and of course the brush engine here is so much more promising - but in its current state - for me anyway - is unusable. Two questions, really:

  • is this a recognised problem
  • is it on the roadmap for a fix

Thanks

Share this post


Link to post
Share on other sites

Hi Whitehead,

This issue is known and with development to fix, so the answer to both of your questions is Yes! It seems to be that any texture brushes that contain only one texture (Effects > Effect 2 for example) will show the preview instead of the cursor, but Texture brushes that contain more than 1 texture (Effects > Effect 4 for example) will show the cursor. Regular round brushes do work as intended, however.

Share this post


Link to post
Share on other sites
On 2017-7-22 at 8:14 PM, af-user said:

Text on Path was a bit better now.

Atleast I could move the start and end position before typing anything.

But sometimes it is still not possible to move the positions afterwards.

I just painted some (overlapping) circles and added Text on path to it.

 

I've placed the text on a ellipse shape and I cannot drag the text placement controllers. On other paths I sometimes can move the controllers but I loose the ability to adjust them at some point, too.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×