Jump to content

Affinity Photo Public Beta - 1.5.0.44 (RC)


Recommended Posts

  • Moderators

Click here to download the latest beta

Status: Release Candidate
Purpose: Stability
Requirements: None

As this is a beta release, it is considered to be not suitable for production use. This means that you should not attempt to use it for commercial purposes or for any other activity that you may be adversely affected by the application failing. In addition it is worth noting that files created in Affinity Photo 1.5 cannot be opened in Affinity Photo 1.4, which means that they cannot be opened in the latest Mac App Store version of Affinity Photo, and instead you will need the latest macOS 1.5 beta.

We hope you enjoy the latest build, and as always, if you've got any problems, please don't hesitate to post here and we'll get back to you as soon as we can. Thanks once again for your continued feedback.

If you have a general question about the software, please head over to the Questions Forum, or if you have any suggestions, please head over to the Feature Requests forum.

Fixes

  • Fixed Alignment tools breaking after customizing the toolbar
  • Fixed loading TIFF files as RAW from OnOne
  • Fixed PSD 32-bit mask
  • Changed Develop to gamma-correct with more precision
  • Changed HSL based adjustments to use more precision
  • Fixed releasing Alt when dragging a Levels Adjustment slider doesn't revert the image
  • Fixed Denoise dialog missing entry boxes
  • Fixed performance problems when creating multiple views of the same document
  • Fixed Outer shadow rendering
  • Added missing Colour picker from Bevel / Emboss layer effect
  • Added missing File > New... menu items to Panorama Persona
  • Fixed Increase/Decrease Brush Size shortcuts are not retained when the application is restarted
  • Fixed loading images with EXIF DPI set to 1
  • Added noise reduction to HDR merge
  • No longer add snapshots for initial Focus/HDR merge and panorama stitch
  • Reduced tone mapping memory footprint
  • Fixed Live Depth of Field Mode drop down always set to Elliptical when re-opening dialog
  • Added Create Palette from Image
  • Fixed Save is not initially disabled with an unmodified file
  • Fixed rotating the healing brush with keyboard doesn't update context toolbar
  • Fixed The Clipping buttons appear to be on after clicking Develop in Develop Persona
  • Fixed crash when using preferences shortcut in Develop Persona
  • Fixed Preferences missing from Edit menu in some Personas
  • Improved handling of Type 3 fonts (which still aren't supported)

Installer

  • Fixed application not appearing in Explorer's "Open With" menu
Link to post
Share on other sites

We already have RC? That's fast.

Rig:Board: GigaByte Z97X-Gaming 3 ,CPU: Intel Core i7-4790K CPU @ 4.00GHz, GPU: GeForce GTX 970, RAM: 16 GB / 2 x Crucial BLS8G3D1609DS1S00 8GB DIMM DDR3 PC3-12800U DDR3-1600 (9-9-9-24 5-39-12-6), Display: ACI VS248 24" 1920x1080, 60Hz, OS:Microsoft Windows 10 Pro x64, Main HDD: ADATA SP900 (256GB, SATA600, SSD), driver always up to date. :)

Link to post
Share on other sites

Woah! We are reaching the first Release for Windows.

 

Waiting to buy it!

You'll never know what you can do until you get it up as high as you can go!   

AMD FX 8350 :: Radeon HD 7870 :: Windows 10 ::  http://mithferion.deviantart.com/

Oxygen Icons :: Free Quality Fonts :: Public Domain Pictures :: iOS 11 Design Resources :: iOS App Icon Template :: Hot to do High Quality Art :: Mesh Warp / Distort Tool Considerations

Link to post
Share on other sites

 

Fixes

  •  
  • Fixed loading TIFF files as RAW from OnOne

 

Just to let you know this issue with ON1 isn't solved, the big issue here is that it produces TIFF images that aren't flattened. If you take the TIFF image into, say PS, and flatten it it is OK to open otherwise it opens like in this screen copy:

post-41030-0-99388100-1481031445_thumb.jpg

Win 10 x64 System with Intuos Pen & Touch
 - Sys : Intel® Core™ i7-7700HQ CPU @ 2.80GHz (8 CPUs), 16GB RAM
 - GPU 1: Intel HD Graphics 630, GPU 2: NVIDIA GTX1050, 4GB

iPad (8th Gen) 2020

 

Link to post
Share on other sites
  • Moderators

Just to let you know this issue with ON1 isn't solved, the big issue here is that it produces TIFF images that aren't flattened. If you take the TIFF image into, say PS, and flatten it it is OK to open otherwise it opens like in this screen copy:

 

Can you upload that image, and we'll take a look. If it's too big, you can upload to Dropbox or something and give me a link.

Link to post
Share on other sites

Can you upload that image, and we'll take a look. If it's too big, you can upload to Dropbox or something and give me a link.

 

Hi Mark, 

 

Try this image as it is another generated by ON1 with the same problem (small at 93MB) - https://www.dropbox.com/s/69eo1qunuxqyhkw/Treated%20as%20RAW%20-%20ProPhotoRGB.tif?dl=0 

 

This other is 168MB but I can upload it if you need another.

 

BTW just to mention that the PSD's generated by ON1 work fine.

Win 10 x64 System with Intuos Pen & Touch
 - Sys : Intel® Core™ i7-7700HQ CPU @ 2.80GHz (8 CPUs), 16GB RAM
 - GPU 1: Intel HD Graphics 630, GPU 2: NVIDIA GTX1050, 4GB

iPad (8th Gen) 2020

 

Link to post
Share on other sites
  • Moderators

Hi Mark, 

 

Try this image as it is another generated by ON1 with the same problem (small at 93MB) - https://www.dropbox.com/s/69eo1qunuxqyhkw/Treated%20as%20RAW%20-%20ProPhotoRGB.tif?dl=0 

 

This other is 168MB but I can upload it if you need another.

 

BTW just to mention that the PSD's generated by ON1 work fine.

 

Thanks, I've added in an extra fix for this.

Link to post
Share on other sites

Thanks, I've added in an extra fix for this.

 

Hi Mark,

 

Will you flatten it on save, it would be better as ON1 doesn't care if it is flattened or not? Many other apps don't read their style of TIFF.

Win 10 x64 System with Intuos Pen & Touch
 - Sys : Intel® Core™ i7-7700HQ CPU @ 2.80GHz (8 CPUs), 16GB RAM
 - GPU 1: Intel HD Graphics 630, GPU 2: NVIDIA GTX1050, 4GB

iPad (8th Gen) 2020

 

Link to post
Share on other sites

RC and i still have the same bug with Wacom Intuos. Are you looking into this problem ?
I have this line in the Log file

"WinTab: Failed to get tangent pressure info"

 

My Wacom works perfectly with other raster and vector softwares. I downloaded lates drivers for it, I don't think problem lies on my side.
Does anyone else experience a one second delay every time when starting new stroke with Wacom Intous in Affinity Photo ?

Link to post
Share on other sites

The cursors for the Text Tools still don't show the cross clearly at 100% zoom (and the same applies to those tools and the Artboard Tool in the 1.5.1.43 release build of Designer).

 

Edited to add: Although the 'Preferences...' option is no longer missing from the Edit menu in any of the Personas, it still has no default shortcut in the Photo Persona.

Alfred online2long.gif
Affinity Designer/Photo/Publisher for Windows 1.9.2 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.9.2 • Designer for iPad 1.9.2 • iPadOS 14.4.2 (iPad Air 2)

Link to post
Share on other sites

on this new beta (1.5.0.44) Nik Collection Analog efex and Color efex do not open . Error 1114 loadlibrary fail. I remove the plugin from the preferences and wait for a fixed release

OS: windows 10 home 64 bits
Lenovo core I7 6700HQ
8Gb Ram
Nvidia GTX 950 4 gb Memory

SSD 256Gb

HD 1TB 5400 rpm

Link to post
Share on other sites

Thanks for this update... but I can't get the Rectangular Marquee Tool to work anymore.

-- Window 10 - 32 gb - Intel I7 - 8700 - NVIDIA GeForce GTX 1060
-- iPad 2020 - 12,9 - 256 gb - Apple Pencil 2 -- iPad 6th gen 128 gb - Apple Pencil 1

Link to post
Share on other sites

Thanks for this update... but I can't get the Rectangular Marquee Tool to work anymore.

 

The Freehand Selection Tool isn't working for me, but the Rectangular and Elliptical Marquee Tools seem to work fine.

 

Edit: I've just discovered that the Freehand Selection Tool was in 'Subtract' mode. paperbag.gif

Edited by Alfred

Alfred online2long.gif
Affinity Designer/Photo/Publisher for Windows 1.9.2 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.9.2 • Designer for iPad 1.9.2 • iPadOS 14.4.2 (iPad Air 2)

Link to post
Share on other sites
  • Moderators

on this new beta (1.5.0.44) Nik Collection Analog efex and Color efex do not open . Error 1114 loadlibrary fail. I remove the plugin from the preferences and wait for a fixed release

 

Hi sduccio,

Welcome to Affinity Forums :)

Both plug-ins are working correctly for me in 1.5.044. Can you try to restart Affinity Photo and check again please?

Link to post
Share on other sites

on this new beta (1.5.0.44) Nik Collection Analog efex and Color efex do not open . Error 1114 loadlibrary fail. I remove the plugin from the preferences and wait for a fixed release

Not seeing that here, using the latest (RC) version, both open and work fully, although the plug-ins display of portrait images is still rotated through 90 degrees!  :huh:

Win 10 Pro, i7 6700K, 32Gb RAM, AMD Radeon R7 360 and Intel HD530 Graphics

Long-time user of Serif products, chiefly PagePlus and PhotoPlus, but also WebPlus, CraftArtistProfessional and DrawPlus.  Delighted to be using Affinity Designer, Photo, and now Publisher.

iPad Pro (11") running Affinity Photo and Designer (iOS 14.5)

Link to post
Share on other sites

When trying to use an 'Invert Hue' HSL adjustment to recolour the petals in the image from this thread, I got the result shown in the attached screenshot.

 

post-8358-0-70154400-1481039821_thumb.jpg

Alfred online2long.gif
Affinity Designer/Photo/Publisher for Windows 1.9.2 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.9.2 • Designer for iPad 1.9.2 • iPadOS 14.4.2 (iPad Air 2)

Link to post
Share on other sites
  • Moderators

Dropping a 32-bit HDR image about 911MB and res 21604 X 10802 into this version (and previous versions), I get unhandled Exception Code 0xC0000005

 

In general the app seems slow and unstable with highres 32bit images

 

Can you upload the image to Dropbox? Even though it's a massive image, it should still be able to load it without running out of memory (which I suspect is what is happening).

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.