Jump to content
MattP

Affinity Designer Customer Beta (1.6.1 - RC1) [Now Released]

Recommended Posts

This beta cycle has ended and this release candidate build is now the retail MAS version 1.6.1

Status: Release Candidate

Purpose: Improvements, fixes

Requirements: Purchased Mac Affinity Designer [from Mac App Store]

Mac App Store: Submitted

Download: Download from Here

 

To use this beta, simply download the file from the link given above and double-click on the file to open the installer. Follow the instructions to install the beta version. The beta sits alongside the Mac App Store version and will not interfere with it.

 

This beta is an iteration of the current App Store release and should be used in preference to the App Store release, if you are affected by any of the issues listed below.

 

Fixes/Improvements:

  • Improved Pressure response in pixel tools.
  • Fix for 3D profile crash and Blend Ranges dialog crash.
  • Fix for missing Place Image Tool icon.
  • Fixed Korean Hangul text entry.
  • Vector export improvements.
  • Fix for failures when using compound objects inside groups with Constraints set on them.
  • Font support improvements - specifically relating to fonts which substitute spaces or have truncated Unicode CMAP tables.
  • Transparent TGA import support + misc TIFF loading fixes.
  • Fix for deleting a node of a bitmap fill causing crash.
  • Improved pixel painting smoothing. Any pixel-based painting tools should now have better smoothing by default.
  • Fix for combo boxes causing crashes for certain users on High Sierra.
  • Fix for exporting JPEG automatically choosing to export clips as paths which is a poor default and causes confusion.
  • Fix for text objects being created outside the hierarchy of the artboard they were supposed to be created in.
  • Fix for rotated text bounding boxes being incorrect and for disappearing text following Power-Duplicate.
  • Fixed sporadic hanging when opening many image files at once.
  • Fixed crashing bug when exporting certain large PSDs.
  • Fixed a number of UI memory leaks.
  • Added special case PSD import code for “SketchClub” PSD files (they should fix this!).
  • Fixed PSD export of Fill layers.
  • Fixed UI labels on macOS versions prior to Mavericks.
  • SVG import can now handle gradients with missing x1 or y1 values.
  • Assorted PDF export improvements.
  • Localisation improvements.
  • Paste and file-drop of PDF format files will now honour the DPI, as per File->Place.
  • Fix for marching ants not showing on a rotated canvas.
  • Miscellaneous other fixes and tweaks.

Share this post


Link to post
Share on other sites

NICE! Thanks yet again. We truly love the Affinity eco-system. 


17"-inch MacBook Pro,  Mid 2011, 2.3 GHz Intel Core i7

Share this post


Link to post
Share on other sites

Hi,

Please I have a problem with export EPS, I have 4 Page in my document and AD create 1 file in export EPS why? I prefer 4 file in export.

 

Tks for all

Thierry

Capture d’écran 2018-02-01 à 11.07.39.png

Share this post


Link to post
Share on other sites
27 minutes ago, ThierryMbp15 said:

Hi,

Please I have a problem with export EPS, I have 4 Page in my document and AD create 1 file in export EPS why? I prefer 4 file in export.

 

Tks for all

Thierry

Capture d’écran 2018-02-01 à 11.07.39.png

I don’t believe this is a regression with 1.6.1 - it has always done this. You can use export persona to divide this into 4 separate exported eps files if that’s what you wish - right now, Designer doesn’t support ‘pages’ as such, so what results you get with ‘artboards’ is really up for debate :)

Share this post


Link to post
Share on other sites
2 hours ago, A_B_C said:

You mean the purple frames? These are snapping candidate indicators, and you can get rid of them by unchecking Show snapping candidates on the Snapping Panel:)

 

Snapping-Candidates.png.04a218b96bdab78e3708593d4e3c398a.png

@A_B_C thank you :)  Danke Dir, jetzt bin ich wieder beruhigt !!!


MacBook Pro, iMac, Sierra 10.12.6

500px.com/maxxxworld

www.instagram.com/markus_linner

Share this post


Link to post
Share on other sites

Thanks for you reply,

 

I export with persona but I have to manually rename slices, is there a variable that retrieves the name of the import file?

Im French my English is not nice school is far ;-)))))

 

Thierry

 

Share this post


Link to post
Share on other sites
51 minutes ago, ThierryMbp15 said:

Thanks for you reply,

 


I export with persona but I have to manually rename slices, is there a variable that retrieves the name of the import file?

Im French my English is not nice school is far ;-)))))

 

Thierry

 

Hi, sorry but I don't think Export Persona has a variable available for the document name at the moment, if that's what you mean? Your English is much better than my French, so please don't apologise at all! :)

 

Thanks again, Matt

Share this post


Link to post
Share on other sites

Huge bugs to fix with 1.6 and beta 1.6.1, and it is not the first time... I start to think to go back to illustrator which works well, cost too much but at least I can put food on the table with it.

I am on MacBook Pro 2016, High Sierra, amd pro... 

When I am working on a second monitor there is a glitch that make a lot of my items that I draw disappear or glitch. Here's 2 screenshots, 1st on my main monitor MacBook and the other on my 32" monitor on which I want to work like any professional...

I am sorry to be annoying or impolite, but you seriously can't sell a software with a bug as big as that...

Capture d’écran 2018-02-21 à 16.17.48.png

Capture d’écran 2018-02-21 à 16.18.27.png

Share this post


Link to post
Share on other sites

I can confirm I see the same glitches as G.M.1986 when using a secondary display (non-retina) on my MBP 2013 (retina), macOS 10.12.6. It happens most often when reconnecting the display while AD is running. It is a little annoying, but closing and reopening the misbehaving document usually resolves the issue.

 

Another, probably related glitch, is the content of the document being suddenly rescaled to 1/4 of its size (1/2 height, 1/2 width) on the external display, and being impossible to rescale to any other size. The solution is, here also, to close and reopen the document.

Share this post


Link to post
Share on other sites
11 hours ago, G.M.1986 said:

I am sorry to be annoying or impolite, but you seriously can't sell a software with a bug as big as that...

Uhm… you realize that you’re currently testing a beta version, right? Nobody is selling it like this, and reporting bugs is why this thread here exists in the first place. The point is to get it working to a point where it can actually be released. You’d do a better service by just reporting issues and not adorn your posts with such unconstructive comments.

Share this post


Link to post
Share on other sites

The wacom line glitch on raster brushes, which created jagged lines and weird pressure readings seams to have improved. Thanks a lot, as it really made affinity designer unusable for me!

Share this post


Link to post
Share on other sites

I may be confused, but I seam to remember there was a way to link the brush and eraser (and other brush tools) so when you switched between it kept the same brush and brush size. Can this be switched on?

Share this post


Link to post
Share on other sites

Apple is really taking its time to release the app into the store.  I hope they are not being difficult and asking for further modification.

Share this post


Link to post
Share on other sites
On 19.2.2018 at 3:05 PM, MattP said:

Assorted PDF export improvements.

Unfortunately the font embedding issue I reported previously isn’t fixed yet. And also unfortunately it appears randomly and I don’t know any way to reliably reproduce it. Sometimes fonts are embedded, sometimes they aren’t. Sorry, I can’t be of any more help. :(

Share this post


Link to post
Share on other sites
1 hour ago, andremacola said:

Subtract Shapes not working properly. See the video and the file attached for example. The same vector layers works fine on Sketch.

bug480.mov

bug.afdesign

I tested, and yes there's  a bug on the latest AD 1.6.1 from the apps store. I  also have a copy of AD 1.6.0 and the substract shape is working.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×