Jump to content
MattP

Affinity Designer Customer Beta (1.5 - Beta 10)

Recommended Posts

Status: Beta Release

Purpose: New features, fixes

Requirements: Purchased Affinity Designer

Mac App Store: Not Submitted

Download: 1.5 Beta 10 Here

 

 

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

PLEASE BE AWARE - If you have not already run Beta 9, this version will reset all your settings. If you have already run Beta 9 then it will not. Please make sure that if you have created any palettes, styles, assets, brushes, etc in the current beta that you export them in the current version first BEFORE installing this beta otherwise you will lose them. This was unfortunately necessary for the Beta 9 build and should hopefully not be required again.

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

 

 

 

This is a beta of a substantial change to our codebase and as much as we have tried to ensure the quality of the code, it should be considered to be not suitable for production use. This means that you should not attempt to use it for commercial purposes or for any other activity that you may be adversely affected by the application failing. In addition it is definitely worth noting that files created in Affinity 1.5 cannot be opened in 1.4 so always make a copy of your important documents before opening them in 1.5 to ensure you do not accidentally overwrite them and are unable to open them in your 1.4 version.

 

To use this beta, simply download the file from the link given above and double-click on the file to open the installer. Follow the instructions to install the beta version. The beta sits alongside the Mac App Store version and will not interfere with it.

 

Fixes/Improvements:

  • Fix for Assets not snapping on the document as they are dragged out of the Assets panel
  • Fix for measurements not working on documents with Artboards
  • Fix for measurements stopping users from being able to resize about center in the Move Tool
  • Fix for boolean geometry operations failing on many trivial cases
  • Fix for incorrect cursors in Shape tools
  • Fix for Zoom Tool not zooming about the point you dragged from!
  • Fix for Assets with non-RGB8 data drawing strangely in the Assets panel
  • Fixed 'Print Ready' documents accidentally defaulting to Grey/16 colour format
  • Fix for Artboards with constraints applied causing mayhem
  • Added ability to drag Opacity label in layers panel to change its value
  • 'New from Clipboard' now sets the new document to dirty so it prompts on closing
  • Use DPI information from placed images/embedded documents to place them at their correct physical size
  • Miscellaneous other small fixes

Share this post


Link to post
Share on other sites

CAN´T BELIEVE THIS IS HAPPENING!!!!

>>>>> one CAN drag the "opacity" label to change the opacity of layers  :D :D :D

+ dropping stuff into assets and symbol panels

+ might we get the docking of two columns of tool panels to the right (and left) side like possible in AD for Windows?

 

+ Bleed preview, linked bleed values

 

 thanks for the update!   :lol:

 

so what´s your opinion on the state of this AD release?  :lol: judging from your profile picture you seem to be happy  :lol:


 

 

Share this post


Link to post
Share on other sites

 

so what´s your opinion on the state of this AD release?  :lol: judging from your profile picture you seem to be happy  :lol:

 

 

Definitely getting there, but we still have a way to go to make it a solid release. My cat definitely seems happy at the moment - he often spends his evenings sitting on top of my keyboard demanding to be fussed and stopping me working! ;)

Share this post


Link to post
Share on other sites

I may be a bit behind the curve here, but noticed the dropper tool is now BADASS. Great work guys.

 

One thing I'd love to see, which has been niggling at me for forever is up and down arrow being able change all number box values (font size specifically) it's a bit of polish and a really long term issue. :D

Share this post


Link to post
Share on other sites

Just wanted to give thanks for all the hard work the Affinity team is putting in. Its truly appreciated. I so glad that the Affinity Eco-system is coming together.

FAN FOR LIFE! NO DOUBT!


15"-inch MacBook Pro, 2017, 2.9GHz Intel Core i7 | 16Gb

Share this post


Link to post
Share on other sites

The default set of bevel profiles in the FX panel is not working properly. There is little to no change when you go from a linear profile to the fully rounded profile. The fully rounded should look like the it would when you tick Remove Profile. As it is now the round  profile gives a straight bevel plateau like the linear. Please take a look.

Share this post


Link to post
Share on other sites

The default set of bevel profiles in the FX panel is not working properly. There is little to no change when you go from a linear profile to the fully rounded profile. The fully rounded should look like the it would when you tick Remove Profile. As it is now the round  profile gives a straight bevel plateau like the linear. Please take a look.

This is working fine for me.

 

Check that you don't have soften set too high, because then you won't see much of a difference between each profile.

Share this post


Link to post
Share on other sites

the document is still moving to the left by a good amount each time one switches persona view.

Ah, this is if you've got the Assets panel open (or anything else docked to the left) - we'll get that sorted, thanks.... :)

Share this post


Link to post
Share on other sites

Ah, this is if you've got the Assets panel open (or anything else docked to the left) - we'll get that sorted, thanks.... :)

i have half of the panels docked to left side and the other half is docked to the right. on the left side is the assets panel (also) but the layers panel is in front.

Share this post


Link to post
Share on other sites

weird UI stuff for swatches on Sierra.

 

Hi 00Ghz,

 

I'm not seeing this on the Sierra machine. Do you have a recipe how it happened? Are you on the latest Sierra?

 

A

 

Edit: We are using 10.12 build 16A294a

Share this post


Link to post
Share on other sites

 

  • Use DPI information from placed images/embedded documents to place them at their correct physical size

@mattP, thanks so much for fixing this! Indeed, when importing pdfs using the "Place" command they now get imported at the correct physical size, which is great! The instance in which the old behavior still persists is when importing them via drag&drop, but for me personally that's not a big issue.

Thanks again for taking the time to fix this!

 

EDIT: I just realized the problem also persists when directly selecting vector elements in another application (in my case Graphpad Prism) and then importing these into AD via paste. If you could align that behavior with the now revised Place command that would be greatly appreciated.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×