Jump to content
AdamW

Affinity Publisher Public Beta - 1.7.0.192

Recommended Posts

Please Click here to download the latest beta for macOS

Status: Public Beta
Purpose: Stability and General Testing
Requirements: Mac OS 10.9 or above

Hi, Affinity Publisher build 192 is now available on auto-update and as a manual download from the link above.

As this is a beta it is considered to be not suitable for production use. This means that you should not attempt to use it for commercial purposes or for any other activity where you may be adversely affected by the application failing, including the total loss of any documents. 

We hope you enjoy the product, and as always, if you've got any problems installing or running up, please don't hesitate to post in this thread.

Any problems actually using this version please make a new topic in this forum and we'll get back to you as soon as we can. Please feel free to leave general suggestions and comments in the Discussion Forum. Many thanks for your continued feedback.

---

Updates and Fixes

General Menus / Studio
(Mac) Fixed Mojave rendering issue when editing certain context toolbar controls
(Mac) Fixed issue changing unit spinners on docked panels
(Mac) Changing the UI gamma now works in Mojave
(Mac) General fix for tabbing within UI tables on panels
(Mac) Disabled mouse wheel (but not trackpad) scrolling for certain panels due to conflict with mouse wheel behaviour on individual controls
(Mac) Fixed Guides Manager not populating with the current document's guides when first shown
(Mac) Fixed Effects Panel not changing background when scheme changes in Mojave
(Win) Fix for Colour Panel's colour picker being offset from cursor position
(Win) Fix for modifier keys not being shown in tooltip for tool shortcuts on Preferences dialog
Updated some shortcut keys

New / Open / Save
Fixed 'Actual Size' zoom dropdown on Document Setup dialog
Fixed overflow issue loading huge JPEG files
Fix for fonts being replaced on PDF Import when not requested
(Win) Fix for app locking up after exporting to external drive if drive removed

Main View
Fix for 'Show Grid' etc UI occasionally becoming out of sync with the setting in force in the view
(Mac) Fix for possible view tiles not drawing on switching documents

Pages
Fixed column guides not being assigned from master page when adding a page
Added an option to auto-scroll the Pages Panel with the main document view
Fixed issues with master page renaming
(Win) Pages tab now auto-scrolls on drag reorder
(Mac) Fixed issues entering a section name for the first document section

Picture Frames
(Mac) Fixed images dragged in from Finder not honouring placement policy
Fix for place panel not reappearing after changing tool then undoing
Double Clicking on a Picture Frame now reselects tool
Fixed Lock Children not functioning for Picture Frames
Fixed Picture Frames and multiple children being marked as content
Fixed Picture Frame furniture displaying in Preview Mode

Text
Fixed some story key bindings, (Cmd+) Home / End,  Cmd+ Up / Down
(Mac) Fix for pasting from Excel into multiple table cells
Letter spacing now applies to spaces as well as other characters
Fix for letter and word space maximums not being honoured for 'Justify All'
- Note there is still a UI bug here on Windows
Fix for Greek uppercase and tonos
(Mac) Fix for Text Frame panel / Balance text columns not updating
Fix for possible text disappearing into overflow when 'Balance Columns' is used
(Mac) Fixed pasting characters into Bullet Text not being committed
(Win) Fix for rendering of certain bullet glyphs in Bullet Text field
(Mac) Fixed Draw highlight for Special Characters in Bullet Text field
Reverted width of Thin Space to be more standard
Fixed 'Show Special Characters' for hair space and medium mathematical space
Fixed Find and Replace character style does not correctly apply when also replacing text
Fixed Find and Replace All crash
Fixed Find and Replace on master page crashing after undo / redo
Fixed Find in Glyph Browser when Glyphs or Alternates were shown
Fixed Glyph Browser lock icon to more accurately reflect the state of the Panel

Adjustments / Effects
(Win) Upgraded to new shadows and highlights filter
(Mac) Fixed HSL Control crash / redraw on non-retina displays

Export / Printing
Fix for masks in embedded documents not being exported to vector formats / PDF
Fix for incorrect colours in bleed area when exported to Vector / PDF
Fixed issue with dashed / dotted lines showing hairlines on PDF export
(Win) Fix for curves printing incorrectly
Fix for potential issue when generating palletised PNGs for use in PDF Export
Fix for crop marks missing for N-Up Printing
(Win) Fix for potential crash when crop marks would be displayed outside of the print preview control's area
(Win) Fix for PDF failing to export when 'Preview export' is selected
Fix for 'Preflight check' warning about overflow in hidden text

---

Earlier Release Notes Beta 174

Share this post


Link to post
Share on other sites

Thank you for this update. :)

I don’t know if that’s a bug, therefore I just post it here. Is it intended that all the standard sliders have a blue highlight that is different from the one in the current app store versions?

Sliders.png.0c730d9fd6de2588d838f2ee492fe435.png

Also I see different highlights within Publisher itself. So … hmm … that must be a bug. Feel free to move my post to a different forum.

Highlights.png.0cfad80fd217c997371e806812ea8f2a.png

Edited by A_B_C
Found another instance … hmm …

Share this post


Link to post
Share on other sites
44 minutes ago, A_B_C said:

[...] Is it intended that all the standard sliders have a blue highlight that is different from the one in the current app store versions?

Also I see different highlights within Publisher itself. So … hmm … that must be a bug. [...]

Hi, I'd suggest the inconsistencies are fallout from the Mojave update and new 'modes'. People are working on it. :)

Share this post


Link to post
Share on other sites

Probably a minor bug left over from the 133 build: the Rotate anticlockwise in plane button once again appeared in the main toolbar after installing this 192 build. I am not sure about this but I think it replaced the multi-function "Alignment" button in my slightly customized toolbar.

Easily fixed by dragging the 'in plane' button off the toolbar & replacing it with the Alignment one.


Affinity Photo 1.6.7 & Affinity Designer 1.6.1; macOS High Sierra 10.13.6 iMac (27-inch, Late 2012); 2.9GHz i5 CPU; NVIDIA GeForce GTX 660M; 8GB RAM
Affinity Photo 1.6.9.81 & Affinity Designer 1.6..2.24 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iOS 12.0

Share this post


Link to post
Share on other sites

When Publisher is fully released and available, how will the upgrade be handled for all of the now Beta users.  I'm concerned that if I install the Beta software now I may have conflict when going to the Apple Store for product.  Please explain the process.  Thanks.

Share this post


Link to post
Share on other sites

Impressive list! Thank you!
(It's more for your self-check and you don't expect me to have it in mind before any posting, – right?)

 

8 hours ago, AdamW said:

Fix for 'Preflight check' warning about overflow in hidden text

Preflight? – Can any preflight be triggered by the user, too?

 

Can I install two different beta versions - or do they conflict with each other / override shared data?


macOS 10.12.6,  Macbook Pro 15" + Eizo 24"

Share this post


Link to post
Share on other sites

Because I suspect this message only appears because of the app-update when opening an existing document I post it at this topic.

  837662927_missingrecources-1.jpg.84afee1f671ac5177cc19c20d6df573a.jpg   >>    1733426749_missingrecources-2.jpg.acf569b7ace0171748a3a3fcd7605298.jpg

I have never called or knowingly used a file called "Image Mask 1.jpg".

p.s.: I am glad to notice that "linked" starts to fight against "embedded" successfully :)

 

EDIT: Solved – Please excuse these quick posting. It is not related to the app-update.
The missing image was a placed screenshot I meanwhile discovered in Recource Manager.


macOS 10.12.6,  Macbook Pro 15" + Eizo 24"

Share this post


Link to post
Share on other sites
10 hours ago, thomaso said:

Fix for 'Preflight check' warning about overflow in hidden text

Hi thomaso,

We do a few simple checks before print or export - checking for overflowing text, and that TOC and Index are up to date. It's not really a 'feature' yet. 

Share this post


Link to post
Share on other sites
7 hours ago, thomaso said:

Can I install two different beta versions - or do they conflict with each other / override shared data?

If you copy the folder before you run the new install you can have both versions side by side and run either one OR the other (not concurrent). They share application data but tend to be backward compatible except when it comes to things like new toolbar buttons.


Patrick Connor

Serif (Europe) Ltd.

Share this post


Link to post
Share on other sites
10 hours ago, CreativePW said:

When Publisher is fully released and available, how will the upgrade be handled for all of the now Beta users.  I'm concerned that if I install the Beta software now I may have conflict when going to the Apple Store for product.  Please explain the process.  Thanks.

Welcome to the Serif Affinity forums :)

The Public beta is not the same install as the purchase version (whether bought direct from us or from the Mac App Store). Consequently there is no conflict because there is no shared data between them (you could export any customised settings (keyboard shortcuts etc) from the beta across to import into the purchased one if you wish). You files created in the betas should all load into the released version, unless we specifically announce during the beta that we have found a problem with a feature that stops this being possible (we are trying hard to avoid that situation). 

The Public beta will stop working shortly after launch and can be uninstalled without affecting the purchased version.


Patrick Connor

Serif (Europe) Ltd.

Share this post


Link to post
Share on other sites
On 11/29/2018 at 5:39 PM, AdamW said:

Hello @AdamW thank you so much for this update but ... the Affinity Store link is often failing when i download from that place when the other links you sent (Amazon S3 i think !!!) worked a charm and never failed a download.
At the moment i'm writing this, my first download failed at 25% and i had to restart again.
Please consider to check and fix the download sources as i suspect few guys here also failed from that link or from the software itself, look like the link drops or something similar.
Please fix for better tomorrow.
Blessings !

EDIT: Check the two capture i took from my laptop, the displayed sizes are different. The store show a different size than what the download manager display.
Do i need to worry ?
store.png.995729ddd829619a9e6102b82f912c61.png

downloader.png.a48ce06d1b3401886ad6557e1ef90531.png

Edited by Uncle Mez

Never be the Same Again !
MacBook Pro (13-inch, Mid 2010) - 2.4 GHz Intel Core 2 Duo - 8 GB 1067 MHz DDR3 - VIDIA GeForce 320M 256 MB

MacOS High Sierra 10.13.6  - Affinity Designer + Affinity Photo + Affinity Publisher + Snagit 2019 + Camtasia 2018 + Movavi Video Editor Business 15

Share this post


Link to post
Share on other sites

Hi Uncle Mez :)

I've checked the store download. It looks fine from here, and should be superior to S3. Looks like the file size on the download webpage is wrong but I think is just static content and hasn't been updated recently. Apologies for any confusion.

Hope your download works out OK in the end.

 

Share this post


Link to post
Share on other sites
2 hours ago, AdamW said:

Hope your download works out OK in the end.

Well finally managed to get it loaded and installed on Mac without any issue.
Load fast, no bug on load, also load my previous projects no problem ... Still i need to check if something is missing etc.
Also Thanks for the Help manual it's more faster loading but still certain descriptions need to be developed or enlarged they just tell what the tool or the function is but nothing else.
We are lacking of serious affinity content for learning so making a detailed help is okay !

Blessings !


Never be the Same Again !
MacBook Pro (13-inch, Mid 2010) - 2.4 GHz Intel Core 2 Duo - 8 GB 1067 MHz DDR3 - VIDIA GeForce 320M 256 MB

MacOS High Sierra 10.13.6  - Affinity Designer + Affinity Photo + Affinity Publisher + Snagit 2019 + Camtasia 2018 + Movavi Video Editor Business 15

Share this post


Link to post
Share on other sites

In terms of GPU acceleration should we stick to Open GL or is it possible to use Metal now.  I remember there were issues using Metal in Affinity Designer but Metal is so much faster.  But if it's safer to stick to Open GL then I will do that.

Share this post


Link to post
Share on other sites

OK I am and I'm literally having so much fun.  If I were to place a very complex vector object in InDesign even with my super high end laptop (i9) the program would be so incredibly laggy that I was forced to make a PNG file out of it and then work with that only.  Here with AP + Metal I am pinching and zooming a VERY complex vector object and I get zero lag.  Absolutely amazing.  With OpenGL it was also sort of fast but there was blurriness and a very slight lag while the screen was redrawing.  Also fonts would slightly blur when zooming - not anymore.  Thank you for fixing this. 

Share this post


Link to post
Share on other sites

While that is up for discussion: Just to clear a few basic details about display settings ( OpenGL vs Metal) : If Metal is available in the Affinity settings, then it is automatically supported by the OS and the hardware, or do I need to figure out that myself before using it? There are also software and OpenGL (basic) as options. What are the general recommendations on how to choose one option over the others?

Share this post


Link to post
Share on other sites

I think there is a bug when creating a text frame by drawing a shape with the pen tool, then converting to a text frame. There is a visible line around the polygon text box and can't seem to get rid of it. I first thought that I had a stroke on the text box itself, but there is no stroke.  This doesn't happen when I create a normal text frame box.

TEST.pdf

Share this post


Link to post
Share on other sites
39 minutes ago, abarkalo said:

I think there is a bug when creating a text frame by drawing a shape with the pen tool, then converting to a text frame. There is a visible line around the polygon text box and can't seem to get rid of it. I first thought that I had a stroke on the text box itself, but there is no stroke.  This doesn't happen when I create a normal text frame box.

TEST.pdf

I do not see that (on Windows). It would help to have your .afpub file.

By the way, this thread is only for discussing installation problems. You should create a new topic for potential bugs, as Adam requested in the first post to this thread:

On 11/29/2018 at 11:39 AM, AdamW said:

Any problems actually using this version please make a new topic in this forum and we'll get back to you as soon as we can.

 


-- Walt

Windows 10 Home, April 2018 Update (1803), 16.0GB memory, Intel Core i7-6700K @ 4.00Gz
Affinity Photo 1.6.5.123 and 1.7.0.188 Beta
Affinity Designer 1.6..5.123 and 1.7.0.188 Beta
Affinity Publisher 1.7.0.192 Beta

Share this post


Link to post
Share on other sites

Placing PDFs is broken again in this release. They are inserted small. This was happening two versions ago, then it was fixed, now it's broken again. My temporary fix is to resize them to 8.5" W in the transform studio. Remember to set the H and W to be linked so they scale together.

2099603870_ScreenShot2018-12-02at7_40_23AM.png.0bd8d0f46771e9c2e48558cddc31959c.png

Share this post


Link to post
Share on other sites
49 minutes ago, Mr. K said:

Placing PDFs is broken again in this release.

Then, as @walt.farrell mentioned in the post just above yours, you should be creating a new topic to discuss that.


Affinity Photo 1.6.7 & Affinity Designer 1.6.1; macOS High Sierra 10.13.6 iMac (27-inch, Late 2012); 2.9GHz i5 CPU; NVIDIA GeForce GTX 660M; 8GB RAM
Affinity Photo 1.6.9.81 & Affinity Designer 1.6..2.24 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iOS 12.0

Share this post


Link to post
Share on other sites

Hi! any one has this problem as well?  I followed instruction, downloaded latest version of beta, installed it. But when I try to open affinity publisher, this window just appears again :(

Screen Shot 0030-12-07 at 14.01.05.png

Share this post


Link to post
Share on other sites
5 hours ago, Hean said:

But when I try to open affinity publisher, this window just appears again :(

Just to mention the obvious, is the clock on your computer set to the correct date?

Share this post


Link to post
Share on other sites
5 minutes ago, fde101 said:

Just to mention the obvious, is the clock on your computer set to the correct date?

oh! Oh I was using Japanese calendar, after switching to Gregorian the problem is fixed. Thank you so much ! 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×