Jump to content

Recommended Posts

Im I missing something?

Did someone manage to get hyphenation to work?

I set spelling, hyphenation, … in the character panel to „German“, switched on hyphenation in the paragraph style, but nothing happens.

Will the necessary libraries only be part of the release version?

Share this post


Link to post
Share on other sites

I'm sorry, I did not notice it was a 'Mac' topic. I moved to the 'Win' topic.

A solution for implementing the Polish dictionary. Download the files downloaded from https://donate.libreoffice.org/home/dl/src/5.1.3/all/libreoffice-dictionaries-5.1.3.2.tar.xz?idx=2 and place them in the place shown in the screenshot. You can probably use this method for other languages.

Zrzut ekranu (21).png

Zrzut ekranu (22).png

Zrzut ekranu (23).png

Share this post


Link to post
Share on other sites

German works.

Make sure at each language section in your text style it is set to German. There is a bug in the last language setting--the Hyphenation Language will revert to no change.

Set the score lower. Basically I just set it to 1 right now.

Share this post


Link to post
Share on other sites
23 hours ago, pgraficzny said:

I'm sorry, I did not notice it was a 'Mac' topic. I moved to the 'Win' topic.

A solution for implementing the Polish dictionary. Download the files downloaded from https://donate.libreoffice.org/home/dl/src/5.1.3/all/libreoffice-dictionaries-5.1.3.2.tar.xz?idx=2 and place them in the place shown in the screenshot. You can probably use this method for other languages.

Thanks for tip. Tried on macOS with czech language, not succesfull.

EDIT: after few restarts, it's working now. But hyphneation really really need some aditional work as mentioned already.

Share this post


Link to post
Share on other sites

You are right @MikeW. Hyphenation is working, but really really bad!

Try to hyphen „Rolltreppe“, it won’t work. You have to insert a soft hyphen.

By the way: If Publisher would use macOS’ hyphenation support, it would do the job! :)

Share this post


Link to post
Share on other sites
5 minutes ago, mac_heibu said:

You are right @MikeW. Hyphenation is working, but really really bad!

Try to hyphen „Rolltreppe“, it won’t work. You have to insert a soft hyphen.

By the way: If Publisher would use macOS’ hyphenation support, it would do the job! :)

Did you try setting the Score to 1? Pardon the squigglies. I should have shut that off for the screen shot.

capture-002169.png.1641abe55db98e44a1bb93c3cdf16d45.png

The other settings matter, too.

But yes, Hyphenation needs some serious work.

Share this post


Link to post
Share on other sites
17 hours ago, pgraficzny said:

Works for me too on Mac! Thanx to pgraficzny.

1247229910_Screenshot2018-08-31at07_31_40.thumb.png.2bed459ca5e811fbc72e736e281d0fed.png

 

 

 

I'm sorry, I did not notice it was a 'Mac' topic. I moved to the 'Win' topic.

A solution for implementing the Polish dictionary. Download the files downloaded from https://donate.libreoffice.org/home/dl/src/5.1.3/all/libreoffice-dictionaries-5.1.3.2.tar.xz?idx=2 and place them in the place shown in the screenshot. You can probably use this method for other languages.

Zrzut ekranu (21).png

Zrzut ekranu (22).png

Zrzut ekranu (23).png

 


iOs: iPad Pro 12,9" 1st gen., Apple pencil; Mac: Affinity Photo & Designer and really looking forward to Affinity Publisher

Share this post


Link to post
Share on other sites

No luck with Galician language. I was able to create a /gl-ES directory in /Contents/Resources/Dictionaries, the language appears in the list of possible hyphenation languages but it doesn't work (even with score=1). Curiosly, if I replace the hyph_gl_ES.dic file with the Spanish file (in the /gl-ES directory), that fake Galician hyphenation works. Any suggestion?

Share this post


Link to post
Share on other sites
On 8/31/2018 at 1:33 AM, Pedrober said:

No luck with Galician language. I was able to create a /gl-ES directory in /Contents/Resources/Dictionaries, the language appears in the list of possible hyphenation languages but it doesn't work (even with score=1). Curiosly, if I replace the hyph_gl_ES.dic file with the Spanish file (in the /gl-ES directory), that fake Galician hyphenation works. Any suggestion?

Pedrober,

Does this look right to you? I do not read/understand the language so I have no idea if even the web pages I copied from were correct!

capture-002183.png.0bf5a13a7a6380ea5ed94cf184cadbc7.png

 

Share this post


Link to post
Share on other sites

Mike,

Thank you very much for your message. Your first quotation is a medieval text. The last one is modern Galician. Everything is OK. How do you get that result? Brilliant!

Share this post


Link to post
Share on other sites

Mike,

Thank you very much for your message. Your first quotation is a medieval text. The last one is modern Galician. Everything is OK. How do you get that result? Brilliant! Maybe the problem could be linked to the fact I am a Mac user?

Share this post


Link to post
Share on other sites
2 hours ago, Pedrober said:

Mike,

Thank you very much for your message. Your first quotation is a medieval text. The last one is modern Galician. Everything is OK. How do you get that result? Brilliant! Maybe the problem could be linked to the fact I am a Mac user?

I'll upload a zip file. Back up your files, download the zip. The zip will contain a folder with the three files. If the folder name is the same as your present folder name, just copy the files it contains into your folder. If the folder name is different, delete your folder and copy the folder out of the zip containing the files into the dictionary folder.

It will be uploaded in a few minutes as I'm away from the computer right now. 

Uploaded the ZIP file...

gl_ES.zip

Edited by MikeW
Added ZIP file

Share this post


Link to post
Share on other sites

Mike,

Thank you for the files. No problem if I use the Windows version, but Galician hyphenation doesn't work in my Mac. I suppose it's a bug.

Best wishes.

Share this post


Link to post
Share on other sites
1 hour ago, Pedrober said:

Mike,

Thank you for the files. No problem if I use the Windows version, but Galician hyphenation doesn't work in my Mac. I suppose it's a bug.

Best wishes.

Bummer! Sorry. 

Share this post


Link to post
Share on other sites

We have rewritten some of the hyphenation routines for the next release, and I would be grateful if all the participants can retest hyphenation once the NEXT beta build (so one with a build number higher than .133) is available. Thank you. If there are still problems can you make new threads with sample files, as this one has so many participants.


Patrick Connor
Serif (Europe) Ltd.

Latest releases on each platform 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×