Jump to content
MattP

Affinity Designer Customer Beta (1.5 - Beta 10)

Recommended Posts

@mattP, thanks so much for fixing this! Indeed, when importing pdfs using the "Place" command they now get imported at the correct physical size, which is great! The instance in which the old behavior still persists is when importing them via drag&drop, but for me personally that's not a big issue.

Thanks again for taking the time to fix this!

 

EDIT: I just realized the problem also persists when directly selecting vector elements in another application (in my case Graphpad Prism) and then importing these into AD via paste. If you could align that behavior with the now revised Place command that would be greatly appreciated.

No problems :)   Interesting you mention about the drag/drop not working, I'll look into that one too!

 

Interestingly, the problem you mention with 'paste' from another application may not be so easy - unless the data they provide is via a PDF pasteboard type, for example... I'll look at it...

 

Thanks,

Matt

Share this post


Link to post
Share on other sites

Hi All,

 

Have a crash bug to report, see attached log incase its of use. 

 

I was changing the layer order of a Symbol, nested inside a symbol. 

Thanks for the heads-up Malcolm - you don't happen to have a document at all that shows this do you? (I'm guessing not, but thought I'd ask just on the off-chance....)

 

Thanks,

Matt

Share this post


Link to post
Share on other sites

CAN´T BELIEVE THIS IS HAPPENING!!!!

>>>>> one CAN drag the "opacity" label to change the opacity of layers  :D :D :D

+ dropping stuff into assets and symbol panels

+ might we get the docking of two columns of tool panels to the right (and left) side like possible in AD for Windows?

 

+ Bleed preview, linked bleed values

 

 thanks for the update!   :lol:

 

so what´s your opinion on the state of this AD release?  :lol: judging from your profile picture you seem to be happy  :lol:

 

 

How do I see the bleed? 

Share this post


Link to post
Share on other sites

Thanks for the heads-up Malcolm - you don't happen to have a document at all that shows this do you? (I'm guessing not, but thought I'd ask just on the off-chance....)

 

Thanks,

Matt

Hey Matt, our friendly Time Machine will help out on that front. I'll mail it over to you at some point this afternoon.

Cheers.

Share this post


Link to post
Share on other sites

In Draw persona, if I finish my design and go to File/Export, I get troubles with the Export settings. The buttons Cancel, More and Export sometimes do not work. I have to click back and forth between formats, and suddenly More works, but then if i close it and try to reopen, it does not work.

 

Also my customs setting for PDF printing were erased from the list of options in Export.

 

I know you will fix this. Thank you very much in advanced.

 

Bogar

Share this post


Link to post
Share on other sites

I still have an issue when trying to reopen a file I've closed. It's the same whether I drag to app, go "Open Recent" or just Open and navigate to the file. I get this:

 

Screen%20Shot%202016-08-20%20at%2003.33.

 

And then I get something like this, no matter which option above I choose:

 

Screen%20Shot%202016-08-20%20at%2003.29.

 

The only way forward from there is to quit the Beta and reopen it.

 

Can someone please weigh in on this? It's been like this for the last three betas.

 

Share this post


Link to post
Share on other sites

Bogar: if you are on OSX 10.9.5, try to target the lower edge of the buttons when ckicking them with the mouse in the export dialogue.

Share this post


Link to post
Share on other sites

Hi 00Ghz,

 

I'm not seeing this on the Sierra machine. Do you have a recipe how it happened? Are you on the latest Sierra?

 

A

 

Edit: We are using 10.12 build 16A294a

 

I just made it a floating panel and that's it. It freaked out.


UI Designer, CG Artist

 

Macbook Pro 15" 2014

2.5 Ghz, 750M

 

https://www.behance.net/VladMafteiuScai

Share this post


Link to post
Share on other sites

On Constraints,

 

I've been using constraints to implement my own arrows before the development team implements native arrows support in the application.

 

What I'm missing right now the fact that I can't lock the vertical or horizontal resizing of the Constraints Group.

 

In the case of arrows I want to make sure that the constraints group is not resizable vertically only horizontally.

 

At other times I want to make sure that I can only resize the group vertically not horizontally.

 

I'm not sure what the 3 icons do at the bottom right corner of the Constraints Panel. Does anyone out there know what they are for?

Best regards

Share this post


Link to post
Share on other sites

Hi Meb,

 

I am using 10.9.5 in a Mac Pro 2.8 GHz Quad-Core with 32 GB RAM.

I had the button issue since the first Beta 1.5.

Now it works for one time if i click in several formats and get back to PDF, then More opens, if I close it, then click More again do not work.

In JPG it does not work at all and so in some formats.

The Export Button (next to More) finally works in Beta 10.

 

Thank you again,

 

Bogar

Share this post


Link to post
Share on other sites

Can someone please weigh in on this? It's been like this for the last three betas

 

There's a thread about that issue here.


Alfred online2long.gif
Affinity Designer/Photo/Publisher 1.7.1.404 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.7.1.143 • Designer for iPad 1.7.1.1 • iOS 12.4 (iPad Air 2)

Share this post


Link to post
Share on other sites

A couple of little things that I think might improve the artboard experience.

 

1 - when an artboard is copy dragged to create a new duplicate, perhaps an updated artboard number be added to it's name both in the document window and in the layer stack.

 

2 - Command 1 or 8 for 100% or actual size zoom into the artboard that is active or was active last, currently it centres the view.

 

:D

 

 

Can we add another tab to the Assets Panel for linked or placed image/textures etc... management? Or is there somewhere else that would be better located?

 

 

... While I think of it, I'm wondering why there isn't a global noise adjustment layer capability in Designer. Does it have something to do with the vector and raster nature of Designer?

 

It seems to work great as a live noise filter in Photo over raster and vector shapes. When put on the top most layer it covers everything below it and it's a live effect so you can adjust it... really cool.

(Post merged by PJC into one suggestion post)

Share this post


Link to post
Share on other sites

Export size is initialised with the wrong values - which is more of an annoyance than bug. Still:

  • With multiple artboards in a row, resulting in a canvas size of e.g. 1000w × 100h.
  • I select one of the artboard,  with a size of e.g. 100×100 and hit export. The export dialog will be initialised as 100×100 despite "Whole document" being selected.
  • Then when changing e.g. the height to 200, the width changes to 2000. Which is correct, given that the While document is selected.
Ideally having an artboard selected would initialise the export dialog to the corresponding size (100×100) and area (artboard).

 

Hm.. the list in this post stopped being formatted as a list in the preview. Weird.

Share this post


Link to post
Share on other sites

Hi All, might be a known issue as it's to do with Constraints.

 

When I apply a constraint the artwork inside appears to be cropped to the bounding volume of the newly converted 'Constraints Group'. See image.

post-6493-0-76822100-1471873306_thumb.png

Share this post


Link to post
Share on other sites

Hi Bogar,

I'm not having issues with those buttons. Which OS are you running? 

 

Regarding custom settings, this latest Beta (1.5.10) was reset (see warning in the first post "PLEASE BE AWARE ") for more info.

 

Hi Meb,

 

I am using 10.9.5 in a Mac Pro 2.8 GHz Quad-Core with 32 GB RAM.

I had the button issue since the first Beta 1.5.

Now it works for one time if i click in several formats and get back to PDF, then More opens, if I close it, then click More again do not work.

In JPG it does not work at all and so in some formats.

The Export Button (next to More) finally works in Beta 10.

 

Thank you again,

 

Bogar

 

 

Share this post


Link to post
Share on other sites

Hi,
 
first of all: thanks for getting the measurements to work with art boards! :)
There is one thing that bugs me though:
 
Measurements don’t work inside of groups:

  • Put three elements in a group
  • Select one of its children via double click
  • Try to ⌘-Measure its distance to another child of the group

Instead of measuring the distance between the two elements, it shows the distance to the group boundaries.

 

measurement_in_groups.jpg

Share this post


Link to post
Share on other sites

Would love to see Designer's brush behaviour updated to the same as Photo 1.5 beta, where when you pick a brush it automatically selects the right tool in the tool panel i.e. pixel or brush paint tool.

 

Even if I am using the text tool and select a brush in the brush panel the app knows to switch to the right brush tool. This is exactly how it should work. Awesome!  :D

 

Right now in designer, pixel persona, you pick the tool, then the brush, then sometimes you have to re-select the tool and then sometimes you have to re-select the brush... it seems inconsistent and not ideal. 

 

a boy can dream... would like a sticky highlight of the brush in the panel as well.  :)  

 

a boy can push his luck... of course ultimate nirvana would be custom panels users could create and save.  :P brushes, artboards, styles etc...

 

... but seriously that first point would be awesome.  ;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×