Jump to content

Affinity Photo Windows Customer Beta - 1.9.4.1048


Recommended Posts

  • Moderators

Click here to download the latest beta

Status: Customer Beta
Purpose: Fixes
Requirements: A valid product key (for Affinity Store purchases), or an installation of the full retail version from the Microsoft Store

As this is a beta it is considered to be not suitable for production use. This means that you should not attempt to use it for commercial purposes or for any other activity that may be adversely affected by the application failing, including the total loss of any documents. We hope you enjoy the latest build, and as always, if you've got any problems, please don't hesitate to post a new thread in this forum and we'll get back to you as soon as we can. Thanks once again for your continued feedback. 

If you have a general question about the software, please head over to the Questions Forum, or if you have any suggestions, please head over to the Feature Requests forum.

  • Added 'Limit Initial Zoom to 100%' preferences option (defaulted to off) 
  • Fixed crash on document load when the OpenCLOn12 compatibility pack has been installed
  • Added hardware acceleration to Gradient Map adjustment
  • Fixed renaming a LUT preset to also change the name of the underlying ColourCubeRGB (so it manifests as expected in the LUT adjustment dialog)
  • Fixed F-number always showing in the UI as "f/0" for Leica M-series cameras (and likely others) 
  • Render EXIF exposure time as decimal (rather than fractional) if above one
  • Implemented GPOS Cursive rule (used by "Charis SIL" font)
  • Fixed PDF Export group opacity potentially being applied twice

Previous release notes

Link to post
Share on other sites

1- Talking Hardware Acceleration and drivers etc.

I'm planing to buy this GPU before end of 2021: GEFORCE GTX 1660 Ti 
Will it enable that feature on Affinity?

2- Hardware Acceleration seem to be sort of enabled by default when it is manually disabled on non supported devices, I hope this new build fixes it because it makes the app lag on stuffs it wasn't lagging before which is anoying and/or deal breaker as Affinity had the reputation of being lighter, fast and not resources demanding.

BTW I'm fetching this build now and will test it later in the day.
Blessings.

Never be the Same Again !
---
Dell Precision T3500 
Intel Xeon W3530 @2.80GHz with 16GiB 1333 MHz DDR3
Nvidia Quadro K2000 2GB vRAM
Windows 10 Pro N x64 20H2 + LibreOffice 7.1

My well suited Set of Apps [Production only]
* Affinity Suite [Designer + Photo + Publisher]
* Camtasia 2020 + Inkscape 1.0.2 beta + Blender 2.92 Beta

Link to post
Share on other sites
13 minutes ago, Uncle Mez said:

1- Talking Hardware Acceleration and drivers etc.

I'm planing to buy this GPU before end of 2021: GEFORCE GTX 1660 Ti 
Will it enable that feature on Affinity?

2- Hardware Acceleration seem to be sort of enabled by default when it is manually disabled on non supported devices, I hope this new build fixes it because it makes the app lag on stuffs it wasn't lagging before which is anoying and/or deal breaker as Affinity had the reputation of being lighter, fast and not resources demanding.

BTW I'm fetching this build now and will test it later in the day.
Blessings.

I have 1660 Super. Graphics acceleration works under Windows 10.

__________________

Windows 10 64-bit,

AMD Ryzen 5 3600 + Nvidia 1660 Super + Nvidia Studio driver + 32 Gb RAM.

Link to post
Share on other sites
2 hours ago, Max N said:

I have 1660 Super. Graphics acceleration works under Windows 10.

Definitely that the one i will buy.
expect it to live another 4y or so ... i only can buy a GPU once every 5y ... no budget for Extras 

Never be the Same Again !
---
Dell Precision T3500 
Intel Xeon W3530 @2.80GHz with 16GiB 1333 MHz DDR3
Nvidia Quadro K2000 2GB vRAM
Windows 10 Pro N x64 20H2 + LibreOffice 7.1

My well suited Set of Apps [Production only]
* Affinity Suite [Designer + Photo + Publisher]
* Camtasia 2020 + Inkscape 1.0.2 beta + Blender 2.92 Beta

Link to post
Share on other sites
  • Added 'Limit Initial
    Quote
    • Added 'Limit Initial Zoom to 100%' preferences option (defaulted to off) 

It works, but only on the first image. If you open a second (small) image it will still get zoomed to fullscreen.

There is also a noticeable "flash" effect as if the image was first @ full width and then rapidly resized to 100%. Can it be avoided?

Link to post
Share on other sites
8 hours ago, RichardMH said:

There's also a new NVIDIA studio driver 462.31 (Windows 10) that so far has improved stability with OpenCL acceleration on.

Nvidia has been added to Geforce Experience Affinity Photo and Affinity Designer and Affinity Publisher has not yet been added. In general, good news :-)

 

__________________

Windows 10 64-bit,

AMD Ryzen 5 3600 + Nvidia 1660 Super + Nvidia Studio driver + 32 Gb RAM.

Link to post
Share on other sites

Hi Mark, I noticed that if you set Limit Initial Zoom to 100% to on you need to restart the application. Is this correct?

Win 10 x64 System with Intuos Pen & Touch
 - Sys : Intel® Core™ i7-7700HQ CPU @ 2.80GHz (8 CPUs), 16GB RAM
 - GPU 1: Intel HD Graphics 630, GPU 2: NVIDIA GTX1050, 4GB

iPad (8th Gen) 2020

 

Link to post
Share on other sites
8 hours ago, Max N said:

Nvidia has been added to Geforce Experience Affinity Photo and Affinity Designer and Affinity Publisher has not yet been added. In general, good news :-)

 

That´s really good news and i believe that Publisher follows with the next Update. I use a NVIDIA GeForce GTX 1060 with 6GB and it works very well.

 

17 hours ago, Mark Ingram said:

Click here to download the latest beta

Status: Customer Beta
Purpose: Fixes
Requirements: A valid product key (for Affinity Store purchases), or an installation of the full retail version from the Microsoft Store

As this is a beta it is considered to be not suitable for production use. This means that you should not attempt to use it for commercial purposes or for any other activity that may be adversely affected by the application failing, including the total loss of any documents. We hope you enjoy the latest build, and as always, if you've got any problems, please don't hesitate to post a new thread in this forum and we'll get back to you as soon as we can. Thanks once again for your continued feedback. 

If you have a general question about the software, please head over to the Questions Forum, or if you have any suggestions, please head over to the Feature Requests forum.

  • Added 'Limit Initial Zoom to 100%' preferences option (defaulted to off) 
  • Fixed crash on document load when the OpenCLOn12 compatibility pack has been installed
  • Added hardware acceleration to Gradient Map adjustment
  • Fixed renaming a LUT preset to also change the name of the underlying ColourCubeRGB (so it manifests as expected in the LUT adjustment dialog)
  • Fixed F-number always showing in the UI as "f/0" for Leica M-series cameras (and likely others) 
  • Render EXIF exposure time as decimal (rather than fractional) if above one
  • Implemented GPOS Cursive rule (used by "Charis SIL" font)
  • Fixed PDF Export group opacity potentially being applied twice

Previous release notes


Installation of the Software went without problems and both apps are running fast and stable and i i have a feeling that the apps are running from update to update a bit faster. Or am i wrong? 😉
Thumbs up Guys, well done 🙂

 

Have a nice day.
Ich wünsche einen schönen Tag.

Link to post
Share on other sites
On 4/15/2021 at 8:27 PM, LuBre said:

It works, but only on the first image. If you open a second (small) image it will still get zoomed to fullscreen.

I can confirm that only the first opened image is zoomed to 100%. Also, I suggest this option as a default option. What is the point of having a small image blown up to the entire display area? The first thing I always have to do is zoom the image to 100%.

Link to post
Share on other sites
On 4/16/2021 at 3:07 AM, AiDon said:

Hi Mark, I noticed that if you set Limit Initial Zoom to 100% to on you need to restart the application. Is this correct?

No, I did not have to reboot.

Link to post
Share on other sites
  • 3 weeks later...
On 4/15/2021 at 8:27 PM, LuBre said:
  • Added 'Limit Initial

It works, but only on the first image. If you open a second (small) image it will still get zoomed to fullscreen.

There is also a noticeable "flash" effect as if the image was first @ full width and then rapidly resized to 100%. Can it be avoided?

That is a long needed feature. I hope that it's not only for the initial zoom, but all zooms by the program (i.e. not initiated by the user).

Right now, the zoom operates without asking the user on many occasions (returning from plugin, Affinity macro operation etc).

Thanks for working on it!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.