Jump to content
Mark Ingram

Affinity Photo Windows Customer Beta - 1.9.0.852

Recommended Posts

Click here to download the latest beta

Status: Customer Beta
Purpose: New features, performance, fixes
Requirements: A valid product key (for Affinity Store purchases), or an installation of the full retail version from the Microsoft Store

As this is a beta it is considered to be not suitable for production use. This means that you should not attempt to use it for commercial purposes or for any other activity that may be adversely affected by the application failing, including the total loss of any documents. We hope you enjoy the latest build, and as always, if you've got any problems, please don't hesitate to post a new thread in this forum and we'll get back to you as soon as we can. Thanks once again for your continued feedback. 

If you have a general question about the software, please head over to the Questions Forum, or if you have any suggestions, please head over to the Feature Requests forum.

Changes

  • Fixed Develop Persona Overlay Paint Brush not accumulating
  • Improved colours in EOS R5 CR3 files
  • Changed Adjustments panel LUT category to be displayed in list mode
  • Fixed Adjustments panel right click not showing cell selection highlight
  • Improvements to Affinity store registration and download
  • Fixed crash when quitting the app from the Enter Product Key dialog 
  • Add auto-updating linked resources
  • Opening a template from File>Open or Drag and drop will now open it as untitled
  • Fixed Filter Effect dialog to enable the use of Global Colours
  • Fixed crash during raster brushing with hardware acceleration enabled
  • Fixed crash when starting a document with hardware acceleration enabled, but with unsupported GPU
  • Fixed New Document Dialog to prevent multiple selections in Presets

1.9.0.834 release notes

Share this post


Link to post
Share on other sites

The Mac beta mentions Pattern Layers.

Are these not in the Windows version yet, or am I looking in the wrong place?


Win10 Home x64   |   AMD Ryzen 7 2700X @ 3.7GHz   |   16 GB RAM   |   1TB SSD   |   nVidia GTX 1660   |   Huion 1060 Plus

How I make GIFs >>> ScreenToGIF (Windows only, Open Source, Portable, ~600kB)

Share this post


Link to post
Share on other sites

Hi Folks,

Thank you all for a beautiful product.

Just about to purchase a i7 16Gb with NVIDIA GTX1660 Super. I'm getting a bit worried now.

Will I get into trouble with hardware acceleration? Is there anyone who can give me some advice?

Thank you very much for your help.

Peter

Share this post


Link to post
Share on other sites
34 minutes ago, PetervL said:

Hi Folks,

Thank you all for a beautiful product.

Just about to purchase a i7 16Gb with NVIDIA GTX1660 Super. I'm getting a bit worried now.

Will I get into trouble with hardware acceleration? Is there anyone who can give me some advice?

Thank you very much for your help.

Peter

There are no problems at 1660 super. Perhaps you should look at the AMD processor, they seem to be more interesting for the price.


__________________

Windows 10 64-bit,

AMD Ryzen 5 3600 + Nvidia 1660 Super + Nvidia Studio driver + 32 Gb RAM.

Share this post


Link to post
Share on other sites
11 hours ago, Max N said:

There are no problems at 1660 super. Perhaps you should look at the AMD processor, they seem to be more interesting for the price.

Thank you very much.

Peter

Share this post


Link to post
Share on other sites

"auto-updating linked resources"

is this an option which can be disabled? (could not find it)

sry, found it, it's in the general prefs.

 

Share this post


Link to post
Share on other sites

Beautiful build but one thing I've noticed that it making use of enormous resources compared to release you shipped before this, which is something a bit frustrative.
But I love your works and wait for another one to come so I can compare.


Never be the Same Again !
---
Dell Precision T3500 
Intel Xeon W3530 @ 2.80GHz + 12GiB 1333 MHz DDR3
AMD Radeon HD 5450 with 1GiB RAM
Windows 10 Pro x64 20H2 + LibreOffice 7

My well suited Set of Apps [Production only]
* Affinity Suite [Designer + Photo + Publisher]
* Camtasia 2020 + Inkscape 1.0.2 beta + Blender 2.92 Beta

Share this post


Link to post
Share on other sites
On 11/23/2020 at 4:56 AM, Fritz_H said:

Sorry, I am tired of explaining USABILITY to Serif...

While it isn't intitive, it is VERY usable.  I had no idea that function existed and it is as efficient as I could imagine.

 

Once you know the function it is as easy as can be.  

 

Share this post


Link to post
Share on other sites

I am not sure if that happens to anyone else, but I am unable to customize my toolbar. Whenever I open the Customize Toolbar option and try to drag a tool into the space to delete it, nothing happens. ANy help, please? Thank you.

Share this post


Link to post
Share on other sites
On 11/23/2020 at 2:01 AM, Patrick Connor said:

@Thoraldus

Welcome to the Serif Affinity forums :) 

What would you like to resize by percent please? There is probably already a way to do it for most things

Sorry. After a bit more investigation I've found that Resize Document by percentage IS available, just not in the form I was used to.  

The key was looking up "Expressions for field input" ;-)

Edited by Thoraldus

Share this post


Link to post
Share on other sites

@Mark Ingram Hi Mark, I know this is an ongoing issue where suggested causes are both NVIDIA and Capture One, but how is it I can open and process a single RAW image but not multiple RAW images at the same time whilst using these settings? On a single image I can use Develop, Liquify and Tone Map Personas but working with more than one image still causes a Stack overflow in nvwgf2umx.dll :

image.png.bcc12e4a989317f72279ffd1f7e204dd.png


Win 10 x64 System with Intuos Pen & Touch
 - Sys : Intel® Core™ i7-7700HQ CPU @ 2.80GHz (8 CPUs), 16GB RAM
 - GPU 1: Intel HD Graphics 630, GPU 2: NVIDIA GTX1050, 4GB

iPad (8th Gen) 2020

 

Share this post


Link to post
Share on other sites

@PhotoSuprgeon20

Welcome to the Serif Affinity forums :) 

8 hours ago, PhotoSuprgeon20 said:

I am not sure if that happens to anyone else, but I am unable to customize my toolbar. Whenever I open the Customize Toolbar option and try to drag a tool into the space to delete it, nothing happens. ANy help, please? Thank you.

Is this a problem that happens in this current Photo beta version 1.9.0.852 or is this a problem with the release build. If it is problem with the release build please post in the Questions forum, if it's specific to the beta can you please make a new thread in this beta forum, as the beta thread is not the ideal place for assistance  


Patrick Connor
Serif Europe Ltd

Latest releases on each platform 

 

Share this post


Link to post
Share on other sites
6 hours ago, Patrick Connor said:

@PhotoSuprgeon20

Welcome to the Serif Affinity forums :) 

Is this a problem that happens in this current Photo beta version 1.9.0.852 or is this a problem with the release build. If it is problem with the release build please post in the Questions forum, if it's specific to the beta can you please make a new thread in this beta forum, as the beta thread is not the ideal place for assistance  

Well, it's embarrassing, but I did the wrong thing. I chose the "customize toolbar" option to customize the tools, not the toolbar. I only discovered it after I posted the above. I thought it was a bug with the current beta (1.9.0.852). My apologies.

Share this post


Link to post
Share on other sites
14 hours ago, AiDon said:

@Mark Ingram Hi Mark, I know this is an ongoing issue where suggested causes are both NVIDIA and Capture One, but how is it I can open and process a single RAW image but not multiple RAW images at the same time whilst using these settings? On a single image I can use Develop, Liquify and Tone Map Personas but working with more than one image still causes a Stack overflow in nvwgf2umx.dll :

Unfortunately I don't know - that crash location is the NVIDIA driver, as previously mentioned, so only they can say why it is crashing. I have reported the issue to them (and shared a crash dump, to which they have confirmed the stack overflow in their driver), but as we can't reproduce it here internally, they won't investigate further. 

My only suggestions are:

1) Report the bug to Capture One

2) Report the bug to NVIDIA

As frustrating as this is, at this point, there is nothing else we can do.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.