Jump to content
MattP

Affinity Designer Customer Beta (1.5 - Beta 12)

Recommended Posts

Hello,

I have already reported 2x, unfortunately received no response:

 

PDF export always exported the entire art board. A particular slice of exporting is not possible.

 

:-) Gerhard

 

 

Sorry, Google Translate ;-))

Share this post


Link to post
Share on other sites

Hi GerhardL,

Can you be more specific please? Are you exporting using the menu File ▸ Export or the Export Persona?

You can choose the Artboard you want to export from the Area dropdown when you use the File ▸ Export command from the menu. Are you selecting the correct artboard here?

If you are using the Export Persona you can click the Export icon in front of each Artboard in the Slices panel. Both seems to be working fine here.

Share this post


Link to post
Share on other sites

Hi GerhardL,

Can you be more specific please? Are you exporting using the menu File ▸ Export or the Export Persona?

You can choose the Artboard you want to export from the Area dropdown when you use the File ▸ Export command from the menu. Are you selecting the correct artboard here?

If you are using the Export Persona you can click the Export icon in front of each Artboard in the Slices panel. Both seems to be working fine here.

 

Hi MEB,

 

  • I Click Symbol in Export Persona (Slices) see Attachement
  • Export PNG is correct (Slice only)
  • Export PDF is the complete ArtBoard

 

:-) Gerhard

Test.afdesign

post-27500-0-70281900-1473065801_thumb.jpg

Share this post


Link to post
Share on other sites

Hi GerhardL

Thanks for the details. I was generating the slices automatically.

This issue was already logged. I've updated/bumped the log. 

 

Thanks,

 

:-) Gerhard

Share this post


Link to post
Share on other sites

Can you say if it is going to be in the 1.5 final version? Thank you for the quick reply.

Hi dannyj,

 

Sorry to be the bearer of bad news, but it will not be included in the 1.5 update that goes to the App Store. As Miguel has said, it is something that we do intend to add, but we have a number of other issues that are taking priority at present.

 

Thanks,

Matt

Share this post


Link to post
Share on other sites

One have to dig into the layers panel to find the selected one, or right-click 'Reveal in layers panel' to make it show up. Why not automatizing it! Manipulations in the layers panel can be frequent. It would be a huge time saver.

 

Yes, this would be most helpful. I mentioned a similar request here. But it was right at the end of the previous beta and might be too late for consideration. Again the benefit is substantial and I'm surprised others aren't clamoring for it.

 

Please consider adding this as a feature.

 

Thanks.

Share this post


Link to post
Share on other sites

Hi dannyj,

 

Sorry to be the bearer of bad news, but it will not be included in the 1.5 update that goes to the App Store. As Miguel has said, it is something that we do intend to add, but we have a number of other issues that are taking priority at present.

 

Thanks,

Matt

 

That is bad/sad news. I'll have to stick with Adobe till that gets implemented :(

Share this post


Link to post
Share on other sites

Sorry, I must have missed something (I didn't use the previous betas so much) could someone tell me what does the Yellow outline around shapes drawn with the pen tool indicate? 

 

Thanks,

Hokusai

Share this post


Link to post
Share on other sites

Yes, this would be most helpful. I mentioned a similar request here. But it was right at the end of the previous beta and might be too late for consideration. Again the benefit is substantial and I'm surprised others aren't clamoring for it.

Others actually are clamoring for it (myself included) and have posted similar requests. However, the developers can’t split themselves to work on everything at the same time; there are most likely more pressing issues than this one.

Share this post


Link to post
Share on other sites

Others actually are clamoring for it (myself included) and have posted similar requests. However, the developers can’t split themselves to work on everything at the same time; there are most likely more pressing issues than this one.

 

Exactly. We are aware of the issue and we will fix it as soon as we can. The fact that it has not yet been implemented is not a reflection of how interested we are in doing the feature. Everything will get fixed as soon as we're able to get to it - hopefully it's not that far away now :)

Share this post


Link to post
Share on other sites

Sorry, I must have missed something (I didn't use the previous betas so much) could someone tell me what does the Yellow outline around shapes drawn with the pen tool indicate?

 

This is part of the improved snapping algorithm, Hokusai. You can snap now to arbitrary points on an existing path (and a fortiori also to path intersections), not only to the nodes that control the shape of the path …  :)

post-1198-0-40857000-1473144893_thumb.png

post-1198-0-02373600-1473145130_thumb.png

Share this post


Link to post
Share on other sites

I'm seeing some inconsistency in the Move Tool. Handles seem to disappear frequently. Seems to happen mostly when elements are nested within other elements. Escaping and reselecting brings the handles back. Sometimes pressing Option does too.

 

Also (and I don't know if this is intentional or not, or there's is a system here) proportional scale, which I thought was Shift-Command and drag, sometimes is just Command and drag. I'm often testing and Undo'ing to find the right key selectors to do what I want. They seem to change in different contexts. 

Share this post


Link to post
Share on other sites

I'm seeing some inconsistency in the Move Tool. Handles seem to disappear frequently. Seems to happen mostly when elements are nested within other elements. Escaping and reselecting brings the handles back. Sometimes pressing Option does too.

 

Also (and I don't know if this is intentional or not, or there's is a system here) proportional scale, which I thought was Shift-Command and drag, sometimes is just Command and drag. I'm often testing and Undo'ing to find the right key selectors to do what I want. They seem to change in different contexts. 

I spotted something funny happening with the tool handles yesterday, too... I'll look into that, thanks...

 

Aspect-ratio constraining is governed by the Shift key. Some objects constrain by default, some do not, Shift will always select the opposite. You can set in the Preferences if you'd like constraining to be determined by the type of objects selected (the default) to be always on or always off.

 

Thanks,

Matt

Share this post


Link to post
Share on other sites

Exactly. We are aware of the issue and we will fix it as soon as we can. The fact that it has not yet been implemented is not a reflection of how interested we are in doing the feature. Everything will get fixed as soon as we're able to get to it - hopefully it's not that far away now :)

Thanks Matt! I'm just excited to know it's on the radar. I totally understand priorities, especially for all the new (and crazy complicated) features you're working.

Share this post


Link to post
Share on other sites

⌘ + [ cause the app to crash immediately (when working with symbols).

 

Edit: (OS X El Capitan 10.11.6) – AD 1.5.0 (Beta 12)

 

1. Created a new document

2. Add a shape to the canvas

3. Make shape into symbol

4. Duplicate Symbol

5. Move backward

6. Crash

 

MattP,

 

I tried saving a file but after closing the app, opening the app, and returning to the file it seems to not crash now. So maybe it's only before you've saved the file?

Share this post


Link to post
Share on other sites

Another oddity I noticed with symbols...

 

Shouldn't the order be reflected in all symbols? I tried reordering a layer in a symbol and it didn't update, even after playing with "sync" button on the symbols panel. See attached image.

 

Edit: Also playing with the symbols some more I'm seeing what I think is unexpected behavior, but you guys tell me. See this dropbox link for the video: https://dl.dropboxusercontent.com/u/61613349/AD%20%E2%80%93%C2%A0Symbol%20Behavior.mp4

post-26528-0-68114400-1473192091_thumb.png

Share this post


Link to post
Share on other sites

Sorry, I must have missed something (I didn't use the previous betas so much) could someone tell me what does the Yellow outline around shapes drawn with the pen tool indicate? 

 

Thanks,

Hokusai

 

 

 

Sorry, I must have missed something (I didn't use the previous betas so much) could someone tell me what does the Yellow outline around shapes drawn with the pen tool indicate?

 

This is part of the improved snapping algorithm, Hokusai. You can snap now to arbitrary points on an existing path (and a fortiori also to path intersections), not only to the nodes that control the shape of the path …  :)

 

 

Yes - a new snapping feature.  I try and highlight the things that are snapped to.  In the case of a geometry snap, I highlight the outline in yellow.  I know this can be a bit intrusive, so I may look to improve on it in the future.  (Just got other things on the to-do list).


SerifLabs team - Affinity Developer
  • Software engineer  -  Photographer  -  Guitarist  -  Philosopher
  • iMac 27" Retina 5K (Late 2015), 4.0GHz i7, AMD Radeon R9 M395
  • MacBook (Early 2015), 1.3GHz Core M, Intel HD 5300
  • iPad Pro 10.5", 256GB

Share this post


Link to post
Share on other sites

What about displaying the Snap state via the cursor and not the object, s as not to interfere with accuracy of artworks' visibility ?

 

Yes - a new snapping feature. I try and highlight the things that are snapped to. In the case of a geometry snap, I highlight the outline in yellow. I know this can be a bit intrusive, so I may look to improve on it in the future. (Just got other things on the to-do list).


2017 15" MacBook Pro 14,3 w/ Intel 4 Core i7 @ 2.8 GHz, 16 GB RAM, AMD 455 @ 2 GB, 512 GB SSD, macOS High Sierra

2018 11" iPad Pro 256 GB, latest iPadOS public beta

Share this post


Link to post
Share on other sites

Ben,

 

I turned off the "geometry snap" but every time I open a document, I have to turn it off. Is there some reason that it always on? I have all snapping turned off but the geometry snap doesn't seem to be a part of the snapping. It looks promising but for what I'm working on right now, it is a little intrusive. I hope to get the chance to play around with it more soon. Thanks for all the hard work. 

 

 

Hokusai

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.