Andy Somerfield

Affinity Photo Customer Beta (1.3.5.18 - RC8 GM3)

28 posts in this topic

Purpose: Fixes

Status: Release Candidate - Gold Master (really this time - we promise!!)

Requirements: Purchased Affinity Photo

Mac App Store: Submitted

Download: Here

 

To use this beta, simply download the file from the link given above and double-click on the file to open the installer. Follow the instructions to install the beta version. The beta sits alongside the Mac App Store version and will not interfere with it.

 

This is a Release Candidate (and desperate last minute update to the last GM!) build. It is our intention to submit this for review to This build has been submitted to Apple. We will obviously start adding more features again as soon as this update goes live.

 

Fixes

 

- Enable RAW for stacks
- Fix for Panorama studio in separated mode
- Fix hard-to-hit handles in Panorama’s crop tool
- Fix for overprint in PDF export
ronnyb, MacGueurle, A_B_C and 4 others like this

Share this post


Link to post
Share on other sites

I don't want to be a kill joy but the rate of issue of these Betas seems to indicate panic. In my experience, launching too early usually ends in tears.

Better to postpone a formal issue until  everything is fully tested and watertight.

Reputation can be so easily lost and impossible to regain.

Share this post


Link to post
Share on other sites

Hi MikeT,

 

Nothing to worry about - we got a couple of days spare which we hadn't planned for and thought we'd make use of them fixing some things which had no real chance of side-effects :)

 

Thanks,

 

Andy.

KipV, Mark_A, JGD and 2 others like this

Share this post


Link to post
Share on other sites
Vielen herzlichen Dank für Ihre ausgezeichnete Arbeit. Ich bin selbst in der Softwareentwicklung tätig und kenne die Herausforderungen, die Sie die letzten Tage gemeistert haben. Ich hätte dies als Betriebsverantwortlicher langsamer angegangen.
 

 

Gratulation!
 
------------
translation with google Translator:
 
Thank you very much for your excellent work. I am automatically in software development and know the challenges that you have mastered the last few days. I would have this addressed as operations manager slower.
 
Congratulations!
MattP and Andy Somerfield like this

Share this post


Link to post
Share on other sites

Hmmm … entering a value for the stroke of a vector-form – a rectangle in my case – results in a display bug.

As it seems the new value is displayed on top of the old one, I think.

 

post-5367-0-22025000-1449261812_thumb.png

 

Good job nonetheless with everything else! :)

 

Cheers

Dennis ;)


slice1.png

Share this post


Link to post
Share on other sites

Hi Andy, have now the thumbnail saved in Photoshop under ”Save As” and the thumbnail appears correctly on the desktop. I also think that it was not so under earlier versions of Affinity Photos beta...

Just discovered: the image was previously saved in Photoshop, then it is saved under Affinity Photos with the correct thumbnail.

Seems to: generate the no thumbnail icons are generated panoramic images of Tiff's; it is definitely so!

post-5756-0-38638800-1449267659_thumb.png

Share this post


Link to post
Share on other sites

I think quicklook of .afphoto files in finder should be fixed in especially retina display. You'd better check this out, Andy!

Share this post


Link to post
Share on other sites

tyler26,

 

If you expand the layer (using the triangle on the left), you should see them listed vertically - so you should be able to select them all..

 

Thanks,

 

Andy.

Share this post


Link to post
Share on other sites

The title says 1.3.5.18 but the download gives me 1.3.5.12. I received an email saying 1.4 was out.. How do we download the latest version? I clicked the link that is 'pinned' at the top of the page.  Never mind..I got the .18 version.. but the email did say 1.4.

Share this post


Link to post
Share on other sites

If the layers box is dragged from the Studio then when the cursor is placed over the rubbish bin it changes to a resize cursor but still deletes the item selected.

 

Thanks to all the team for the hard work in producing a great Photo editing program.

Share this post


Link to post
Share on other sites

I am having trouble with my plugins, I have uploaded a raw file adjusted and cropped it in Photo the opened  it in the plugin. The file in the plugin is the original not the cropped version. I have tried  saving  the picture and reloading it to no avail. I suspect that if I saved it as a jpeg and lost all the history the problem would disappear but that is not really an answer. Any suggestions as I need to have the plugin working on the adjusted and cropped image?

 

See attachment below

post-14506-0-28838200-1449415820_thumb.png

Share this post


Link to post
Share on other sites

I don't want to be a kill joy but the rate of issue of these Betas seems to indicate panic. In my experience, launching too early usually ends in tears.

Better to postpone a formal issue until  everything is fully tested and watertight.

Reputation can be so easily lost and impossible to regain.

 

Well, Mike, I don't think that releasing Betas in short intervals and with small fixes close to a GM release is an indication of panic at all… In fact, it's perfectly normal; if you look at other software companies, like Apple itself with iOS and OS X Beta builds (public or otherwise), it's pretty much standard practice. ;)

billtils, bogarguz and A_B_C like this

Share this post


Link to post
Share on other sites

Develop Persona issues:

 

When using the overlay brush and eraser tools, my waco's eraser is not supported. Perhaps the app should automatically switch from the brush to the eraser when I flip the stylus? Additionally, when I swap foreground or background colors (black and white) while on the brush tool, it does not erase the mask, only paint. If so, Why have the color /foreground-background selector active?

 

thanks for all you do


2011 MacBook Pro 8,2; Intel Core i7 @ 2.2 GHz, 16 GB RAM, 240 GB SSD Boot Disk + 750 GB HDD in optical bay, MacOS High Sierra

Share this post


Link to post
Share on other sites

I can't expand the group… Where is my little triangle ?

OS X 10.8.5

!?! that's very odd! I thought I'd seen this working in Lion onwards... I'll take another look!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now