Jump to content
Patrick Connor

Affinity Photo for Windows - 1.6.5

Recommended Posts

Hi,

 

We are pleased to announce the Windows release of Affinity Photo, version 1.6.5

FIXLIST

The changes in Affinity Photo for Windows 1.6.5 over the last APh patch 1.6.4 are as follows:

- Fixed Document Setup dialog failing to show correct Height and Width values when switching between portrait modes
- Fixed incorrect colour from CMYK waterfall model
- Fixed Info panel not showing W, H and D information in document units 
- Fixed being unable to select layers whilst recording Macros 
- Improve Microsoft Dial support
- Improve PDF import 
- Fixed resized floating panel not sticking when swapping to a different panel 
- Fixed floating window panels to remember their width as well as height
- Fixed Colour Picker shortcut not working with Surface Pen 
- Improved performance of shutdown 
- Fixed Leading Override (Character panel) and Paragraph Leading (Paragraph panel) key modifier inconsistencies
- Fixed Pen point being placed when panning with spacebar 
- Added missing "Scrubby Zoom"
- Fixed Space bar panning with the paintbrush tool placing nozzles
- Fixed crash when selecting Perspective Tool after using Mesh Warp Tool
- Fixed tool handle selection with touch input 
- Fixed SVG export to avoid exporting spurious groups
- Fixed pressing escape key on font size context toolbar editor not returning focus
- Added option to prefer metafile over raster with per-application default (defaulted to off)
- Fixed main window closing on second monitor not appearing at next start
- Fixed Adjustments panel starting below the visible window 
- Fixed Transform panel fields losing focus when using arrow and shift+arrow keys to increment/decrement values
- Fixed intermittent crash when using the Pen Tool 
- Fixed drag dropping a PNG file into the document locks the file
- Fixed Live Diffuse Glow filter opacity slider stuck at 100%
- Fixed editor boxes not incrementing correctly
- Fixed rendering issues with custom display scales between 125% and 150%
- Fixed crash pasting into Microsoft Paint
- Fixed some HDR images not loading
- Fixed dialogs not appearing on second monitor 
- Fixed keyboard shortcuts becoming disabled after pressing Escape in the Pressure dialog 
- Fixed colour conversion of bitmaps during vector export
- Fixed adjusting line pressure being laggy 
- Fixed deleting a node on the stroke pressure editor not updating the document
- Fixed New Document dialog not being aligned nicely
- Fixed rotating nodes not being remembered
- Fixed editing a Curves Adjustment preventing you from using Keyboard Shortcuts to add additional 
- Fixed unable to type after tabbing when editing a swatch value
- Fixed RGB slider field getting a dotted outline when tabbing into it 
- Fixed pressing delete with a stop selected on the Gradient Flyout deletes the object, not the stop
- Fixed Colour Replacement brush missing options on context toolbar 
- Fixed sporadic crash when sizing text frames to fit
- Fixed editing a guide in Guides Manager not correctly changing selection 
- Fixed Develop Persona lens adjustments rotation values differing to macOS
- Fixed Lens filter CMYK colour sliders jitter between values 
- Fixed adding colour to swatch causes crash 
- Fixed shaking a floating panel minimizes other panels
- Fixed fill layers built-in masks are broken 
- Fixed export area dropdown not working like the macOS version 
- Fixed Pen tool to add snapping while restart dragging under Pen mode
- Numerous other fixes and stability improvements.

REGRESSIONS

There is one known regression in this build over the previous release 1.6.4 (available here), sorry for this inconvenience

 - Artboards in embedded .afdesign file do not export to PDF

Please do not post bugs or problems that you find when using this version of the software in this thread, instead make a new thread in the Bugs on Windows section

 

For purchases from the Affinity Store the software, each time you start the software it will check for updates and offer any available update, or it can be downloaded from here

For purchases from the Microsoft Store are done automatically (next time you run after it is available in the store)


Patrick Connor

Serif (Europe) Ltd.

Share this post


Link to post
Share on other sites
Quote

MOD EDIT by Patrick Connor: Although what follows from Alex_M is true, we think this is NOT a regression introduced in 1.6.5 and that 1.6.4 is also affected.

So we (Serif) would still suggest that you DO install this build 1.6.5 which has many fixes MOD EDIT END

This new version has a terrible bug where panning while the paint brush tool is active results in an instant crash 100% of the time. This makes 1.6.5 practically unusable. I will shortly post a thread in the Bugs forum with more details. How do I safely revert back to 1.6.4 without my user settings being reset/deleted?

EDIT: Here's the thread


Affinity Photo 1.6.5.123 for Windows Windows 10 x64 1803  CPU AMD Threadripper 1950X @3.9 Ghz  RAM 32 GB GPU GTX 1080 ti 11GB NVMe SSD Samsung 960 Pro 512 GB

Share this post


Link to post
Share on other sites

Whoow Good news @Patrick Connor
Will switch to it when possible i'm still enjoying Beta 123 of both products.


Never be the Same Again !
MacBook Pro (13-inch, Mid 2010) - 2.4 GHz Intel Core 2 Duo - 8 GB 1067 MHz DDR3 - VIDIA GeForce 320M 256 MB

MacOS High Sierra 10.13.6  - Affinity Designer + Affinity Photo + Affinity Publisher + Snagit 2019 + Camtasia 2018 + Movavi Video Editor Business 15

Share this post


Link to post
Share on other sites
1 hour ago, Mark Ingram said:

This is exactly the same as the beta 123 (hence the identical build numbers).

Well have seen that but thank you for your quick reply @Mark Ingram.
Just a question please: have you planed to add eye drop tools on coming versions ?
I mean having the eye drop tool added to an adjustment layer such as HSL or White balance or anything that needs it will be a game changer.
Well sorry if this is far from what this topic is originally intended for but i took a chance to ask ... :D

Also, @Mark Ingram as i said in my mail to Serif and into few old post i wrote here, my Home Graphic Art Studio is now 100% Affinity, all other products have been dumped except Logoist (for mockups until Affinity make it possible to make stunning mockups) and RapidWeaver (for website learning).
Wanted to share it here with you to say, you are helping peoples like us have a space or place to stay on the sunny side of this already controlled and well ruled world of design & art.

So, keep pushing forward.
Soon i will share what i did with beta 123 as promised on that other topic of this forum and tell you what was my hard times and if this still is with stable 123.

Blessings !


Never be the Same Again !
MacBook Pro (13-inch, Mid 2010) - 2.4 GHz Intel Core 2 Duo - 8 GB 1067 MHz DDR3 - VIDIA GeForce 320M 256 MB

MacOS High Sierra 10.13.6  - Affinity Designer + Affinity Photo + Affinity Publisher + Snagit 2019 + Camtasia 2018 + Movavi Video Editor Business 15

Share this post


Link to post
Share on other sites
Posted (edited)

Bonjour ,

Malgré la dernière mise à jour, mon PC, i5, plus de 45 pour ouvrir une photo RAW de 30 m dans 5D MK 4.

Est ce normal, sachant que je n'ouvre que Affinity à ce moment là ??

De plus, les vignettes en RAW n'affichent que le logo Affinity sur Win 10, très désagréable de ne pas pouvoir faire un premier tri avant de cliquer sur une photo.

Merci

Edited by Matouman
fautes

Share this post


Link to post
Share on other sites

@Patrick Connor can you please look at @Matouman question here ?

in fact he is having hard time with RAW files/pictures they are all showing with Affinity logo (on the explorer) making it not possible for him to preview and choose before opening the file.
# think this maybe a system issue but ...

also he says that his core i5 computer takes a while to open a RAW file/photo ... the other 30 m dans 5D MK 4 is simply hard to understand for me because i think it maybe more related to photo and camera stuffs (sorry i'm not that skilled to help you @Matouman)

Blessings !


Never be the Same Again !
MacBook Pro (13-inch, Mid 2010) - 2.4 GHz Intel Core 2 Duo - 8 GB 1067 MHz DDR3 - VIDIA GeForce 320M 256 MB

MacOS High Sierra 10.13.6  - Affinity Designer + Affinity Photo + Affinity Publisher + Snagit 2019 + Camtasia 2018 + Movavi Video Editor Business 15

Share this post


Link to post
Share on other sites

Merci Arnaud !!

J'ai essayé avec le 7D, tout va bien avec Affinity. Vignettes photos RAW s'affichent et chargement instantané, m ^ m taille, 30 Mo.

C'est pour cela que j'ai mis hors de cause mon PC plutôt l'incompatibilité de l'Affinity avec le 5D MK4.

Share this post


Link to post
Share on other sites
2 hours ago, artphotopro said:

Hello,

Please can you confirm if the jpeg metadata export bug has been fixed in this update.

It's not listed in the Change List above, so it should not be fixed, yet. And, since the release version is now identical to the current beta version, if it's not fixed in the beta for you then it's not fixed in the new release version, either.


-- Walt

Windows 10 Home, April 2018 Update (1803), 16.0GB memory, Intel Core i7-6700K @ 4.00Gz
Affinity Photo 1.6.5.123 and 1.7.0.188 Beta
Affinity Designer 1.6..5.123 and 1.7.0.188 Beta
Affinity Publisher 1.7.0.192 Beta

Share this post


Link to post
Share on other sites
23 hours ago, Alex_M said:

This new version has a terrible bug where panning while the paint brush tool is active results in an instant crash 100% of the time. This makes 1.6.5 practically unusable. I will shortly post a thread in the Bugs forum with more details. How do I safely revert back to 1.6.4 without my user settings being reset/deleted?

EDIT: Here's the thread

Doesn't happen for me.

Share this post


Link to post
Share on other sites
50 minutes ago, Phil_rose said:

Doesn't happen for me.

I thought the same ;) Go to linked thread and you will find there steps to reproduce error. It does happens.

Share this post


Link to post
Share on other sites
Quote

- Fixed Pen point being placed when panning with spacebar 

- Fixed intermittent crash when using the Pen Tool 

Finally! Now I can cut my images in peace.

Still waiting for being able to move my pen points with space bar while adjusting them (not right after I've created 'em).

Share this post


Link to post
Share on other sites

Thought for sure they would have fixed the "Windows 10 only" debacle whereby Photo doesn't even run without the --no-dwm-warningn "fix", which isn't a fix at all for those who use, for example, a ZBrush to Photo workflow  - the very reason i and many others bought Photo. SO MANY people use Win7.

Share this post


Link to post
Share on other sites
On 8/26/2018 at 10:18 PM, truthdigger said:

Thought for sure they would have fixed the "Windows 10 only" debacle whereby Photo doesn't even run without the --no-dwm-warningn "fix", which isn't a fix at all for those who use, for example, a ZBrush to Photo workflow  - the very reason i and many others bought Photo. SO MANY people use Win7.

It does run without --no-dwm-warning on Windows 7. You only need that if you disable the DWM (which is permanently enabled from Windows 8, with no way of disabling).

Share this post


Link to post
Share on other sites

Bonjour,

Toujours aussi lent et après essais avec d'autres logiciels, en RAW , je m'aperçois que celà ne provient pas de mon i5. Je rame !!!

Share this post


Link to post
Share on other sites

Matouman

Pour moi  6 sec sur un raw de 30Mo (D610 Nikon) un i5 également.C'est le point faible de Photo, mais après le chargement cela passe.! Attention, cependant Photo extrait les données du raw, directement et n'affiche pas le jpg encapsulé du raw ce que d'autre fond à l'ouverture rapidité fallacieuse

J'ai 16go avec 8g0 trop juste win 10 faisait trop de swapping. Voir avec le gestionnaire des taches CTRL ALT SUP, pour objectiver.

 

 

Share this post


Link to post
Share on other sites
On 8/22/2018 at 5:12 PM, Patrick Connor said:

Hi,

 

We are pleased to announce the Windows release of Affinity Photo, version 1.6.5

Hello @Patrick Connor as promised in my comments above i've done few test and worked with APhoto beta & stable 123 and it was a good experience, took it to use a lot of stuffs in one project and i was not that much disappointed because the software just did what i wanted (as it is intended to do :))

The only thing i noticed was an increase of speed when merging visible layer, i make a lot of use of this method of work and it's life saving as it compensate with the times i forgot to snapshot or save with history; in fact for the same project tested on both release, beta 123 was not good at doing merge visible layer as i expected but won against beta 119 and lost against stable 123 which is precise was just a bit faster and did not crash but interface freezing was there as in the previous versions.

The installation of stable 123 went smoothly no bug and no crash and i have not yet experienced a crash that makes me go to task manager and kill the thing, so it's a good sign but i believe it still need to be improved.
Software start and shutdown is good also, i still use the same number of fonts and it's loading a bit faster ;)
See i'm not a photo artist but i really believe that if you make APhoto a bit more intuitive it will help increase the attention and "Prouesse" of users of any level; sorry to say this but i found it really easy and was close to be seduced by Luminar 2018 last version, i tried for minutes and was amazed ( i think their dev's looked at APhoto and used what they discovered to make their software better) and ... APhoto won on Luminar on my windows laptop ^_^ Luminar requested video drivers to be updated before processing the work when APhoto was just --at Home :x!

As said i'm not yet a photo artist but would recommend you look at Luminar interface and logic etc... and just create something amazing that will fit any level of user not only targeting Pro or skilled peoples.

Whatever, i'm happy with APhoto stable 123 and will give it more work with coming projects and share some here.

Blessings !


Never be the Same Again !
MacBook Pro (13-inch, Mid 2010) - 2.4 GHz Intel Core 2 Duo - 8 GB 1067 MHz DDR3 - VIDIA GeForce 320M 256 MB

MacOS High Sierra 10.13.6  - Affinity Designer + Affinity Photo + Affinity Publisher + Snagit 2019 + Camtasia 2018 + Movavi Video Editor Business 15

Share this post


Link to post
Share on other sites

This version is not reading EXIF metadata at all. Tried files from three different cameras, NEF/RAWs, converted TIFs, JPGs. It shows "No Camera data" every time.

Share this post


Link to post
Share on other sites
52 minutes ago, awhite said:

This version is not reading EXIF metadata at all. Tried files from three different cameras, NEF/RAWs, converted TIFs, JPGs. It shows "No Camera data" every time.

Working fine for me (and presumably many others, who would have complained), so it may be something unique to your machine or installation. If you start Task Manager, and in the Processes tab expand the entry for Affinity Photo, what processes do you see? I have Photo itself, a Console Window Host, and 2 copies of exiftool.exe running.


-- Walt

Windows 10 Home, April 2018 Update (1803), 16.0GB memory, Intel Core i7-6700K @ 4.00Gz
Affinity Photo 1.6.5.123 and 1.7.0.188 Beta
Affinity Designer 1.6..5.123 and 1.7.0.188 Beta
Affinity Publisher 1.7.0.192 Beta

Share this post


Link to post
Share on other sites

There is just one more "Affinity Photo" process under the main process, nothing more. I'll try to reinstall Photo and see if that helps.

Edit: Attempt to repair the installation ended with "Setup failed", so I did full uninstall/reinstall and the exiftool is working now. Thanks walt.farrell.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×