Mark Ingram

Affinity Designer Customer Beta - 1.6.0.85

52 posts in this topic

Click here to download the latest beta
 
Status: Customer Beta
Purpose: Stability
Requirements: A valid product key, issued when Windows Affinity Designer version 1.5 was purchased.

This is a beta of a substantial change to our codebase and as much as we have tried to ensure the quality of the code, it is considered to be not suitable for production use. This means that you should not attempt to use it for commercial purposes or for any other activity that you may be adversely affected by the application failing. In addition it is definitely worth noting that files created in Affinity 1.6 may not open in 1.5 so always make a copy of your important documents before opening them in 1.6 to ensure you do not accidentally overwrite them and are unable to open them in your 1.5 version.

We hope you enjoy the latest build, and as always, if you've got any problems, please don't hesitate to post here and we'll get back to you as soon as we can. Thanks once again for your continued feedback.

If you have a general question about the software, please head over to the Questions Forum, or if you have any suggestions, please head over to the Feature Requests forum.
 
Fixes

  • Fixed Angle and Tilt for Wacom and Surface Pen
  • Fixed Colour Panel switches back when trying to change non-Tint sliders on Global Colours
  • Fixed Font Traits cause a Font Family to appear multiple times under Used Fonts
  • Fixed Colour Chooser dialog missing 'selected colour node' in the Sliders waterfall
  • Fixed Fonts are not organised by weight in font lists
  • Fixed Layer > Hide and Show are missing from the Layer Menu
  • Fixed Live lighting bump map opacity reverts to 0
  • Fixed Multiply blend in 32bit RGB
  • Fixed artifacts appearing when Depth of Field Live filter placed above Curves Adjustment
  • Fixed being unable to edit Brush Dynamic curve nodes
  • Fixed Adjustment dialog staying open when an Adjustment is deleted
  • Fixed Backspace does not delete node on curves adjustment
  • Fixed being unable to edit swatch via double click
  • Fixed invalid selections when document size or DPI are changed
  • Fixed Save As on a Read Only file removing the Read Only flag
  • Fixed Gradient Type being reset when changing node colour
  • Fixed Brush Editor values appearing with loss of precision
  • Fixed Edit text styles Baseline not correctly applying
  • Fixed Brush Editor and Context Toolbar not properly linked
  • Fixed Opening a file in conjunction with Reopen Last Document opens a Read Only file
  • Fixed Blend Range channel list doesn't update after changing colour mode
  • Fixed Align Left on Paragraph tab fails to work
  • Fixed Baseline value can be set to -0%
  • Fixed Leading Override Up/Down arrows fail when set to Auto

Share this post


Link to post
Share on other sites

A super thank you.jpg

Burny and IvanDoganov like this

-- 

Rick

 

yoda.gif

Affinity Designer 1.5.3.69 & beta 1.6.0.86  Affinity Photo 1.5.2.69, beta 1.6.0.86

Windows 10 Pro 64-bit

CPU Intel Core i7 4770 @ 3.40GHz Haswell 22nm Technology

RAM 32.0 GB Dual-Channel DDR3 @ 798 MHz (11-11-11-28)

Motherboard Gigabyte Technology Co. Ltd. B85M-D3H (SOCKET 0)

Graphics Intel HD Graphics 4600 (Gigabyte)

Share this post


Link to post
Share on other sites

Bug or feature?

Duplicating an artboard doesn't create a new slice for it automatically like it does in the 1.5 version. So you have to manually go to the Export Persona > Layers > select the duplicated artboard and click Create Slice.

Also creating a new artboard from scratch gets a new slice automatically.

 

By the way, nice job with the Font Styles! Finally they are ordered in a logical way from lightest to thickest.

Share this post


Link to post
Share on other sites

The upper tools settings panel disappear after closing an image... The bottom part of the "Layers" panel to the right disappear also.

But they come back when you open a file or create a new one.

Exactly the same thing in Photo .85 (reported)

Share this post


Link to post
Share on other sites
28 minutes ago, dpcdpc11 said:

Bug or feature?

Duplicating an artboard doesn't create a new slice for it automatically like it does in the 1.5 version. So you have to manually go to the Export Persona > Layers > select the duplicated artboard and click Create Slice.

 


This is already in and with Development :)

Share this post


Link to post
Share on other sites
12 minutes ago, AlainP said:

The upper tools settings panel disappear after closing an image... The bottom part of the "Layers" panel to the right disappear also.

But they come back when you open a file or create a new one.

Exactly the same thing in Photo .85 (reported)

This has been reported and with development. It should have no negative impact on your processes however, just a visual annoyance.

Rick G likes this

Share this post


Link to post
Share on other sites

Hello Affinity,

I still see bug 1.5.0.7 - Visual line miss calculation while dragging curve edges whilst in this beta and in current production version.

The crosshair issue in the Pixel Persona brushes seems to have been solved, but brush preview continues to be always 'on'.

Thank you.

 

Share this post


Link to post
Share on other sites
On 12/10/2017 at 7:57 AM, Mark Ingram said:

Fixed Font Traits cause a Font Family to appear multiple times under Used Fonts

 

Nice, thanks!

Share this post


Link to post
Share on other sites

There is a bug in 1.6.0.85 that doesn't appear in 1.5.3.69: Expanding a stroke, results in slight distortions of the resulting object. I've made two screenshots of both superimposed objects, the red one being the stroke, and the green one being the resulting expanded object.

It looks like a regression, since to my knowledge, early betas of 1.5.xx had similar problems.

bug.png

bug2.png

Share this post


Link to post
Share on other sites
On 10/12/2017 at 5:11 AM, Rick G said:

A super thank you.jpg

 

Neat retro/cartoon stock art thumbnail. Too bad one cannot make the vector halftone in AD...

Rick G likes this

My computer is a nothing-special Toshiba laptop with unremarkable specs running Windows 10 64-bit.

Share this post


Link to post
Share on other sites
17 hours ago, RPC said:

The noise selection for solid colors seems to be missing now, or was it moved to some place else?

 

 

capture-001449.png.389639e8a9027f0091cee0dfdfe29889.png

Rick G likes this

My computer is a nothing-special Toshiba laptop with unremarkable specs running Windows 10 64-bit.

Share this post


Link to post
Share on other sites

Not sure if it's a feature or a bug but it's the same in the stable 1.5 as well.

I'm talking about the stroke alignment on an open shape. It makes not difference if you set it to exterior or interior as it's always aligned to Center.

This makes it a problem especially when exporting to PSD as Photoshop handles stroke position the same way for closed and opened objects as well.

What do you think guys?

Rick G and rubs like this

Share this post


Link to post
Share on other sites

If it is then a fix is in order


-- 

Rick

 

yoda.gif

Affinity Designer 1.5.3.69 & beta 1.6.0.86  Affinity Photo 1.5.2.69, beta 1.6.0.86

Windows 10 Pro 64-bit

CPU Intel Core i7 4770 @ 3.40GHz Haswell 22nm Technology

RAM 32.0 GB Dual-Channel DDR3 @ 798 MHz (11-11-11-28)

Motherboard Gigabyte Technology Co. Ltd. B85M-D3H (SOCKET 0)

Graphics Intel HD Graphics 4600 (Gigabyte)

Share this post


Link to post
Share on other sites

Personally, I don't see the point of stroke alignment on open paths. How would a design benefit from such a capability?


My computer is a nothing-special Toshiba laptop with unremarkable specs running Windows 10 64-bit.

Share this post


Link to post
Share on other sites

Here ya go, Rick...

 

s-thank-you.png.610909df262b932840a9a76cfcf0bd90.png

 

Designed by someone else, used here for illustrative purposes...

Rick G likes this

My computer is a nothing-special Toshiba laptop with unremarkable specs running Windows 10 64-bit.

Share this post


Link to post
Share on other sites
3 minutes ago, MikeW said:

Here ya go, Rick...

 

s-thank-you.png.610909df262b932840a9a76cfcf0bd90.png

 

Designed by someone else, used here for illustrative purposes...

WOOHOO! Thanks!


-- 

Rick

 

yoda.gif

Affinity Designer 1.5.3.69 & beta 1.6.0.86  Affinity Photo 1.5.2.69, beta 1.6.0.86

Windows 10 Pro 64-bit

CPU Intel Core i7 4770 @ 3.40GHz Haswell 22nm Technology

RAM 32.0 GB Dual-Channel DDR3 @ 798 MHz (11-11-11-28)

Motherboard Gigabyte Technology Co. Ltd. B85M-D3H (SOCKET 0)

Graphics Intel HD Graphics 4600 (Gigabyte)

Share this post


Link to post
Share on other sites
10 minutes ago, kabiani said:

when Affinity designer 1.6 final version will come. Beta version is always keep udating its boring now. 

Betas are supposed to keep updating as they work the bugs out. There are still a lot of bugs in this beta so I would be surprised if it was any time real soon

rubs and kabiani like this

-- 

Rick

 

yoda.gif

Affinity Designer 1.5.3.69 & beta 1.6.0.86  Affinity Photo 1.5.2.69, beta 1.6.0.86

Windows 10 Pro 64-bit

CPU Intel Core i7 4770 @ 3.40GHz Haswell 22nm Technology

RAM 32.0 GB Dual-Channel DDR3 @ 798 MHz (11-11-11-28)

Motherboard Gigabyte Technology Co. Ltd. B85M-D3H (SOCKET 0)

Graphics Intel HD Graphics 4600 (Gigabyte)

Share this post


Link to post
Share on other sites
11 minutes ago, Rick G said:

Betas are supposed to keep updating as they work the bugs out. There are still a lot of bugs in this beta so I would be surprised if it was any time real soon

ok thank you sir. Can we continue working in this Beta version....There will be no problem later on...when the final version release...

Share this post


Link to post
Share on other sites
8 hours ago, MikeW said:

Personally, I don't see the point of stroke alignment on open paths. How would a design benefit from such a capability?

Try making an X from 2 lines with exterior stroke alignment and export that to Photoshop. You'll see the problem. 

Also why shouldn't the stroke behave the same way for opened shapes as it does for closed ones? Or at least disable the stroke alignment for opened shapes. 

See my point? 

Share this post


Link to post
Share on other sites

I think that a bug and it's my second report.

It's all in Chinese world to says:

1. when justify left, insert space in article is very reluctantly. 

2. Punctuation in the line start, It's not consider non-english world Placeholder or something...

bug.png

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.