Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

Affinity Photo Customer Beta - 1.6.0.81


Recommended Posts

  • Moderators

Click here to download the latest beta

 

Status: Customer Beta
Purpose: New features
Requirements: A valid product key, issued when Windows Affinity Photo version 1.5 was purchased.

This is a beta of a substantial change to our codebase and as much as we have tried to ensure the quality of the code, it is considered to be not suitable for production use. This means that you should not attempt to use it for commercial purposes or for any other activity that you may be adversely affected by the application failing. In addition it is definitely worth noting that files created in Affinity 1.6 may not open in 1.5 so always make a copy of your important documents before opening them in 1.6 to ensure you do not accidentally overwrite them and are unable to open them in your 1.5 version.

We hope you enjoy the latest build, and as always, if you've got any problems, please don't hesitate to post here and we'll get back to you as soon as we can. Thanks once again for your continued feedback.

If you have a general question about the software, please head over to the Questions Forum, or if you have any suggestions, please head over to the Feature Requests forum.

Fixes

  • Fixed startup crashes
  • Fixed application hangs (Not Responding)
  • Improved performance of document render when dragging out a new object
  • Fixed hang when dragging by frame text with snapping enabled
  • Fixed crash reporter failing to generate crash reports
  • Fixed failure to edit a Global Colour Fill that is not already applied
  • Fixed being unable to change matte colour on export 
  • Fixed Export Preset not being remembered
  • Fixed setting blend mode for bevel and emboss preventing file from saving 
  • Fixed Global Colours importing to Application Palettes incorrectly
  • Fixed Colour well incorrectly showing colour when using Greyscale
  • Added missing boolean operation menu in the Layers panel
  • Fixed EPS load crash
  • Added rotation of nodes in NodeTool
  • Fixed occasional failure to finish loading files
  • Performance improvements to Inpainting
  • Fixed PDF import never completing when they contain tile patterns
  • Further improvements to stroke expansion
  • Improved error reporting in installer
  • Improved the way we load ICC and WCS profiles so WCS profiles give a better description
  • Fixed DNG files failing to load properly
  • Fixed PDF import crash
  • Disabled Radial Controller support (i.e. Dial) unless the --radial-controller flag is passed on the command line
Link to comment
Share on other sites

Not the easiest of installations. The dialog shot almost all the way off the top left-hand corner of the screen, leaving just the right-hand edge visible (so I could only click the Close 'X', not grab the title bar to drag the window to somewhere more sensible). I had to rely on the thumbnail image on the taskbar, firstly to tell me when I had the checkbox in focus so that I could check it (via the space bar) to continue with the installation, and then to tell me that I had tabbed to the correct button for proceeding to the next stage.

Alfred spacer.png
Affinity Designer/Photo/Publisher for Windows 1.10 • Windows 10 Home/Pro
Affinity Photo for iPad 1.10 • Designer for iPad 1.10 • iPadOS 15.6.1 (iPad Air 2)

Link to comment
Share on other sites

Thanks Guys, appreciated! Speed and responsiveness is a great improvement!

Asus ROG Strix G17 Notebook:
AMD Ryzen 7 5800H 3.80 GHz with Radeon Vega Graphics | 32GB DDR4 3200mHz RAM
Nvidia GeForce RTX 3060 Ti 8GB Gfx | 2x 2TB SSD NVMe PCIe M.2 3x4 | Windows 11 Version 22H2 Build 22623.870

Link to comment
Share on other sites

thank you thank you thank you  

just finished several hours edit session and not one crash, solid as a rock and an absolute bleedin pleasure to work with love it!!!!

what ever the heck you did you did good!

(could do with the colour picker in the curves dialogue working though but I'm sure it's in the to do list some where) :) 

Regards

Link to comment
Share on other sites

1 hour ago, harrym said:

(could do with the colour picker in the curves dialogue working though but I'm sure it's in the to do list some where) :) 

 

For the Curves it isn't a color picker, the picker allows you to drag on the image to modify the adjustment. The initial click will place a point on the curve in relation to the pixel selected, to lighten the image drag up and drag down to darken it.

Win 11 x64 System with Intuos Pen & Touch
 - Sys : Intel® Core™ i7-7700HQ CPU @ 2.80GHz (8 CPUs), 16GB RAM
 - GPU 1: Intel HD Graphics 630, GPU 2: NVIDIA GTX1050, 4GB

iPad (8th Gen) 2020

 

Link to comment
Share on other sites

Thank you for the new beta.

Unfortunately, I can't use it here because layers visibility is buggy. Turning layers or masks on or off most of the time have no effect, the image doesn't show any differences in terms of layers being switched on or off.

Too bad, it actually felt a little faster compared to the previous beta.

Andrew
-
Win10 x64 AMD Threadripper 1950x, 64GB, 512GB M.2 PCIe NVMe SSD + 2TB, dual GTX 1080ti
Dual Monitor Dell Ultra HD 4k P2715Q 27-Inch

Link to comment
Share on other sites

congratulations ! :11_blush:

 

10 hours ago, harrym said:

thank you thank you thank you  

just finished several hours edit session and not one crash, solid as a rock and an absolute bleedin pleasure to work with love it!!!!

what ever the heck you did you did good!

(could do with the colour picker in the curves dialogue working though but I'm sure it's in the to do list some where) :) 

Regards

 

13 hours ago, Dave Quail said:

Thanks Guys, appreciated! Speed and responsiveness is a great improvement!

 

19 hours ago, IndigoMoon said:

Hey, 3.5 sec start up time for this beta! Wow, what an improvement, but I guess you've forgotten to include the debug code, right?  ;)

 

cheers 

 

 

Link to comment
Share on other sites

When the document is closed, the application hangs. The image disappears, but the panel with a cross is closed.

jjnx`n.PNG

__________________

Windows 11 64-bit,

AMD Ryzen 9 3900 + Nvidia 1660 Super + Nvidia Studio driver + 32 Gb RAM.

Link to comment
Share on other sites

Bug (windows 8.0)

Open any image

Add an adjustment (e,g, exposure)

Can't switch off image in layers panel

i.e. has no effect until you zoom in or out

 

Same with shapes etc

Seems to be a problem when adding adjustment

 

EDIT: Now happening in documents without any adjustment layer(s)

Edited by carl123
More information
Link to comment
Share on other sites

48 minutes ago, carl123 said:

Bug (windows 8.0)

Open any image

Add an adjustment (e,g, exposure)

Can't switch off image in layers panel

i.e. has no effect until you zoom in or out

 

Same with shapes etc

Seems to be a problem when adding adjustment

 

I just followed your steps (under Windows 10) and can switch off the image layer with no problem. Do you mean switching off by unticking at the very right end of the layer?

 

d.

Affinity Designer 1 & 2   |   Affinity Photo 1 & 2   |   Affinity Publisher 1 & 2
Affinity Designer 2 for iPad   |   Affinity Photo 2 for iPad   |   Affinity Publisher 2 for iPad

Windows 10 21H2 (19044.2251) 64-bit - Core i7 - 16GB - Intel HD Graphics 4600 & NVIDIA GeForce GTX 960M
iPad pro 9.7" + Apple Pencil

Link to comment
Share on other sites

1 minute ago, dominik said:

 

I just followed your steps (under Windows 10) and can switch off the image layer with no problem. Do you mean switching off by unticking at the very right end of the layer?

 

d.

Yes exactly that

 

Link to comment
Share on other sites

I'm getting that too, was zooming around so much didn't notice until now. If you switch any layer off and on again it doesn't re-appear until you force a refresh like a zoom. Adjustments do show/hide unless they are under a layer.

Still not crashing though yaaaaa!!!! :)

 

edit: Yip, Inpainting tool definitely feels faster 

 

 

Link to comment
Share on other sites

" Hey, 3.5 sec start up time for this beta! Wow, what an improvement, "

really fasttttt...THANKS !!!!!!!!!!!!!!!!!!!

and a little poin pleasant ...."correction de brume"  :D

i said every time

you are the best TEAM !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

sur

Link to comment
Share on other sites

14 hours ago, AiDon said:

 

For the Curves it isn't a color picker, the picker allows you to drag on the image to modify the adjustment. The initial click will place a point on the curve in relation to the pixel selected, to lighten the image drag up and drag down to darken it.

 

I'm an idiot! You are absolutely correct.

I had it in my head that the picker worked differently thanks for making me rtfm :)

Link to comment
Share on other sites

4 minutes ago, newty said:

just a question in a new reply

why when i download my official affinity is always 1.5.2 ?????

thanks

Because 1.5.2.69 is the latest official (to buy) version, there hasn't been a new release since that. This is the beta program thread.

Regards

Link to comment
Share on other sites

9 minutes ago, newty said:

just a question in a new reply

why when i download my official affinity is always 1.5.2 ?????

thanks

The beta release is totally separate to the official release, both releases can run at the same time on your computer.

You should have a separate icon on your desktop to run the beta release once installed, click that one to run the beta

 

 

Link to comment
Share on other sites

i would like to erase bottom , left

but affinity freezed

i have let it to "wait and see" but nothing  happened

<<<<

thanks for ooficial

excuse me i d like to sai

if rightt the official is 1.5.2 ???? , thanks >>>

Edited by newty
new
Link to comment
Share on other sites

Started perfomance testing for langer real estate work.
Worked with two machines in parallel:
I7 5575 3,6GHz, integrated video card, 8GB Ram

AMD Ryzen 7, 1800x 3,6GHz, liquid cooled, Nvidia 1050Ti, 16GB Ram
Both running from SSD Sandisk extreme 960GB


You would expect a serious faster response from the AMD, because this one can work with up to 16 cores.
I hardly found speed differences. The Intel was ofet loaded to almost 100%, the AMD up to 60 percent. I've no clue why this is not going any faster.
I guess, Affinity is not optimized to use all processor cores. (limited to 8) which might result in a max 60% load of the AMD.
Using all cores would serious increase speed on those newer AMD processors which are especially designed for rendering these kind of thing.
Unfortunately Affinty is not getting the max out of it which turns out in no difference between many processors having 8 cores running around 3,5GHz.
I think serious performance increase is possible just by enabling the use of more cores.


 

Link to comment
Share on other sites

4 hours ago, carl123 said:

Bug (windows 8.0)

Open any image

Add an adjustment (e,g, exposure)

Can't switch off image in layers panel

i.e. has no effect until you zoom in or out

 

Same with shapes etc

Seems to be a problem when adding adjustment

 

EDIT: Now happening in documents without any adjustment layer(s)

 

It seems the same issue I'm having.

I rolled back to the previous beta.

Andrew
-
Win10 x64 AMD Threadripper 1950x, 64GB, 512GB M.2 PCIe NVMe SSD + 2TB, dual GTX 1080ti
Dual Monitor Dell Ultra HD 4k P2715Q 27-Inch

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.