Andy Somerfield

Affinity Designer Customer Beta (1.3.5.13 - RC3)

40 posts in this topic

Purpose: Improvements / Fixes 

Status: Release Candidate
Requirements: Purchased Affinity Designer
Mac App Store: Not Submitted
Download: Here
 
To use this beta, simply download the file from the link given above and double-click on the file to open the installer. Follow the instructions to install the beta version. The beta sits alongside the Mac App Store version and will not interfere with it. Please note that if you use features which are only present in the Beta version then save your document, it will no longer open in the Mac App Store version.

 

This is a Release Candidate build. It is our intention to submit this for review to Apple in the first week of December. Any help you could offer to stabilise and refine the product at this stage will be very gratefully received   :)  We won't be implementing any new features now for this version and we will be focusing on stabilising the product for the immediate future. We will obviously start adding more features again as soon as this update goes live.
 

Improvements / Fixes

 

- "Smart" alpha export - any exported / saved images will not contain an alpha channel if no pixels have alpha. This should help with DAM’s which hate alpha and with Xcode - which sometimes hates alpha.

- Fixed issue whereby transparent areas of a palletised PNG export would be blue instead of transparent.
- Attempted to automatically repair bad CMYK Levels values generated by older versions of Affinity Photo / Designer.
- Fixed crashes caused by assigning a shortcut key to the place image tool.
- Prevented boolean operations on artboards (!)
- Stability improvements when moving artboards around.
- Numerous localisation improvements.
 

Share this post


Link to post
Share on other sites

Nice, not long now. Any chance of getting rid of the automatic appearance of the canvas grid when you delete an artboard? ;)

 

 

 

Allan


About me: Trainer at Apple, Freelance Video Editor, Motion Graphics Artist, Website Designer, Photographer. Yes I like creating things!!!

Twitter:@mystrawmonkey  @imAllanThompson

Web: mystrawberrymonkey.com 

YouTube: Affinity Designer & Photo Tutorials

Share this post


Link to post
Share on other sites

This is great … :) 

 

Seems you fixed most of the art board bugs … the only issue I noticed (and I do not want to sound annoying, but this is still a major issue) is the snapping bug that seems to be still there:

 

https://forum.affinity.serif.com/index.php?/topic/15272-affinity-designer-customer-beta-13512-rc2/?p=68914

 

Thanks, Alex  :)

predick likes this

Share this post


Link to post
Share on other sites

and just to point it straight into this thread 

- linked bleed values so that you don´t have to type 4 times (in probably most cases)

- same for margins please

 

 

And very important (I posted it in the AP thread but it really belongs to AD)

- bleed for artboards and bleed preview 

predick, vonBusing and Brian D like this

 

 

Share this post


Link to post
Share on other sites

I noticed a serious bug in this version that I can always reproduce on my machine. When switching to the export persona the application hangs indefinitely and I need to force quit it. I don't know how to attach the crash report to this post here. It's too big to paste and there is no attachment upload feature. Let me know if you need it.

Share this post


Link to post
Share on other sites

WOW Great step you guys are doing with this update, I feel that now is a pro app for graphic design, specially by the typography tools and pantone colors. I m still waiting a tool to distort mesh objects as illustrator, I think my money was well expended. well done! I continue testing it!

Share this post


Link to post
Share on other sites

I noticed a serious bug in this version that I can always reproduce on my machine. When switching to the export persona the application hangs indefinitely and I need to force quit it. I don't know how to attach the crash report to this post here. It's too big to paste and there is no attachment upload feature. Let me know if you need it.

Hi tiguchi,

 

Can you try restarting Designer, but holding down Ctrl as soon as you click to launch it? This should bring up a dialog to reset settings - select them all and reset. Does your problem go away now? I'm wondering if there is something unhappy about your setup (sometimes going from one beta to another will make some settings get into a state they normally couldn't be in...)

 

Thanks,

Matt

Share this post


Link to post
Share on other sites

Hi tiguchi,

 

Can you try restarting Designer, but holding down Ctrl as soon as you click to launch it? This should bring up a dialog to reset settings - select them all and reset. Does your problem go away now? I'm wondering if there is something unhappy about your setup (sometimes going from one beta to another will make some settings get into a state they normally couldn't be in...)

 

Thanks,

Matt

 

Thanks Matt for your quick response! Resetting the settings did solve the problem :-)

Will there be similar problems when upgrading the regular app store version?

Share this post


Link to post
Share on other sites

Thanks Matt for your quick response! Resetting the settings did solve the problem :-)

Will there be similar problems when upgrading the regular app store version?

Great, glad to know that worked :)  Typically, it's just a beta-to-beta thing - we often change things and sometimes they conflict as they evolve - but between major versions on the App Store the feature should be in and working or not there at all, rather than changing during development and going a little 'funky' at times... Sorry about that!

Share this post


Link to post
Share on other sites

Please change in both AP AD that the numerical rotation input in the transform panel does not respect the custom rotation centre, but overwrites it with one of the 6 standard dots...


 

 

Share this post


Link to post
Share on other sites

Just a quick update, as I go to the export menu and choose selection without background the app crashes. Tried it out at least 5 times in a row...

 

 

 

Allan

MattP likes this

About me: Trainer at Apple, Freelance Video Editor, Motion Graphics Artist, Website Designer, Photographer. Yes I like creating things!!!

Twitter:@mystrawmonkey  @imAllanThompson

Web: mystrawberrymonkey.com 

YouTube: Affinity Designer & Photo Tutorials

Share this post


Link to post
Share on other sites

Wow! You guys are so on top of your game!  :)


Affinity Designer 1.6

Affinity Photo 1.6.6

Canon EOS 50D

iMac 27" 3,4 GHz Intel Core i7 32 GB RAM

 

Share this post


Link to post
Share on other sites

Great work so far!

 

Just wondering if you could reconsider grouping the Artboard Tool with the Move Tool? The Artboard tool is rarely used while the Move tool is used constantly.

 

There's also a bug if you add the separate Artboard Tool button to the toolbar - When you select it, the Move Tool swaps to the Artboard Tool as well.

Share this post


Link to post
Share on other sites

2 things so far:

 

- Graphics are very choppy when you zoom in-out and after doing the artboard rotation. 

- I can't see the 'smart guides' anymore, don't know why.

 

Question:

Is there any shortcut for artboard rotation?, I think I still don't get this function right. The way I usually use the canvas or artboard rotation in other softwares is for drawing tricky angles with my wacom by pressing a key for rotation angle and then a key to reset the rotation. As far as I can see, in AD the canvas rotation thing is permanent.  Am I missing something guys?


• Frankentoon - Tutorials and Resources for Affinity Designer

• Get a Free eBook for Affinity Designer - Subscribe HERE

 

Follow us on Instagram  |  Follow us on Twitter |  Like us on Facebook

Share this post


Link to post
Share on other sites

-Bug Report-

 

For Artboard,

Transform input boxes usually cannot work, have to close the file and open it again to work with the input boxes.

post-15219-0-32973700-1448849838_thumb.png

Frankentoon likes this

Share this post


Link to post
Share on other sites

-Bug Report-

 

For Artboard,

Transform input boxes usually cannot work, have to close the file and open it again to work with the input boxes.

 

This happens to me all the time as well.


• Frankentoon - Tutorials and Resources for Affinity Designer

• Get a Free eBook for Affinity Designer - Subscribe HERE

 

Follow us on Instagram  |  Follow us on Twitter |  Like us on Facebook

Share this post


Link to post
Share on other sites

Hi,

 

Both Designer and Photo crash when clicking to go to Export Persona. I tried resetting both with the control key - clear the app - start and still got the same behavior.

 

This is on 10.10.4, in separated window mode, with 8 GB RAM iMac.

Share this post


Link to post
Share on other sites

This happens to me all the time as well.

Now I can solve it by changing Document Units to pixels, it always works fine.

Share this post


Link to post
Share on other sites

Opening a new document always reverts back to the Grays application color palette.  I have tried to change the default pallet based upon document color format but the application always defaults back to Grays.

Share this post


Link to post
Share on other sites

Hi everyone,

 

When I'm working on a CMYK document, and I try to add tints of a defined colour - global or not - to the swatches, I get tints with RGB values instead of the original CMYK colour.

Same thing goes for shades and tones as well. Also, when I tried the triadic, complementary, analogous colour chords, I got HSL values in the swatches palette. 

 

Maybe it's me, but I also couldn't find how to add only a specific tint of a defined colour to the colour swatches.

 

This post applies to Photo as well.

Share this post


Link to post
Share on other sites

I still have some issues with exporting PDF. AD won't crash anymore, thanks for that. That really helps when working.

But I am getting this error screen (see the attachment) when saving specific files).

I was experimenting with file and it is related to some layers. So I have reduced the image to the layers, which make the file unexportable to PDF…

The issues is related to the betas (currently RC3), I am able to export this file in App Store version.

Hopefully helps make AD more stable and better :-)

 

 

post-1445-0-10486700-1448877578_thumb.png

pdf export issue - c4test.afdesign

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now