Jump to content
AdamW

Affinity Publisher Public Beta - 1.7.1.399 (GM Preview)

Recommended Posts

Status: GM Preview
Purpose: Improvements and Fixes
Requirements: 64 Bit Win 7 SP1 / Win 8.1 / Win 10  (>=1607)
Download: No longer available
Auto-update: No longer available

Hi,

We are pleased to announce that Affinity Publisher Build 399 (GM Preview) is now available as a download from the link above. This is the build we hope to  ship to customers next week.

After launch we will start a new Customer Beta for those who have purchased the software and wish to have early access to on-going updates and fixes.

We hope you enjoy the product, and as always, if you've got any problems installing or running up, please don't hesitate to post in this thread. 

Any problems actually using this version please make a new topic in this forum and we'll get back to you as soon as we can. Please feel free to leave general suggestions and comments in the Discussion Forum

Many thanks to all users in the forum who have helped us get to where we are - we couldn't have done it without you.

---

Fixes and updates

Menus / Studio
Turned 'Clip To Canvas' off by default for Publisher only
Moved Stock panel to left had side in default studio setup
Shadows and Highlights updates
(Mac) Selection of swatch in Swatch Palette now considers overprint
(Win) Custom panel height is no longer reset on reopening the app
(Win) Fixes for Gradient Colour selector
(Win) Setting CMYK Colour profile in preferences was blanking Grey profile
(Win) Fixed Tint slider for Column Guides colour
(Mac) Fix for HSL Adjustment crashing on some setups

Tools
Fixed Drag-clone with Alt behaviour in Move Tool

Text / Tables
Fixed possible hang processing 'Keep With Next'
Fixed possible hang resizing table cells
Apply with Next Style was producing local formatting only
Fix for crash deleting pinned images in specific file
Setting capitalisation options on fields was causing them to disappear

Find and Replace
Updated search results to not display <U+XXXX> notation

Index
Fix issue with stale index topics failing to save correctly

Import / Export
Fixed issue exporting zero size bitmaps
---

Earlier Release Notes Beta 384

Share this post


Link to post
Share on other sites

Initially, I had a problem with the download.  After the second download, I was able to update the program.  I was hoping to see Assets panel feature with this release.

Share this post


Link to post
Share on other sites
2 minutes ago, Patrick Connor said:

What happens when you choose 'View' > 'Panels' > 'Asset panel'

I have the Assets panel visible by default here. It’s in the left-hand Studio group, sandwiched between ‘Pages’ and ‘Find and Replace’.


Alfred online2long.gif
Affinity Designer/Photo/Publisher 1.7.3.481 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.7.3.155 • Designer for iPad 1.7.3.1 • iOS 12.4.1 (iPad Air 2)

Share this post


Link to post
Share on other sites

Setup failed again while trying to update


Affinity Designer 1.7.1.404 & beta 1.8.0.486   Affinity Photo 1.7.1.404 beta  1.8.0.486 Affinity Publisher 1.7.0.422 beta  1.7.2.458

Windows 10 Pro 64-bit 1709

CPU Intel Core i7 4770 @ 3.40GHz Haswell 22nm Technology

RAM 32.0 GB Dual-Channel DDR3 @ 798 MHz (11-11-11-28)

Motherboard Gigabyte Technology Co. Ltd. B85M-D3H (SOCKET 0)

Graphics Intel HD Graphics 4600 (Gigabyte)

yoda.png

Share this post


Link to post
Share on other sites
6 minutes ago, ErrkaPetti said:

Is it really 1.71?

I think it should be version 1.70.399... Or?

It's 1.7.1. It's not 1.7.0 any more because we keep the major version numbers in sync with Design and Photo.

Share this post


Link to post
Share on other sites
Just now, Dave Harris said:

It's 1.7.1. It's not 1.7.0 any more because we keep the major version numbers in sync with Design and Photo.

Ok, I’m in!

Pretty excited of the coming future of the whole Affinity Suite!

Share this post


Link to post
Share on other sites

I am still having issues with the spell check Beta 399  Windows 8

I have 'the society' in my text. It will not ignore the apostrophe 'the

Also it will not learn. I thought the problem was resolved in the previous beta but sadly not.

Share this post


Link to post
Share on other sites
23 minutes ago, John T said:

I have 'the society' in my text. It will not ignore the apostrophe 'the

That isn’t an apostrophe, it’s a (straight) quotation mark! Do you get the expected result if you type

‘the society’

instead of

'the society'

?


Alfred online2long.gif
Affinity Designer/Photo/Publisher 1.7.3.481 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.7.3.155 • Designer for iPad 1.7.3.1 • iOS 12.4.1 (iPad Air 2)

Share this post


Link to post
Share on other sites
5 minutes ago, Alfred said:

That isn’t an apostrophe, it’s a (straight) quotation mark! Do you get the expected result if you type


‘the society’

instead of


'the society'

?

Sorry for the error had a late night.

Yes you have sorted it. Many thanks Alfred.

Share this post


Link to post
Share on other sites

@Rick G,

I'm aware you seem to have install issues quite frequently, do you get restarts after a fail?

I've just reproduced an issue where it restarted after an update, saying it failed. However it did actually succeed the install, do you get this behaviour?


Serif Europe Ltd. - www.serif.com

Share this post


Link to post
Share on other sites
Posted (edited)

How works linked documents info afpub? I created Picture Frame and linked document (afpub) in proximity 1GB file and save the primary document. In Resource Manager, I see "Linked document", so after saving file have more than 1GB weight? If I duplicate a few times I've got more than 5GB file? 

I noticed that now because the file was huge now.

[EDIT]

Affinity for Windows 10.

Edited by Corny
I forgot mention about platform, Windows Edition.

Uses: Affinity Designer and Photo | Beta Publisher

Share this post


Link to post
Share on other sites

Certain document types at the moment (pdf, affinity files) will lead to large file sizes even when linked, this is something we are aware of and are looking to improve.


Serif Europe Ltd. - www.serif.com

Share this post


Link to post
Share on other sites

Hello,

Been using Publisher on and off (off mainly due to joint characters not supported in certain languages).

Say in, Gujarati or Hindi, Publisher is unable to type out characters which have a joint pronunciation.

I have an artwork getting ready. It says FREE MATTRESS, wherein it can be seen what Publisher types out.

image.thumb.png.57dcf67ffafd17baacf42ab419876bba.png\

Now, the real version (also as per Google) is as below:

image.thumb.png.8cee7d6b67365bfac272eae3de350d81.png

As a result of non-support of such texts, I unfortunately have to go back to CorelDraw for such purposes.

Would be awesome if this could be addressed.

Thanks.

Share this post


Link to post
Share on other sites
4 hours ago, Jon P said:

@Rick G,

I'm aware you seem to have install issues quite frequently, do you get restarts after a fail?

I've just reproduced an issue where it restarted after an update, saying it failed. However it did actually succeed the install, do you get this behaviour?

Thanks for the reply

Consistently I will download the Publisher update, Launch it and let it proceed though the update until it ends with a setup failed message

It went smoothly to that point but it wiped out the Publisher install (I have checked the program folder after the failure and the program is indeed gone)

Rebooting, and running the installer again, it then makes a fresh install successfully


Affinity Designer 1.7.1.404 & beta 1.8.0.486   Affinity Photo 1.7.1.404 beta  1.8.0.486 Affinity Publisher 1.7.0.422 beta  1.7.2.458

Windows 10 Pro 64-bit 1709

CPU Intel Core i7 4770 @ 3.40GHz Haswell 22nm Technology

RAM 32.0 GB Dual-Channel DDR3 @ 798 MHz (11-11-11-28)

Motherboard Gigabyte Technology Co. Ltd. B85M-D3H (SOCKET 0)

Graphics Intel HD Graphics 4600 (Gigabyte)

yoda.png

Share this post


Link to post
Share on other sites

Ah ok, that's not something I've seen internally. I'm not sure if we have asked for these before but I can't find them, but can you attach the contents of your install logs found in %temp%\AffinitySetup ?


Serif Europe Ltd. - www.serif.com

Share this post


Link to post
Share on other sites
1 hour ago, Jon P said:

Ah ok, that's not something I've seen internally. I'm not sure if we have asked for these before but I can't find them, but can you attach the contents of your install logs found in %temp%\AffinitySetup ?

I no longer have them as I clean out the temp files nightly. I do have them posted all over this forum from past install failures that were exactly the same

I stopped posting them as there was never a reply but if you wish I can go back a beta then do the update again, generating the install logs


Affinity Designer 1.7.1.404 & beta 1.8.0.486   Affinity Photo 1.7.1.404 beta  1.8.0.486 Affinity Publisher 1.7.0.422 beta  1.7.2.458

Windows 10 Pro 64-bit 1709

CPU Intel Core i7 4770 @ 3.40GHz Haswell 22nm Technology

RAM 32.0 GB Dual-Channel DDR3 @ 798 MHz (11-11-11-28)

Motherboard Gigabyte Technology Co. Ltd. B85M-D3H (SOCKET 0)

Graphics Intel HD Graphics 4600 (Gigabyte)

yoda.png

Share this post


Link to post
Share on other sites

I think I've looked at them before to be honest, the failure is here from one the ones I've dug up:

+Error: The installer has insufficient privileges to access this directory: C:\Program Files\Affinity\Publisher Public Beta.  The installation cannot continue.  Log on as administrator or contact your system administrator.

I'm not sure why something would have a lock on this, but it's probably why the restart fixes it as it clears it. I'll see if I can get any extra info on why this might be happening.

 


Serif Europe Ltd. - www.serif.com

Share this post


Link to post
Share on other sites
2 minutes ago, Jon P said:

I think I've looked at them before to be honest, the failure is here from one the ones I've dug up:

+Error: The installer has insufficient privileges to access this directory: C:\Program Files\Affinity\Publisher Public Beta.  The installation cannot continue.  Log on as administrator or contact your system administrator.

I'm not sure why something would have a lock on this, but it's probably why the restart fixes it as it clears it. I'll see if I can get any extra info on why this might be happening.

 

I use an administrator account all the time so I should have sufficient privileges. Sometimes I will update publisher without ever launching it that day so that error may be hiding a deeper issue


Affinity Designer 1.7.1.404 & beta 1.8.0.486   Affinity Photo 1.7.1.404 beta  1.8.0.486 Affinity Publisher 1.7.0.422 beta  1.7.2.458

Windows 10 Pro 64-bit 1709

CPU Intel Core i7 4770 @ 3.40GHz Haswell 22nm Technology

RAM 32.0 GB Dual-Channel DDR3 @ 798 MHz (11-11-11-28)

Motherboard Gigabyte Technology Co. Ltd. B85M-D3H (SOCKET 0)

Graphics Intel HD Graphics 4600 (Gigabyte)

yoda.png

Share this post


Link to post
Share on other sites

I'm having "Setup failed" when I try to update photo/designer or publisher. I tried to run the installers as an administrator, but I still get the same error.

I tried uninstalling the software and re-install them from scratch, but they disappeared form Windows "Apps and Features"

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.