Jump to content
Mark Ingram

Affinity Photo Public Beta - 1.5.0.43 (Windows)

Recommended Posts

Click here to download the latest beta

Status: Public Beta
Purpose: Stability
Requirements: None

As this is a beta release, it is considered to be not suitable for production use. This means that you should not attempt to use it for commercial purposes or for any other activity that you may be adversely affected by the application failing. In addition it is worth noting that files created in Affinity Photo 1.5 cannot be opened in Affinity Photo 1.4, which means that they cannot be opened in the latest Mac App Store version of Affinity Photo, and instead you will need the latest macOS 1.5 beta.

We hope you enjoy the latest build, and as always, if you've got any problems, please don't hesitate to post here and we'll get back to you as soon as we can. Thanks once again for your continued feedback.

If you have a general question about the software, please head over to the Questions Forum, or if you have any suggestions, please head over to the Feature Requests forum.

Fixes

  • Potential fix for Wacom users who aren't receiving pressure data
  • Added ability to rename macro item parameters
  • Fixed "Scale with Object" for Soften parameter
  • Fixed 32-bit Preview Display Transform radio button defaults to ICC Display Transform but is using OCIO Transform
  • Fixed OCIO Display Transform being applied in Develop
  • Fixed being able to type a 7 digit Hex value into the Colour panel
  • Fixed crash clearing fill in Edit > Fill
  • Added missing Retina Rendering Performance Preference
  • Fixed Refine Selection dialog getting unintentionally dismissed
  • Fixed sporadic PDF import crash for compressed streams
  • Fixed zooming with the mouse wheel so that zooming in and out is consistent
  • Fixed Stock panel typo
  • Fixed crash creating new document with Character panel open
  • Fixed crash when selecting a font using the Character panel
  • Added missing SVG, EPS, and WMF from export dialog
  • Added scrollers around menus for lower resolution screens
  • Fixed Layer Effects "Soften" value can't exceed 20px
  • Fixed Stock search doesn't clear correctly
  • Fixed Layer Effects dialog wrong values displayed when "Scale With Objects" is on
  • Fixed Layer Effects "Scale with Objects" check box not updating when document selection changes
  • Fixed being unable to click through onto the document when a popup is open
  • Changed the default tone curve, so it has less dark in the shadows
  • Prefer exif:ExposureTime to exif:ShutterSpeedValue as the latter does not seem reliable
  • Fixed editing a Global Colour and selecting a colour using the eyedropper will lose it's Global Colour status
  • Fixed grid spacing is capped to slider value
  • Fixed Apply Image dialog can't tab efficiently between channel equation input fields
  • Fixed Rename Tone Mapping preset category doesn't reflect correct name 

Installer

  • Fixed thumbnail provider not working without VC Runtime on Windows 7 and 8
  • Fixed product key appearing incorrectly when display zoom is set to 200%

Share this post


Link to post
Share on other sites

Yay! More Wacom love!  Downloading...


Affinity Designer, Affinity Photo and Affinity Publisher licenses, Windows 7, i7  860 (2009) 2.8 GHz,  8 GB RAM, GTX 1050 2 GB, HD 7200 RPM.  Wacom Intuos 4 XL.

Share this post


Link to post
Share on other sites

Nice update (and quick) but no luck with my Wacom Bamboo... still no pressure.


Window 10 - 32 Gb - Intel I7 - 8700 - NVIDIA GeForce GTX 1060

Share this post


Link to post
Share on other sites

Nice update (and quick) but no luck with my Wacom Bamboo... still no pressure.

 

Hi AlainP, I've also added some logging to try to diagnose any further problems. Can you take a look in %APPDATA%\Affinity\Photo\1.0 (Beta)\ and attach the Log.txt file here so I can take a look?

Share this post


Link to post
Share on other sites

Hi AlainP, I've also added some logging to try to diagnose any further problems. Can you take a look in %APPDATA%\Affinity\Photo\1.0 (Beta)\ and attach the Log.txt file here so I can take a look?

Good news Mark.... it works perfectly ! I looked at the "Log.txt" file you mentionned and saw a line "WinTab: No tablets found"... I use my tablet in wireless mode so I turn it off when I don't use it. It has to be on before I start AP and then it works like a charm. Thanks.


Window 10 - 32 Gb - Intel I7 - 8700 - NVIDIA GeForce GTX 1060

Share this post


Link to post
Share on other sites

Nice, some errors fixed. Thou it seems the stability went down a bit, managed ot get 3 crashes in an hour or so.


"I'm a lumberjack and I'm OK, I sleep all night, and I work all day..."

Share this post


Link to post
Share on other sites

Good news Mark.... it works perfectly ! I looked at the "Log.txt" file you mentionned and saw a line "WinTab: No tablets found"... I use my tablet in wireless mode so I turn it off when I don't use it. It has to be on before I start AP and then it works like a charm. Thanks.

 

OK, that's interesting. I can perhaps try to get that fixed so that when you switch it on it automatically connects. What tablet are you using?

Share this post


Link to post
Share on other sites

Nice, some errors fixed. Thou it seems the stability went down a bit, managed ot get 3 crashes in an hour or so.

 

Do you remember what you were doing when it happened ?


Affinity Designer, Affinity Photo and Affinity Publisher licenses, Windows 7, i7  860 (2009) 2.8 GHz,  8 GB RAM, GTX 1050 2 GB, HD 7200 RPM.  Wacom Intuos 4 XL.

Share this post


Link to post
Share on other sites
Affinity Photo Public Beta - 1.5.0.43 (Windows)

 

On this beta and previous one, I get crashes when AP is in the background, IOW, when I'm in another active program. In case 1, in previous beta, I had closed the image but left AP idling in the background, activated Word 365 from the background and edited a doc that was already open. A few moments later, a Win 10 alert popup informed me AP crashed (while still in the background) and needed to close. Only one button appears in the alert box: CLOSE THE PROGRAM.

 

In case 2 with current beta AP, I saved the image but left it in AP, activated Outlook 365 from the background to check and respond to an incoming email. A few moments later, a Win 10 alert popup informed me AP crashed (while still in the background) and needed to close. Only one button appears in the alert box: CLOSE THE PROGRAM.

 

I hoped 1.5.0.43 might accidentally have fixed the problem but I guess not. No, I don't usually restart Windows after updating the beta, and I don't do anything special with the previous beta - I assume the process of installing the new beta does whatever with the previous beta you devs want to happen. Also I have not had similar problems with AD Win beta or paid versions. System info attached.

 

post-37528-0-25184800-1480716685_thumb.jpg

 

 


♥  WIN 10 AD & AP  ♥  Lenovo Legion Y520 15.6" Laptop

Share this post


Link to post
Share on other sites

OK, that's interesting. I can perhaps try to get that fixed so that when you switch it on it automatically connects. What tablet are you using?

That would be nice. I have a Wacom Bamboo CTH-470.


Window 10 - 32 Gb - Intel I7 - 8700 - NVIDIA GeForce GTX 1060

Share this post


Link to post
Share on other sites

Hello, when editing from a panorama with the "repair tool" AP is frozen.
I had to press ESC and tried to work with another tool.
No tool has responded. Property then restart AP.

post-44324-0-35633700-1480738825_thumb.jpg

post-44324-0-64547300-1480738833_thumb.jpg


Win7 HP 64 Bit, AMD Six-core 3.50 GHz, 16 GB Ram, NVIDIA GeForce GTX 750 Ti
 

Share this post


Link to post
Share on other sites

Do you remember what you were doing when it happened ?

At least for one thing, I was transforming an object (perspective correcting) when I got a corruption of memory (visible artifacts) and then it crashed.


"I'm a lumberjack and I'm OK, I sleep all night, and I work all day..."

Share this post


Link to post
Share on other sites

Hi,

 

Thanks for the update 1.5.0.43, the program will become better.

Just a pity that the Plug-in for ePaperPress still does not work.

Do you think that this will work in the next update?

I work with Windows 10

Share this post


Link to post
Share on other sites

HI,
it's nice to have Affinity Photo on Win :) - great job !

Is it possible to expect addjusting sliders beeing reactive on mouse wheel moove ?
(or may be it goes but can't find how to set it ?)

Regards,
Fotomak


Affinity Photo 1.7.2.471; Affinity Photo customer beta 1.8.0.526
GIMP 2.10.14, RawTherapee 5.7, Darktable 3.0.0;

Win10Pro (v. 10.0.17763), IntelCore i7-4790-3.60GHz, ram 8GB, , ssd 256GB, Huion new 1060plus;
Monitor 2D FHD LG 1920 x 1080 px, Onboard Intel Graphics HD 4600.

Share this post


Link to post
Share on other sites

Wacom Intuos still has delay when starting new stroke. (pressure is working)

 

I got this info in my log.

 

Attempting to create Direct3D device with adapter NVIDIA GeForce GTX 765M
Setting screen DPI to 117.797101449275 (scale = 1.0)
WinTab: Failed to get tangent pressure info

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.