Jump to content
Andy Somerfield

Affinity Photo Customer Beta (1.4.1 - Beta 1)

Recommended Posts

Purpose: Fixes

Status: Incremental bug-fix track on 1.4

Requirements: Purchased Affinity Photo

Mac App Store: Not submitted

Download: Here

 

To use this beta, simply download the file from the link given above and double-click on the file to open the installer. Follow the instructions to install the beta version. The beta sits alongside the Mac App Store version and will not interfere with it.

 

This is an Incremental Bug-Fix release - it should be considered more stable than the current MAS version (1.4) and should be used in preference to that build, if you are experiencing any of the problems listed below.

 

Fixes

 

- Fixed crashes when loading a document which has been saved in Quick Mask mode.

- Fixed crashes when using documents in the ProPhoto colour space in Mac OS X 10.9.5.
- Fixed stroke clipping / invalidation issues.
- Fixed crashes when loading documents saved with “Delete Slices” history items.
- Fixed weird zombie-open-dialog when starting the app.
- Fixed crashes when using calibrated monitor profiles with high-accuracy LUTs.
- Fixed layer “Expand” buttons disappearing in Mac OS X 10.8.
 

Share this post


Link to post
Share on other sites

Affinity Photo's icon on the OS X Dock won't allow me to drag and drop images from Apple Photos... is this normal? Photoshop and others accept the dragged and dropped thumbnail just fine...


2017 15" MacBook Pro 14,3 w/ Intel 4 Core i7 @ 2.8 GHz, 16 GB RAM, AMD 455 @ 2 GB, 512 GB SSD, macOS High Sierra

2018 11" iPad Pro 256 GB, latest iPadOS public beta

Share this post


Link to post
Share on other sites

I have downloaded the Affinity Photo Beta version and installed it in order to be able to use the Haze Removal which is not available in the Affinity Photo 1.4 which I have bought from the Apple Store.

 

The installed version 1.4 works regularly with no problems. Trying to open the beta version, a message appears that I have to install a purchased version. The purchased version is already installed. Also if I go to the apple store it says that the application is already installed. How can I exit this impasse?

 

Thanks,

Claudio

post-23553-0-64023300-1450091698_thumb.jpg

Share this post


Link to post
Share on other sites

I have bought Affinity Photo 1.4 from the Apple Store. Unfortunately the Haze Removal Function is not present. Following the advice on this forum I have downloaded the Beta version in order to be able to use this function. Installing the beta version appears a message that I have to installed a purchased version. The purchased version is regularly installed and working, but the message continues to appear. What can I do?

Thanks,

Claudio

Share this post


Link to post
Share on other sites

Hi Claudio,

Welcome to Affinity Forums :)

The Haze Removal Filter is already available in the Mac App Store version (1.4)

 Go to menu Filters ▸ Haze Removal... (it's the second item counting from bottom).

 

Only the latest Photo Beta 1.4.1 is recognised/valid (downloaded from the top of this thread). Previous Betas will not work.

Check your Applications folder and drag all Betas to the Trash. Then reinstall it from the link on top of this thread.

Share this post


Link to post
Share on other sites

I have downloaded Photo Beta 1.4.1 using the link on top of this thread.  On my copy of Mac App Store version (1.4) on the menu filter from the bottom I read (Italian language version): Plugin, Rimozione distorsione..., Ombreggiature/Evidenziazioni..., Illuminazione..., Applica immagine..., Separazione frequenza...

 

None of the above filters seem to make any Haze Removal and "Haze Removal" (or some kind of Italin translation) does not appear.

 

Claudio

Share this post


Link to post
Share on other sites

I have just changed the language from Italian to english and now the Haze Removal Appears!

Now I have switched back to Italian and instead of Haze Removal there is "Rimozione distorsione" which is not the correct and a real misleading translation ("Distortion" has nothing to do with "Haze"-  it should be: Rimozione Foschia) but it works to remove the haze!

 

Thanks a lot,

Claudio

Share this post


Link to post
Share on other sites

:D

 

(By the way, who creates your Photo tutorials on Vimeo? They are fabulous … had I already said this?)

 

 

Perfect to improve spoken language and pronunciation too.

Well.. At least to me...  :P


The white dog, making tools for artists, illustrators and doodlers

Share this post


Link to post
Share on other sites

I´m sorry that I missed that thing. I complained several times that new filter layers get nested under each other and I said that this should be changed.

 

And there is this preference setting which works perfectly. THANKS.

Maybe this helps someone else as well ;) 

post-10405-0-39130100-1450371144_thumb.png


 

 

Share this post


Link to post
Share on other sites

Andy,

 

I upgraded the base program on Apple App to 1.4. I enjoy working with the Beta developments and so after a few days went to download 1.4.1 and received the dialog message that I had to purchase the program to download the beta. Any advice?

 

tom nequette

Share this post


Link to post
Share on other sites

Hi Tom,

 

sometimes this message shows up, when the App Store version and the Beta do not share the same folder, to be more precise: they both have to reside inside the standard Applications folder on your start-up volume. Hope that was the root of the problem …

 

Kind regards, Alex  :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.