Jump to content
MattP

Affinity Designer Customer Beta (1.5 - Beta 9)

Recommended Posts

Status: Beta Release

Purpose: New features, fixes

Requirements: Purchased Affinity Designer

Mac App Store: Not Submitted

Download: Here

 

 

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

PLEASE BE AWARE THAT THIS VERSION WILL RESET EVERYTHING BACK TO DEFAULTS. Please make sure that if you have created any palettes, styles, assets, brushes, etc in the current beta that you export them in the current version first BEFORE installing this beta otherwise you will lose them. This was unfortunately necessary for this build and should hopefully not be required again.

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

 

 

 

This is a beta of a substantial change to our codebase and as much as we have tried to ensure the quality of the code, it should be considered to be not suitable for production use. This means that you should not attempt to use it for commercial purposes or for any other activity that you may be adversely affected by the application failing. In addition it is definitely worth noting that files created in Affinity 1.5 cannot be opened in 1.4 so always make a copy of your important documents before opening them in 1.5 to ensure you do not accidentally overwrite them and are unable to open them in your 1.4 version.

 

To use this beta, simply download the file from the link given above and double-click on the file to open the installer. Follow the instructions to install the beta version. The beta sits alongside the Mac App Store version and will not interfere with it.

 

Fixes/Improvements:

  • Fix for all adjustments that use curve splines
  • Fixed 'Bake Corners' in Corner Tool
  • Fix for Divide geometry operation being incorrectly disabled
  • Fix for incorrect colours being generated when a vector object is masked with a semi-transparent mask
  • Symbols can be nested inside containers and the containers can be added to Assets correctly now

  • Stop Artboards reparenting into other Artboards while they are being dragged around
  • Hopefully resolved file save/restore issues seen when starting from a 'recovery file'
  • Fix for file corruption issues associated with certain SMB network shares
  • Fix for crash seen when cancelling the Fill Tool's drag operations
  • Fix for matte colour in Export Persona
  • Fix for constraints applied to objects with have no width or no height
  • Prevent nested symbols creating dangerous cross-document links!
  • SVG export of relative coordinates uses a relative move for subpaths
  • SVG import of <a> tags implemented
  • Many text style bug fixes and tweaks
  • PDF export improvements
  • Asset panel UI improvements when interacting with it
  • Fixed hex colour input not working as expected for the 'b' slider
  • Fixed line properties flyout showing incorrectly rounded width in some circumstances
  • Page Up/Down/Home/End should appear correctly as customisable shortcuts now
  • Updated icon and cursor for Artboard Tool
  • Slice Tool can now nudge with arrow keys, Slices now work correctly with document snapshots
  • Added 'Space Horizontally' and 'Space Vertically' alignment options to complement the 'Distribute' variants
  • Miscellaneous other small fixes

Share this post


Link to post
Share on other sites

- one still can´t drag the "opacity" label to change the opacity of layers      :wacko: (like it works for brush size e.g.)

​- when you have a brushes mod panel opened and press the v key, the controls are not editable anymore guess it´s supposed to be so

NEW (from what I can tell)

- if I switch from the move to the rectangle tool the cursor remains the same

 

- new asset > right klick > delete asset just locks up AD in total and beeps, after some time it stops and asks if I want to delete and then you can delete the asset 

- non artboard document: draw some stuff, insert additional artboard with the artboard tool >> view is unclipped and can´t be clipped to canvas (option is greyed out)

 

+ dropping stuff into assets and symbol panels

+ might we get the docking of two columns of tool panels to the right (and left) side like possible in AD for Windows?

 

+ Bleed preview, linked bleed values

 

 thanks for the update!  :lol:


 

 

Share this post


Link to post
Share on other sites

Thanks for your report MBd,

1. Issue with mouse cursor logged.

2. I'm not able to reproduce the assets issue. What kind of objects are you having trouble with?

3. The artboard behaviour is by design. You can only set Clip to Canvas on non-artboard documents, since objects outside the canvas in artboard documents are always visible by design.

Share this post


Link to post
Share on other sites

1. the mouse cursor also showed a skew/ resize/ move sign (although it was still creating just rectangles) at some point so it´s really creative  :D

2. hm can´t recreate it neither now

3. hm doesn´t really convince me but ok


 

 

Share this post


Link to post
Share on other sites

yeah I´m currently on my MB, great if that only is a macOS issue it´s not that bad, I was a bit surprised at first cause I guess you have some sort of quality check  :D

 

sadly it´s happening on my iMac with 10.11.6

Edited by MBd

 

 

Share this post


Link to post
Share on other sites

I've obviously tried on my Mac Pro and Mac Book Pro and I don't get the same behaviour? Both on 10.11.6

 

EDIT: We're talking about the Asset -> Add then Asset -> Delete, right? :)

Share this post


Link to post
Share on other sites

Oh no I was talking about the rectangle courser thing

 

The asset issue happened once on my MB running macOS, correct

 

Sorry for the confusion!


 

 

Share this post


Link to post
Share on other sites

Can't wait for this 1.5 version to show up in  Tea Apps Store  [ as Arnold Schwarzenegger would say ]


Hardware
 Mac mini (late-2014), 2.6GHz, 16GB RAM, Intel Iris 5100 Graphics  iPad Air 16GB White

Software I love, and you should get :wink:
Affinity Desinger - Affinity Photo - Sketch - Coda - CodeKit - iA Writer - Dropbox - 1Password

 

Share this post


Link to post
Share on other sites

Awesome to see so many fixes Matt! Keep up the great work!

 

 

 

Status: Beta Release

Purpose: New features, fixes

Requirements: Purchased Affinity Designer

Mac App Store: Not Submitted

Download: Here

 

 

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

PLEASE BE AWARE THAT THIS VERSION WILL RESET EVERYTHING BACK TO DEFAULTS. Please make sure that if you have created any palettes, styles, assets, brushes, etc in the current beta that you export them in the current version first BEFORE installing this beta otherwise you will lose them. This was unfortunately necessary for this build and should hopefully not be required again.

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

 

 

 

This is a beta of a substantial change to our codebase and as much as we have tried to ensure the quality of the code, it should be considered to be not suitable for production use. This means that you should not attempt to use it for commercial purposes or for any other activity that you may be adversely affected by the application failing. In addition it is definitely worth noting that files created in Affinity 1.5 cannot be opened in 1.4 so always make a copy of your important documents before opening them in 1.5 to ensure you do not accidentally overwrite them and are unable to open them in your 1.4 version.

 

To use this beta, simply download the file from the link given above and double-click on the file to open the installer. Follow the instructions to install the beta version. The beta sits alongside the Mac App Store version and will not interfere with it.

 

Fixes/Improvements:

  • Fix for all adjustments that use curve splines
  • Fixed 'Bake Corners' in Corner Tool
  • Fix for Divide geometry operation being incorrectly disabled
  • Fix for incorrect colours being generated when a vector object is masked with a semi-transparent mask
  • Symbols can be nested inside containers and the containers can be added to Assets correctly now

  • Stop Artboards reparenting into other Artboards while they are being dragged around
  • Hopefully resolved file save/restore issues seen when starting from a 'recovery file'
  • Fix for file corruption issues associated with certain SMB network shares
  • Fix for crash seen when cancelling the Fill Tool's drag operations
  • Fix for matte colour in Export Persona
  • Fix for constraints applied to objects with have no width or no height
  • Prevent nested symbols creating dangerous cross-document links!
  • SVG export of relative coordinates uses a relative move for subpaths
  • SVG import of <a> tags implemented
  • Many text style bug fixes and tweaks
  • PDF export improvements
  • Asset panel UI improvements when interacting with it
  • Fixed hex colour input not working as expected for the 'b' slider
  • Fixed line properties flyout showing incorrectly rounded width in some circumstances
  • Page Up/Down/Home/End should appear correctly as customisable shortcuts now
  • Updated icon and cursor for Artboard Tool
  • Slice Tool can now nudge with arrow keys, Slices now work correctly with document snapshots
  • Added 'Space Horizontally' and 'Space Vertically' alignment options to complement the 'Distribute' variants
  • Miscellaneous other small fixes

 


2017 15" MacBook Pro 14,3 w/ Intel 4 Core i7 @ 2.8 GHz, 16 GB RAM, AMD 455 @ 2 GB, 512 GB SSD, macOS High Sierra

Share this post


Link to post
Share on other sites

Just running it through the paces and one thing I'm noticing is a bit of a lag moving things around. Just basic square shapes. It's more of a visual screen redraw sort of thing, really choppy...

Share this post


Link to post
Share on other sites

I keep getting stuff like this:

 

Screen%20Shot%202016-08-13%20at%2009.37.

 

Is this a known issue?

Usually quitting and restarting the app is enough to clear it, but not as I write. I hope a machine reboot clears it.

 

 

EDIT: A restart didn't clear it, and I'm not sure if the problem originated in AD. It might have been a system problem on my machine. I ran disk permissions verify and repair from the command line and then rebooted in Safe mode, and then booted normally. It seems to have cleared the issue. Could be unrelated to AD.

Share this post


Link to post
Share on other sites

Tiny issue: I'd love that the notification that fonts are missing in a document stay on the screen and not disappear automatically. It used to stay until dismissed. Right now, it disappears faster than I can take a screenshot or note which ones are missing.

Share this post


Link to post
Share on other sites

Tiny issue: I'd love that the notification that fonts are missing in a document stay on the screen and not disappear automatically. It used to stay until dismissed. Right now, it disappears faster than I can take a screenshot or note which ones are missing.

 

You can get the list again by setting the font category to Missing in the Character panel.

Share this post


Link to post
Share on other sites

I often make temporary files that I don't save when I'm done with them.  Starting a couple versions ago and continuing with Beta 9 the next time I enter AD I get the following message offering to restore the unsaved files.  When I exited I told AD I didn't want to save these but it still asks the next time I go in.

 

post-2932-0-44790800-1471119231_thumb.jpg


iMac (27-inch, Late 2009) with macOS Sierra

Share this post


Link to post
Share on other sites

I often make temporary files that I don't save when I'm done with them.  Starting a couple versions ago and continuing with Beta 9 the next time I enter AD I get the following message offering to restore the unsaved files.  When I exited I told AD I didn't want to save these but it still asks the next time I go in.

 

attachicon.gifScreen Shot 2016-08-13 at 1.10.00 PM.jpg

 

I get this often (always, actually) if I open AD Beta, work with a file, close it, and try to open it again. 100%, I think, if I try to open via the File menu. Sometimes dragging into AD from the Finder reopens the file. After this warning box, I get another, no matter which option I choose, that says the file is in use by another application.

 

Only quitting the Beta and reopening it resets this.

Share this post


Link to post
Share on other sites

New bugs

  • Vector shape drawing uses the select cursor
  • Vector shape drawing cursor keeps the last hovered (rotate / resize / move) after leaving the selected element
 
Still there
 
Nice to have
  • Up and down arrow key support for opacity, font-size and line-height
 
Is there a public bug tracker or a list, where we can see known bugs?

Share this post


Link to post
Share on other sites

Hi Afterlame,

Welcome to Affinity Forums :)

 

All bugs are/were logged. Thanks for your report. 

There's no public bug tracker. Please check each Beta release log to know what have been fixed.

Some issues may take more than one release to be corrected.

 

You can increase/decrease font-size pressing ⌘ (cmd) + > and ⌘ (cmd) + <

To change line-height press ⌥ (option/alt) + ↑ or

You can change the opacity pressing the numbered keys on your keyboard (0-9). Quickly press two keys sequentially to set the corresponding opacity value (7 + 8 to set 78% opacity for example).

Share this post


Link to post
Share on other sites

Could you guys please fix boolean operations?

It's bugged since beta 2…

 

post-30307-0-12116700-1471193720_thumb.png

 

Oh and also, could you please add an option to remove borders on artboards? Looks ugly on a dark background.

post-30307-0-54078200-1471196190_thumb.png

 

Thank you  ^_^

Share this post


Link to post
Share on other sites

Bug?

 

I'm getting some weird cursor behaviour creating shape objects. It's consistent no matter which shape I choose.

 

When I select a shape say a rectangle and hover over the artboard the cursor is an arrow not a crosshair. I can draw out a rectangle and if I hover over the shape I get the move arrows crosshair which makes sense but if I click to move it it draws another rectangle...?

 

Edit: just read the above mention of the same issue. Sorry for doubling the post...  :wacko:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×