Jump to content
Andy Somerfield

Affinity Photo Customer Beta (1.4.2 - Beta 4)

Recommended Posts

Purpose: Fixes

Status: Incremental bug-fix track on 1.4.1

Requirements: Purchased Affinity Photo

Mac App Store: Not submitted

Download: Here

 

Firstly, please accept our apologies for the interruption in the Beta program - this was an accident, we will learn from this and continue to improve.

 

To use this beta, simply download the file from the link given above and double-click on the file to open the installer. Follow the instructions to install the beta version. The beta sits alongside the Mac App Store version and will not interfere with it.

 

This is an Incremental Bug-Fix release - it should be considered more stable than the current MAS version (1.4.1) and should be used in preference to that build, if you are experiencing any of the problems listed below.

 

Fixes

 

- Fix for scaling issues during copy/paste of text items

- Improved RTF clipboard support so that InDesign is happier

- Slightly thinner Text Tool caret

- Don't output file path to PDF export, only use file name (for improved privacy)

- Fix for line weight incorrectly scaling based on object size when applying Styles even when 'Scale with object' was deselected in the Stroke panel

Share this post


Link to post
Share on other sites

it is rather disappointing that nowbody here at serif  thinks it is worth to adress the color problems many users face with dual display setups.  

Share this post


Link to post
Share on other sites

Layer blend live preview is not working in this beta. Is it just my mac tired from the tough week? I am trying the live filter black and white, regular layer… and no preview at all. I feel like in the dark ages of photoshop…

 

EDIT: creating this post fixed the problem :-/

Share this post


Link to post
Share on other sites

I don't know if this is the best place to ask this question, but here it goes. I'm trying to export a file for PDF/X1-a for my publisher. Cover design is more of a hobby than full time profession (I can do it for myself, but I don't have the patience to do it for others) I don't know what the problem is, but regardless if I use the Beta or formal program, I can't get it to export. 

If it didn't have to be in this format, that would be fine, but it does. I will admit that the psd file is a little over 90MB if that matters. Help!

Share this post


Link to post
Share on other sites

Hi Prymevil

Welcome to Affinity Forums :)

If i understood correctly you are importing a PSD file in Affinity then trying to export it as a PDF/X1-a without success. Is that correct?

Can you please upload the original PSD file using this link so i can check what's going on?

Actually, I tried doing that in addition to simply exporting the project as PDF/X1-a. Neither works. I've uploaded the AF project rather than the PSD file, since that is the original source. Thanks for the help. I'm losing my mind.

Share this post


Link to post
Share on other sites

Thanks for the file Prymevil.

Seems there's a few issues with the PDF exporter that's preventing the file from exporting correctly.

I'm passing this to the development team to be looked at.

 

 

Meanwhile to fix your work do the following:

- right-click the Kozzi layer in the Layers panel and select Rasterise..., uncheck Preserve layer FX in the dialog that will appear, then change the Blend mode (on top of the Layers panel) from Colour to Normal

- you also have to rasterise the two yellow booktrope logos layers right-clicking on them in the Layers panel and selecting Rasterize...

 

You can then Export your document as PDF/X1-a.

Share this post


Link to post
Share on other sites
Seems there's a few issues with the PDF exporter that's preventing the file from exporting correctly.

I'm passing this to the development team to be looked at.

 

I can reproduce this in 1.4, but not in our 1.5 beta branch, so I think it will be fixed when we release that.

Share this post


Link to post
Share on other sites

whenever I open this beta, the tools on the tool panel are invisible, thus making it kinda unusable.

I mean, hitting the hotkey still switches to the desired tool, but I don't have all those memorized.

Share this post


Link to post
Share on other sites

Hi Crimson Designs,

Go to menu View ▸ Show Tools.

Yeah, I probably should've mentioned that I already tried that.

Nothing changes (see attached screenshot)

 

 

Any help appreciated.

post-9964-0-24093400-1462349993_thumb.png

Share this post


Link to post
Share on other sites

Hi Crimson Designs,

Press and hold ⌃(ctrl) while launching the app from Launchpad, then select Clear from the dialog that will open.

This will reset the app and should revert the UI to its default.

that did it, thanks!

Share this post


Link to post
Share on other sites

Hi gordo,

 

Just bumped that thread you linked to, as far as your camera goes (think you have a Sony A7 model?), it may just be a case of some more vigilant defringing (it's a powerful filter if you balance the settings correctly).

 

Regarding the Fuji camera decoding, that is a separate issue. I believe that the X-Pro models will be better supported in an upcoming 1.5 beta (proper X-Pro2 support is being added). For now the best recommendation is to use Apple's Core Image decoder via the assistant menu.

 

Thanks!


Product Expert (Affinity Photo) & Product Expert Team Leader

@JamesR_Affinity for tutorial sneak peeks and more

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.