Jump to content
You must now use your email address to sign in [click for more info] ×

Migrate your release version content to beta


Recommended Posts

15 hours ago, Tom Lachecki said:

We currently have no plans to implement it in reverse - this would be problematic in many cases. But I appreciate it would be useful!

Wouldn't it be possible to do the reverse once the beta version becomes a release version? By then, it should have more feature parity than just backporting from Beta to the last release.

For me, that would be the most important case, knowing that I might have set things up for these new features in particular.

Link to comment
Share on other sites

2 hours ago, HarryMcGovern said:

But not in iPad 

Correct, as (I think) sandboxing in iPadOS would prevent it from working there. And the restriction to Windows and macOS is noted at the beginning of this topic: 

On 3/16/2023 at 10:56 AM, Ash said:

Apps: All
Platforms: Windows and macOS

For it to work on iPadOS, I think it would need to be an Export function from the retail release, into a folder/file specified by the user. And then an Import from the Beta where the user specifies the folder/file they Exported to earlier.

-- Walt
Designer, Photo, and Publisher V1 and V2 at latest retail and beta releases
PC:
    Desktop:  Windows 11 Pro, version 23H2, 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 

    Laptop:  Windows 11 Pro, version 23H2, 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
iPad:  iPad Pro M1, 12.9": iPadOS 17.3, Apple Pencil 2, Magic Keyboard 
Mac:  2023 M2 MacBook Air 15", 16GB memory, macOS Sonoma 14.3.1

Link to comment
Share on other sites

24 minutes ago, spiderpod7d said:

Hi Again

 

There is still a problem with the tool bar not aligning with the top of the panels and it also moves down by itself every time AP V2 is opened. This was also to the case in 2.0.4

That doesn't sound like a beta problem, and should be posted on the regular Bugs forum.

Also, if it were a Beta problem, it doesn't sound related to this feature topic about migrating content, and would be better posted in the Other Beta Issues forum.

-- Walt
Designer, Photo, and Publisher V1 and V2 at latest retail and beta releases
PC:
    Desktop:  Windows 11 Pro, version 23H2, 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 

    Laptop:  Windows 11 Pro, version 23H2, 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
iPad:  iPad Pro M1, 12.9": iPadOS 17.3, Apple Pencil 2, Magic Keyboard 
Mac:  2023 M2 MacBook Air 15", 16GB memory, macOS Sonoma 14.3.1

Link to comment
Share on other sites

32 minutes ago, spiderpod7d said:

Hi Walt. It isn't just in Beta but also in release version which I reported to them team before Christmas.

Which is why I suggested it doesn't belong here :)

-- Walt
Designer, Photo, and Publisher V1 and V2 at latest retail and beta releases
PC:
    Desktop:  Windows 11 Pro, version 23H2, 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 

    Laptop:  Windows 11 Pro, version 23H2, 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
iPad:  iPad Pro M1, 12.9": iPadOS 17.3, Apple Pencil 2, Magic Keyboard 
Mac:  2023 M2 MacBook Air 15", 16GB memory, macOS Sonoma 14.3.1

Link to comment
Share on other sites

I noticed that the two things I typically spend the most time on customising (Tools and Toolbar) are overwritten with something that's certainly not what I have in my GA version and also isn't the application's default.

Well, that's then a nice exercise for the Sunday afternoon. 😞

Affinity Photo - Affinity Designer - Affinity Publisher | macOS Sonoma (14.2) on 16GB MBP14 2021 with 2.3 versions

Link to comment
Share on other sites

  • Staff
On 3/18/2023 at 10:13 PM, spiderpod7d said:

Back Again

I had to Also copy the from the release version 2.04 the ~user/library/group container/user folder from the release V2 folder to the V2 Beta folder to get my lens processing presets

Are you referring to custom XML Lens Profiles?

Link to comment
Share on other sites

Hi Tom

Yes I am. But the V2 release and the V2 Beta looks for them in the Develop propcol file found in ~username/library/group container/V2/user folder. They are not visible by either application even of present in the ~username/library/application support/Affinity Photo 2 Beta/ lens profiles folder.

Link to comment
Share on other sites

14 minutes ago, spiderpod7d said:

Yes I am. But the V2 release and the V2 Beta looks for them in the Develop propcol file found in ~username/library/group container/V2/user folder.

Tom was asking about the XML lens calibration info that you can manually add. That's different from the Develop presets you just pointed to.

-- Walt
Designer, Photo, and Publisher V1 and V2 at latest retail and beta releases
PC:
    Desktop:  Windows 11 Pro, version 23H2, 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 

    Laptop:  Windows 11 Pro, version 23H2, 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
iPad:  iPad Pro M1, 12.9": iPadOS 17.3, Apple Pencil 2, Magic Keyboard 
Mac:  2023 M2 MacBook Air 15", 16GB memory, macOS Sonoma 14.3.1

Link to comment
Share on other sites

I'm not sure if it did move all my settings correctly, but like was said before, Windows did have a small change to where our information is stored so I'd more likely put it to that. It also probably does not help I have both MSIX and MSI installed (release versions), so that could also be confusing things.

The main thing I noticed missing were my presets in the New File dialogue.

Microsoft Windows 10 Home (Build 19045)
AMD Ryzen 7 5800X @ 3.8Ghz (-30 all core +200mhz PBO); Mobo: Asus X470 Prime Pro
32GB DDR4 (3600Mhz); EVGA NVIDIA GeForce GTX 3080 X3C Ultra 12GB
Monitor 1 4K @ 125% due to a bug
Monitor 2 4K @ 150%
Monitor 3 (as needed) 1080p @ 100%

WACOM Intuos4 Large; X-rite i1Display Pro; NIKON D5600 DSLR

Link to comment
Share on other sites

I know this feature is only to help us public beta testers duplicate our settings for a better "real world test"... (*)

...but just to be picky 😉:

Should it not also copy the toolbar arrangement and customized tool box?

 

(*) I also ask, because it would be great if you some day could save these settings externally as a backup in case of a computer crash or just to sync settings between two workstations.

  • Main machine: iMac 2019 (21,5-inch 4k, 6core), 64GB RAM, 1TB nvme + 2TB ssd, running on Mac OS 13;
  • Display setup: 28" 5k Display (primary) + 21,5" iMac4k-Display for studio panels (secondary);
  • Keyboard layout: german apple extended keyboard (aluminium);

 

Link to comment
Share on other sites

Shortcuts still don't carry over to Designer 2 Beta. I stops me from using Beta. I have some custom shortcuts and I really don't want to set them from beginning again.  EDIT: I've found out I can save and load shortcuts manually.

Shortcuts Panel need some improvement like search option and support for keys like Shift, Ctrl etc. for tools shortcuts.

Edited by Radosław
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.