Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

Affinity Designer 2 for Windows - (2.0.3)


Patrick Connor
 Share

Recommended Posts

  • Moderators

We are pleased to announce an update for the Windows release of Affinity Designer 2, version 2.0.3

The changes in Affinity Designer 2 for Windows 2.0.3 (those made since the last release Affinity Designer 2 for Windows 2.0.0) are as follows:

We plan to also release this build as a MSI/EXE installer. Please follow this FAQ thread for notification of it's release.

Fixes & Improvements:  (since the last release 2.0.0)

  • New Document: Custom Document Preset order is not retained between app sessions
  • Current DPI of selected layer does not show in V2
  • Shape Builder Tool now has an additional option to delete open curves that were inside a newly created area, plus you can now hold Alt to delete areas while still in Add mode - more to come...
  • Warp Group editing now supports the Shift modifier to lock node edits to an 8-axis grid. Also can be used with off-curve nodes to maintain their angle while dragging them
  • Modifying Global Colour swatch fails to update document until you click out of the Colour Selector
  • Sliders for Warp Group are broken
  • Using the Select object/ transparency object selects all objects
  • Symbols - Delinked nodes get forgotten when swapping out nodes from synchronised instances
  • Shape Builder Tool: Alt to delete on rotated shapes fails
  • Shape Builder Tool: sometimes drags out a selection marquee
  • Shape Builder Tool: functional improvements on some shapes
  • Placed documents with bleed fail to render the top and left side correctly
  • Quotes can be incorrectly put on newlines and cause text to render differently compared to V1
  • Straightening in the Develop Persona offsets the image from the canvas entirely, until developed or crashes
  • Transform Panel- Differences in panel size when switching between Curve strokes and expanded objects
  • Cmd+Z / Ctrl+Z isn't working in V2 apps for adjustments
  • Outline Layer Effect is making the anti-aliased edges transparent, rather than blending with the shapes colour
  • Quick Access to Node Tool no longer allows you to insert node
  • Fixed spurious "future version" error under certain circumstances
  • Improvements with PDF Import and Layers
  • Fixes for RTF import - font name discrepancies, fields in footnotes
  • Update for HEIF importer
  • DWG Import scaling improvements
  • DWG file takes a long time to open then shows incorrectly (file specific).
  • Colour Panel now remembers user preference for CMYK documents
  • Export Panel UI fixes
  • Fixed some tool drawing issues relating to selections across spreads etc
  • Pen tool tweaks and fixes
  • Fixed hang that could occur composing vertical centre aligned text
  • OpenType handling does not respect lookup flags such as IgnoreMarks
  • Hit box of scaled text could be incorrect
  • Gradients on text strokes don't render unless the fill also has a gradient
  • Fixes for line breaking in some odd cases with punctuation
  • Resource Manager updates
  • Light UI Improvements
  • Many and various Layers Panel updates and fixes
  • Clipboard: 32 bit DIB support added
  • Auto Flow Place: Added an option to auto-flow place to replace the content of already populated picture frames
  • More attributes are retained when replacing images in frames
  • Ensure global colour edits update live
  • Select Same Name should only select objects with user supplied names
  • New clearer icons for stroke properties (cap, join, align)
  • Help & localisation improvements.
  • Licensing and Registration improvements and new help links

 

UPDATING TO THIS VERSION (Free for existing customers)

The software version can be seen on the splash screen and the About dialog (in Help > About Affinity Designer ).

If you’ve purchased from the Affinity Store — each time you start the Affinity Store software it will check for updates and offer any available update. The latest update will install over the top of any earlier version, with no need to uninstall. You can download the latest installer by logging into the affinity store here and find the order in your account and use the "Download" button in there. Alternatively, this new release (and previous versions of Affinity Publisher for Windows) can be downloaded from this link. (those installers are NOT for Windows Store purchases).

If you’ve purchased from the Microsoft Store — Microsoft Store updates are done automatically by the operating system (each time you start the application). If this does not happen for you, open the Windows Store app and click the three dots in the top right corner of the app and then go to Downloads and Updates. Click Get Updates. This should hopefully force the update to show.

Patrick Connor
Serif Europe Ltd

"There is nothing noble in being superior to your fellow man. True nobility lies in being superior to your previous self."  W. L. Sheldon

 

Link to comment
Share on other sites

Thank you for the update. Although the updating is extremely slow and task manager barely show any activity. (not even download)

Current Workstation:
CPU: AMD Ryzen 1600AF - MOBO: Asus B450 - RAM: 16GB DDR4 2667Mhz - GPU: AMD Radeon 7790 1GB
SSD: Samsung Evo 850 256GB - HDD:  Toshiba P300 1TB, WD Blue 2.5" 5400rpm 1TB - PSU: XFX TS450 - OS: Win11

Link to comment
Share on other sites

1 hour ago, nitro912gr said:

Thank you for the update. Although the updating is extremely slow and task manager barely show any activity. (not even download)

Less than 20 seconds here in UK

 

Alan Pickup

Windows 11 Home all Affinity suite of Apps PC and Gigabyte Laptop 16gb Ram and Nvidia GTX1660 Super on each.

Link to comment
Share on other sites

It probably depends of where you are as it also took just a few seconds here in Canada.

-- Window 11 - 32 gb - Intel I7 - 8700 - NVIDIA GeForce GTX 1060
-- iPad Pro 2020 - 12,9 - 256 gb - Apple Pencil 2 -- iPad 9th gen 256 gb - Apple Pencil 1

Link to comment
Share on other sites

  • Moderators
10 minutes ago, NNN said:

I've got the updates for Photo and Publisher at Thursday, but for Designer just now. Why so long delay?

If you mean last week, then the Photo 2.0.3.1682 and Publisher 2.0.3.1682 you get were not the final release builds. Everything for Windows was officially released yesterday as 2.0.3.1688, and you need to update Photo and Publisher again if they are not yet 2.0.3.1688 (as shown in My Account top right)

 

Patrick Connor
Serif Europe Ltd

"There is nothing noble in being superior to your fellow man. True nobility lies in being superior to your previous self."  W. L. Sheldon

 

Link to comment
Share on other sites

Just a suggestion:

Why don't you announce the updates in one thread instead in 3 with links to all 3 apps?

The main reason for this is that you can separate the info into 4 categories (easier for you):

Common for all 3 apps
Fixes, improvements...

Designer
Fixes, improvements...

Photo
Fixes, improvements...

Publisher
Fixes, improvements...

This way we can easily see what is specific for each app and what is common to all 3.

Link to comment
Share on other sites

  • Moderators
4 minutes ago, NNN said:

Why don't you announce the updates in one thread instead in 3 with links to all 3 apps?

We may well start doing this, or something like it, thanks

Patrick Connor
Serif Europe Ltd

"There is nothing noble in being superior to your fellow man. True nobility lies in being superior to your previous self."  W. L. Sheldon

 

Link to comment
Share on other sites

If you do announce all the updates in one thread (which I do think is a good idea) maybe one comment for the updates and the next comment for the improvements, fixes, new features (or better still the links to them) then locking the thread to keep it purely for Serif announcements. Goes without saying the linked thread would also be locked.
 

Link to comment
Share on other sites

4 hours ago, nitro912gr said:

Thank you for the update. Although the updating is extremely slow and task manager barely show any activity. (not even download)

It depends on your PC specs. On my laptop it's quite slow. On my main desktop, it's easy to miss the update process entirely if I look away.

Microsoft Windows 10 Home (Build 19045)
AMD Ryzen 7 5800X @ 3.8Ghz (-30 all core +200mhz PBO); Mobo: Asus X470 Prime Pro
32GB DDR4 (3600Mhz)
EVGA NVIDIA GeForce GTX 3080 X3C Ultra 12GB
Monitor 1&2 4K @ 150%

WACOM Intuos4 Large; X-rite i1Display Pro; NIKON D5600 DSLR

Link to comment
Share on other sites

I got 100mbps fiber connection, and generally affinity servers are quite fast, I mean I didn't noticed when it even downloaded the app, after realizing it was idle it didn't downloaded anything. As for the system it was idle most of the time of updating. I was wondering if the update was crashed after a couple of min (so far all the setups of affinity take like less than a minute) and checked the task manager. Barely some cpu usage, and some SSD usage here and there but from other unrelated processes.

It took like 10 minutes or less for something that is a 1 min job so far.

Maybe it was some bug? Anyway it worked and it is nice to be able to update through the app, it just took it's sweet time with no good reason, so maybe there is something broken somewhere.

Current Workstation:
CPU: AMD Ryzen 1600AF - MOBO: Asus B450 - RAM: 16GB DDR4 2667Mhz - GPU: AMD Radeon 7790 1GB
SSD: Samsung Evo 850 256GB - HDD:  Toshiba P300 1TB, WD Blue 2.5" 5400rpm 1TB - PSU: XFX TS450 - OS: Win11

Link to comment
Share on other sites

13 minutes ago, nitro912gr said:

It took like 10 minutes or less for something that is a 1 min job so far.

This is largely anecdotal, but installation process seems sensitive to age of hardware/Windows installs from what I can tell and behaves as if it's idling when it's running. Not sure that means the process is "bugged", but maybe has to do with the unpacking process /shrug I don't overthink it. It's Windows.

Microsoft Windows 10 Home (Build 19045)
AMD Ryzen 7 5800X @ 3.8Ghz (-30 all core +200mhz PBO); Mobo: Asus X470 Prime Pro
32GB DDR4 (3600Mhz)
EVGA NVIDIA GeForce GTX 3080 X3C Ultra 12GB
Monitor 1&2 4K @ 150%

WACOM Intuos4 Large; X-rite i1Display Pro; NIKON D5600 DSLR

Link to comment
Share on other sites

9 minutes ago, debraspicher said:

This is largely anecdotal, but installation process seems sensitive to age of hardware/Windows installs from what I can tell and behaves as if it's idling when it's running. Not sure that means the process is "bugged", but maybe has to do with the unpacking process /shrug I don't overthink it. It's Windows.

My computer is old, All three downloaded & installed in around 5 mins doing one at a time. No complaints from me about the speed.

 

Link to comment
Share on other sites

1 minute ago, Dangerous said:

My computer is old, All three downloaded & installed in around 5 mins doing one at a time. No complaints from me about the speed.

 

Yeah, it took 5, maybe 10 on laptop. But on desktop, it took seconds. Crazy. Original installation was similarly fast.

Microsoft Windows 10 Home (Build 19045)
AMD Ryzen 7 5800X @ 3.8Ghz (-30 all core +200mhz PBO); Mobo: Asus X470 Prime Pro
32GB DDR4 (3600Mhz)
EVGA NVIDIA GeForce GTX 3080 X3C Ultra 12GB
Monitor 1&2 4K @ 150%

WACOM Intuos4 Large; X-rite i1Display Pro; NIKON D5600 DSLR

Link to comment
Share on other sites

I suspect Avast is the culprit here... gives me a ton of slowdowns lately.

Current Workstation:
CPU: AMD Ryzen 1600AF - MOBO: Asus B450 - RAM: 16GB DDR4 2667Mhz - GPU: AMD Radeon 7790 1GB
SSD: Samsung Evo 850 256GB - HDD:  Toshiba P300 1TB, WD Blue 2.5" 5400rpm 1TB - PSU: XFX TS450 - OS: Win11

Link to comment
Share on other sites

10 hours ago, NNN said:

Why don't you use Windows Defender?

This is what I research right now. A couple of years back I tried my luck again and it was consuming too many resources. I read around now that is on par with the best antiviruses out there right now, so I might give it another go. I just need to make sure first it have proper folder ignore function because I have this folder with old exe little apps that antiviruses keep erasing "I don't know what is this, it must be virus" or something.

Current Workstation:
CPU: AMD Ryzen 1600AF - MOBO: Asus B450 - RAM: 16GB DDR4 2667Mhz - GPU: AMD Radeon 7790 1GB
SSD: Samsung Evo 850 256GB - HDD:  Toshiba P300 1TB, WD Blue 2.5" 5400rpm 1TB - PSU: XFX TS450 - OS: Win11

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.