Jump to content

Can´t import brushes

Recommended Posts

  • Moderators

Hey Struppi, welcome to the Affinity Forums.

Would you be able to upload the brush to this private Dropbox folder please?

Can you also upload yours to the same place @gregory ciencin?

Edit - It looks like we've already logged this but it still wouldn't hurt to get the brushes from you just to be safe.

Link to comment
Share on other sites

Here on my System it's the same. Not able to import .abr files. They all giving the same error.

If needed, i can upload some of them in the evening when i'm back at home.

Have a nice day.
Ich wünsche einen schönen Tag.

Link to comment
Share on other sites

yes can confirm this. Most .abr files can't imort in 1.7.2 
i have test this with brushes I have already active from 1.7.1 see the screen shot, the same brushe is active, but a test to import gives error, normal I got a second version in the list.


Windows 11 (Home) build: 22H2-Version :  10.0.22623 Build 22624 - 1391 (Windows insider)
-  64 bits. 
11th Gen Intel(R) Core(TM) i5-11400F @ 2.60GHz.
Ram: 48 GB  DDR4 -3200 Mhz-  34" wide screen
GpuGeforce 3060 -12GB  OC- studiodriver: 528-49 - XP-Pen star03
Affinity Photo2 - Designer 1.10-  Publisher 1.10 - ArtRage 6 - Aurora 

https://studio97visuals.jouwweb.nl - mastodon.nl/@digitalvisuals

Link to comment
Share on other sites

On 8/23/2019 at 8:36 AM, richapple said:

using windows 10 latest update

Affinity, current

I tried to imprt some oldish photoshop brushes [for lightening effect] without success into the latest Affinity Photo release.


Quick fix, since they had imported into the last beta [], was to export from there and import into the current Affinity photo release

This suggested workaround (fix) is indeed working:

1. downgrade your AP beta version to
2. import the brushes you want
3. export the brushes
4. import them to AP

Link to comment
Share on other sites

I did it. If you have Publisher, I didn’t accept the update, I went to the Photo persona and downloaded all the abr brushes with no problem.

if you don’t have publisher, you’ll have to wait for Affinity to do another update fixing what they messed up.

Link to comment
Share on other sites

I have another workaround that works without needing to downgrade but it is a bit of a pain. It got me through what I wanted to do for now.


TextureMate .com has a little app that is free called AbrMate.  AbrMate can open most .abr files and allow you to convert them to png files which can then be used to recreate the brushes in Affinity as Affinity brushes. If you are needing only a few brushes this is Ok    But I would still like to find out how to downgrade. :)

Link to comment
Share on other sites

  • 2 weeks later...
On 19.8.2019 at 10:31, Chris B said:

Hallo Struppi, willkommen in den Affinity-Foren.

Könntest du den Pinsel bitte in diesen privaten Dropbox- Ordner hochladen ?

Können Sie auch Ihre an den gleichen Ort @Gemeinschaft Ciencin hochladen ?

Bearbeiten - Es sieht so aus, als hätten wir dies bereits protokolliert, aber es würde trotzdem nicht schaden, die Pinsel von Ihnen zu bekommen, nur um sicher zu gehen.

Es sind alle Pinsel!

Link to comment
Share on other sites

Same Problem with every brushes.

I downloaded also AP and install them. But, now I've got two running Versions on my PC. And the AP asks me to download the newest Version. And there is no possibility to enter the Productkey.....

And the Brushes a have imported bevore (there are many brushes) , now are not avalible in this beta version. This is not the way to fix the Problem! AffinityTeam please fix the bug :)


Edited by Eva1
Link to comment
Share on other sites

Same here with Version (latest) on a fresh Win10 installation. 

The error message appears with all .abr brushes. With the 1.7.1.xxx the import still worked perfectly.

AMD Ryzen 7 5700x | INTEL Arc A770 | 32 GB DDR4 3200MHz | Windows 11 Pro (22621.1314)
Affinity Suite V2.0.4
Better translations with: https://www.deepl.com/translator  
SVG preview in Windows Explorer with "SVG-See  Download SVG-See

"The biggest mistake is the arrogance to always believe that others are to blame."

Link to comment
Share on other sites

1 hour ago, Komatös said:

Same here with Version (latest) on a fresh Win10 installation. 

The error message appears with all .abr brushes. With the 1.7.1.xxx the import still worked perfectly.

On Windows you can install beta of Photo which resolves the import problem. You can then export .afbrushes files for use in the 1.7.2 versions of all 3 applications.

-- Walt

Desktop:  Windows 11 Home, version 22H2 (22621.1413) 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 
Laptop:  Windows 10 Home, version 21H2 (19044.2728) 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
        Affinity Photo 1.10.6 (.1665) and 2.0.4  and beta/ Affinity Designer 1.10.6 (.1665)  and 2.0.4  and beta / Affinity Publisher 1.10.6 (.1665)  and 2.0.4  and beta
iPad Pro M1, 12.9", iPadOS 16.3.1, Apple Pencil 2, Magic Keyboard

      Affinity Photo 1.10.7 and 2.0.4 and beta/ Affinity Designer 1.10.7 and 2.0.4 and beta/ Affinity Publisher 2.0.4 and beta

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.