Jump to content
Mark Ingram

Affinity Photo Customer Beta - 1.6.1.92

Recommended Posts

Click here to download the latest beta

 

Status: Customer Beta
Purpose: Stability
Requirements: A valid product key, issued when Affinity Photo was purchased.

As this is a beta it is considered to be not suitable for production use. This means that you should not attempt to use it for commercial purposes or for any other activity that you may be adversely affected by the application failing, including the total loss of any documents. 

We hope you enjoy the latest build, and as always, if you've got any problems, please don't hesitate to post here and we'll get back to you as soon as we can. Thanks once again for your continued feedback.

If you have a general question about the software, please head over to the Questions Forum, or if you have any suggestions, please head over to the Feature Requests forum.

Fixes

  • Fixed rendering issues with ASUS SonicRadar, MSI Nehemic 2, etc (had to remove check for legacy RivaTuner crashes, see Third Party Software thread) 
  • Fixed saving a preset in the raster crop tool context bar saves the wrong values 
  • Fixed unable to increase brush dynamics using mouse wheel 
  • Changed keyboard shortcuts to sorted alphabetically
  • Tidied brush nozzle preview text in Brush panel
  • Added missing custom wet edges from brush editor 
  • Fixed brush settings disabling when editing brush after creating new layer 
  • Fixed being unable to retrieve EXIF information from files that have non-ANSI characters in their path
  • Fixed autosave not executing for readonly files 
  • Fixed readonly documents having Save option disabled (now directs to Save As) 

Share this post


Link to post
Share on other sites

Im near always happy with AP and AD. The Workflow is great, the programms are stable for hours of work per day and I made many artworks and prints for my clients this year with it.
I think you all affinity guys make and made a great job with it.

But, sorry to bother again, is the RAW Development Persona still on your to do list? Or is it the hated little child in AP? There are no changes within the last Betas for editing or loading RAW Files and other important functions like preset management, highlight and shadow recovery and many more. Im looking forward to finally see some steps there in the next Betas. 

Share this post


Link to post
Share on other sites
30 minutes ago, Hofnaar said:

Im near always happy with AP and AD. The Workflow is great, the programms are stable for hours of work per day and I made many artworks and prints for my clients this year with it.
I think you all affinity guys make and made a great job with it.

But, sorry to bother again, is the RAW Development Persona still on your to do list? Or is it the hated little child in AP? There are no changes within the last Betas for editing or loading RAW Files and other important functions like preset management, highlight and shadow recovery and many more. Im looking forward to finally see some steps there in the next Betas. 

 

We'll soon be testing out a new Shadows and Highlights algorithm in Develop (1.6.2). We are still looking at Develop, it's just that's one of the most complicated areas of the program, so changes are slower to implement.

Share this post


Link to post
Share on other sites

Thanks! Im happy to hear that. :)

btw: the shadows & highlights under filters works great in comparison to the one under adjustments - its horrible like in the development persona :D
may this helps, but Im sure, you already know this.

Share this post


Link to post
Share on other sites
13 minutes ago, R34V3r said:

Custom wet edges is there, but I cant seem move any nodes on the graph, I also can't choose one of the preset graphs sometimes.

 

This will be fixed in build 93 (coming in the next couple of hours!)

Share this post


Link to post
Share on other sites
1 hour ago, verysame said:

The build seems very stable so far. Oddly, the RAF files from my X-T10 now are slow to load again.
Anyway, keep up the good work!

 

There has been no changes to image loading, so I wonder whether some other process was using CPU time when you were looking?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.