Jump to content
You must now use your email address to sign in [click for more info] ×

Windows Install FAQ


Recommended Posts

  • Staff

 

Help me!
I'm opening the same PC, Corel, Adobe Illustrator, xara designer, and also the Affinity, more in Affinity can not put white nor standard sheet.
Can someone help me? 

 

 

Hi Andre,

 

I've seen something very similar before on the Mac version... It is related to the screen's transform from document colour space to screen device space... Basically, you should first check to see what colour profile you chose in Affinity Designer when you made your document. Try setting it to sRGB. If that hasn't fixed anything, it's possible that your screen profile is corrupt or is non-standard in some way and is provoking a problem? Are you able to try changing your screen's colour profile in Windows to see if that fixes the problem?

 

If neither of these fixes anything, then we'll have to try to reproduce it and fix it as the bug must be in Affinity Designer's hardware colour correction...

 

Thanks,

Matt

Link to comment
Share on other sites

I installed the program but it crashes during the startup process. The startup window  shows on the screen, but after about 30 seconds it closes.

I have this graphic card :

Generic PnP Monitor (1600x900@60Hz)
Intel HD Graphics Family (HP)
2047MB NVIDIA GeForce 840M (HP)    40 °C
ForceWare version: 359.37

 and in this Laptop I run Window 8.1. with 8 gigs RAM , with Intel core i7

Link to comment
Share on other sites

I can't install install on win 8.1 64bit. Installation repeatedly fail (freez) installing prerequisite: Microsoft .NET Framework.

Any solution?

OK, I've installed it finally after installing MS .NET Framework 4.5.2 from MS site: https://www.microsoft.com/en-gb/download/details.aspx?id=42642

But it's absolutely unusable for me, crashing down in a few seconds after launching.

Link to comment
Share on other sites

  • Staff

Please can you try again using this replacement installer (and new build) linked from this post at the top of the forum

 

https://forum.affinity.serif.com/index.php?/topic/21537-affinity-designer-on-windows-1504/

Patrick Connor
Serif Europe Ltd

"There is nothing noble in being superior to your fellow man. True nobility lies in being superior to your previous self."  W. L. Sheldon

 

Link to comment
Share on other sites

If I had known that my home pc needed a graphics card capable of supporting DirectX 10 or higher I would have never downloaded the Beta. I don't have the money for hardware. What a shame I can't check out this great product on a Windows 7 PC on an HP Pavilion Slimline dated 2010. If I can't play with a Beta copy I will never be able to use the full version either.

Link to comment
Share on other sites

Guest Arun Sarkar

If I had known that my home pc needed a graphics card capable of supporting DirectX 10 or higher.......... If I can't play with a Beta copy I will never be able to use the full version either.

 

Same for me..... :( I will not purchase another NVEDIA GeForce only for DirectX 10. 

Link to comment
Share on other sites

For people wishing to run Affinity Designer on an older Mac under VMware fusion, I discovered something that looks like a bug more than anything else, but which works: unintuitive as it may seem, turning off 3D acceleration will switch from DirectX 9 to DirectX 11 behind the scenes (I don't really know why, but it does).

 

So… at first I though I would be left out of the Beta because I got the dreaded “DirectX 10 (Shader Model 4.0) hardware not found” but, lo and behold, it runs and (mostly) doesn't crash. The mouse cursor is, by default and in Windows as a whole, super glitchy (each time I switch desktops, it flickers between the Mac and Windows cursor, and even jumps around a bit, until it eventually settles down), and scrolling and dragging objects in Designer is laggy as hell, but that is to be expected and, besides, I am not using the Windows build to thoroughly test the tools but mostly just stability, the UI/UX, and file rendering.

 

I have already managed to crash it while messing with the Studio panels (much like I did back during the pre-release Mac Beta) and found a few UI/UX glitches, so I'll be sure to post my feedback in the appropriate thread. ;)

Link to comment
Share on other sites

  • Staff

JGD,

 

If you can get the app to run under any sort of VM, you are both clever and lucky :)

 

However, we do not recommend running Affinity on anything other than a native installation of Windows - and unfortunately we cannot provide proper support to users who choose to take that path :(

 

Hope this helps,

 

Andy.

Link to comment
Share on other sites

Hi, I have a HP Stream 11" Laptop and install most of my software to a 256GB MicroSD card mounted as D:/ due to the small hard drive.

 

Unfortunately Affinity doesn't allow installs outside of the C:/ drive and gives a error that 'Installation directory must be a local disk' if you try and force it to install to D:/

 

Could this please be looked at as it looks like the install fails to recognize other drive letters as a valid install location ( possibly it is assuming that D: is a DVDRom drive?).

 

On the positive it did install correctly and runs fine from C:/ even with the low laptop specs :)

Link to comment
Share on other sites

Unfortunately Affinity doesn't allow installs outside of the C:/ drive and gives a error that 'Installation directory must be a local disk' if you try and force it to install to D:/

 

Could this please be looked at as it looks like the install fails to recognize other drive letters as a valid install location ( possibly it is assuming that D: is a DVDRom drive?).

 

I don't think it's failing to recognize the drive letter as a valid install location, I think it's correctly recognizing that your drive D: is removable storage.

Alfred spacer.png
Affinity Designer/Photo/Publisher 2 for Windows • Windows 10 Home/Pro
Affinity Designer/Photo/Publisher 2 for iPad • iPadOS 17.3.1 (iPad 7th gen)

Link to comment
Share on other sites

Guest Oldestyle79

Installed Affinity Beta for Windows on my 64 bit Windows 10 PC and I am experiencing the problem of seeing the splash screen for 10 or so seconds, then nothing else happens.

 

I have tried re-installing as an administrator to the root of C:\ and also to the desktop with the same result.

Bob.

I am having the same problem as well.  These are my specs for the machine I am trying to install this on:

 

Windows 10 Home 64-bit, Intel Core i5-6200U CPU @ 2.30GHz, 8.00GB Ram, Dell Inc. 06CMH7 (U3E1), Generic PnP Monitor (1366x768@60Hz) Intel HD Graphics 520 (Dell)

 

Any help would be greatly appreciated!  Thanks!

Link to comment
Share on other sites

I am having the same problem as well.  These are my specs for the machine I am trying to install this on:

 

Windows 10 Home 64-bit, Intel Core i5-6200U CPU @ 2.30GHz, 8.00GB Ram, Dell Inc. 06CMH7 (U3E1), Generic PnP Monitor (1366x768@60Hz) Intel HD Graphics 520 (Dell)

 

Any help would be greatly appreciated!  Thanks!

 

@Oldstyle79,

 

I had the exact same problem as you, but I found an updated version of the download software on another affinity forum board. I have pasted the link, but if it doesn't work search for a post titled: Affinity Designer on Windows (1.5.0.4)

 

https://forum.affinity.serif.com/index.php?/forum/33-affinity-designer-on-windows-beta/

 

Failing that, the download link is:

 

https://s3.amazonaws.com/affinity-beta/download/affinity-designer-public-beta.exe

 

Hope this helps!

 

Regards

Neil

Link to comment
Share on other sites

I keep getting error: Windows 7 service pack platform update not found (KB2670838)

I managed to find and download this update (tried 2 different files/types listed at Microsoft) but neither will install, resulting in:

Windows6.1-KB2670838-x64.msu 11.3 MB - error / FAILED
Windows6.1-KB2670838-x86.msu 5.6 MB - error / NOT APPLICABLE)

I'm on Windows 7 64-bit, 64-bit machine, service pack 1.

# The application file is on drive:C as suggested, still not working
# I've tried 'Run as Administrator' - error
# I've updated all windows updates - error

So in a nutshell: when I try to run Affinity I get an error that an update is not being found. When I try to install the update it won't install.

Link to comment
Share on other sites

  • Staff

I keep getting error: Windows 7 service pack platform update not found (KB2670838)

 

I managed to find and download this update (tried 2 different files/types listed at Microsoft) but neither will install, resulting in:

 

Windows6.1-KB2670838-x64.msu 11.3 MB - error / FAILED

Windows6.1-KB2670838-x86.msu 5.6 MB - error / NOT APPLICABLE)

 

I'm on Windows 7 64-bit, 64-bit machine, service pack 1.

 

# The application file is on drive:C as suggested, still not working

# I've tried 'Run as Administrator' - error

# I've updated all windows updates - error

 

So in a nutshell: when I try to run Affinity I get an error that an update is not being found. When I try to install the update it won't install.

Unfortunately it looks as though there is a problem with your Windows installation that is preventing your machine from installing the KB2670838 update (you have a 64bit machine so that is why the x86 version is not applicable). I would suggest contacting Microsoft's Tech Support about why the KB2670838 update is failing.

Link to comment
Share on other sites

×
×
  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.