Jump to content
Andy Somerfield

Affinity Photo Customer Beta (1.4.1 - Beta 4)

Recommended Posts

Purpose: Fixes

Status: Incremental bug-fix track on 1.4 - Release Candidate
Requirements: Purchased Affinity Photo
Mac App Store: Not submitted
Download: Here

To use this beta, simply download the file from the link given above and double-click on the file to open the installer. Follow the instructions to install the beta version. The beta sits alongside the Mac App Store version and will not interfere with it.

This is an Incremental Bug-Fix release - it should be considered more stable than the current MAS version (1.4) and should be used in preference to that build, if you are experiencing any of the problems listed below.

Fixes

 

- Fixed splash screen flicker issues (yay!).

- Fixed PSD Export line width issues.
- Further PDF export improvements.
- Restored ability to change background colour.
- O / Shift-O cycles crop tool overlay / orientation correct in Develop, Panorama.
- Fixed crashes in brush editing panel when no brush is selected.
- Fixed issues in Develop Extension when using split screen.
- Crop tool improvements (presets, DPI awareness of presets, etc).
- Fixed issues with Row / Column Marquee tool.
 

 

(Fixes from 1.4.1 Beta 3)...

- Fixed a number of Live Filter issues

- Performance improvements when converting from 8 to 16 bit formats
- Disable Haze filter when it is inappropriate
- Fixed Gradient tool not working with the keyboard shortcut
- Fixed Lighting filter’s controls appearing in the wrong place in some locales
- Fix for ‘Apply Image’ not working properly if the image is a different format to the document
- Stop Live Filters auto-committing when changing to another Live Filter layer
- Update the Live Filter panel’s blend mode and opacity correctly when they may have changed
- Fix for potential degraded performance on OS X Mavericks or earlier when panning/zooming
- PDF Import and Export Improvements
- Divide geometry operation functioned incorrectly on curves which used corners
- SVG import now understands the fallback font list
- SVG export now uses postscript name for font export
- Styles now normalise/denormalise when created/applied. Applying a style to a large object then shrinking it will now produce the same result as applying the style directly to a small object.
- Fix for incorrect operation of menus on context toolbars on OS X Lion
- Fix for Alt/Option modifier not working correctly as a modifier to the increment of a numerical text field when the decimal indicator is not a period ‘.’
- Fix for OpenType issue - not being able to apply Case Sensitive Forms
- Fix for spell checker using the wrong spelling language
- Fix for Character panel issue with setting language to “None” or “Invalid”
 

(Fixes from 1.4.1 Beta 2)...
- Fix for random crash when using PNG file export
- Text improvements (leading, justification and Paragraph panel improvements)
- Fix for certain text shortcuts not appearing in the customisable list for keyboard shortcuts
- Fix for PDF export failing when the document included specific dash patterns (usually imported from AI/PDF source files)
- Numerous PDF import fixes
- Numerous vector export fixes (PDF, SVG, etc)
- Fix for logic relating to copy/paste of layers and Artboards
- Fix for spelling languages failing to display correctly
- Fix for TGA files coming in flipped sometimes
- Fix for incorrect application of adjustments with blend modes
- Fix for snapping gutters not working if one was set to zero
- Fix for moving views between retina/non-retina screens not updating whether a retina draw was required for that view or not
- Added missing keyboard shortcut for switching between views
- Disable 'save' menu item for documents which have not been modified or cannot be saved


(Fixes from 1.4.1 Beta 1)...
- Fixed crashes when loading a document which has been saved in Quick Mask mode.
- Fixed crashes when using documents in the ProPhoto colour space in Mac OS X 10.9.5.
- Fixed stroke clipping / invalidation issues.
- Fixed crashes when loading documents saved with “Delete Slices” history items.
- Fixed weird zombie-open-dialog when starting the app.
- Fixed crashes when using calibrated monitor profiles with high-accuracy LUTs.
- Fixed layer “Expand” buttons disappearing in Mac OS X 10.8.

Share this post


Link to post
Share on other sites

I´d say that the performance improvement on the iMac 5k with the X GPU is noticeable. MattP said something about this....

I´ve got a file that was hardly usable and now get´s closer to a usable speed! And we´re still not even on Metal right? I mean I´m not aware that any App on my Mac utilizes Metal (apart from Adobe Stuff which I don´t have anymore) so I won´t blame you in particular but it´s somehow a bit disappointing. I think not even FCPX had an Update for this technology? I just hope Apple got the best out of it anyway.

[ I’m also reading about Metal support on OS X – as well as iOS – and working out the best way to fit our raster architecture around that. Looks easy 20. Oct. 2015 Andy]

 

And there´s a ton of stuff I mentioned in the 1.4.1 beta 2 thread but overall it´s really great getting these bug fixes!

 

Your rendering really has improved very much! Awesome!

It has always been a pain to work with images that had Denoise or USM applied and now it just works like a dream! THANKS


 

 

Share this post


Link to post
Share on other sites

Just updated from the MAS—about to put some work in. Thanks guys. 


15"-inch MacBook Pro, 2017, 2.9GHz Intel Core i7 | 16Gb

Share this post


Link to post
Share on other sites

I just updated from the MAS and now the beta 1.4.1 - beta 4 won't load... Saying that I need the purchased version. It was loading fine before the update (earlier in the day).  One other note, I had also upgraded to OS X version 10.11.13.

 

Any ideas on what's happening or if it can be fixed?

 

Thanks.


          MelG

 

If you want to tell people the truth, make them laugh, otherwise they'll kill you. - Oscar Wilde

Share this post


Link to post
Share on other sites

I just updated from the MAS and now the beta 1.4.1 - beta 4 won't load... Saying that I need the purchased version. It was loading fine before the update (earlier in the day).  One other note, I had also upgraded to OS X version 10.11.13.

 

Any ideas on what's happening or if it can be fixed?

 

Thanks.

Same here with 10.11.4 beta. Glad it's not just me.

Share this post


Link to post
Share on other sites

Hi rwakeford,

Welcome to Affinity Forums :)

As @mac_heibu said as soon as the Mac App Store is updated it doesn't recognise the old Betas anymore. You can safely move the Beta from the Applications folder to the trash.

Soon a new Beta cycle will start that will include new features and recognise the (now) current Mac App Store version (1.4.1).

Share this post


Link to post
Share on other sites

Thanks MEB (and mac_heibu) for explaining that. I had just assumed that the Beta was ongoing. :blink:


          MelG

 

If you want to tell people the truth, make them laugh, otherwise they'll kill you. - Oscar Wilde

Share this post


Link to post
Share on other sites

jpeg export question: 

please refer to the comparison I made: https://www.dropbox.com/s/culzz8tg24x1hgu/jpeg%20export%20comparison%20.afphoto?dl=0

the color gradient not continuas bother me for a long time. Now I use Preview.app to resize jpeg exported from affinity photo with Best quality preset instead directly export and resize jpeg from affinity photo.

 

is it my setting problem or other reasons?

 

 

Thank you

Share this post


Link to post
Share on other sites

Is there a particular hardware requirement for the beta? The performance on my 2011 laptop is terrible compared to the current MAS version. Just zooming in and out is painfully slow, for example.

Share this post


Link to post
Share on other sites

Hi iaindavies,

Welcome to Affinity Forums :)

No, the requirements are the same. The current Betas are now obsolete since we have just released a new updated Mac App Store version (1.4.1) which is the most up to date version available. A new beta cycle will start soon.

 

@tyler26,

I will check this out. Thanks for your report and file.

Share this post


Link to post
Share on other sites

Hi rwakeford,

Welcome to Affinity Forums :)

As @mac_heibu said as soon as the Mac App Store is updated it doesn't recognise the old Betas anymore. You can safely move the Beta from the Applications folder to the trash.

Soon a new Beta cycle will start that will include new features and recognise the (now) current Mac App Store version (1.4.1).

 

I just installed the MAS 1.4.1 version and found that all my presets and preferences from the previous MAS version were lost. I just spent half an hour reinstating them and I don't have that many yet.

 

I was using the 1.4.1 Beta and had changed most of the preferences and presets in the Beta version. Is this why the new MAS didn't pick them up? If so, what happens when new Betas are released for this version? If I update the prefs/presets in a future Beta, will they again be lost when I install a future MAS after that? It will be incredibly tedious if this will be happening with every new update.

Share this post


Link to post
Share on other sites

Everything is great but I'm wondering how making tool settings sticky is coming along? It's painful to retouch 20-30 images in a row and have to setup every single tool for every image! I'm still using it over photoshop but just remembering my flow settings or the current sampling layer setting would be really awesome.

 

Oh, also, it would be awesome if the lowest setting for opacity and flow on brushes was 1% and not 0%. That would make dragging to the left quickly to reach 1 - 3% a lot friendlier. As it stand sometimes you hit 0% and wonder why nothing's coming out.

Share this post


Link to post
Share on other sites

Hi Jonathan Thomas,

Welcome to Affinity Forums :)

Sticky settings are coming with the next Beta cycle (1.5).

Hi MEB, 

 

When is beta cycle (1.5) being released to us?  Ten days of waiting is too much to bear B)

 

Nana

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×