Jump to content
Sign in to follow this  
Mitsurugi

Affinity Publisher beta installation issue on Windows 7

Recommended Posts

Aero is on, I tried with turning off all the composition, still nothing. I add a screen with the pop-out. After that nothing happens.
specs:
Windows 7 Home Premium SP1

CPU: i7 - 4770
RAM: 16GB
GPU: GF 650 GTX

scr.jpg

Share this post


Link to post
Share on other sites

Hi guys, just tried to install it under Windows 10, and the installer didn't even start. It asked me for permission to install, I granted and nothing happened after that. Downloaded the installer again, didn't work. Restarted the system and even that didn't work. Is there everything fine with the installer? 
I'll try at home later, too. The machine is up to date with an i7, 32gb of Ram and a Geforce 1070 GPU.

Can't wait to check Publisher out finally! :) 

Share this post


Link to post
Share on other sites
3 hours ago, Mitsururgi said:

I'm unable to run it on Windows 7. I run it with administrator priviliges, and it shows that the program stopped working :(.

You run it with administrator rights, but did I install it with administrator rights?
Did you try to run with the Anti-Virus disabled?
I saw such a message, but in older programs, and the problem from what I remember is not from the side of the program.

Share this post


Link to post
Share on other sites
1 hour ago, Adam Mierzwa said:

You run it with administrator rights, but did I install it with administrator rights?
Did you try to run with the Anti-Virus disabled?
I saw such a message, but in older programs, and the problem from what I remember is not from the side of the program.

Well Im trying to install it actually, so yes I tried to install it with administrator rights :).

Share this post


Link to post
Share on other sites

I have installed it on window 10 Pro laptop I7 6700HQ with 16Gb and GTX 970 - no problems whatsoever.   First impressions is VERY NICE.  I know it beta but it would have been nice to try the personas for designer and photo.   Indesign pages also not implemented in beta.

Share this post


Link to post
Share on other sites
2 hours ago, TheFlow said:

Hi guys, just tried to install it under Windows 10, and the installer didn't even start. It asked me for permission to install, I granted and nothing happened after that. Downloaded the installer again, didn't work. Restarted the system and even that didn't work. Is there everything fine with the installer? 
I'll try at home later, too. The machine is up to date with an i7, 32gb of Ram and a Geforce 1070 GPU.

Can't wait to check Publisher out finally! :) 

Running it here on a bleeding edge Win10 RC5, no issues whatsoever. Did you try installing it with admin rights?

Share this post


Link to post
Share on other sites

Hi Mitsurugi

In control panel under uninstall a program, could you go to turn Windows features on or off and turn off .NET 3.5. there is an issue in our installers across the board at the moment with this combined with certain fonts which we will hopefully have sorted within the next couple of build but this work around may allow you to install the app on your machine


Serif Europe Ltd - Check the latest news at www.affinity.serif.com

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×