Jump to content

Move tool keeps transforming

Recommended Posts

Hi - sorry if this has already been answered - searching forum not finding anything.

Using Affinity Designer on iPad with Apple Pencil.   I find when I click on the center of an object the first time with the Move Tool.  But after I transform that shape - I want to move it again.  It keeps transforming.  Even if I click on the center of the object and not on one of the corners.

Am I missing a step?


Link to comment
Share on other sites

  • Moderators

Hi Stevie,

Welcome to the forums.

I can't seem to reproduce the issue here, after resizing it will revert to moving and not resizing.  Would you be able to do a screen recording which shows the issue occurring.

Link to comment
Share on other sites

I'm having this same problem. It seems to me that AD doesn't recognize the "touch" precision of using the pencil for these interactions. So if I zoom in far enough that the entirety of the touch radius of a finger resides fully inside the shape, then I can move it with the pencil. But if I'm not zoomed in that far, then the pencil's "touch" is still the same size as a finger, so it tends to select the transform handles of the shape. This is really disappointing and makes using the pencil on the iPad Pro really less useful than it should be. I feel like AD should be able to recognize the point of the Apple Pencil with much more precision than a finger touch.

Link to comment
Share on other sites

On 7/23/2018 at 8:35 AM, Lee D said:

I can't seem to reproduce the issue here, after resizing it will revert to moving and not resizing.  Would you be able to do a screen recording which shows the issue occurring.

Hi Lee,

Quick way to reproduce this is:

  1. Using iPad with Apple Pencil, draw a square
  2. Convert the Square to Curves
  3. Select the Move tool and select the square
  4. Zoom the drawing until the square is less than 1/2" on a side
  5. Attempt to use the Apple Pencil to touch the middle of the square and drag it to move the square.

Note that if you skip step #2, it behaves as expected, so maybe this has less to do with the Apple Pencil precision and more to do with the Curves/Move tool?

Link to comment
Share on other sites

Chiming in to say I'm seeing this issue as well. I also often find myself trying to move a selected object without switching to the Move tool first, simply by using a one-finger touch outside the selected area (a gesture I've gotten used to in other apps). I wonder if that might make sense to implement here, so we can move objects without needing to cover them with a finger/pencil.

Link to comment
Share on other sites

I’m also having this issue, Move tool selected, but the selected object keeps transforming. I use an Apple pencil also. I tried deselecting and selecting again, but the transforming sometimes happens then too. 


Well, after trial and error, I noticed I have much better success if I do not select the object first and then try to move it, but instead DEselect it and use the move tool without tapping the object first. Sometimes it will move if already selected, but results seem more consistent if the object is not selected.

Fantastic app overall!  Really enjoying learning my way around it, the combo of vector and raster is awesome! Extremely well thought out for iPad use!

Edited by ChromaLinda
update after more use
Link to comment
Share on other sites

I am also having this issue. I select an object or group of objects and try to move, but the obect(s) just keep transforming. I love the app, this is my only frustration with it. Perhaps it would be good to have a crosshairs appear in the center of the object on selection which can be used for move only? Something like that?

Link to comment
Share on other sites

Same problem here as well. Very annoying to keep having to undo a transform you didn’t want to perform after attempting to just move an object.  Given the importance of moving objects around in a design application, I would think that this would be a showstopper bug and should get highest priority to get this fixed.  Vectornator, Graphic and Procreate do not have this problem.  Please fix this.  

iPad Pro 9.7” (A1674), Affinity Designer for iPad

Link to comment
Share on other sites

  • 3 weeks later...
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.