Jump to content

Recommended Posts

Designer and Publisher (apparently not Photo) launches slowly since MacOS Big Sur 11.1 (i.e. 45 dock icon bumps) in its first launch after Mac reset or after a while closed (versus 4 icon bumps when recently launched).

Why?, is it normal?, is OS guilty or the app?, Apple Silicon Macs will solve it?

Emilio

Link to comment
Share on other sites

On 1/12/2021 at 11:55 AM, Sean P said:

Hi Emilio,

This is something we're aware of and is being investigated by the developers. It isn't related to Silicon Macs (as my intel Mac gets it). I will pass your comments over though.

Thnx Sean !!

Link to comment
Share on other sites

  • 3 weeks later...

I've had the 'slow launch' problem with every one of my Affinity apps since purchasing when it was still in the 1.8.x developmental stage. It is the single most aggravating aspect of using these otherwise terrific wares. I'd love to see the 'slow launch' problem corrected in all three wares.

As an aside, I just today upgraded all three to 1.9. I have not yet attempted to use Designer & Publisher since upgrading about an hour ago.

When Affinity crosses the line to V.2, will its wares still be compatible with macOS 'Sierra' or will it be 'High Sierra' and beyond? If 'HighSierra' and beyond, I will no longer be able to use any of its products. Why? Because to upgrade my Mac beyond 'Sierra' will cause the new OS to break my 32-bit apps that I still use on a regular basis. 'Sierra' is the end of the line for me, and I'm not keen on expending mucho cashola on the 'Silicon' Macs with ARM, so this 1.9 upgrade will (unless the next is 1.9.5) likely be my last shot at continuing to use Affinity's wares.

Mac Pro (Mid-2010) G5, 2.8 GHz Quad-Core Intel Xeon i7; macOS ‘Sierra,’ 12GB RAM, ATI Radeon HD 5770; S271HL Acer Display (1920 x 1080); Affinity Designer, Photo, and Publisher 1.10.5, Photoshop CS6, Illustrator CS6, InDesign CS6, QuarkXpress 9.5.4.1, ON1 RAW 2020, Portrait Professional Studio64, Topaz Labs Suite, Nik Collection, NeoOffice; separate Western Digital external HDs for storage  

Proudly Wearing the Shame of ThoughtCrime …

Link to comment
Share on other sites

In my case, the slow-launch problem occurs only after upgrading macOS to 11.1, and only in one of my Macs, unfortunately in the most used and most powerful. It occurs with 1.8.x and with the new 1.9.

Neither with older macOSes, nor with less powerful Macs this awsome problem happens.

I'm now thinking the problem could be the system configuration, not only the app.configuration.
I wait for my new MacM1  to see if there also occurs, and also have time and a new Mac to erase completely my slow-launching-Mac, and reinstalling all to see if this can be te problem (the jump from 11.0 to 11.1 macOS version was full of problems, even with lost information in iCloud!)

Is an annoying problem, but is really not a severe one, since it only happens the first launch on an app after reset/restart, or after a long inactivity period.

Apparently AFFINITY is aware of the problem, it will have a solution, even when after a long time.

Link to comment
Share on other sites

  • 3 weeks later...

Hi
My brand new M1 Mac has ALSO the slow-launching problem with the 3 apps.... only it's no so severe: instead of more than 40 icon bounces, now is only 18 to 20 bounces. But it continues to happen every time I reset or start the Mac. 
It is probably more due to Big Sur problems, since this behavihor started when updating to OS 11.01 or 11.1  ....

Emilio

Link to comment
Share on other sites

  • 1 month later...

Been seeing this here, too, on an M1 MacBook Air (16 GB RAM). Got this machine in November, so it’s coming up on 5 months since this was brought up — any news from Affinity? This launch delay is really noticeable. Literally nothing else I’m running does this.

  • Affinity Publisher (direct-download, non-App Store version): 20 dock bounces before the app launched (after fresh OS reboot).
  • Affinity Photo (Mac App Store): 21 bounces.
  • Affinity Designer (Mac App Store): 22 bounces.
Edited by tantramar
added more detail.
Link to comment
Share on other sites

  • Moderators
16 hours ago, tariq said:

Can Affinity tell us what the cause of these slow apps is?

We believe it is that our mac application having a JIT (just in time) runtime flag, and the operating system not remembering that the application is safe has not changed since the last time it checked the security of our installation. Unfortunately when we do not have that JIT flag set the process we use for the Welcome screen and other browser based UI in the application can crash on certain operating systems. Apple are aware of the issue and we are still working on a solution that neither takes too long to run up nor crashes using the browsing features.

Also please do not post in multiple threads on a topic, it is simply not helpful. 

Patrick Connor
Serif Europe Ltd

"There is nothing noble in being superior to your fellow man. True nobility lies in being superior to your previous self."  W. L. Sheldon

 

Link to comment
Share on other sites

  • 1 month later...
  • 4 weeks later...
  • 1 month later...

Just downloaded update 1.10, app purchased via Apple store still takes a long time to start initially -- bounces about 30times. The app purchased direct Affinity Publisher opens quickly 3 bounces. All apps updated to 1.10.

Link to comment
Share on other sites

1 hour ago, ianhg said:

Just downloaded update 1.10, app purchased via Apple store still takes a long time to start initially -- bounces about 30times. The app purchased direct Affinity Publisher opens quickly 3 bounces. All apps updated to 1.10.

I recall that to be the case in the beginning -- direct app worked normally.  Then, after a while, people started reporting delays at launch also.  So, enjoy the normal operation while it lasts!

Link to comment
Share on other sites

1 hour ago, ianhg said:

Just downloaded update 1.10, app purchased via Apple store still takes a long time to start initially -- bounces about 30times. The app purchased direct Affinity Publisher opens quickly 3 bounces. All apps updated to 1.10.

The issue that causes slow launching of the Affinity applications on some Mac releases has not been fixed yet. Work is required from, probably, both Apple and Serif.

-- Walt

   Desktop: new:  Windows 11 Home, version 21H2 (22000.613) 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090  (old: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970 )
   Laptop:  Windows 10 Home, version 21H2 (19044.1706) 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
    Affinity Photo 1.10.5 (.1342) and 1.10.5.1342 Beta   / Affinity Designer 1.10.5 (.1342) and 1.10.5.1342 Beta  / Affinity Publisher 1.10.5 (.1342) and 1.10.5.1282 Beta
 iPad Pro M1, 12.9", iPadOS 15.4.1, Apple Pencil 2, Magic Keyboard

  Affinity Photo 1.10.5 (.280) and 1.10.2 (.266) Beta / Affinity Designer 1.10.5 (.21) and 1.10.3 (.19) Beta 

Link to comment
Share on other sites

  • 2 months later...

Had some hope that under Monterey this issue would have been solved, but idle hope. Still just as bad as it was. With Serif not able to solve a crucial software fix in over a year really places question marks over either the company’s development skills or priority settings. My advice to management would be: double the price (still cheap) and hire some people to fix things.

Changed back to Photoshop beginning this year, and it has served me well, so planning to stay. Still not a big fan of Adobe as a company, but in PS they do have a fantastic product that is a joy to use.

Link to comment
Share on other sites

5 hours ago, Willem Jan Drijfhout said:

Had some hope that under Monterey this issue would have been solved, but idle hope. Still just as bad as it was. With Serif not able to solve a crucial software fix in over a year really places question marks over either the company’s development skills or priority settings. My advice to management would be: double the price (still cheap) and hire some people to fix things.

Changed back to Photoshop beginning this year, and it has served me well, so planning to stay. Still not a big fan of Adobe as a company, but in PS they do have a fantastic product that is a joy to use.

I'm pretty sure they don't care.  It was, what -- April of this year when we last heard from them on this topic when we were told they were working on a solution?  They blame it on Apple because they use a browser UI for the splash screen (you can't develop a native splash screen graphic in like a day?) and some other elements in the app?  Does no other software company use browser UI or does Apple have it out for Affinity apps and are purposefully targeting them with slow as mud startup?

It's been over a year now since this issue and nothing has changed.  Probably never will.

 

Link to comment
Share on other sites

6 minutes ago, DEMinSoCAL said:

I'm pretty sure they don't care.  It was, what -- April of this year when we last heard from them on this topic when we were told they were working on a solution?  They blame it on Apple because they use a browser UI for the splash screen (you can't develop a native splash screen graphic in like a day?) and some other elements in the app?  Does no other software company use browser UI or does Apple have it out for Affinity apps and are purposefully targeting them with slow as mud startup?

It's been over a year now since this issue and nothing has changed.  Probably never will.

 

Its true its frustrating .. but give them a break just look at the price of the apps and the steady improvements. Once the apps open once they are speedy enough and I dont have the M1 chip yet. 

Link to comment
Share on other sites

6 minutes ago, ianhg said:

Its true its frustrating .. but give them a break just look at the price of the apps and the steady improvements. Once the apps open once they are speedy enough and I dont have the M1 chip yet. 

Please don't confuse my attitude about their (in)ability to fix a problem they said they would (but haven't), with the quality and value of the the product.  I still recommend the product to friends and hope someday they become the "Adobe killer".  They certainly do not deserve "a break" on fixing an issue (or at least coming clean with the fact that they probably never will) that only their software has yet being blamed on Apple.

FWIW, I would 100% excuse them if they said they've taken development resources away from fixing the startup issue to concentrate on throwing together an Acrobat clone that sells for $50.  :)

Link to comment
Share on other sites

the problem with slow app starting on m1 macs seems to be related to the systems ocsp certificate check.
https://ravicpoon.medium.com/if-bigsur-is-slowing-down-your-mac-32d9fd4d5a5b

when turning off internet, the apps start speedy.

unfortunately i havent figured out a workaround yet. blocking the ocsp servers in etc/hosts doesnt do the trick.
blocking the ocsp and trustd-processes via little snitch also not. 

can somebody comfirm this?

Link to comment
Share on other sites

9 minutes ago, DooshPastesh said:

My test after Macbook restart (MBA M1, 7 core, 8gb):

With internet connection, four "bounces" of icon, then splash and after less than second, main window appears.

Without internet connection, three "bounces" of icon, rest the same.

I've tested it few times. Always the same time.

It seems that may be the case for a few days, then BOOM!  Bounce-hell.  Good luck.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.