Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

DEMinSoCAL

Members
  • Posts

    49
  • Joined

  • Last visited

Everything posted by DEMinSoCAL

  1. My V1 was from the App Store and was plagued with startup delays. I bought V2 direct from Affinity and have no issues.
  2. Just launched Designer 2 after having launched it this morning, and it took 23 bounces on the dock before it launched. (MBP 13 M1) Disappointing.
  3. Pretty sure Apple had nothing to do with it, otherwise V1 apps would launch lickety-split now. But glad to hear V2 launches like every other app now (fast).
  4. Anyone try Affinity V2 apps to see how fast they start? Web or App Store versions?
  5. According to an email I just received, "Something BIG is coming...". New versions? Probably. Free upgrades to those of us that already bought? Hopefully (but unlikely). Will the apps launch quickly? Not unless Apple fixed something on their end.
  6. Interesting, but none of the "fixes" I have found to work long term. They may work for a few weeks, but then...BAM! back to the 17-23 seconds of bouncing icon on the dock.
  7. So the lingerling "logical" questions are why this happens MOSTLY with Affinity apps and why it only happens with the App Store versions? Does Pixelmator Pro, for example, not use codesigning and somehow bypasses Gatekeeper as the reason their app launches immediately? Why do your Web versions, for the most part, not delay on start? Secondly, there is no way to provide Affinity Web Store replacements for people that can prove they bought the Apple App Store versions since this seems it will never be fixed? Also, YES...there are reports of other apps (mostly complaints of MS Office) that exhibit similar behavior, but if you read the posts, most say they have no issues with other apps (except MS Office, in the case of the particular thread). It just seems if Apple changed something, then why isn't EVERY app exhibiting the delay?
  8. You sort of answered your own question. If they cared, they'd redesign their software to work like literally every other app that doesn't stall on start. I would guess they have zero resources working on this.
  9. Seems you have hit upon a bit of good luck then. Metal didn't work for me as a fix. Unfortunately, no one else has chimed in with their experience using Metal setting.
  10. Have you rebooted a few times? I just rebooted and my apps are back to 15 bounces before opening. Before rebooting, they were quick at launching. As a matter of fact, right after updating to macOS 15.4 they still launched fast. But did a manual restart and then back to slow again. Checked Preferences and still on "Metal" for all three apps.
  11. I've rebooted mine after fast opening and sometimes it still opens fast. Sometimes it doesn't. Like I said, it's very unpredictable. Come back in a couple weeks and let us know if any of the apps have reverted to 20+ seconds. Basically, Affinity has said that the problem is with some sort of "check" with Apple servers that is failing. Why they are the only app that has this check is yet to be explained. I don't think (and my results don't show) that switching how the video works fixes the startup glitch.
  12. I'm not disproving your results, I'm saying the OpenGL --> Metal change doesn't work for me. I do know that the apps don't always stall on opening after a reboot. It's very random. As is how long the copy-app "fix" stays working. By your results above, Designer and Photo should be opening in 2-4 seconds normally. Even after your "fix", they still take 15+ seconds. That's not "fixed". Is it quicker? Yes, but not "fixed". I just don't want others to think that switching an app to Metal fixes the app so it opens in 2-4 seconds because it doesn't.
  13. Of course that seems to work because once you run an app, it starts quickly thereafter. But after I restart, Photo goes back to 22 bounces to start (expected).
  14. And that is normal behavior. Even after copying the apps and running those, while it seems to work for a while, it stops working and reverts back to 20+ bounces on the taskbar, requiring you to do the "fix" again. I know you think you found a fix, but give it time. You mentioned in your post that Designer was already launching in 2 seconds before any "fix". If that's the case, you don't have the problem the rest of us have. ALL the apps take 20+ bounces before they open. But once open, they tend to open quickly, even after a reboot, but WILL revert to super slow open soon. I don't see how making a preference change in ONE APP affects all the other apps (if it even does).
  15. I would have to say that whatever issue you were seeing with the long delay that was somewhat fixed by the "copy app" workaround is not fixed by this OpeGL--> Metal switch because while Designer was set to OpenGL, my Photo and Publisher were already on Metal and have had the slow start for over a year. Logically, this switch may fix some other slow startup issue but not the one that plagues the App Store apps.
  16. While it seems like a solution, copying the app trick does revert back to 17-22 bounces after some time. Trust me on this.
  17. No, but for me, I don't use all the Affinity apps all the time. So keeping them all open all the time is just a waste of resources.
  18. Affinity will have you believe that. Yet no other apps have this annoying delay. My Pixelmator Pro from the App Store starts instantly, for example. Affinity seems content to sit on their hands and point the blame on Apple instead of changing their App store version so there isn't such a huge delay. The "copy-of-app" fix doesn't work anymore -- they take forever to launch now.
  19. You are fooling yourself if you think, after almost 18 months, that Affinity is actually working on fixing this. They aren't.
  20. Buy lottery tickets. You have a better chance of winning the lottery than Serif/Affinity fixing the app.
  21. Yes, it's been stated that the problem is with the App Store versions of the apps.
  22. Did you try the "copy App" trick? Make copies of each Affinity app and put those down in your Dock and launch. For me, it's worked much better with just a few bounces on initial launch (after a fresh boot or restart) and almost immediate if quit and relaunched. Do you mean if you quit the app and immediately launch it,, it still bounces 14 times? That's not right, even for Affinity.
  23. Doesn't work. Also, needs to have "sudo" before each command otherwise you get permission denied.
  24. In my testing last year when all this started, it was initially thought that only the App Store version was affected, so I downloaded trial version from the Affinity web site, and installed those also. At first, they appears to start normally, but after a few days, even the web site downloaded versions would stall at startup. I wound up removing the web versions. Making duplicates of the apps and using the duplicates also did not seem to keep working properly and would start stalling. So, I haven't seen a permanent fix. Someone above recommended some host file entries. That did not work for me at all, unless there is more to it than editing the host file and running the app. Mine still stalled (20+ bounces on first launch).
×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.