Jump to content

GrinningShark

Members
  • Content count

    18
  • Joined

  • Last visited

  1. Wondering about this also. Cannot get clean SVG files for export to TinkerCAD (just imports the vector all chopped up) or Blender (imports better, but still has problems).
  2. Thanks Callum. The popups aren't a super huge deal, they just kind of stuck out once everything else went dark and I wanted to point it out. Appreciate your reply.
  3. You should be able to fix the sort order in the iCloud Drive folder. If you right click while inside this view and select "Show View Options" you may find that Group By is not set to None. I had this happen with one of my folders and it causes things to not behave or work like you want.
  4. Wow! I post a simple question, with no implied urgency, and get a snarky, insulting reply. I own ALL of the Affinity products on both macOS and iOS and am very happy with all of them and have every right to ask a simple question without getting insulted.
  5. Will full support for macOS Mojave dark mode be enabled in the Affinity apps? I know they can be set to dark, but some UI elements still come up as light... like the File Open, Save As and Print Popups to name a few.
  6. GrinningShark

    DAUB Pencils

    You rock! Was just looking for some good pencils to use with new Wacom tablet.
  7. I figured out how to resolve it. The fix is on the macOS side. It looks like information about the folders is cached and somewhere along the way Affinity probably misconfigured the folders (after looking through the forums, it looks like these folders at some point would both go to Affinity Photo, but that was resolved later by the developers). Since I have been using both Affinity programs since the day they were launched, I probably had some remnants of this somewhere that was hosing my iMac and MacBook. Steps I followed (use at your own risk): - Go into iCloud settings and turn off Affinity Designer and Affinity Photo in the iCloud Drive settings. This DOES NOT delete your files from iCloud. - Go to ~/Application Support/CloudDocs/session and then delete these files and folders to the trash: 6LVTQB9699.com.seriflabs.affinitydesigner (folder) iCloud.com.seriflabs.affinityphoto (folder) 6LVTQB9699.com.seriflabs.affinitydesigner.plist (file) iCloud.com.seriflabs.affinityphoto.plist (file) This DOES NOT delete your files from iCloud or impact the Affinity software or settings, it only gets rid of details related to icons and application references for the special App Library folder on your macOS. - Reboot. - Go into iCloud settings and turn both Affinity Designer and Photo back on. - Launch Designer and Photo. - Check the iCloud Drive folder and the directories should be correctly setup. Hope this helps anyone else who has this bizarre problem.
  8. I only use macOS/iOS for this software. At work I use Windows, so I have an occasional brain fart and slip in the word directory now and then. LOL
  9. Thanks for your reply. I forgot to mention I had done that a few times and also tried doing GET INFO on one of the files and adjusting it from there. My bad. When doing GET INFO on the files in iCloud Drive, it does say it opens with Affinity Photo. When I do that for any files not in that mystical iCloud Drive folder (App Library), it does say AD is the application of choice. No matter what I do, it just keeps defaulting back to Affinity Photo only for files in the Affinity Designer iCloud Drive folder. I noticed that the folder in iCloud Drive for Affinity Designer is showing the icon for Affinity Photo (purple) instead of the one for Designer (blue). So, whenever I pick stuff in that folder I'm guessing it will always launch Photo for these items. I backed up the files in the Designer folder and completely deleted it and it disappeared from all devices as expected. I then tried going into Affinity Designer and saving a file directly to the cloud. AD created the directory, but it still had the wrong icon on the folder on the Mac, it was fine on the iPad when I looked at it in Files (on my iPhone I noticed icon was wrong in files, just like on the Mac). So, I'm guessing the top level folder (aka App Library) in iCloud defines which app should launch for any files in that particular folder and something is amiss with it. As another test, I deleted the folder again and then saved a file to iCloud from the iPad edition and the folder and file appeared on my Mac, however the darn icon was still the Photo one. Going to try deleting it again, dumping the trash and rebooting to see what happens and if that works will post the results. I'd love to see if there is a way to fix this so that folder (App Library) behaves as it should again. I moved my files to my Documents folder for now, so they open correctly.
  10. I have both Affinity Designer and Photo on my iMac. I have one annoying thing that happens that I cannot fix. When I double click an .afdesign file in Finder, it almost always opens Affinity Photo instead of Designer for anything located in the "Affinity Designer" iCloud Drive folder. The only way for me to get it to open in the right program is to specifically select it using "Open With" or by opening it from inside Designer. How do I fix this? Things of note: - In Finder the files all do say they are the "Affinity Designer Document" type. - As I mentioned, this appears to mostly occur for files stored in iCloud Drive in the Affinity Designer folder. If they are on my computer or in the documents folder (I do have that being stored on iCloud so I can access it from my iMac or MacBook), the files tend to consistently open in Affinity Designer.
  11. GrinningShark

    Grid Settings Not Saving (Designer/Windows)

    I have some more info and think I know what is going wrong. I was able to reproduce this on another PC. I discovered that the color will save when the "link" button is enabled to link the grid and subdivision colors to the same color. When I un-link them (so I can pick two different colors), the color is not restored on entering the software. So, it looks like when un-link feature is broken. I was un-linking them so I could use red or blue for the grid and a light grey for the subdivision.
  12. GrinningShark

    Grid Settings Not Saving (Designer/Windows)

    The settings appear to be saving. The values change to the new color. But, when I go back into the software, the colors are back to the defaults. When I exit and check the settings file again, the colors are back to where they originally started (designer defaults). So, it looks like it is saving the color, just not loading it back. Note that other settings in that file appear to be working correctly -- like my default swatch/palette set. It is selecting the right one each time and I don't have to pick it each time.
  13. GrinningShark

    Grid Settings Not Saving (Designer/Windows)

    I tried resetting my settings as described, also tried an uninstall/reinstall and also tried blowing away the settings folder. The settings still won't stick. I decided to check the application logs (in system management) and it appears as if an exception is occurring when the application is shutdown. I'm guessing this is probably what is preventing the settings from being saved, since the settings are probably saved while the software exits. Putting on my developer hat, looks like a null reference exception inside a destructor. Here are the details: Faulting application name: Designer.exe, version: 1.5.0.36, time stamp: 0x58253c23 Faulting module name: KERNELBASE.dll, version: 6.1.7601.23569, time stamp: 0x57f7c0b4 Exception code: 0xe0434352 Fault offset: 0x000000000001a06d Faulting process id: 0x19fc Faulting application start time: 0x01d2499765a946c6 Faulting application path: C:\Program Files\Affinity\Affinity Designer\Designer.exe Faulting module path: C:\WINDOWS\system32\KERNELBASE.dll Report Id: 6f6a5169-b591-11e6-b1e5-ec8eb5a3b693 Application: Designer.exe Framework Version: v4.0.30319 Description: The process was terminated due to an unhandled exception. Exception Info: System.NullReferenceException at Serif.Interop.Persona.Data.GridAndAxisManagerDataSource.!GridAndAxisManagerDataSource() at Serif.Interop.Persona.Data.GridAndAxisManagerDataSource.Dispose(Boolean)
  14. GrinningShark

    Grid Settings Not Saving (Designer/Windows)

    It did save a random shortcut and it is keeping other settings and also my workspace layout. I also tried installing it into a Windows 10 system (a VM) and it retained that particular setting without any issues. I also tried resetting the defaults through preferences and that didn't help. The only machine I cannot get it to save on is a work laptop that is Windows 7 based (has a crap load of encryption and security stuff on it that the infrastructure team installed on it). I bought the Windows version so I could use AD on my work laptop and not have to drag in my personal MacBook for creating icons for .NET applications my team develops. Any other suggestions? Where are the settings saved at -- registry or settings file? Any way to completely remove these and start fresh or does the preferences option do that automatically? Thanks!
  15. When I adjust the grid line colors, they are not saving between sessions on the Windows version. The Mac version is working fine. Is it just me or is this a bug?
×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.