Jump to content

Recommended Posts

Hello,

I have an interesting problem: Publisher drop a paragraph to next page, but paragraph lines can fits end of column. Anyone have tip, why drop this paragraph to next page? No column or page break, I deleted character and press Enter again, but Publisher drop to next page...

 

 

paragraph3.jpg

Share this post


Link to post
Share on other sites

You may have Keep paragraph together  turned on in the Paragraph Style's Flow section. It may even be turned on in a Paragraph Style which this one is based on and is inherited as this screen shot would show.

1695455756_ScreenShot2019-10-10at7_58_00AM.png.f38ba86613b6a44f7ca7032acdb6ad94.png


MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.5

Affinity Designer 1.7.3 | Affinity Photo 1.7.3 | Affinity Publisher 1.7.3 | Affinity Designer Beta 1.7.x.x | Affinity Photo Beta 1.7.x.x | Affinity Publisher Beta 1.8.0.502

Share this post


Link to post
Share on other sites

If turn on this option, then I get many holes in text frame... This is a book, and have problem with paragraph wrapping.

What I tried:

  • Keep with previous paragraph -> previous paragraph will go to next page too
  • Keep paragraph together -> get many holes (I use these settings to a paragraph style)
  • Keep with next 1 line -> program crashed and closed.

Text is imported from docx, and no include any linked formats. I attached paragraph settings.

paragraph3a.jpg

Share this post


Link to post
Share on other sites

You may have a Frame Break, Column Break, Page Break in there. Turn on Show Special Characters and see what is there, there shouldn't be anything other than the one Paragraph Return.

537039541_ScreenShot2019-10-10at12_22_04PM.thumb.png.75fbee99aeaffd1d2152ef1b1d1e85bc.png


MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.5

Affinity Designer 1.7.3 | Affinity Photo 1.7.3 | Affinity Publisher 1.7.3 | Affinity Designer Beta 1.7.x.x | Affinity Photo Beta 1.7.x.x | Affinity Publisher Beta 1.8.0.502

Share this post


Link to post
Share on other sites

Ok, I turned on special characters for you, but I didn't see any special characters. Any tip? I think this is a bug...

image.thumb.png.d2cc79199f896d36cdd8baefa5b8ec64.png

image.thumb.png.7f6a54c30fe2ad88ed9131f469e6c404.png

 

Share this post


Link to post
Share on other sites

I am out of ideas from off of the top of my head, I would need to see the document and go through the Paragraph Styles and Text Frames and some other things to see what the problem is. 


MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.5

Affinity Designer 1.7.3 | Affinity Photo 1.7.3 | Affinity Publisher 1.7.3 | Affinity Designer Beta 1.7.x.x | Affinity Photo Beta 1.7.x.x | Affinity Publisher Beta 1.8.0.502

Share this post


Link to post
Share on other sites

That's joke, if I change character tracking to bigger (or biggest) or smaller/smallest, or turn off zones of hyphenation, then Publisher put the paragraph to correct place...

Share this post


Link to post
Share on other sites

I am so glad you solved it, but sorry I didn't think of that too. I shall remember that.


MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.5

Affinity Designer 1.7.3 | Affinity Photo 1.7.3 | Affinity Publisher 1.7.3 | Affinity Designer Beta 1.7.x.x | Affinity Photo Beta 1.7.x.x | Affinity Publisher Beta 1.8.0.502

Share this post


Link to post
Share on other sites

Sorry, this not nolved, because I set zones for no hyphenation to end of column :( Tracking is not solution too, because I get many spaces. :( If I set a few options, then Publisher will working strangely

Share this post


Link to post
Share on other sites

Unless you can provide a .afpub file that demonstrates the problem we can only guess at solutions.


-- Walt

Windows 10 Home, version 1909 (183623.476), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.3.481 and 1.8.0.486 Beta   / Affinity Designer 1.7.3.481 and 1.8.0.486 Beta  / Affinity Publisher 1.7.3.481 and 1.8.0.502 Beta

Share this post


Link to post
Share on other sites

Sorry, my project is a book, and writer's have many rights for this, and I cannot publish here. :( I think, this is a complicated bug with many parameters (maybe font, but I think with hyphenation settings and flow options will help, if try). I used Times New Roman 12 pt, with Line-height multiply 1.08, and left indent 5mm in paragraph if help. Other changed  flow and hyphenation settings see my screenshots.

Share this post


Link to post
Share on other sites
42 minutes ago, mykee said:

Sorry, my project is a book, and writer's have many rights for this, and I cannot publish here. :( I think, this is a complicated bug with many parameters (maybe font, but I think with hyphenation settings and flow options will help, if try). I used Times New Roman 12 pt, with Line-height multiply 1.08, and left indent 5mm in paragraph if help. Other changed  flow and hyphenation settings see my screenshots.

Can you reproduce the issue with a shorter version, perhaps just two or three pages of your book, with the text replaced by filler text?

If so, you could provide that.


-- Walt

Windows 10 Home, version 1909 (183623.476), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.3.481 and 1.8.0.486 Beta   / Affinity Designer 1.7.3.481 and 1.8.0.486 Beta  / Affinity Publisher 1.7.3.481 and 1.8.0.502 Beta

Share this post


Link to post
Share on other sites
6 hours ago, mykee said:

"Publisher drop a paragraph to next page, but paragraph lines can fits end of column"

 

(Well, it was actually yesterday, but I extracted a part of your original post. )  Does this happen with every page, or is this an isolated incident?  If isolated, I have a one-time suggestion.  Why not replace your paragraph break (Return key) for the last paragraph before the white space,  with a line break (Shift+Return).  This will treat the next paragraph as a continuation and should fill the page, but should avoid the large white space.  Worth a try? 


21.5 iMAC Retina 4K display. MacOS Sierra v. 10.12.6 (which I am not changing).  3.1 GHz quad-core Intel Core i5, Turbo Boost up to 3.6 GHz.  Memory 8 GB 1867 MHz LPDDR3.  1TB Fusion Drive.  Intel Iris Pro Graphics 6200 1536 MB.   iPad Pro 12.9, iOS v. 12.3.1, Apple Pencil.  Affinity Publisher 1.7.3, Affinity Photo 1.7.3, Affinity Designer 1.7.3. 

Magic mouse.9_9

Share this post


Link to post
Share on other sites

When I select all text, cut it, paste it into a pure text editor app, copy/paste back to your .afpub, reassign style "Normal" then the page break appears fine:

919709058_pagebreakhungary.jpg.a34ada83c032403b2134c82b0103ca18.jpg

 

But there still is something weird: I am not able to delete the paragraph breaks: If I place the text cursor before the first character of any line and hit the 'delete' key then nothing happens.

Do you experience strange behavior only with this document? Could it be related to the text source file?


macOS 10.12.6,  Macbook Pro 15" + Eizo 24"

Share this post


Link to post
Share on other sites

I took a look again and I have realized that what you are experiencing is the paragraph's first two lines being kept together (Prevent orphaned first lines) and the paragraph's last two lines being kept together (Prevent widowed last lines). As there are only three lines in the paragraph they are all being kept together.

Having said all that I do not understand why the three line paragraph is not being included in space that looks like it is four lines high on the previous page.

Your file (hozzad-lancolva-test) has the paragraph style (Normal) using the base line grid but the base line grid is off on both the spreads and the Text Frames. Then there is some additional spacing going on with the three asterisks used as a break which messes up the spacing for the page not using the baseline grid.


MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.5

Affinity Designer 1.7.3 | Affinity Photo 1.7.3 | Affinity Publisher 1.7.3 | Affinity Designer Beta 1.7.x.x | Affinity Photo Beta 1.7.x.x | Affinity Publisher Beta 1.8.0.502

Share this post


Link to post
Share on other sites

I noticed something odd.

If I place the cursor at the end of the last visible text on page 1, and press Enter to begin a new paragraph, I get Arial font and [No Style] as the paragraph style, rather than the Times New Roman and Normal paragraph style that I expected. I deleted that paragraph break.

Then I zoomed out to enable me to see the bottom of page 1 and the top of page 2, put the cursor at the end of the last visible text on page 1, pressed Shift and down arrow. I was able to select 2 lines of invisible text before the cursor dropped to page 2.

Deleting those lines of invisible text fixes your problem, I think.

By copying them and pasting into another program I was able to see that they are a control character (shown in NotePad++ as a PS, hex e280a9) and some text:

Quote

– Nagyon szexi – válaszolom. Tényleg nagyon jól áll rajta. Fehér bőr, sötétszőke haj, vékony deré

Here's how the selection looked with the invisible text still present:

image.png.aad0d8d18e11b29fa2e9f36197ea1340.png


-- Walt

Windows 10 Home, version 1909 (183623.476), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.3.481 and 1.8.0.486 Beta   / Affinity Designer 1.7.3.481 and 1.8.0.486 Beta  / Affinity Publisher 1.7.3.481 and 1.8.0.502 Beta

Share this post


Link to post
Share on other sites

The problem is that APub think "–" should behave like an hyphen and should stay part of the previous sentence (if you disable the option about Widow, it'll be fine).

Using a space before, or — (alt+0151) for dialogues solve this, but we can't use – (alt+0150) for lists.

2019-10-11_220314.thumb.png.373d8730fc593944cdbb7ce54410daf7.png

2019-10-11_220403.thumb.png.45c5540b204b2ea3815fa9c856c643e6.png

 

Share this post


Link to post
Share on other sites
On 10/10/2019 at 7:34 AM, mykee said:

Hello,

I have an interesting problem: Publisher drop a paragraph to next page, but paragraph lines can fits end of column. Anyone have tip, why drop this paragraph to next page? No column or page break, I deleted character and press Enter again, but Publisher drop to next page...

 

 

paragraph3.jpg

The main issue, the moving of two paragraphs when resizing the text frame, is due to the massive hyphenation zone setting. 

Why so large?

Share this post


Link to post
Share on other sites

For the main issue: see line numbers on odd page, there is four lines yet, dropped paragraph is three lines... Why not leave on page?

What I tried from your tips:

  • text frame site change is not solved, because if change text before, then text will move
  • Prevent windowed last line option disable not option for me, because this is a wrapper rule for books, this option use turn on like Prevent orphaned first line too
  • walt.farell: This hidden text is next paragraph first line. If I delete this, I deleted your quoted text too. :( 
  • MikeW: I set Hyphenation zone to 10mm, because I get many hyphenation. If I change this to 0, this not solved my problem.

 

I attached part of original text in docx, what I imported to Publisher.

HL-test.docx

In original layout drop this paragraph to new page, but there is ok, because Word leave two lines bottom of first page, no four as Publisher. But line-height is same...

Here is screenshot, because auto-hyphenation is on under Word, use hungarian dictionaries too.

image.thumb.png.df086bafd03a8bd8b29cadb1ae37976b.png

Share this post


Link to post
Share on other sites

The APub file I downloaded from above had the column end zone at 80 or something huge. That is what was affecting the dropping of the paragraphs down.

You have 0% letter spacing for all three values. If adjusted to allow for some letter spacing (I used 5,0,10), then this is what I get in APub with a 5% column end zone.

Capture_000267.png.31af2ab051e4fb055914995d5daa1a3b.png

 

Share this post


Link to post
Share on other sites

Yes, zone is huge, because developers said: set this parameter to big size, if I need no hyphenation at last line at end of column. I suggested to developers, need an option: no wrap for last word of column, but said this trick. But paragraph dropped... 

Share this post


Link to post
Share on other sites

The usual "no wrap for capitalized word", "no wrap for end of column|frame|page", "no wrap at last word of paragraph" would be simpler and fit a lot of situations, when those parameters seems to need adjustments depending of the column's width, especially if they cause trouble with setting for large values.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.