Jump to content

Recommended Posts

5 hours ago, mykee said:

Yes, zone is huge, because developers said: set this parameter to big size, if I need no hyphenation at last line at end of column. I suggested to developers, need an option: no wrap for last word of column, but said this trick. But paragraph dropped... 

The zone is so large it incorporates not only the 3 line paragraph but up into the preceding one. It doesn't need to be longer than a long word. I doubt you have a word at that point size 80 mm in length. 

Note, I do not believe even a large setting should cross a paragraph boundary but it appears to do just that. If not a bug then I suspect it is unintended behavior. @Dave Harris

Share this post


Link to post
Share on other sites

There's a bug in how the Column end zone interacts with the flow options, in this case the widow and orphan control. That's what causes an extra line to be moved -  and then the short paragraphs mean that more lines get moved to avoid widows and orphans. This will be fixed in 1.8 (but the fix may not make the next beta).

The Column end zone doesn't extend past the last line (or paragraph boundary), so it should be safe to set to a large value. The reason it is a value rather than a checkbox is that if the text engine is not allowed to hyphenate a very long word, you may end up with a last line that is either very loose or very ragged. Sometimes a hyphen may be the lesser of evils.

 

Share this post


Link to post
Share on other sites
On 10/11/2019 at 10:00 PM, thomaso said:

Another oddity: When I change the frame height the line spacing becomes influenced, in a elastic way:

I'm not seeing that behaviour with the file attached. Are you sure you didn't set the frame to be Justify Vertically?

Share this post


Link to post
Share on other sites
On 10/11/2019 at 9:00 PM, walt.farrell said:

I noticed something odd.

If I place the cursor at the end of the last visible text on page 1, and press Enter to begin a new paragraph, I get Arial font and [No Style] as the paragraph style, rather than the Times New Roman and Normal paragraph style that I expected. I deleted that paragraph break.

That's because the Normal style has its Next style set to [No Style]. I'm not getting the hidden control characters.

Share this post


Link to post
Share on other sites
1 hour ago, Dave Harris said:

I'm not seeing that behaviour with the file attached. Are you sure you didn't set the frame to be Justify Vertically?

Oh, indeed – I just checked my file again where I had cut/copy/pasted the entire text via a txt editor. Yes, in my .afpub this text frame is set to justify vertically – I wonder how because for this test I had intended to cut & copy/paste only. I just tried again and now neither the elastic behavior does occur nor the the last paragraph flow from pg 1 to pg 2 doesn't differ from the original .afpub (as I had reported different above) – Sorry for my kind of useless posts, and thank you, Dave, for clarifying.


macOS 10.14.6, Macbook Pro Retina 15" + Eizo 27" // Affinity preferred in Separated Mode + Merged Windows

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.