Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

Trying to add designs to Assets tab


Recommended Posts

I have downloaded the excellent set of snowflake designs from the Resources section of this forum.  I would like to add the designs to my Assets tab.  The Help file clearly says I can simply select and drag each separate snowflake to the Assets tab (I think).  I'm certain I've done this exact procedure before.

 

But this time, the + sign that the Help file says will appear does not and the individual design is, apparently, dragged beneath the tab but not added to it.  I've attached a quick screen recording which shows what happens, or rather doesn't happen.

 

I'd be very appreciative of any advice on this.

 

Thanks,

Jeff

Capture.mp4

 

EDIT: to add I'm running version 1.6.2.97 of Designer.

Edited by emmrecs01
Add information

Win 10 Pro, i7 6700K, 32Gb RAM, NVidia GTX1660 Ti and Intel HD530 Graphics

Long-time user of Serif products, chiefly PagePlus and PhotoPlus, but also WebPlus, CraftArtistProfessional and DrawPlus.  Delighted to be using Affinity Designer, Photo, and now Publisher, version 1 and now version 2.

iPad Pro (11") running Affinity Photo and Designer (iOS 16.2) version 1 and all three version 2 apps.

Link to comment
Share on other sites

Hi Miguel.

 

Many thanks for this; clearly, my memory of how I achieved this before was wrong.

 

However, I now see another problem.  I've attached two screenshots: the first is the Sub-category tab when I first open the app and select to add the first design to the panel.  The addition is successful.

 

The second screenshot shows what then happens when I select a second design to add it: the hamburger menu disappears and can only be "resurrected" by closing and then re-opening AD.  I also notice the scrollbar at the right hand side of the Assets panel has disappeared!

 

ScreenShot00370.jpg.2352bac5e9f4ff8617c2f4ead4967278.jpg

 

 

 

ScreenShot00371.thumb.jpg.3be3978f08f13e9d1ae38a80bcf33d08.jpg

 

???? :S

 

Jeff

 

EDIT: Having checked all this again, and reproduced the problem once, but then failed to do so a second time, I see the "sub-category" "Assets" header below the "Personal" category tab "disappears".  Sometimes it can be restored by dragging the Assets panel wider and then narrower.

 

Now I am even more confused! :S :S

 

Edited by emmrecs01
To add additional information

Win 10 Pro, i7 6700K, 32Gb RAM, NVidia GTX1660 Ti and Intel HD530 Graphics

Long-time user of Serif products, chiefly PagePlus and PhotoPlus, but also WebPlus, CraftArtistProfessional and DrawPlus.  Delighted to be using Affinity Designer, Photo, and now Publisher, version 1 and now version 2.

iPad Pro (11") running Affinity Photo and Designer (iOS 16.2) version 1 and all three version 2 apps.

Link to comment
Share on other sites

Does this happen if you select show as list

 

Capture.PNG

You can also add multiple items to the assets panel by selecting more than one, bear in mind if a shape has several components and isn't grouped each of those components will become a separate asset, grouping them will create a combined asset.

 

iMac 27" Late 2019 Fully Loaded and running Monterey 12.6.1, iMac 27" Late 2013 running Catalina 10.15.7 - Affinity Designer, Photo & Publisher V1 & V2, Adobe, Inkscape, Blender, C4D, Sketchup + more... XP-Pen Artist-22E, - iPad Pro 12.9 B|  

Affinity Help - Affinity Desktop Tutorials - Feedback - FAQ - most asked questions

Link to comment
Share on other sites

I"m having the same issue with the snowflakes even on a Mac.

 

When I try dragging one of the snowflakes into a new asset category I created, called Snowflakes, nothing happens. I noticed that under this subcategory there is another line that says Assets and I can't figure out how to change that. See screenshot to snowflakes. In my other Asset categories, that second line is a specific subcategory.

 

I wanted to see if the problem had something to do with my new category I'd created so I went to another category I had previously successfully created, called Arrows, and tried to drag in one of the snowflakes. When I did this, I saw a grey rectangle in the asset panel. I then went to the same snowflake, right clicked it, and grouped it. I was then able to drag the group into the Arrow asset panel. It didn't show up as an image, just a white box, but when I dragged it back to the art board, another copy of the snowflake appeared. This suggests that I was able to include the entire snowflake as an asset.

 

But none of this was possible when I tried to repeat the process with the new snowflake category. So, I too, am confused. 

 

If anyone can explain this inconsistent behaviour, that would be helpful. Thanks.

Screen Shot 2017-12-26 at 10.12.00 PM.png

Affinity Photo, V 1.9.1    Affinity Designer, V 1.9.1, Affinity Publisher, V 1.9.1

Mac Book Air, Big Sur 11.2.3

Link to comment
Share on other sites

6 hours ago, DianeF said:

When I try dragging one of the snowflakes into a new asset category I created, called Snowflakes, nothing happens. I noticed that under this subcategory there is another line that says Assets and I can't figure out how to change that.

I think what you have is an assets category named "Snowflakes" with a sub-category with the default name "Assets." You can change the name of the sub-category by clicking on the sub-category's menu & choosing "Rename..." from the popup menu. 

 

As far as I know, you can't add items to a category, only to a sub-category, but on a Mac you should be able to drag & drop an item into the sub-category as long as it is opened. To do that, make sure its disclosure triangle is pointing downward.

assets.png.ae4d83725978bd604b6f6121b298f715.png

All 3 1.10.6, & all 3 V2.03 Mac apps; 2020 iMac 27"; 3.8GHz i7, Radeon Pro 5700, 32GB RAM; macOS 10.15.7
Affinity Photo 
1.10.6; Affinity Designer 1.10.6; & all 3 V2 apps for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 15.7

Link to comment
Share on other sites

Thanks R-C-R.  Very helpful, as always, especially the tip for changing the subcategory name.

 

I think what was happening last night when I tried to move the snowflakes into the assets panel was that they were actually moving into the panel but because it was late and dark I couldn't see them in the assets panel. The color of the snowflakes is white against a white background so it looked as though nothing was there. This morning when I tried it again, dragging the snowflakes worked. It worked whether or not I grouped each one first. The ones that I grouped came in with the name "Group" while the others came in with the name "Curve".  I see that I can now rename each snowflake with its own unique name if I wanted to.

 

 

Affinity Photo, V 1.9.1    Affinity Designer, V 1.9.1, Affinity Publisher, V 1.9.1

Mac Book Air, Big Sur 11.2.3

Link to comment
Share on other sites

20 minutes ago, DianeF said:

The ones that I grouped came in with the name "Group" while the others came in with the name "Curve".  I see that I can now rename each snowflake with its own unique name if I wanted to.

Asset names take on the name of the layer they come from. So if you have not named a layer prior to adding it to the Asset panel, it will default to the generic layer identifier, like Curve, Curves, or Group. If you named the layer prior to adding it, like say to "Snowflake 1," the asset will inherit that name.

All 3 1.10.6, & all 3 V2.03 Mac apps; 2020 iMac 27"; 3.8GHz i7, Radeon Pro 5700, 32GB RAM; macOS 10.15.7
Affinity Photo 
1.10.6; Affinity Designer 1.10.6; & all 3 V2 apps for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 15.7

Link to comment
Share on other sites

  • 4 months later...

I'm glad I found this thread!

I was getting quite frustrated trying to drag items into the Assets tab, having read in Help that I could add items by dragging.

Useful to know that it doesn't work in Windows.

Also useful to know that I can't rely on the Help file in AD for Windows, because (apparently) Serif just included the MAC version rather than making it Windows specific!

Considering that the only Assets included are for IOS10, I'm starting to feel like a "poor relation" compared to MAC users.

I can only assume that Serif aren't really that interested in their Windows customers! :(

Acer XC-895 : Core i5-10400 Hexa-core 2.90 GHz :  32GB RAM : Intel UHD Graphics 630 : Windows 10 Home
Affinity Publisher 2 : Affinity Photo 2 : Affinity Designer 2 : (latest release versions) on desktop and iPad

Link to comment
Share on other sites

1 hour ago, PaulEC said:

Also useful to know that I can't rely on the Help file in AD for Windows, because (apparently) Serif just included the MAC version rather than making it Windows specific!

Considering that the only Assets included are for IOS10, I'm starting to feel like a "poor relation" compared to MAC users.

 

Since iOS is a mobile operating system for iPad and iPhone, it’s no more Mac-related than Windows-related (and anyway it’s now at version 11, so those assets may be out of date). But there are indeed a number of places where Mac-specific references have been left in the Help files for the Windows versions of the Affinity apps.

Alfred spacer.png
Affinity Designer/Photo/Publisher 2 for Windows • Windows 10 Home/Pro
Affinity Designer/Photo/Publisher 2 for iPad • iPadOS 15.7.3 (iPad Air 2)

Link to comment
Share on other sites

2 hours ago, PaulEC said:

I can only assume that Serif aren't really that interested in their Windows customers! :(

Or just that they are normal humans & missed a few things?

All 3 1.10.6, & all 3 V2.03 Mac apps; 2020 iMac 27"; 3.8GHz i7, Radeon Pro 5700, 32GB RAM; macOS 10.15.7
Affinity Photo 
1.10.6; Affinity Designer 1.10.6; & all 3 V2 apps for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 15.7

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.