Jump to content

Adding anchor points on curve


Recommended Posts

  • 5 months later...

Sorry, MEB, I had the same question as Paige, but that answer isn't working for me.

 

When I select the node tool, it doesn't matter where on a curve I click or hover; the curve never becomes selectable in any way, and I'm unable to create a node.

 

When I *have* selected the curve first, the node tool becomes a transform tool; clicking a curve then just distorts it, but doesn't add a node.

 

I've tried various permutations of things with both the node and pen tools, but am entirely unable to add new nodes to a curve.

 

Designer v. 1.2. Am I missing something blindingly obvious?

Link to comment
Share on other sites

  • Moderators

Hi warrenao,

Welcome to Affinity Forums :)

If your object is a shape or text (i.e. created with the shapes or with the text tools) you have first to converted it to curves as @joost suggested.

With the object selected go to the context toolbar (right above the work area) an press Convert to Curves button (it's available from the Move, Node and Text tools context toolbar).

Link to comment
Share on other sites

Thanks for the replies, but hmm.
 
I drew the shape originally in the 'Draw' persona, using the pen tool, which leads me to believe it began life as curves. I have been able to edit the stroke thickness, which further leads me to conclude that it began life as a curve, not as bitmap art.
 
Hitting cmd+rtn doesn't show any visual difference.
 
Trying to add an anchor point afterward, using the node tool, still doesn't permit me to do anything but warp the selected curve segment. I can't add any anchor points.
 
Screenshot attached in case seeing the UI's behavior will in any way help. (Note that the node tool doesn't appear in this screenshot, argh, but it's there, along with a little wavy line alongside the cursor that seems to suggest 'warp', since that's what happens when I click the selected segment.)

 

post-11323-0-00748200-1431896562_thumb.png

Edited by warrenao
Link to comment
Share on other sites

Hmm. That's what I've been doing. It appears that only after I've clicked the path several times am I able to somehow hit the right 'butter zone' to make the node appear. The rest of the time, I just end up distorting the curve, not adding nodes to it.

 

Is there any chance of making a ctrl-click or right-click option available that sort of 'forces' the node tool to actually create a node on the first try?

Link to comment
Share on other sites

  • Moderators

Are you using a Wacom or any other tablet (or even the Apple's Magic Mouse)? I think what's happening here is that you are inadvertently moving (dragging) the cursor while clicking on the path (even if sligthly), adjusting it instead of adding a node. Make sure the cursor doesn't move and click to create a node. Let me know if you still have trouble.

Link to comment
Share on other sites

  • 4 years later...

Hello,

Same here. I'm using a Surface Pro 4 tablet. There's no way I can add anchor points when using the tablet pen. It works adding points with the mouse but not with the pen.

Initially I thought it happened because I had no stroke. I added a stroke but it's the same, I can only add points with the mouse.

Thanks a lot for your answer!

Link to comment
Share on other sites

  • Moderators

Hi VRGheba,
Welcome to Affinity Forums :)
This is a known issue we are looking into. Unfortunately there's no workaround at the moment other than using a mouse, 
sorry. I've bumped the existing report to bring it up to devs attention again.

@chillywilson, If you are using a Surface device see my reply above. If you are using an external table (Wacom etc) turn off 'Use Windows Ink for Tablet Input' in Preferences and it should work correctly until we fix this.

Link to comment
Share on other sites

1 hour ago, MEB said:

Hi VRGheba,
Welcome to Affinity Forums :)
This is a known issue we are looking into. Unfortunately there's no workaround at the moment other than using a mouse, 
sorry. I've bumped the existing report to bring it up to devs attention again.

@chillywilson, If you are using a Surface device see my reply above. If you are using an external table (Wacom etc) turn off 'Use Windows Ink for Tablet Input' in Preferences and it should work correctly until we fix this.

Hey @MEB

I'm using a Huion GT-126hd draw on screen. 

I would assume the trick to this would be to put a click range on the add point area because pressure clicks are getting in the way. 

Link to comment
Share on other sites

  • 5 months later...

I thought I experienced the same issue; being able to select and move nodes, but not being able to add nodes to a curve. After 1 million clicks I found out that the curve I was trying to select was NOT CLOSED, which is kind of hard to see (no thin blue line, no double handles on the nodes). After closing the curve I was able to add nodes to the segment. Hope this helps!

Link to comment
Share on other sites

  • 6 months later...

I just had a similar issue after tinker around with the stroke settings.  It's seems it's pretty easy to change the path alignment of a line from the center to the outside.  Then when you intuitively click on the center of the line, you miss the path.  It's worth checking if anyone else has experienced this problem.

Link to comment
Share on other sites

  • 1 month later...

I have been experiencing something similar. I was working with the Desktop version + mouse, however I wanted to add an anchor with the node tool on a circle shape drawn with the ellipse tool. None of the above mentioned worked for me, unfortunately. I'd be happy about any pointers. Thanks!

Link to comment
Share on other sites

On 6/11/2021 at 9:33 AM, Jamie_ said:

however I wanted to add an anchor with the node tool on a circle shape drawn with the ellipse tool. None of the above mentioned worked for me...

If by anchor you mean node, you have to convert quick shapes like ellipses to curves first. Do this with the ellipse selected by clicking the Convert to Curves button on the context toolbar or using the same-named item on the Layer menu.

Affinity Photo 1.10.5, Affinity Designer 1.10.5, Affinity Publisher 1.10.5;  2020 iMac 27"; 3.8GHz i7, Radeon Pro 5700, 32GB RAM; macOS 10.15.7
Affinity Photo 
1.10.5.280 & Affinity Designer 1.10.5 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 15.7

Link to comment
Share on other sites

  • 1 month later...

This is what I want to do:

  1. Select the Ellipse tool
  2. Draw a circle
  3. With the pen tool, click on a curve between two anchor points
  4. Then be able to edit or delete that path by that anchor point

Selecting the node tool instead of the pen tool is a hurdle. Having to convert the circle to a curve first is another hurdle.

Every time I get back into Affinity Designer with a positive attitude I just get disappointed with how awful the UI and UX is for modifying objects and drawing paths! Please take cues from that big monopoly (which name we shall not speak)!

Link to comment
Share on other sites

20 minutes ago, DesignByAdrian said:

Selecting the node tool instead of the pen tool is a hurdle.

It’s hardly a major hurdle, given that you can switch back and forth with a single shortcut key.

21 minutes ago, DesignByAdrian said:

Having to convert the circle to a curve first is another hurdle.

The Ellipse Tool creates a parametric shape. If that isn’t what you want, you can draw an elliptical curve with the Pen Tool.

Alfred spacer.png
Affinity Designer/Photo/Publisher for Windows 1.10 • Windows 10 Home/Pro
Affinity Photo for iPad 1.10 • Designer for iPad 1.10 • iPadOS 15.6.1 (iPad Air 2)

Link to comment
Share on other sites

  • Moderators

Hi @DesignByAdrian,
Welcome to affinity Forums :)
Here's how it's done in Affinity. It's not the same but it's not much complicated either. You do not have to create a node to delete a segment (notice the modifiers being pressed).
In this particular case there's an additional step involved (pressing cmd + Enter) to convert the ellipse to a path. For regular paths created with the Pen Tool that's not necessary - simply switch to the Node Tool, press CTRL and click the segments you want to delete. Note you can do this from the Pen Tool directly too: with the Pen Tool selected, press and hold cmd (to switch temporarily to the Node Tool) and press simultaneously ctrl while clicking on the segments to delete them.

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.