Jump to content
You must now use your email address to sign in [click for more info] ×

Brush icon no longer shows in Layers panel for Beta 1736


Recommended Posts

In both Photo and Designer Beta 1736, the little brush icon no longer appears.  Example screenshots of Photo 2.0.3 and Photo Beta 1736 below.  

Photo 2.0.3:

810346463_Screenshot2023-03-30at13_36_54.png.f6998f8fd5b7d07c64715b4ea10f9a75.png

Photo Beta 1736:

1030302011_Screenshot2023-03-30at13_16_49.png.5f30e10a3bbb63e2501c130eea4f0d43.png


24" iMAC Apple M1 chip, 8-core CPU, 8-core GPU, 16 GB unified memory, 1 TB SSD storage, Ventura 13.6.  Photo, Publisher, Designer 1.10.5, and 2.2.0.
MacBook Pro 13" 2020, Apple M1 chip, 16GB unified memory, 256GB  SSD storage
,  Ventura 13.6.   Publisher, Photo, Designer 1.10.5, and 2.1.1.  
 iPad Pro 12.9 2020 (4th Gen. IOS 16.6.1); Apple pencil.  
Wired and bluetooth mice and keyboards.9_9

Link to comment
Share on other sites

Seems to be working as expected in Monterey so unsure if it's OS version specific... :)

Affinity Designer 2.2.0 | Affinity Photo 2.2.0 | Affinity Publisher 2.2.0
Affinity Designer 1.7.3 | Affinity Photo 1.7.3 | Affinity Publisher 1.10.6
MacBook Pro 16GB, macOS Monterey 12.6.8

Link to comment
Share on other sites

46 minutes ago, jmwellborn said:

Beta 1736, the little brush icon no longer appears

You also seem to be missing the Dot for visibility in the beta 1736. I guess due to the width of the Layers panel. That seems to be a known bug. 

Works fine here with the betas 1736 on Mac OS 11.7

Mac Pro (Late 2013) Mac OS 12.7 
Affinity Designer 2.2.0 | Affinity Photo 2.2.0 | Affinity Publisher 2.2.0 | Beta versions as they appear.

I have never mastered color management, period, so I cannot help with that.

Link to comment
Share on other sites

51 minutes ago, Hangman said:

Seems to be working as expected in Monterey so unsure if it's OS version specific... :)

Except that @Old Bruce is also using MAC OS 11.7.  I am on v. 11.7.4.  Just updated my signature.


24" iMAC Apple M1 chip, 8-core CPU, 8-core GPU, 16 GB unified memory, 1 TB SSD storage, Ventura 13.6.  Photo, Publisher, Designer 1.10.5, and 2.2.0.
MacBook Pro 13" 2020, Apple M1 chip, 16GB unified memory, 256GB  SSD storage
,  Ventura 13.6.   Publisher, Photo, Designer 1.10.5, and 2.1.1.  
 iPad Pro 12.9 2020 (4th Gen. IOS 16.6.1); Apple pencil.  
Wired and bluetooth mice and keyboards.9_9

Link to comment
Share on other sites

@jmwellborn, have you tried a factory reset for .1736?

Affinity Designer 2.2.0 | Affinity Photo 2.2.0 | Affinity Publisher 2.2.0
Affinity Designer 1.7.3 | Affinity Photo 1.7.3 | Affinity Publisher 1.10.6
MacBook Pro 16GB, macOS Monterey 12.6.8

Link to comment
Share on other sites

  • Staff

Hi jmwellborn,

This is a direct result of the issue Old Bruce has mentioned above whereby the items at the end of each layer go missing when the Layers Panel is too wide. A simple rescale of the Layers Panel width to be smaller will bring them back.

Link to comment
Share on other sites

7 hours ago, Sean P said:

Hi jmwellborn,

This is a direct result of the issue Old Bruce has mentioned above whereby the items at the end of each layer go missing when the Layers Panel is too wide. A simple rescale of the Layers Panel width to be smaller will bring them back.

It is quite erratic.  If I drag the layers panel back to the smaller width and then out again, the brush icons show.  And having done that once, I can then open a new document with my Preset already at a wider panel width, and the icons do show.  Both Designer and Photo.  Definitely a bug.  


24" iMAC Apple M1 chip, 8-core CPU, 8-core GPU, 16 GB unified memory, 1 TB SSD storage, Ventura 13.6.  Photo, Publisher, Designer 1.10.5, and 2.2.0.
MacBook Pro 13" 2020, Apple M1 chip, 16GB unified memory, 256GB  SSD storage
,  Ventura 13.6.   Publisher, Photo, Designer 1.10.5, and 2.1.1.  
 iPad Pro 12.9 2020 (4th Gen. IOS 16.6.1); Apple pencil.  
Wired and bluetooth mice and keyboards.9_9

Link to comment
Share on other sites

Not an issue on Windows.

Affinity Photo 2.1.1.; Affinity Designer 2.1.1.; Affinity Publisher 2.1.1.; Affinity2 Beta versions. Affinity Photo,Designer 1.10.6.1605 Win10 Home Version:21H2, Build: 19044.1766: Intel(R) Core(TM) i7-5820K CPU @ 3.30GHz, 3301 Mhz, 6 Core(s), 12 Logical Processor(s);32GB Ram, Nvidia GTX 3070, 3-Internal HDD (1 Crucial MX5000 1TB, 1-Crucial MX5000 500GB, 1-WD 1 TB), 4 External HDD

Link to comment
Share on other sites

  • Staff

The issue "Layer Visibility toggles won't show if you make the Layers Panel wider" (REF: AFP-5740) has been fixed by the developers in internal build "2.1.0.1742".
This fix should soon be available as a customer beta and is planned for inclusion in the next customer release.
Customer beta builds are announced here and you can participate by following these instructions.
If you still experience this problem once you are using that build version (or later) please reply to this thread including @Serif Info Bot to notify us.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.