Jump to content

M1 / Mac Monterey - Affinity Photo etc now has the wheel of death quite a lot


Recommended Posts

Affinity Photo was fairly fast before Monterey on my M1, now it takes a lot longer to start up as well as the spinning wheel quite often appearing now, quite a few tasks without any real heavy load and the spinning wheel appears. Not unusable but just not great. When I first got my M1, Affinity Photo native was super fast ... now it is not in such a great state.  Perhaps some caches etc need to be cleared or something ?? A fresh start or install ?

Link to comment
Share on other sites

  • Moderators

@Andrew Buckle thanks for your post, the general lagginess and delay is due to something macOS Monterey has introduced that impacts the way we load certain UI elements. Do you have the Channels panel visible in the bottom right? If so, try switching to another panel such as Navigator and you should find that some of the hitching and lagginess disappears. Unfortunately, startup time will be impacted, and opening certain dialogs (e.g. Crop Tool presets, Fill and Stroke colour dialogs, macro libraries) will have a delay.

We are trying to work towards a resolution by communicating this with Apple—apologies that we don't have more news at this point.

Product Expert (Affinity Photo) & Product Expert Team Leader

@JamesR_Affinity for tutorial sneak peeks and more

Link to comment
Share on other sites

Will try that. Is there a quick way to close all the panels in one go ?? (I would love to see that feature as at the moment I have to go around closing each panel in turn). 

I have just closed all the panels and restarted AP, the spinning did initially appear and then I displayed the navigator panel and now I don't get it (not so far) so it seems to appear to be panel related. 

Thank you for the response, hopefully that resolves it for now. On the M1 it has been very fast (though startup is a little slower now) but after the change to Monterey this did become an issue for me, especially doing video tutorials where I had to abandon the recordings

Link to comment
Share on other sites

2 hours ago, Andrew Buckle said:

Will try that. Is there a quick way to close all the panels in one go ?? (I would love to see that feature as at the moment I have to go around closing each panel in turn). 

Perhaps View > Studio > Hide Studio? The default shortcut on Windows is Ctrl+Shift+H. Probably Cmd+Shift+H on Mac, but the menu will show you.

-- Walt

   Desktop: new:  Windows 11 Home, version 21H2 (22000.613) 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090  (old: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970 )
   Laptop:  Windows 10 Home, version 21H2 (19044.1706) 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
    Affinity Photo 1.10.5 (.1342) and 1.10.5.1342 Beta   / Affinity Designer 1.10.5 (.1342) and 1.10.5.1342 Beta  / Affinity Publisher 1.10.5 (.1342) and 1.10.5.1282 Beta
 iPad Pro M1, 12.9", iPadOS 15.6.1, Apple Pencil 2, Magic Keyboard

  Affinity Photo 1.10.5 (.280) and 1.10.2 (.266) Beta / Affinity Designer 1.10.5 (.21) and 1.10.3 (.19) Beta 

Link to comment
Share on other sites

1 hour ago, wezlo said:

The color picker delay is VERY frustrating. I'm sorry Monterey is triggering this for you all, I hope you're able to fix it without much trouble.

Have you tried the 1.10.5 beta for Photo, which is supposed to fix this problem on Monterey?

-- Walt

   Desktop: new:  Windows 11 Home, version 21H2 (22000.613) 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090  (old: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970 )
   Laptop:  Windows 10 Home, version 21H2 (19044.1706) 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
    Affinity Photo 1.10.5 (.1342) and 1.10.5.1342 Beta   / Affinity Designer 1.10.5 (.1342) and 1.10.5.1342 Beta  / Affinity Publisher 1.10.5 (.1342) and 1.10.5.1282 Beta
 iPad Pro M1, 12.9", iPadOS 15.6.1, Apple Pencil 2, Magic Keyboard

  Affinity Photo 1.10.5 (.280) and 1.10.2 (.266) Beta / Affinity Designer 1.10.5 (.21) and 1.10.3 (.19) Beta 

Link to comment
Share on other sites

No, the colour picker is truly rubbish at the moment with monterey with the Beta 1.10.5 ... click it, it may respond, it may respond 5 minutes later, double click multiple times and no response ... it has to be said, changing the color via the fill / stroke fields in Affinity Photo is awful at times. Sometimes it is too responsive, sometimes it closes before you can even think, sometimes it just ignores you for ages and ages. I often just go off and have a coffee and then come back maybe time find the colour picker there.  Not sure what the issue is but it is really unworkable. I often just use the swatches panel but that can be equally frustrating as the color picker often just fills the stroke when I want it to fill the fill and vica versa ... not a happy experience with it

Link to comment
Share on other sites

same here. I'm testing a new MacBookPro 16 M1Pro 16/16/1Tb on Monterey 12.0.1 and at first I thought it was a problem with my file server but I've made a comparison with my actual MacBookProRetina late2013 under osx Mojave 10.14.6 and my "old" computer with an Affinity Publisher file is faster on rendering. I don't know if I have to laugh yet but… well I have a month and a half to test this computer and I really hope this kind of nasty bugs will be resolved either within the Affinity apps and/or within osx Monterey. Did anyone tried 12.1beta?

Link to comment
Share on other sites

Sadly, the fault now seems to be extending itself onto the Affinity Photo Beta 

1.10.5.270

Get the spinning wheel for layers and quite a bit for the Affinity Photo Beta, seems to kick in when you create a lot of layers in Affinity Photo on the M1 Monterey. Making the beta nearly unusable as well so probably be back doing video tutorials on Photoshop etc soon enough or Affinity Designer until this is fixed. 

Is there a way to clear the Affinity Photo Beta data files, perhaps tons of junk in that. Likewise, always get the restore the recovery file option 50% of the time even after I have closed the files. Sometimes useful, sometimes just plain odd. 

 

Andrew

Link to comment
Share on other sites

On 11/18/2021 at 10:00 AM, nicolasbulb said:

same here. I'm testing a new MacBookPro 16 M1Pro 16/16/1Tb on Monterey 12.0.1 and at first I thought it was a problem with my file server but I've made a comparison with my actual MacBookProRetina late2013 under osx Mojave 10.14.6 and my "old" computer with an Affinity Publisher file is faster on rendering. I don't know if I have to laugh yet but… well I have a month and a half to test this computer and I really hope this kind of nasty bugs will be resolved either within the Affinity apps and/or within osx Monterey. Did anyone tried 12.1beta?

Yes, worked fine for a while but now have the same problem with the beta as well. Really needs to be fixed as it makes the app totally hopeless to use. 

Link to comment
Share on other sites

  • Moderators
On 11/25/2021 at 12:29 PM, Andrew Buckle said:

Yes, worked fine for a while but now have the same problem with the beta as well. Really needs to be fixed as it makes the app totally hopeless to use. 

The latest beta build tried to improve the lag issue on macOS Monterey but our developers have stated that they're waiting on Apple to fix the underlying issue, which is currently out of our control, sorry.

Link to comment
Share on other sites

  • 3 weeks later...
  • Moderators
On 12/28/2021 at 12:33 PM, Kiandra said:

Same sitiation with Affinity Designer. Even if I somply ned to fill ashape with colour the app goes into wheel of death for a solid 15 mins.

 

Mac 12.1

 

Does it also happen with the latest beta too?

 

Link to comment
Share on other sites

Sadly, Affinity Photo Beta as well as Affinity Photo are really hard to use on M1 Monterey, now seem to get the spinning wheel intermittently.  Some days I don't see the spinning wheel and then other days when I am using the beta or the standard app, it appears all the time doing minor actions such as changing a stroke dash line style etc making the app virtually impossible to use. Not totally unusable but it will be great to see this fixed as it does cause a lot of drag in using the application

Link to comment
Share on other sites

  • Moderators
On 1/6/2022 at 11:25 AM, Andrew Buckle said:

Sadly, Affinity Photo Beta as well as Affinity Photo are really hard to use on M1 Monterey, now seem to get the spinning wheel intermittently.  Some days I don't see the spinning wheel and then other days when I am using the beta or the standard app, it appears all the time doing minor actions such as changing a stroke dash line style etc making the app virtually impossible to use. Not totally unusable but it will be great to see this fixed as it does cause a lot of drag in using the application

I'm sorry to learn that the beta made no difference. I use a MacBook Air M1 and haven't encountered similar issues but can you try the two suggestions from this post to see if that improves things:

Link to comment
Share on other sites

  • 2 months later...

Disabling the Metal preference seems to be a workaround for the frequent spinning pinwheel problem. It was becoming severe enough to render Affinity Photo almost unusable. I don't think it was this bad when I first installed it on this computer. I think the problem became noticeable after one or more macOS updates.

Hopefully the developers are still working on this issue.

Affinity Photo 1.10.5, Mac OS 12.3.1, MacBook Pro M1 Max.

 

Metal disabled.png

Edited by Dean C
Link to comment
Share on other sites

I wish we could hear something from Affinity on this. Even with Metal compute turned off, I'm still having a lot of freezes -- way worse than Affinity is on an older Intel Mac, despite the system generally running way faster. I love Affinity Photo, but I almost feel like I need to set it aside for now this has gotten so bad. I'd gladly see a paid upgrade for a fix, if the problem is Affinity isn't getting any upgrade revenue...

Link to comment
Share on other sites

  • Moderators

Pretty sure our developers are using the latest Macbooks with the M1 Max chips and i use a Macbook Air M1 and haven't noticed any issues. We're not aware of any specific issues but another user reported a similar issue but it resolved itself. Can you provide more information on this issue or a screen recording? I can then look into this further.

 

Link to comment
Share on other sites

  • Moderators

I have a bit of an update on this issue. If you're using Affinity Photo on a M1/M1 Pro/M1 Max Macbook/iMac or using a display that supports Extended Dynamic Range, can you try re-enabling Metal from Preferences > Performance from within the app and turn off Automatic Brightness in System Preferences > Displays and see if this stops the app from lagging/beach balling when in use.

Let me know how you get on :)

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.