Jump to content
AdamW

Affinity Publisher Public Beta - 1.7.0.257

Recommended Posts

Please Click here to download the latest beta for Windows

Status: Public Beta
Purpose: Stability and General Testing
Requirements: 64 Bit Win 7 SP1 / Win 8.1 / Win 10  (>=1607)

Hi,

We are pleased to announce Affinity Publisher build 257 is now available as a manual download from the link above and on auto-update.

As this is a beta it is considered to be not suitable for production use. This means that you should not attempt to use it for commercial purposes or for any other activity where you may be adversely affected by the application failing, including the total loss of any documents. 

We hope you enjoy the product, and as always, if you've got any problems installing or running up, please don't hesitate to post in this thread.

Any problems actually using this version please make a new topic in this forum and we'll get back to you as soon as we can. Please feel free to leave general suggestions and comments in the Discussion Forum

Many thanks for your continued feedback.

---

Arrowheads!
We have Arrowheads for Line Styles from Designer. The best place to report any issues is probably the Designer Beta Forum.

Assets
We have removed the placeholder Assets from Publisher. Publisher will release with an empty Asset Panel.

.NET 4.7.2 (Windows)
Due to a compiler update we now have a dependency on .NET 4.7.2. The installer has been updated to install this version of the framework.
This means that the system requirements have changed slightly and we will no longer install on Windows 8.0 (!) or early unpatched versions (< 1607) of Windows 10.

Other Improvements and Fixes

Main Frame UI
No more duplicate empty panels (!)
Option for large thumbnails in Layers Panel. Layer colour tagging added
Column guide default options are now saved
Adding content with linked images to Assets will switch them to be embedded
Reintroduced Rotate View on context menus
Added command entry on Text Styles combos to create a new style
(Mac) Fixed overlay issue when entering font name into Text context toolbar font control
(Mac) Fixed crash using arrow keys in Pages Navigator on High Sierra and earlier
(Mac) Toggle Unicode shortcut is listed only under Text Menu
(Mac) Find and Replace panel icons missing from Panel on El Capitan and earlier
(Mac) Line Break shortcut is <Shift>-<Enter>

Pages / Master Pages
No longer draw guides from hidden masters
Fixed scroll into view in Pages panel
Fixed crash when pasting a Master into itself
Fixed crash moving items in Z-order having done detached edits

Text
Fixed application of Text Wrap borders (!)
Placing text with a frame selected now populates the frame and replaces the current content
Fix for positioning of path text
Formatting a specific text selection no longer updates text defaults. Formatting at the insertion point still does
Text tool selection improvements. <Alt>-<Click> forces select in front / behind
Long / nested style names in the Text Style panel are now displayed with elllipsis if necessary rather than shrinking
Fixed crash reading text attributes near Drop Caps
Fix for Character Variants for some fonts failing to show up in Typography panel
Fix for erroneous spell check warnings when languages switch within text
Paragraph Leading control not using localised decimal separator
OpenType - Accept newer versions of GSUB / GPOS tables. Used by e.g. Bahnschrift
(Mac) Fixed underline position for e.g. Univers Ultracondensed
(Win) Fixed issues with the Paragraph Decoration dashed stroke UI

Tables 
<Ctrl>-A / <Cmd>-A now selects all text in a cell rather than all cells in text context
Fixes for Table Tool when Table is nested inside layers etc
Fixed issue setting Table Cell insets
(Mac) Fixed glitch changing Table Format names

Find and Replace
Replaced character escapes in Find results with 'User Description' glyphs
RegEx fix for Find with trailing '\b', '\>' not highlighting results and Replace not working
RegEx fix for Replace All for empty search ranges 
RegEx fix for lookaround (?=regex) etc

Hyperlinks
File based Hyperlinks now have an option to copy the linked file to the output folder
Insert Anchor fails on text frames promoted from Master Page
Add Interactive > Insert Hyperlink to customisable keyboard shortcuts

Import / Export / Print
PDF Import - Fix for layers not importing
PDF Import - Improved detection of redundant clips
PDF Export - Use document colour space for transparency blending
Export - Fixed issue rendering image nodes with transparent regions with fills applied on raster export
Export - 'Pages' entry box isn't always enabled correctly
(Win) Fix for CMYK Printer Profiles not showing in Print dialog
(Win) Stroke width being printed incorrectly on rotated objects

Index
Sort index entries by page number

---

Earlier Release Notes Beta 249

Share this post


Link to post
Share on other sites
16 minutes ago, Arun Sarkar said:

So I can't install it on Win 8.1 any more?

It is supported on 8.1 as far as I found on the web.


My computer is a nothing-special Toshiba laptop with unremarkable specs running Windows 10 64-bit.

Share this post


Link to post
Share on other sites
16 minutes ago, MikeW said:

It is supported on 8.1 as far as I found on the web.

Was that for this beta, or for 1.6?


-- Walt

Windows 10 Home, version 1903 (18362.145), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.0.367 and 1.7.1.390 Beta   / Affinity Designer 1.7.0.367 and 1.7.1.390 Beta  / Affinity Publisher 1.7.0.384 Beta

Share this post


Link to post
Share on other sites
11 minutes ago, MikeW said:

Thanks. My confusion was what you meant by "it" is supported. I though you meant Affinity, not .net 4.7.2.


-- Walt

Windows 10 Home, version 1903 (18362.145), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.0.367 and 1.7.1.390 Beta   / Affinity Designer 1.7.0.367 and 1.7.1.390 Beta  / Affinity Publisher 1.7.0.384 Beta

Share this post


Link to post
Share on other sites

HI, im trying to install version 2579 and says win7 sp1 or later not found, these are the screenshots:

image.png.a689a287f1a8608dad43439423ec394c.png

This is my win10 version

image.png.3b242c7c0b3fc38e6007385c5d425b29.png

Share this post


Link to post
Share on other sites

Pacho,

Welcome to the Serif Affinity forums :)

6 hours ago, Pacho said:

This is my win10 version

From the opening post in this thread...

On 3/8/2019 at 10:18 AM, AdamW said:

.NET 4.7.2 (Windows)
Due to a compiler update we now have a dependency on .NET 4.7.2. The installer has been updated to install this version of the framework.
This means that the system requirements have changed slightly and we will no longer install on Windows 8.0 (!) or early unpatched versions (< 1607) of Windows 10.

So the error message (new to this build) is insufficient in that it doesn't mention Windows 10, but the reason for the failure is that you cannot install Affinity Windows 1.7 software on your unpatched Windows 10. You need to install Windows updates before the software will install.


Patrick Connor

Serif (Europe) Ltd.

Share this post


Link to post
Share on other sites

@Pacho,

This is a combination of 3 things.

  1. The latest installer has changed the system requirements, and the English installer says that "Your version of Windows does not meet system requirements "(and not the string you are seeing).
  2. The localisation of the new English string has not yet caught up, so you are ssing an outdated Windows 7.1 string
  3. The link at the bottom of that dialog points to the Windows Installer FAQ, which currently reflects the requirements purchased version (1.6.x) and when 1.7 is sold will be updated to mention the versions of Windows 10 that are additionally required.

Patrick Connor

Serif (Europe) Ltd.

Share this post


Link to post
Share on other sites

when attempting to update my beta to .2579 - i cant install. I just get the message "setup failed".

 

4.7.2 .net is installed.

Share this post


Link to post
Share on other sites

update install failed. I've found a work around and possible issue. here is what I tried and it did not fix my issue.

1) Moved the installer to the same drive.
2) I am fully updated
3) no other .net frameworks
4) ran as admin
5) restarted computer

 

next I tried to check the log files for the install - but the folder 'Publisher Public Beta' was inaccessible. Said I didnt have the right permissions - however I was in powershell as Admin and the folder's size was 0. I re-ran the install and changed the folder name for the installation to 'Publisher Public Beta 2' .. and it worked.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×