Jump to content

Selected text NOT highlighting (AD)


Recommended Posts

I type out text using the Artistic Text or Text Frame tools, then double (or triple) click and proceed to highlight the text that I want to make adjustments to. The only problem is, I can't see what I've selected because the text doesn't become highlighted! I could still make edits, but it takes alot more time if I am moving quickly and don't put my cursor where I think it should be.

Any help?

Screenshot 2018-03-27 20.51.51.png

Affinity Designer 1.6.1, Mac 10.13.3

Link to comment
Share on other sites

Hard to say more unless you say what program or what operating system you are using but it works for me. Dragging to select, double clicking or triple clicking. Photo on Windows.

STEP.jpg.42de2a67de9d7849eabeeb26d301abfb.jpg

Windows PCs. Photo and Designer, latest non-beta versions.

Link to comment
Share on other sites

I also use Affinity Designer 1.6.1 & macOS 10.13.3. I do not have any problems highlighting text. One reason you might is because you have installed some third party 'enhancement' software that affects text entry, copy & paste, the clipboard, or anything that might intercept user input before passing it on to an app. Though not common, it is possible for this kind of software to conflict with only one or a few apps, so even if no other app is affected you can't be 100% certain that it is not causing this issue with Affinity Designer.

 

Do you have anything like that installed on your Mac? If so, is it the latest version & known to be compatible with High Sierra?

Affinity Photo 1.10.5, Affinity Designer 1.10.5, Affinity Publisher 1.10.5;  2020 iMac 27"; 3.8GHz i7, Radeon Pro 5700, 32GB RAM; macOS 10.15.7
Affinity Photo 
1.10.5.280 & Affinity Designer 1.10.5 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 15.0.2

Link to comment
Share on other sites

3 minutes ago, R C-R said:

Do you have anything like that installed on your Mac? If so, is it the latest version & known to be compatible with High Sierra?

I actually do have something like that its called Flycut however I quit the application, restarted AD and the problem still persists :(

Link to comment
Share on other sites

You may also want to check if it is possibly affected by the used font style/type, try the same with some other common font and see if the problem then still persists too.

☛ Affinity Designer 1.10.5 ◆ Affinity Photo 1.10.5 ◆ OSX El Capitan

Link to comment
Share on other sites

32 minutes ago, modiophile said:

I actually do have something like that its called Flycut however I quit the application, restarted AD and the problem still persists :(

I am not familiar with Flycut so I am just guessing, but it is possible that quitting it leaves some daemon or background 'helper' running. Activity Monitor might show if that is true or not but I don't know what to look for so unfortunately you are on your own with that.

 

I also did a very brief web search which did not turn up much other than a user comment that the Mac App Store version has not been updated in a long time & might cause problems, but I do not know how reliable that info really is.

 

It is a long shot, but maybe just quitting the app & restarting your Mac might help, as long as it does not restart automatically when you log into your user account.

 

Sorry I cannot be of more help. :(

Affinity Photo 1.10.5, Affinity Designer 1.10.5, Affinity Publisher 1.10.5;  2020 iMac 27"; 3.8GHz i7, Radeon Pro 5700, 32GB RAM; macOS 10.15.7
Affinity Photo 
1.10.5.280 & Affinity Designer 1.10.5 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 15.0.2

Link to comment
Share on other sites

  • 9 months later...
On 4/3/2018 at 4:16 AM, solarDog said:

This seems to correspond with certain fonts. I was having the same issue with Gotham. Switched to another font and it worked.

What could be causing that to happen?

Screen Shot 2018-04-02 at 2.14.25 PM.png

Screen Shot 2018-04-02 at 2.14.40 PM.png

This is a really unusual bug. I'm having the same problem when using Gotham as a typeface. Any solutions?

Designer 1.6.5 on Mac OS 10.14.2

 

Link to comment
Share on other sites

I can select Gotham

753461624_ScreenShot2019-01-24at07_47_54.png.37c9ea459766e440b98880b424f2aee3.png

iMac 27" Late 2019 Fully Loaded, iMac 27" Late 2013 both running Catalina 10.15.7 - Affinity Designer, Photo & Publisher, Adobe, Inkscape, Blender, C4D, Sketchup, Pepakura Designer + more... XP-Pen Artist-22E, - iPad Pro 12.9 B|  

Affinity Help - Affinity Desktop Tutorials - Feedback - FAQ - most asked questions

Link to comment
Share on other sites

  • 2 months later...
  • 1 month later...
  • 1 month later...

same basic problem: can't see text selection highlight. But with this unusual twist:

If I zoom out, I can eventually see the selection. Thankfully the text is still legible. Font size has no effect, it is solely tied to the zoom scale.

Link to comment
Share on other sites

There was a reported problem some time ago, with text that is outside an artboard. If you zoom in enough that no artboards are visible in the window, the text won't highlight when selected.

-- Walt

   Desktop: new:  Windows 11 Home, version 21H2 (22000.613) 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090  (old: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970 )
   Laptop:  Windows 10 Home, version 21H2 (19044.1706) 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
    Affinity Photo 1.10.5 (.1342) and 1.10.5.1342 Beta   / Affinity Designer 1.10.5 (.1342) and 1.10.5.1342 Beta  / Affinity Publisher 1.10.5 (.1342) and 1.10.5.1282 Beta
 iPad Pro M1, 12.9", iPadOS 15.4.1, Apple Pencil 2, Magic Keyboard

  Affinity Photo 1.10.5 (.280) and 1.10.2 (.266) Beta / Affinity Designer 1.10.5 (.21) and 1.10.3 (.19) Beta 

Link to comment
Share on other sites

  • 1 month later...

Definitely a weird behavior.

I had no problem highlighting text, and suddenly, I can't highlight any text in my file (opening a different tab, copy/paste text frame, I can select/highlight).

I kept clicking around in text, played a bit with some frames (making sure they were within bleed - they were), put the "Show bleed" off and back on… At some point it started working again, not sure which action solved it though.

Link to comment
Share on other sites

  • 8 months later...
  • 1 year later...

Mac OS Big Sur 10.2.2.

I'm having intermittent probs with text highlighting. If I highlight upwards from one page onto the previous page in a multi-page doc, the 1st page highlights, then the remaining text doesn't highlight onto the next page. But when I release the mouse button at the desired stopping point, the edit affects the text as though the highlight was complete.

I find that there is no problem highlighting small areas eg one or two words.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.