Jump to content

Recommended Posts

Hi

 

I'm new to Affinity, and have followed some tutorials. In one I had the luck to use the Inpaint tool - but now I can't make it work. I choose it, mark the spots, and everything is like in the tutorials, and like the first time - all thought now, nothing disappears. Whats am I doing wrong??

 

All the best,

Sidsel

Skærmbillede 2017-12-30 kl. 20.11.42.png

Skærmbillede 2017-12-30 kl. 20.12.27.png

Skærmbillede 2017-12-30 kl. 20.13.08.png

Share this post


Link to post
Share on other sites

Is the layer an image layer ?

im.png.f294dd42a66bcb0aa01420e70a1d5c13.png

 

It wont work on an image layer. You will have to Rasterize it first so it becomes a Pixel layer.

px.png.de6f466ccb58ff71c86c4a66a39485ba.png

 

Right click on the layer to convert.


Windows PCs. Photo and Designer, latest non-beta versions.

Share this post


Link to post
Share on other sites
6 minutes ago, Sidsel Galatius said:

The picture started out as a pixel layer

 

What have you done to it since then? Some operations such as rotation require that you rasterize the layer again afterwards in order for things like inpainting to work.


Alfred online2long.gif
Affinity Designer/Photo/Publisher 1.7.1.404 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.7.1.143 • Designer for iPad 1.7.1.1 • iOS 12.4 (iPad Air 2)

Share this post


Link to post
Share on other sites

Nothing, really. Actually the first I do now. The one time it did work, I had been playing with, light, colours, vignette, blur .... don't remember. Now I'm just fixated - it's the first thing I try. And then try other tools to see if they work. And they do....

Share this post


Link to post
Share on other sites

are all your channels editable? the pencil icon in the Channels panel below right should be active on all channels:

Capture.PNG.accc1c5ae719a88e5c7f46a318e281da.PNG

try ctrl+D or cmd+D to make sure you dont have a selection active.

try rasterizing the layer again, i've had some problems in the past where the layer was shown as a pixel layer but acted as an image layer

 

Share this post


Link to post
Share on other sites

Sounds obvious;-)

 

1.

can you impaint in other documents?

2.

Can you impaint when you jump in the history very far back, if necessary to the start???? If so, go to the last point where it worked and than check what you have done after this!


OSX 10.13.5  / iMac Retina 27" / AMD Radeon R9 M380 / Metall: on!

Share this post


Link to post
Share on other sites

Well, yes they are all editable....

 

About the one time it worked, I didn't save the document, but I tried to open the same picture, and others - still without the luck... Is it the format? I try edit a jpg....?!

Share this post


Link to post
Share on other sites

Woops  -this part of the answer, was for you :):
About the one time it worked, I didn't save the document, but I tried to open the same picture, and others - still without the luck... Is it the format? I try edit a jpg....?!

Share this post


Link to post
Share on other sites
1 minute ago, Sidsel Galatius said:

Woops  -this part of the answer, was for you :):

 

Who is "you"? It's impossible to tell unless you quote the post to which you're replying.

 


Alfred online2long.gif
Affinity Designer/Photo/Publisher 1.7.1.404 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.7.1.143 • Designer for iPad 1.7.1.1 • iOS 12.4 (iPad Air 2)

Share this post


Link to post
Share on other sites

I've just had a similar problem - the selection brush, which I've used countless times before, stopped working!  The Photo Beta was fine!  Starting the app with the <ctrl> key depressed sorted it out.


AP user, running Win10

Share this post


Link to post
Share on other sites
On 1.1.2018 at 3:48 PM, Sidsel Galatius said:

... Is it the format? I try edit a jpg....?!

Well, you have to rasterize this layer before the inpaint works. But didnt you say, you have already done????


OSX 10.13.5  / iMac Retina 27" / AMD Radeon R9 M380 / Metall: on!

Share this post


Link to post
Share on other sites

Yes.... Really weird it doesn't work, because I do all you say I should, and the tool works up to the point I've marked the wished-away item. The tool marks the item with this pink shadow and all... But, nothing disappears. I'm about to give up and love everything in the picture :)

Share this post


Link to post
Share on other sites

Thinking outside the box a bit here but check the brush and brush settings.

What type of image is this jpg, png, raw, tiff.

I've downloaded the image you have shown which is obviously a jpg and inpaint works fine

example1.jpg


iMac 27" Late 2015 Fully Loaded, iMac 27" Mid 2011 both running High Sierra 10.13.6 - Affinity Designer/Photo, Publisher Beta 1.7.0.140, Illustrator CC, Inkscape, Blender, Sketchup, Pepakura Designer, MTC, Pixelmator & Pixelmator Pro + more... XP-Pen Artist-22E, - iPad Pro 12.9 B|  

Affinity Help - Affinity Desktop Tutorials Instagram & Flickr - Affinity Live 19th June 2019

Share this post


Link to post
Share on other sites

The background is locked , maybe thats the problem

edit: that's not it just tested, Works on a locked background


intel core i5,  16GB 128Gb ssd win10 Pro Huion new 1060plus.

philips 272p 2560x1440px on intel HD2500 onboard graphics

Razer Tartarus Chroma

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×