Jump to content
You must now use your email address to sign in [click for more info] ×

Strange graphical glitches on zooming/panning and broken PNG/JPEG Exports


Recommended Posts

I have a M2 Macbook Air with 24GB Ram on the latest everything.

The project file is about 40mb and the png is about 32mb.

I'm working on a file but when I zoom or pan I get black rectangles appearing and disappearing all over random parts of the project.

When I export I get grey, missing, white and black rectangles breaking up the file.

e.g.

image.thumb.png.3943eb0d0a5d35532180bd3fd8aa572e.png

 

I haven't found a reason for this except that when I have layers with some degree of transparency and FX applied to them (i.e. plastic simulated material) it gets worse.

I've got to the point now where I can't continue as I can't save or export my assets.

Please help?

I'm happy to upload the project but I would need some assurance as it's work product and can't be used/shared etc.

Link to comment
Share on other sites

  • Staff

Hi GreenGirl,

Which OS version are you running?

Could you please try disabling Hardware Acceleration in Affinity Designer > options >  Performance and changing Display to OpenGL to see if this resolves the issue for you?

Lee

 

Link to comment
Share on other sites

10 hours ago, Lee_T said:

Could you please try disabling Hardware Acceleration

Usually turning off HA works to solve the strange squares and/or streaks.

Win11Pro/64gbRam/RTX3060Ti  +  Win10Home/32gbRam/GTX1050Ti + Win11Home/16gbRam/RTX3050


 

Link to comment
Share on other sites

5 hours ago, pruus said:

Have you try to restart your Mac? Are there other programs running in the background?

No... the thought of 'turning it off and on again' never occurred to me. /s (I'm not new to the planet.)

Safari, Preview - that's it. Even on a fresh reboot with nothing running it's a mess. 

Link to comment
Share on other sites

Getting some random rectangles while zooming can happen often, and normally does not impact export.

As export is impact, there is a risk that the actual file is damaged, leading to data loss during further edits. Make backup copies before / after every major edit.

Your document may have reached some (not clearly defined) limits of Designer 

Please activate the navigator panel, make it as big as practical (undocking) and include it in the screen recording. 
Depending on Navigator showing (damaged file) the rectangles or not (rendering issues), we can try to find a fix or workaround.

please try to copy/paste all layers into a fresh document of same setup ( size, color model etc).

Try to open in Affinity Photo.

Try save as copy.

Try to scale-down a copy of the file by at least factor 2 and check if every works ok then.

Do you use any of these:

  • Linked / embedded images or bitmap layers?
  • masks or adjustments
  • layer fx with blur
  • blend modes except normal / pass-through?
  • bitmap fills

?

Mac mini M1 A2348

LG34WK950U-W, calibrated to DCI-P3 with LG Calibration Studio / Spider 5

iPad Air Gen 5 (2022) A2589

Special interest into procedural texture filter, edit alpha channel, RGB/16 and RGB/32 color formats, stacking, finding root causes for misbehaving files, finding creative solutions for unsolvable tasks, finding bugs in Apps.

 

Link to comment
Share on other sites

  • Staff

@GreenGirl As @NotMyFault there may be something corrupted within the document. As it's a complex document it may be worth using split half theory to narrow down the offending item(s).

First I'd ensure you backup your project, then hide half the layers and export each half of the document separately, if only one half of the layers shows the issue, half those layers and repeat until you find the offending layer(s). 

Then check the layer for the list of potential issues @NotMyFault lists.

Lee

Link to comment
Share on other sites

23 hours ago, GreenGirl said:

Anything? I'm blocked. 

Uploading a copy of the file should quickly determine whether it is something in the file that is corrupt or your computer's settings, so we know where to concentrate efforts to resolve this

If you do not want to upload to the forum you can request a drop-box link from the moderators

To save time I am currently using an automated AI to reply to some posts on this forum. If any of "my" posts are wrong or appear to be total b*ll*cks they are the ones generated by the AI. If correct they were probably mine. I apologise for any mistakes made by my AI - I'm sure it will improve with time.

Link to comment
Share on other sites

12 hours ago, carl123 said:

Uploading a copy of the file should quickly determine whether it is something in the file that is corrupt or your computer's settings, so we know where to concentrate efforts to resolve this

If you do not want to upload to the forum you can request a drop-box link from the moderators

Funnily enough I did offer such a thing in my first or second post - no one from the dev team or mods has bothered to offer an email or drop box link or even engage with me to try and solve this. 

 

I don't know how else I can scream louder that I'm literally blocked and this is screwing up my work life!!!!!!

Link to comment
Share on other sites

13 hours ago, Lee_T said:

@GreenGirl As @NotMyFault there may be something corrupted within the document. As it's a complex document it may be worth using split half theory to narrow down the offending item(s).

First I'd ensure you backup your project, then hide half the layers and export each half of the document separately, if only one half of the layers shows the issue, half those layers and repeat until you find the offending layer(s). 

Then check the layer for the list of potential issues @NotMyFault lists.

Lee

I've tried hiding everything and only exporting layer by layer (obviously) as that is how it needs to be exported for the app. 

Doesn't work.

I can't reduce the resolution as it's designed and intended for the app to be at this resolution.

I tried copying each layer and pasting it into a new file and saving each layer and then recomposing the whole piece in a new file and it's STILL screwing up. 

I have tried it in pixel mode and in photo - doesn't work. 

I always have at least THREE copies of such a big, important piece of work being saved in 3 different drives. 

It happens with all of them. 

 

Link to comment
Share on other sites

On 7/16/2023 at 1:03 PM, NotMyFault said:

Getting some random rectangles while zooming can happen often, and normally does not impact export.

As export is impact, there is a risk that the actual file is damaged, leading to data loss during further edits. Make backup copies before / after every major edit.

Your document may have reached some (not clearly defined) limits of Designer 

Please activate the navigator panel, make it as big as practical (undocking) and include it in the screen recording. 
Depending on Navigator showing (damaged file) the rectangles or not (rendering issues), we can try to find a fix or workaround.

please try to copy/paste all layers into a fresh document of same setup ( size, color model etc).

Try to open in Affinity Photo.

Try save as copy.

Try to scale-down a copy of the file by at least factor 2 and check if every works ok then.

Do you use any of these:

  • Linked / embedded images or bitmap layers?
  • masks or adjustments
  • layer fx with blur
  • blend modes except normal / pass-through?
  • bitmap fills

?

 Already done most of that - see previous posts. 

  • Linked / embedded images or bitmap layers?

    No.

 

  • masks or adjustments

Yes but not on the layers that tend to cause the whole thing to break.

  • layer fx with blur

Layer FX - Of course - I need them.

NO blur

  • blend modes except normal / pass-through?

Yes, ADD and SCREEN on a few things.

  • bitmap fills

Nope.

Link to comment
Share on other sites

8 hours ago, Bryce said:

It doesn't do anything other than be annoying.

The OP clearly stated that it affects export in her case. 

Mac mini M1 A2348

LG34WK950U-W, calibrated to DCI-P3 with LG Calibration Studio / Spider 5

iPad Air Gen 5 (2022) A2589

Special interest into procedural texture filter, edit alpha channel, RGB/16 and RGB/32 color formats, stacking, finding root causes for misbehaving files, finding creative solutions for unsolvable tasks, finding bugs in Apps.

 

Link to comment
Share on other sites

  • Staff
10 hours ago, GreenGirl said:

Funnily enough I did offer such a thing in my first or second post - no one from the dev team or mods has bothered to offer an email or drop box link or even engage with me to try and solve this. 

 

I don't know how else I can scream louder that I'm literally blocked and this is screwing up my work life!!!!!!

We do not always request a file especially when there are other troubleshooting steps that need to be followed first.

Now they have though you can send the file here for me to take a look at if you wish:

https://www.dropbox.com/request/8O7Vqyy5iIEOSpIIgsqq

Lee

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.