Jump to content

Recommended Posts

Anyone else having issues downloading latest version upgrades?

We're using Malwarebytes, and it is continuously blocking download attempts, labelling the site as potentially dangerous.  Even if we check to let the objection pass or go into the app to allow the serif.com site, it still stops the download.  Maybe Serif could look into this or contact the vendor.


RickyO
APhADe and APu user
New User as of Mar, 2018
(Still stumbling along given too many directions at any given moment)
Windows10 platform

Share this post


Link to post
Share on other sites
11 minutes ago, RickyO said:

Maybe Serif could look into this or contact the vendor.

I’m not sure what you mean by this. If you’re downloading from the serif.com site, Serif is the vendor!


Alfred online2long.gif
Affinity Designer/Photo/Publisher for Windows • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.8.4.186 • Designer for iPad 1.8.4.4 • iPadOS 13.7 (iPad Air 2)

Share this post


Link to post
Share on other sites
6 minutes ago, Alfred said:

I’m not sure what you mean by this. If you’re downloading from the serif.com site, Serif is the vendor!

Hi Alfred,

I think he is referring to us contacting Malwarebytes.

 

21 minutes ago, RickyO said:

Anyone else having issues downloading latest version upgrades?

We're using Malwarebytes, and it is continuously blocking download attempts, labelling the site as potentially dangerous.  Even if we check to let the objection pass or go into the app to allow the serif.com site, it still stops the download.  Maybe Serif could look into this or contact the vendor.

Hi Ricky O

I can assure you this is a false positive we have had this a few times with Malwarebytes in the past. There are no security risks with any downloads on our official site, In this case you will need to disable Malwarebytes to complete your download.

C


Please tag me using @ in your reply so I can be sure to respond ASAP.

Share this post


Link to post
Share on other sites

Agreed; tried that (disabled it), and it still blocked the download  (that's bizarre).  Rebooted, still problems.  And, as far as I tested, it's only specific to this instance.  I chatted with their support providing my side: MW is blocking an auto-download I need from store.serif.com. I've put the website into the MW allow list, I've run your support tool, I've scanned; I've even turned MW off and it still blocks the download. I've gone to the other app's site, logged-in and attempted download directly from them as compared to the auto-notification from their app. MW still blocks the download. WHY??????

They have escalated the ticket.  I suspect the issue(s) are with their app.  I've had good protection in the eight or so months I've used it, so suspect this to be a clitch a bit in their code.  They will be getting back to me.

Hopefully, whatever they find will be usable by all of us in the future.

Thx


RickyO
APhADe and APu user
New User as of Mar, 2018
(Still stumbling along given too many directions at any given moment)
Windows10 platform

Share this post


Link to post
Share on other sites

Just a shot in the dark, but:

I'm wondering if the length of the URL to the download URL could have something to do with it.  It's approx 481 characters.  Or if the base domain name the link points to is an issue for MQ....

Just a bit of mind-acrobatics.

 


RickyO
APhADe and APu user
New User as of Mar, 2018
(Still stumbling along given too many directions at any given moment)
Windows10 platform

Share this post


Link to post
Share on other sites
23 minutes ago, RickyO said:

MW is blocking an auto-download I need from store.serif.com.

Is it really doing that? Or is it blocking a file from cloudfront.net?

For example, the direct download link for Designer 1.8.2 for Windows from the Serif update site is: https://d1gl0nrskhax8d.cloudfront.net/windows/designer/1.8.2/affinity-designer-1.8.2.exe?Expires=1584456356&Signature=JNzAMcyNEu-v3oCD0nn7aKQG1qcLz7PzxQRglDAMyvbROZOa1eTb1PINr1Gvv~HZQSJSp5s9nsNEajtJGwgcF8-S0VMnJr6ztZdNR3xeNKs8VPXB8WXsC1kOYbZJlt6Wh9Ops5VTsLacOOtz9~Kjyt3VpUdEQrkiWOscDBqtaENjknYn5Yumpocx-ReCahrOxmTjZRQzsas86EDIo7qFyUOfAuuJo1jSMXd85gC34ImBWBa-QUitylYA6OpUXAdm6TTvbMAjXvo-4HnlpIqS1QnReilIpInxGqjw0EnnmgnRspcBDN0urzlsDX9vVVXsT9PyGqSj1Vim5~WrCLUBKw__&Key-Pair-Id=APKAIMMPYSI7GSVTEAAQ

They use cloudfront as a server because it has higher bandwidth than their own servers would have.

It is likely that MW is blocking cloudfront either because it doesn't understand that long URL and thinks something is fishy, or it has previously found something suspicious somewhere on cloudfront.

You need to provide that URL (assuming you're on Windows) so the MW team can see what's going on.


-- Walt

Windows 10 Home, version 2004 (19041.388),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop:  8GB memory, Intel Core i7-3625QM @ 2.30GHz, Intel HD Graphics 4000 or NVIDIA GeForce GT 630M
Affinity Photo 1.8.5.703 and 1.9.0.734 Beta   / Affinity Designer 1.8.5.703 and 1.9.0.734 Beta  / Affinity Publisher 1.8.5.703 and 1.9.0.742 Beta.

Share this post


Link to post
Share on other sites
4 minutes ago, walt.farrell said:

Is it really doing that? Or is it blocking a file from cloudfront.net?

For example, the direct download link for Designer 1.8.2 for Windows from the Serif update site is: https://d1gl0nrskhax8d.cloudfront.net/windows/designer/1.8.2/affinity-designer-1.8.2.exe?Expires=1584456356&Signature=JNzAMcyNEu-v3oCD0nn7aKQG1qcLz7PzxQRglDAMyvbROZOa1eTb1PINr1Gvv~HZQSJSp5s9nsNEajtJGwgcF8-S0VMnJr6ztZdNR3xeNKs8VPXB8WXsC1kOYbZJlt6Wh9Ops5VTsLacOOtz9~Kjyt3VpUdEQrkiWOscDBqtaENjknYn5Yumpocx-ReCahrOxmTjZRQzsas86EDIo7qFyUOfAuuJo1jSMXd85gC34ImBWBa-QUitylYA6OpUXAdm6TTvbMAjXvo-4HnlpIqS1QnReilIpInxGqjw0EnnmgnRspcBDN0urzlsDX9vVVXsT9PyGqSj1Vim5~WrCLUBKw__&Key-Pair-Id=APKAIMMPYSI7GSVTEAAQ

They use cloudfront as a server because it has higher bandwidth than their own servers would have.

It is likely that MW is blocking cloudfront either because it doesn't understand that long URL and thinks something is fishy, or it has previously found something suspicious somewhere on cloudfront.

You need to provide that URL (assuming you're on Windows) so the MW team can see what's going on.

I agree.  Was just doing so when I received notification of your post.  And thank you.  It appears we may be on the same thinking path.

 

====================

 

And of course, their chat app won't allow the thread to be re-opened "at this time".  I'll write that one off as legitimate due to the current Covid/staffing issues.

 

 


RickyO
APhADe and APu user
New User as of Mar, 2018
(Still stumbling along given too many directions at any given moment)
Windows10 platform

Share this post


Link to post
Share on other sites
39 minutes ago, RickyO said:

I've even turned MW off and it still blocks the download.

Did you try stopping the Malwarebytes service in Services?

Or did you just try to switch it off in the Malwarebytes program?


Due to the fact that Boris Johnson is now our Prime Minister, punctuation, spelling and grammar will never be worried about ever again.  We now have far bigger problems to be worried about.

Share this post


Link to post
Share on other sites
1 minute ago, carl123 said:

Did you try stopping the Malwarebytes service in Services?

Or did you just try to switch it off in the Malwarebytes program?

Just tried that.  Bizarre.  I won't let me stop the service.  Error 5:  Access denied.

MW support just requested a rerun of their diagnostic and copies of the logs.  We'll see what they say.

Thanks again.

 


RickyO
APhADe and APu user
New User as of Mar, 2018
(Still stumbling along given too many directions at any given moment)
Windows10 platform

Share this post


Link to post
Share on other sites
6 hours ago, carl123 said:

Did you try stopping the Malwarebytes service in Services?

Or did you just try to switch it off in the Malwarebytes program?

Just an update.  Nothing heard from MW.  Sent them a request for update.  Now 6 hrs down the road, (3:30p CDST - US).

 


RickyO
APhADe and APu user
New User as of Mar, 2018
(Still stumbling along given too many directions at any given moment)
Windows10 platform

Share this post


Link to post
Share on other sites

If stopping Malwarebytes didn't work, you might consider uninstalling it, doing the download, and then (perhaps) reinstalling it after the download has worked.


-- Walt

Windows 10 Home, version 2004 (19041.388),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop:  8GB memory, Intel Core i7-3625QM @ 2.30GHz, Intel HD Graphics 4000 or NVIDIA GeForce GT 630M
Affinity Photo 1.8.5.703 and 1.9.0.734 Beta   / Affinity Designer 1.8.5.703 and 1.9.0.734 Beta  / Affinity Publisher 1.8.5.703 and 1.9.0.742 Beta.

Share this post


Link to post
Share on other sites
6 minutes ago, walt.farrell said:

If stopping Malwarebytes didn't work, you might consider uninstalling it, doing the download, and then (perhaps) reinstalling it after the download has worked.

Yes, was considering it.  If I do, I'll scrub the registry as well before re-installing.  Giving MW a few more hours to see if they come up with anything.  All has gone well with it for months.  Have dl'ed earlier Affinity updates no problems.  Makes me wonder if there's a variable I'm just not aware of; and if so, why now?

Thanks


RickyO
APhADe and APu user
New User as of Mar, 2018
(Still stumbling along given too many directions at any given moment)
Windows10 platform

Share this post


Link to post
Share on other sites
18 minutes ago, walt.farrell said:

If stopping Malwarebytes didn't work, you might consider uninstalling it, doing the download, and then (perhaps) reinstalling it after the download has worked.

Interestingly enough, also have a similar dl problem using appsumo.com  Appears they use another dl service which employs very long URLs to the specific downloads.  That service appears to be klclick.com.  Too obvious that both are long URLs.


RickyO
APhADe and APu user
New User as of Mar, 2018
(Still stumbling along given too many directions at any given moment)
Windows10 platform

Share this post


Link to post
Share on other sites
17 minutes ago, RickyO said:

Interestingly enough, also have a similar dl problem using appsumo.com  Appears they use another dl service which employs very long URLs to the specific downloads.  That service appears to be klclick.com.  Too obvious that both are long URLs.

8 hours ago, carl123 said:

Did you try stopping the Malwarebytes service in Services?

Or did you just try to switch it off in the Malwarebytes program?

Someone want to tell me how after uninstalling MW, rebooting, scrubbing the Win10Pro registry, rebooting, I still get the Malwarebytes download warning/stop page???

Something smell ripe in this garden.....

 


RickyO
APhADe and APu user
New User as of Mar, 2018
(Still stumbling along given too many directions at any given moment)
Windows10 platform

Share this post


Link to post
Share on other sites
15 minutes ago, RickyO said:

Someone want to tell me how after uninstalling MW, rebooting, scrubbing the Win10Pro registry, rebooting, I still get the Malwarebytes download warning/stop page???

Something smell ripe in this garden.....

 

Believe it or not, I found it.

It’s in the Malwarebytes Browser Guard, v.2.2.0, last updated 3/6/2020 from Malwarebytes.com website.

 

After disabling it, the dl worked. 

That little extension is going bye-bye....

 

Thanks to everyone.

 

 


RickyO
APhADe and APu user
New User as of Mar, 2018
(Still stumbling along given too many directions at any given moment)
Windows10 platform

Share this post


Link to post
Share on other sites
14 minutes ago, RickyO said:

Believe it or not, I found it.

It’s in the Malwarebytes Browser Guard, v.2.2.0, last updated 3/6/2020 from Malwarebytes.com website.

 

 

 

After disabling it, the dl worked. 

That little extension is going bye-bye....

 

Thanks to everyone.

 

 

 

 

 

How do we get this recorded into the affinity support section??


RickyO
APhADe and APu user
New User as of Mar, 2018
(Still stumbling along given too many directions at any given moment)
Windows10 platform

Share this post


Link to post
Share on other sites
21 minutes ago, RickyO said:

How do we get this recorded into the affinity support section??

I'm not sure it needs to be (and congratulations for figuring it out), but Callum (one of the moderators) is following the discussion and will know.


-- Walt

Windows 10 Home, version 2004 (19041.388),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop:  8GB memory, Intel Core i7-3625QM @ 2.30GHz, Intel HD Graphics 4000 or NVIDIA GeForce GT 630M
Affinity Photo 1.8.5.703 and 1.9.0.734 Beta   / Affinity Designer 1.8.5.703 and 1.9.0.734 Beta  / Affinity Publisher 1.8.5.703 and 1.9.0.742 Beta.

Share this post


Link to post
Share on other sites

Thanks.  I sincerely appreciate the help from all of you.  It definitely helps set the direction, confirm or eliminate paths of logic, and shorten the time.

 

 


RickyO
APhADe and APu user
New User as of Mar, 2018
(Still stumbling along given too many directions at any given moment)
Windows10 platform

Share this post


Link to post
Share on other sites

I regret that I didn't find this particular topic here before I posted elsewhere in the forums.  I had the same problem and spent much too much time and received several unhelpful support replies from Malwarebytes that denied their software was the problem.   I even found and entered the URL of the Cloudfront server as an exemption,  MW support didn't offer me any diagnostics or ask for my log files.  I just received an update from Malwarebytes, and the problem persists.  I downloaded Vivaldi browser and used it rather than Firefox, and somehow managed to get the update.  I'm unclear how to turn off the Browser guard, but I will look into the services.  I believe Malwarebytes is a very good product,and has saved me some grief in the past,  but has some obvious shortcomings, and will try to continue my dialogue with them.

These forums and their members are impressive, but I feel Affinity should have a more direct way of addressing this kind of problem as well.

Share this post


Link to post
Share on other sites
1 hour ago, joltar said:

I feel Affinity should have a more direct way of addressing this kind of problem as well

I'm not sure exactly how Serif/Affinity would be able to do that?  The problem is clearly with Malwarebytes code (somewhere) so not something Serif can address, I think.

Jeff


Win 10 Pro, i7 6700K, 32Gb RAM, AMD Radeon R7 360 and Intel HD530 Graphics

 

Long-time user of Serif products, chiefly PagePlus and PhotoPlus, but also WebPlus, CraftArtistProfessional and DrawPlus.  Delighted to be using Affinity Designer, Photo, and now Publisher.

Share this post


Link to post
Share on other sites
On 7/31/2020 at 11:35 AM, joltar said:

I had the same problem and spent much too much time and received several unhelpful support replies from Malwarebytes that denied their software was the problem.
(...) I feel Affinity should have a more direct way of addressing this kind of problem as well.

Another approach would expect a better work- or information-flow from the part which does the unwanted blocking. Maybe by making this note more present and aware to their users:

Quote

b66ecdd4813c3b2805191d235d1d39b53760eccb.png.1ce4bec432eefe7b83069951302f2191.png   There may be occasions when Malwarebytes for Windows flags an item you trust as malicious. Add the item to your exclusions to stop Malwarebytes for Windows from blocking an item you know and trust. (...) Once an exclusion is added to Malwarebytes for Windows, the exclusion begins to take effect immediately.

https://support.malwarebytes.com/hc/en-us/articles/360039024133

 


macOS 10.14.6, Macbook Pro Retina 15" + Eizo 24", Affinity in Separated Mode (documents merged)

Share this post


Link to post
Share on other sites

I have added the sites blocked from Affinity download to the exclusions, and the problem persists.  I have an open support at Malewarebytes, and they have responded quickly in the past, even though the advice did not work.  I'm awaiting a followup now, and have alerted the support agent of this forum and how the problem isn't just with me.  Wait and see.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.