Jump to content

Search the Community

Showing results for tags 'Export Persona'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Affinity Support
    • News and Information
    • Affinity Support & Questions
    • Feature Requests & Suggestions
  • Learn and Share
    • Tutorials (Serif and Customer Created Tutorials)
    • Share your work
    • Resources
  • Bug Reporting
    • Report a Bug in Affinity Designer
    • Report a Bug in Affinity Photo
    • Report a Bug in Affinity Publisher
  • Beta Software Forums
    • Affinity Designer Beta Forums
    • Affinity Photo Beta Forums
    • Affinity Publisher Beta Forums

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


MSN


Website URL


Skype


Facebook


Twitter


Location


Interests


Member Title

  1. I’m working on a 150 artboards document for an app. I’m using an export preset that saves in 3 files per artboard. I’d like to export only modified artboards or a selection of them and countinuous export isn’t the solutions for some cases (a symbol on all artboards is like and export all). Now we have the ability to export New items only, Export all slices or export only selected output files. I’d like to have the option to select the slices from Slices panel, then get in the export panel an Export selected button. A “select/deselect all" in export panel could help too.
  2. I'm finding when using the Export Persona, saving to a Google Drive location locally, that it freezes and I just keep getting the spinner. I then have to force quit. However, when I use File > Export to a Google Drive location it does not Freeze. Not ideal as I don't get the features I rely upon from the Export persona. I'm on the latest version of the software (1.10.4) and also Mac Os (12.0.1 Monterey). What's going on?
  3. Until now I mostly created graphics inside Affinity and exported it with the export persona without any issues in both Photo and Designer. Today I imported a PSD file into Affinity and created slices of all layers (without even editing inside Affinity). But to my surprise the Slices don't have extensions in the Slices tab of the Export persona and export to files without extensions, eventhough PNG is selected on each slice. When creating a new file and create slices of the new layers everything still works fine; all slices get the PNG extension, because PNG is selected. So there is an issue in Affinity when starting with an already created PSD file to create and export layers as slices. This is how it looks when layers are created inside Affinity (pixel-layers) and we create slices from those layers: This is how it looks when layers are made externally and imported from PSD (to pixel-layers) and we create slices from those layers: As you can see the files don't get an extention when exporting either: The issue is already in the slice-name, so it looks like we cannot even change it [Edit] Added a test PSD file in the Attachment which throws this issue AND the Affinity file created from it where you can see the issue in the export persona. For the record; the PSD is created in the latest Krita (5.1.1). test.afphoto test.psd
  4. HI, I am using version 1.10.5.1342 on a windows notebook. I saw Elaine Giles great youtube about the export persona and, of course I had to get my hands on it. So I took an already existing file with around 10 or 12 artboards, lots of symbols and the Export persona had already some specifications. The idea behind the new set up of the Export Persona is to set the name once and it will ripple through to "everything" so that I do not need search my export folder, create new folder etc. The attachment shows, that I can change the artboard name in Designer Persona, it then changes in the layers panel of the Export persona but it does not pull through to the change the slice name. Interestingly it works, when I set up a complete new file - I tested it with 2 artboards and 2 symbols. Any idea how to solve this except to make everything new from scratch? Should I report that as a bug?
  5. Sometimes, eventhough Spine is selected as Batch builder, no spine.json file is created when exporting slices. I have to watch more closely when exactly this happens, but I'm pretty sure this is what happens: - Have a file, create slices, select Spine batch export and export the slices (spine.json gets created just fine) - Keep Affinity open and start creating a new file, create slices and go to the slices tab in the export persona: now 'Spine' is still selected as batch exporter, but it doesn't use this batch exporter when exporting the slices. It only seems to work if we manually set/refresh the batch export selection by moving to another setting in the dropdown first and than re-select Spine in the dropdown again. So it looks like the batch export method is set to 'none' when creating a new file, but the UI for it wasn't updated, so it still shows 'Spine' while in reality it's set to 'none'. This is obviously confusing and prone to errors.
  6. Hi there! I am writing, because in the last view months I constantly have the same issue with affinity designer. The procedure is always the same: I do some work I change to the export persona Pick the slices to export press "export"... then the finder window appears, where to export to... then I can click one or two times on some folders (very different every time) then the rotating ball appears while searching the desired folder in the finder window... ...then designer get stuck... This is not always the case, but very regularly. There is no difference in my behavior if this occurs or not. I send the crash repot a lot of times...but now I thought its time to tell you directly. Hope you can fix this, its really annoying. Thanks Andreas
  7. This has probably ever be reported by somebody before, but I couldn't find any reporting on this issue with the forum search, so just to be sure it's known and hopefully can get a fix: Slices created from fill layers having a mask vector layer with gausian blur applied to it have bounding boxes that are cutting off the blur. This results in unusable export files as we obviously want the effect to be there fully, not cut off. It looks like effects are ignored by calculating the bounding box to create a slice. [edit] The bounding box of the mask in the normal editor is already ignoring effects by calculating the bounding box. Which is fine in the editor and even wanted in most cases IMO. But the same calculation results in issues in wrong sizes/positions to create slices in the export persona (please see images below) The same issue happens in Photo. I'm sure I know a way to work around this for now, but that's far from ideal and especially in the project I'm currently working at a loooot of (redundant extra) work. This obviously needs to work out of the box, so hoping for a fix! Thanks in advance! 😀 layer and fx situation Masked with this construction by dropping here 🙂 bounding box of the fill layer in the editor mode: bounding box of the mask layer without effect in the editor mode: bounding box of the mask layer WITH effect in the editor mode: created slice is too small (you see the bbox is way smaller than the real boundingbox as seen in the normal editor). The slice seems to ignore the effects applied at calculation time or something else is wrong in its cropping method: output file after exporting using the export persona: blur is cut off
  8. How can I export slices as SVG using Export Persona? Using Export menu I can only export one or all artboards :-(.
  9. Hi! Is it possible to automatically adjust the size of the slice to the same size as the document? I have several layers and all of them I need to save as separate files with different file formats (some as PNG, some as JPEG, etc.). I need a little bit of support on this case from Affinity Photo community. ;) Thanks in advance for help! :)
  10. Quick Explanation When I try to export slices created from layers, the output files are not cropped to the document. I can "Rasterize & Trim" each layer to get the desired output, but I'd like a non-destructive way to do it. Any ideas? Detailed Explanation I'm taking photos of a number of products, each of which have 6 photos of the same size. My goal is to keep one AFPhoto file per product with each of the 6 photos as layers, with all edits made non-destructively, and then export each photo with a lower resolution (for web) in bulk to a designated "Processed Photos" folder. Here's my current, problematic workflow: Open up all product photos as layers in one AFPhoto file Perform various edits, including rotating, cropping, etc to each layer Create slices from layers in Export Persona Set up export settings and export each slice to the destination folder The problem is that the output files are not cropped to the document boundary as shown in AFPhoto. I can solve this problem by selecting each layer and choosing "Rasterize & Trim", but this is destructive, which I don't want. Appreciate the help. I'm guessing it's a pretty simple solution, but I'm an amateur at this software.
  11. Hi. I created manually a huge collection of simulated pixel art. There is a bunch of more than 8 thousand individual pieces that Affinity couldn't manage in one fils, so I have spliced them in files that contains between 400 to less than 600 artboards, each containing one piece. Despite the files are hardly managed by my old laptop, I tried for first time the persona export because up to date I never had to make so massive amount of files. So each artboard, a perfect square of 1008 by 1008 pixels containing colored rectangle shapes of 24px side, perfectly aligned by Affinity snap fitting perfectly inside the square as a different image. I will not upload full size screenshots, but the issue will be clear. Designer persona shows squares like separated in preview. in outline view they are shown with no space at all between, no matters the magnification. Export directly one by one from designer results in a perfect 1008px square, with no separation between the colored squares, but export persona DOES! it export each artboard in 1009px and with a clear separation of 1 px between squares!!! so is totally unusable to export my more than 8 thousands figures!!!! that is not only frustrating, is very imprecise. Note I "adjusted" one to 1008px to test, but the result is very bad too, so I need your help, pleas as soon as possible.
  12. Hey I want to flag this bug/issue again since it is still not being address or fixed and is creating a workflow in affinity that I can no longer continue to use. Please see video below of the example of how force pixel alignment does not work. It is becoming a serious headache, namly the export persona constantly exporting images with a 1px gap. I have since, through shear perservance learned the work flow to get around this problem. Forced pixel alignment should do what it says and the whole document works precisely on whole pixels regardless of scale, snapping or repositioning. Perhaps affinity should even add this as a clear option when creating a document in the first place. Add a tick box option next to the 'document units' dropdown menu and call it 'work with whole pixels'. Then have the additonal forced pixel button in the toolbar. My problem I face now is when a scale an object, let's say a simple piece of text. It does not scale to whole pixels. It introduces the fractured pixels, even though the whole documnent is working in forced pixel alignment. Due to this I have to constantly monitor and be aware of resizing everything to make sure it is working in full pixels. Is there a way when I scale an object, ie grabbing the blue handle points and increasing or decreasing its size, while maintaining full pixels? This would help massively on my end in solving how affinity works. Like others though this is really beginning to dent my ability to use Designer going forward. It is literally adding hours to my work flow. https://www.loom.com/share/d4d68bbd50ac4a68892ca40852a5cf72
  13. Related: https://forum.affinity.serif.com/index.php?/topic/37597-ad-export-persona-item-has-duplicate-paths/ Change the message of the error icon to the specific error: If the artboard was named twice the same, say e.g. "The Artboard/Path-Name is used multiple times". The actual message ("The Item has duplicate Paths") indicates Paths that are exactly the same (not only the name) and do overlap or such thing. Greetings, Johannes
  14. Hello Affinity Friends! I have a problem. Affinity Designer shrinks my images by 2x when I export them with Export Persona. Normally I slove my issues on my own but this time I cant find the solution. Please help me. I have attached two pictures. Big thanks to all of you!
  15. Apologies if this was started already as a suggestion. I think that Export Persona should be very useful in Publisher. Imagine trying to negotiate various PDF export options. Being able to PDF only certain pages or exporting pages in other formats would really be great. I know that we have Export command but Export Persona would act as some sort of Presets for a variety of exporting options. This should be a low-hanging fruit for the dev. team as most of the functionality already exists in Export Persona in Designer and Photo.
  16. I have about 90-80 slices in my project (It's and Android app) , and each slice is exported to a number of files (PNG and SVG). When using my mouse wheel scrolling up and down, folding and unfolding my slice to check that the export looks ok Designer freezes. 1. I first created a "master" export setup manually, exporting one SVG file and a number of PNG files in various resolutions to target all DPI:s 2. I used the "copy export format setup to clipboard" 3. I marked all my other slices (except the top one) 4. I used the "Add export format setup from clipboard", so all my slices is exported in the same manner (keeping the slice name unique) 5. Using mouse wheel in the Slices area up and down 6. Unfolded a few of the slices and rolled the mouse wheel up and down fairly quickly 7. Designer freezes, boom. It recovered my file when I restarted though (phew) I also created a crash dump file of the Designer process was frozen and ran it through DebugDiag Crash Analyzer, the report is attached. I suppose I could send my file to the developers if that helps reproducing the freeze, but I rather not post it on the forum Video capture Sometimes the slices are not redrawn properly in the UI, not sure how to recreate this - but here's what it looks like: Video clip with the error . Designer_MultipleRules.mht
  17. Hello, not 100% certain this is a bug, but its behavior I wasn't expecting. In Export Persona > Export Options tab > Mode set to Default - when choosing an option from the Preset dropdown, the parameters below do not update to show those belonging to that preset. They remain unchanged. For example, in the screenshot I've changed the Preset from EPS to JPEG, but the parameter options (including checkboxes and postscript which do not apply to JPEG) still remain. If I toggle modes from Defaults to Selection and then return to Defaults, it seems to load the selected preset's parameters. This is what led me to believe this is not behaving as intended. Thank you, Walt Affinity Designer: 1.10.4.1198 (in trial) Windows 10 64bit, ver. 21H2, OS 19044.1347, Exp Pack 120.2212.3920.0 I did try searching the forum before posting
  18. I created design with artwork, then I exported SVG format with export persona, and then there was invisible rectangle object in my design. Is there solution? I have some problem with export persona, I think good if "snapping" available in export persona Thanks.
  19. Hi. I've been searching, but I can't find a way in any tutorial, although there must be one: in the export persona, how to give the slices a default aspect ratio (1x1, 4x5, whatever ...), and not having to move the sliders by hand, almost impossible to adjust the size with pixel precision. If anyone knows where that option is, I would appreciate the help.
  20. Hello there, I'm encountering some issues I simply cannot understand. I am trying to export some pixel art through the export persona to be able to handle my slices easily, however, even by setting the defaults & selection export options mode to use the nearest neighbor resampler, the exports seem to not go through the resampler as they come out with the usual blur you get without using nearest neighbor. However when I try to export a selection through the regular export menu File > Export... and select the nearest neighbor resampler, my export comes out fine. Is there something that needs to be toggled on/off for it to work as well on the export persona ? Thanks,
  21. Hey All! Been working on a template for exporting logo files for clients and thought I'd share it here so we can maybe work on improving it together? FILE: Logo Exporter Template CMYK V1.afdesign The idea is that the export persona is already set up to create folders and files for the different parts of the logo and the different colour models. What works: Folders and colour gamuts are exported easily and swiftly (more on this below) It's easy to resize the artboards to fit a new logo. It saves me a generous amount of time! Cheaper than other plugins for other apps with similar functionalities. 😉 -- A few things I'm struggling that could do some help with: 1. File naming The naming convention I am after is the following: "clientname-logoelement-colour-gamut.extension" I managed pretty much everything, by renaming the artboards, and manually updating the export slices. But I can't find a way to replace "clientname" with the name of the afdesign file. 2. Colur gamuts / modes When working form a RGB afdesign file there are limitation on exporting certain files to CMYK - for example EPS only export in the original afdesign file setup. But when working from a CMYK base file (like the attached) the file conversion options are more friendly. A NOTE ON THIS: Although we all know that is best practice to adjust these conversions manually I'm trying to make something that will save me time. Perhaps there is b better way to automate this with the use or symbols or global colours - I'm yet to discover (new to affinity here) 3. Symbols / global colours I'm not very versed on these yet, so would appreciate any suggestions on how using these can help the exporting process, colour settings. Have a go at using it and hope it saves you some time! J.- PS: Dear moderator, if this belongs on a different thread please advice accordingly.
  22. Hi all, I have contacted support last year about a problem I have with the export persona in Designer and it still won't work today. I have also tried to recontact them over email but got no answer probably because WFH. So I decided to write here. Basically the problem is that I can't seem to use the export persona for anything else but iCloud and iPad. All other options are greyed out and no matter what I do (Reauthorize through Files App, logout and login again, etc.) I cannot choose any other save location but iPad or iCloud. Does anyone know what the Problem might be? I have also switched iPad to make sure it was not an OS corruption Problem, the bug still persists. I cannot take the solution of first exporting to iPad and then moving my files anymore as it destroys my workflow. Would be nice if anyone knows a solution to this. Thank you in advance for your help.
  23. When I doubleclick on the name of a slice to rename it, it displays a selected text but the highlight is lightgrey instead of blue (my system colour) so when I begin entering text I get the systembeep. Sometimes it works tho... I just never know when and how. Edit: notice also the missing triangle in the open/close button Bildschirmvideo aufnehmen 2021-05-27 um 20.28.11.mov
  24. Hi there, In the Export persona, is there a way to include a specific layer for one slice only (between various other slices)? So far I know I can exclude a specific layer/group of layers for all slices by unchecking the eye mark. But I want to do like the opposite. For example: I have a usual project file with the original image, various changes in multiple layers and groups. On top of that is a soft-proof profile placed as well as some smaller tweaks for printing. Now if I export those image I want copys for the digital media without those printing tweaks, so I simply uncheck those. But for printing I want a dedicated filename_print.tiff with those printing tweaks applied on top. I know I can go the long road and do two exports but that somewhat defies the logic behind the export persona. And if I try to create a slice from a selection of layers it creates one slice per layer which obviously also isn't what I want.
  25. Hi guys, title explains already everything, however, please have here a video (unlisted) explaining what I mean. What I forgot to mention in the video: please enable Metadata export to slices, thanks.
×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.