Jump to content
MattP

Affinity Designer Customer Beta (1.2.1.25597)

Recommended Posts

Many things for me :

- open /close hierarchies  All or Selected

- search an object by name

- move in world coordinates or in object coordinates

- instances (object Master and clones). You modify the master, clones too.

- Array tool : linear / grid / circular / on object

- copy/paste only fx

- scale / rotate on any point

- deformation tool (twist, bend, free form deformation, zigzag)

- shape gradient

- measure tool

 

I've noticed that I spent a lot of time in AD on boring tasks that could be done in 3 clicks.

 

But in AffinityDesigner I trust !

Share this post


Link to post
Share on other sites

I know I bring this up EVERY beta (Sorry!), but I still get a crash every single time I try and export over an existing file:

 

[...]

 

Is it possible to give me a version to run with the export code inundated with logs or something to at least be able to narrow it down a bit more?

 

Hi Gary,

 

Firstly my apologies that you still get this error - I can't imagine how utterly frustrating it must be! We're really not trying to ignore this issue, it's just that we're finding it impossible to reproduce so we can look at it! :S  We actually have the same MacBook Pro (retina with integrated HD4000 and discrete Nvidia 650 graphics card?) and have used it since 2012 to develop on without running into this issue (or we could've fixed it!) so I'm just a little stumped... The only thing it hasn't got that yours has, is Yosemite. I'll ask the developer who has it to try upgrading and then see if they can perform the same operation as you successfully - I'm imagining they can't reproduce it as we'd have an awful lot of crash reports otherwise! But it is certainly worth a shot. I think it's graphics-related, not Save-related but it obviously has something to do with showing those specific OS dialogs... I don't think that littering our save code with messages and giving it to you will show anything because of that reason - and in fact if it's related to graphics then any extra messages we show would change its behaviour and obscure the problem - but we could certainly try to log something to file...

 

I can't remember if we've already been through this or not, but would you be able to try to make a new Admin user on your system, put the Beta on there and try it out to see if it still crashes? It sounds like a silly thing to ask for, but it does actually fix a lot of system-specific problems! :S You can easily do this in the 'System Preferences...'->'Users and Groups' section and it can be deleted again afterwards with no lasting effect.

 

In the meantime, we'll try it out on Yosemite on that laptop that's the same as yours and we'll also have a chat and see what else we can think of that might help to track it down...

 

Thanks again,

Matt

Share this post


Link to post
Share on other sites

Hi Matt,

 

Another feature which I think is really important - Nudge Distance Tool.

 

This is where we can specify the distance we want to move things using the arrow keys.

 

Will this be implemented in future updates of AD?

Share this post


Link to post
Share on other sites

Hi andyajon,

 

Yes, we'll definitely add the ability to specify nudge distances - but it will probably just be a preferences option, I think... :)

 

Thanks,

Matt

Share this post


Link to post
Share on other sites

Hi Matt,

 

Its difficult to convey one's mood effectively through text, so I'd just like to assure you that its not something I'm fuming at or super upset about. I don't feel like you're ignoring me, or anything :) For the most part, I've learned to work around it but it is frustrating when I forget to delete the existing file first, or save with a different name, and it crashes. ADs crash recovery does help with this, too as (usually) I don't lose much/any work this way :)

 

 I agree that it looks a lot like a graphics issue, but how that manifests itself only on a file overwrite is beyond me :S. I used to do programming work on 3D vehicle simulations systems (multiple machines, multiple displays, all networked under Windows - aargh!) so I know all to well how subtle graphics issues can be! All I know is that I'm only getting this type of crash in AD (MAS version and beta) and the Photo beta so it must be something to do with the combination of my hardware and your code or a library that you use, maybe? I have also mentioned a crash before, with AD or the AP when starting up another app (Aperture or Lightroom) that uses the discrete GPU, which might be connected.

 

The crash report has the info in it but, to confirm, my machine is an early 2013 MacBook Pro Retina (maybe very slightly different if you have one from 2012), 2.7GHz Core i7, 16GB RAM, 500GB SDD with HD4000 and GeForce 650 discrete GPU. It is currently running the most recent Yosemite public beta (10.10.4). Display settings are set to default, no secondary screen plugged in, usually running off mains, not battery power and I usually run AD in fullscreen mode (although I get the same crash in normal mode, too). Something else that is probably different to most of your users is that I do have Xcode installed on my machine (but not running at the same time as AD) - maybe its causing AD to use a funny / debug library? Other slight differences are that I run in English but have Japanese set as a secondary language (I live in Japan, so I need to type in Japanese at times). The keyboard is also a Japanese one (machine bought in Japan). Apart from that, there's not too much different that I can think of. 

 

I just tried the new admin user trick you suggested but it crashed as before (see attached crash file). This time it indicated "/System/Library/Extensions/AppleIntelHD4000GraphicsGLDriver.bundle/Contents/MacOS/AppleIntelHD4000GraphicsGLDriver"  

 

Something I have noticed, though is that the first time I run the app and try to crash it takes a long time (10+ seconds) before the beachball shows up and the app crashes. I also sometimes get this the first time after installing a new beta. Afterwards it usually crashes in a second or less.

 

I hope the above helps. It would be really great to see this issue disappear! :) Apart from that, AD is one of my most used and enjoyable apps on my machine. Thanks for everything.

Crash with Admin User.rtf

Share this post


Link to post
Share on other sites

BTW: as an aside to my issue - the Japanese App store has currently got AD highly rated at 4.5 stars but almost every single review mentions the desire to have a Japanese language version. Might want to get on that sometime ;)

Share this post


Link to post
Share on other sites

Hi andyajon,

 

Yes, we'll definitely add the ability to specify nudge distances - but it will probably just be a preferences option, I think... :)

 

Thanks,

Matt

 

Hi Matt,

 

That's great. But I think it will be more useful if we can specify the distance in a fly for precision works.

 

post-247-0-44448800-1433409044_thumb.jpg

Share this post


Link to post
Share on other sites

Hi Gary,

 

Thanks for giving that a try - sorry to hear it crashed in the same way :(  Would you be able to try installing 'gfxCardStatus' (https://gfx.io) and use it to force your machine to always only use the integrated card. Do you still get the problem? What about when you start Aperture/Lightroom - does that still cause a crash?

 

Our machine had to have a new logic board about 4 months ago - it was a fairly common fault that caused all sorts of weird graphics issues... :(

 

Thanks,

Matt

Share this post


Link to post
Share on other sites

Great, what about the file size - looks huge to me. The image used was originally 4-5mb and that combined with some text and layer effects shouldn't result in a +100mb file?

 

I'm afraid that's just how big it is, at the moment. The image is around 20 mega-pixels, or 80 megabytes uncompressed, and it looks like there. It gets saved in a way that optimises load time rather than file size. We might add an option to let you prefer file size in future. Meanwhile, this is working as designed.

Share this post


Link to post
Share on other sites

Would you be able to try installing 'gfxCardStatus' (https://gfx.io) and use it to force your machine to always only use the integrated card. Do you still get the problem? What about when you start Aperture/Lightroom - does that still cause a crash?

 

I installed gfxCardStatus and forced using only the integrated card but it still crashed the same as before (see attached file) :(

 

So far, with this beta I haven't had the Aperture/Lightroom caused crash yet. It isn't something that I can create on purpose, unfortunately. It happens sometimes only. I'll let you know if it crops up again.

gfxCardStatus forced integrated crash.txt

Share this post


Link to post
Share on other sites

Matt, if I could provide a suggestion to consider...  In a pixel document the nudge tool jumps one pixel of the image per nudge.  But with a vector document when you could be zoomed in at 0.1% 10%, 1000%, 1000000%, etc. the current nudge is really only useful around a 100% zoom.  If instead the nudge could cause a movement of about the equivalent of a pixel on the display maybe for each nudge.  So changing the zoom will change the nudge.  That pixel count per nudge could be something that is selectable by the user.  So with 10 pixels selected about 10 nudges would give a movement of 1" on the display regardless of the zoom.

 

Also what would you think of having it so that if the nudge keys are held down for more than a few seconds, have it accelerate.  Sometimes the nudge works better even for longer distances than dragging does.


iMac (27-inch, Late 2009) with macOS Sierra

Share this post


Link to post
Share on other sites

I installed gfxCardStatus and forced using only the integrated card but it still crashed the same as before (see attached file) :(

 

So far, with this beta I haven't had the Aperture/Lightroom caused crash yet. It isn't something that I can create on purpose, unfortunately. It happens sometimes only. I'll let you know if it crops up again.

Hi Gary,

 

Just a quick question... When you see the system save dialog/replace dialog are they in English or are they in another language? What language is your system set to? What happens if you click to cancel rather than replace the file - does it still crash? We had an idea and want to try to find out if it's a likely candidate...

 

Thanks,

Matt

Share this post


Link to post
Share on other sites

Hi Gary,

 

Just a quick question... When you see the system save dialog/replace dialog are they in English or are they in another language? What language is your system set to? What happens if you click to cancel rather than replace the file - does it still crash? We had an idea and want to try to find out if it's a likely candidate...

 

Thanks,

Matt

 

 

Hi

 

My system is set to English and all dialogs etc. are shown in English. I just have Japanese set as a secondary language so that I can type in Japanese when necessary. Clicking cancel does as expected - no crash. If I cancel the overwrite and choose an untaken filename then the export goes off without a hitch.

Share this post


Link to post
Share on other sites

Hi

 

I need to head off to bed now, but I made a screen capture of the crash for you , run from a newly created Admin user. It also shows the multi-second delay of the first-time crash I mentioned earlier. No settings had been edited for AD. I had also forced integrated graphics with gfxCardStatus. I also included the crash report generated during the video.

 

Hope it helps :)

 

link (9.7MB): https://www.dropbox.com/s/hrhjk9bi2se23hd/AD%20Crash%20Video%20%282015-06-05%29.zip?dl=0

Share this post


Link to post
Share on other sites

These options are currently available directly in the Export Persona, and via presets in File > Export. In the next build, they'll be available directly from File > Export too, so you won't need to use the Export Persona to get at them.

 

 

Just a small question concerning these great news … I just wanted to know if the improvements of the Export Dialogue (File > Export) will also encompass the option to save user-specified export settings? That would be a huge relief …  :rolleyes:

 

(I had to export a lot of different files from Affinity Photo to JPEG recently, and I must confess it was somewhat painful that the Export Dialogue did not remember my last settings regardless of open file – at least I could not find out how to cure this amnesia … any ideas? – and that I was unable to specify once and for all a certain export setting.)

 

By the way: I wondered why the Slice Tool does neither snap to spread nor snap to margin … is that an oversight or is there a deeper reason for this? But once again, thanks for your great work! It’s a pleasure to have these apps available, cheers, Alex

Share this post


Link to post
Share on other sites

Hi A_B_C

If you change the slice export settings in the Export Persona, you can save them going to the menu on the right top of the Export Options tab and selecting Create Preset... Just give it a name and you're done. Next time you access the File ▹ Export dialog you can select that preset from the dropdown.

Share this post


Link to post
Share on other sites

Hi MEB,

 

another question: is there a way to keep the width and height information as well? The custom setting seems to save just file format, quality information and the like (which is to be expected, since it comes from the Export Persona) … If saving width and height information should not be possible, I would like to suggest to implement this option as well …

 

(But I fear this might turn out difficult. How should we apply a 800 x 600 px export preset sensibly to a 600 x 800 px document, for example? Absolute values might not work. Scaling by percentage or dependent on the absolute value of just one side? On the other hand I have often wondered if there’s a real-world use case of unlocking the aspect ratio during export and choosing arbitrary values … I never had to do this with any design … any experience?)

 

Cheers,

Alex

 

P.S. Unfortunately I can’t use the latest Beta, since it crashes on Lion … but the developers know about the issues and promised to have a look as soon as possible …  :)

Share this post


Link to post
Share on other sites

The 800x600 versus 600x800 issue could be resolved by entering max width, max height, with a Maintain aspect ratio checkbox. At least that's how another Serif title handles this for batch processing, which is a step further than export presets.


Twitter: @Writer_Dale
Work: Intel i7-6700, NVIDIA Quadro K1200 and Intel HD 530, Windows 10   |   Home: Intel Q6600, NVIDIA GTX950, Windows 10

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.