Jump to content
You must now use your email address to sign in [click for more info] ×

pdf export not working


Recommended Posts

Hi, @Dan C Still having trouble exporting using the PDF (digital - small size ) preset. The preview never appears and if I go straight to Export there's an error message.
I found a post from @nwhit which solved the problem exporting a PDF for offset printing. Seems it was an issue in Version 1, I did not find any reference to it in the Affinity Help. (See solution below)

Posted August 17, 2021
Okay, after a whole bunch of searches and reading, finally found an answer in a beta thread.
1. In Preflight panel, need to click the Edit Profile in the little Actions menu (top right of pane).
2. Go down to PDF Passthrough, then select the minimum type of PDF you're wanting to Place.
3. Will need to Create a Preset for that setting since the Default seems to be a minimum of X-1a:2003. Otherwise you will always see the error message if you are Placing regular v1.7 PDFs.
Overall, doesn't seem like a very intuitive or smooth way to do this preflighting. Would think there would be a better way, but who knows. Maybe in upcoming versions.
Just wish that this would be explained on the need and how to do this in the online Help for the app! The Help says there is a Preflight for PDF Passthrough, but doesn't explain how it works and the need to set it to what you want in the Edit mode.


@Dan C @nwhit I made the change to PDF Passthrough but still get a warning on one placed Ad that (PDF Version (PDF-1.6) is not compatible?
However the file appears to have output correctly using PDF/X-1a:2003 only. I got an error message using PDF/X-4.


Exporting using the PDF (digital - small size ) preset will not work in any of the RGB colour space settings (Acrobat 5-8).
It will export a 72dpi version as PDF/X-1a:2003, but I need an RGB version for online viewing. Any solutions?
Below are my settings for Digital PDF




Link to comment
Share on other sites

  • Staff

My sincerest apologies for the delayed response here as I was out of the office yesterday.

@ChrisNZAK - unfortunately there are still 0 uploads on our dropbox, so I do not have a copy of your .afpub file - can you please try once more for me, or simply attach a copy to your reply here?

If other PDF/x options are working for you, this could indicate a transparency calculation error, or an issue with a colour conversion when exporting - but I can only make guesses without seeing this file for myself, my apologies.


@D. Bakel, thanks for providing your file for me!

I can see that Page 1 has 2 different .PSD files linked, can you confirm which file you replaced please? If possible, are you able to upload a copy of the .PSD file you replaced with a JPEG to the previous Dropbox link provided?

Equally, which Drop Shadow in your document are you having trouble with, post export?

@Stoffels, sorry to hear you're having trouble also - as can be seen from this thread, this will be a specific issue with the file you are trying to export/your export settings, or a combination of these.

Can you please create a new thread, with as much information as possible regarding your file, and the export settings used etc? A member of our tech support team will be sure to reply to your new thread ASAP, but this helps to stop these threads from becoming even more confusing, as I have to try and follow 3+ different issues in one location.

Many thanks for your understanding here :)

Link to comment
Share on other sites

@Dan C

I replaced both PSD files. The first one was a background image in the middle, a group of kids. I replaced it with another background image (JPG).

The second one was a 8 color logo in the  top right corner. I first replaced it with a JPG. But, because i want get rid of this JPG for a long time, i created a svg from this logo with inkscape (quick and dirty solution). I uploaded both PSD files.

One thing i just realized, both files are not stored localy but on my  NAS. All other files are stored localy.


I will open another thread for the shadow problem.

@Martin Tolley The logo PSD file has only one layer. The Background PSD has 5 layers.

Link to comment
Share on other sites

The error with the pdf export is reproducible for me. But the log file is misleading.
I have placed a transparency over an svg image. This leads to the error with PDF-X4. No preview image is generated either. Without this transparency, the file is saved and a preview is also displayed. In a document with one page, I can look for the error. But if I have a document with 30 or 40 pages, there is no chance of finding the error.

The preview function is not usable at the moment. For example, I have a brochure with 36 pages. I would expect to be able to scroll through the 36 pages in the preview. It would be even better if I could show and hide individual colour channels (CMYK) in the preview for checking.

Nevertheless, I find the version very successful - many thanks to the whole team.

Translated with www.DeepL.com/Translator (free version)

Link to comment
Share on other sites

Error happend again with my new Logo SVG file which has several layers.

Placing the SVG file, the PDF export works. Saving the file and reopen it, PDF export fails with the error msg from above.

Replacing the SVG helps until i save the file.

@Dan C i uploaded my SVG file for you.

Link to comment
Share on other sites

  • Staff

Thank you for all the files uploaded @D. Bakel, I'm using these in my further testing now - just to confirm the above SVG you have mentioned, was this also stored on your NAS, or locally?

@ReinhardJ - thanks for your feedback! 

7 hours ago, ReinhardJ said:

This leads to the error with PDF-X4.

Can you please confirm for me, is this an error you see when exporting the file (ie 'PDF could not be exported'), or is this a warning error from Preflight, based on your current Preflight profile?

Link to comment
Share on other sites

Hello Dan C, this is an error when exporting PDF: "PDF could not be exported".
I put the transparency back over the svg - and today the file was exported again (PDF X4). I will test and observe this more intensively in the next few days.
But there seems to be a "random" problem with SVG files in V2. Because I could also see the behaviour of this error message with me: 

I often use QR codes in SVG format in my publications. 

Translated with www.DeepL.com/Translator (free version)

Link to comment
Share on other sites

Hello, I have now found the same cause for the PDF export error in two documents.
In both documents it was a linked SVG graphic, but it was no longer visible in the document - somehow it got lost (but I cannot judge whether it is due to the SVG format). The solution was to delete the graphic or the element from the layer and thus from the document. Maybe someone can verify this.

Maybe it can be included in the preflight. 

Many greetings

Link to comment
Share on other sites

  • Staff

Thanks for letting me know @ReinhardJ, it certainly sounds related to the SVG thread you've linked above - one of our team will be sure to investigate this issue further and reply to that thread ASAP - our apologies for any inconveniences in the meantime.


@ChrisNZAK, sorry to hear you're having trouble uploading the file, I've created a new request below, please let me know if this works correctly for you :)


Link to comment
Share on other sites

This topic is now closed to further replies.
  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.